libindi-vl.spec 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120
  1. Name: libindi
  2. Version: 0.6
  3. Release: 11%{?_dist_release}
  4. Summary: Instrument Neutral Distributed Interface
  5. Group: System Environment/Libraries
  6. License: LGPLv2+ and GPLv2+
  7. # The code is LGPLv2+ except:
  8. # some files for v4l2 conversion under libs/webcam are GPLv2+
  9. # drivers/video/stvdriver (indi_stv driver) appears to contain GPL code
  10. # upstream bug https://sourceforge.net/tracker2/?func=detail&aid=2572902&group_id=90275&atid=593019
  11. URL: http://indi.sourceforge.net/
  12. %define majorver 0
  13. Source0: http://downloads.sourceforge.net/indi/%{name}%{majorver}_%{version}.tar.gz
  14. Patch0: libindi-suffix.patch
  15. Patch1: libindi-cfitsio.patch
  16. Buildroot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: cmake
  18. BuildRequires: cfitsio-devel
  19. BuildRequires: zlib-devel
  20. BuildRequires: libnova-devel libfli-devel
  21. %description
  22. INDI is a distributed control protocol designed to operate
  23. astronomical instrumentation. INDI is small, flexible, easy to parse,
  24. and scalable. It supports common DCS functions such as remote control,
  25. data acquisition, monitoring, and a lot more.
  26. %package devel
  27. Summary: Libraries, includes, etc. used to develop an application with %{name}
  28. Group: Development/Libraries
  29. Requires: %{name} = %{version}-%{release}
  30. Provides: libindi-static = %{version}-%{release}
  31. %description devel
  32. These are the header files needed to develop a %{name} application
  33. %prep
  34. %setup -q -n %{name}%{majorver}-%{version}
  35. %patch0 -p1
  36. %patch1 -p1
  37. %build
  38. mkdir -p %{_target_platform}
  39. pushd %{_target_platform}
  40. CFLAGS="${CFLAGS:-%optflags}" \
  41. CXXFLAGS="${CXXFLAGS:-%optflags}" \
  42. FFLAGS="${FFLAGS:-%optflags}" \
  43. %cmake \
  44. -DCMAKE_BUILD_TYPE=release \
  45. -DDATA_INSTALL_DIR:PATH=%{_datadir} \
  46. ..
  47. popd
  48. make VERBOSE=1 %{?_smp_mflags} -C %{_target_platform}
  49. %install
  50. rm -fr %{buildroot}
  51. make install DESTDIR=%{buildroot} -C %{_target_platform}
  52. %clean
  53. rm -fr %{buildroot}
  54. %post -p /sbin/ldconfig
  55. %postun -p /sbin/ldconfig
  56. %files
  57. %defattr(-,root,root,-)
  58. %doc AUTHORS ChangeLog COPYING.LIB LICENSE README README.drivers README.robofocus
  59. %{_bindir}/*
  60. %{_libdir}/*.so.*
  61. %{_datadir}/indi
  62. %files devel
  63. %defattr(-,root,root,-)
  64. %doc README COPYING.LIB LICENSE
  65. %{_includedir}/*
  66. %{_libdir}/*.so
  67. %{_libdir}/*.a
  68. %changelog
  69. * Sat Apr 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6-11
  70. - rebuilt with new toolchain and libnova-0.13
  71. * Sat Sep 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 0.6-10
  72. - use %%cmake macro
  73. * Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6-9
  74. - Inisital build for Vine Linux
  75. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-8
  76. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  77. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-7
  78. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  79. * Wed Feb 18 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 0.6-6
  80. - Provides libindi-static
  81. * Tue Feb 17 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 0.6-5
  82. - Need to provide the static library libindidriver.a to build indi-apogee
  83. * Sat Feb 14 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 0.6-4
  84. - Fixed patch to find cfitsio
  85. * Sat Feb 14 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 0.6-3
  86. - Patch to detect cfitsio in all architectures
  87. * Fri Feb 06 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 0.6-2
  88. - Commands (rm, make) instead of macros
  89. - Upstream bug about licenses (GPLv2 missing)
  90. - Upstream bug about libindi calling exit
  91. * Mon Jan 28 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 0.6-1
  92. - First version