udisks-vl.spec 6.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220
  1. %define glib2_version 2.6.0
  2. %define dbus_version 1.2
  3. %define dbus_glib_version 0.82
  4. %define polkit_version 0.92
  5. %define parted_version 2.3
  6. %define udev_version 145
  7. %define mdadm_version 2.6.7
  8. %define device_mapper_version 1.02
  9. %define libatasmart_version 0.12
  10. %define sg3_utils_version 1.27
  11. %define smp_utils_version 0.94
  12. %define lvm2_version 2.02.78
  13. Summary: Storage Management Service
  14. Name: udisks
  15. Version: 1.0.2
  16. Release: 2%{?_dist_release}
  17. License: GPLv2+
  18. Group: System Environment/Libraries
  19. URL: http://www.freedesktop.org/wiki/Software/udisks
  20. Source0: http://hal.freedesktop.org/releases/%{name}-%{version}.tar.gz
  21. Patch0: 10-ide-cd-support.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. BuildRequires: glib2-devel >= %{glib2_version}
  24. BuildRequires: dbus-devel >= %{dbus_version}
  25. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  26. BuildRequires: polkit-devel >= %{polkit_version}
  27. BuildRequires: parted-devel >= %{parted_version}
  28. BuildRequires: device-mapper-devel >= %{device_mapper_version}
  29. BuildRequires: intltool
  30. BuildRequires: libatasmart-devel >= %{libatasmart_version}
  31. BuildRequires: libgudev1-devel >= %{udev_version}
  32. BuildRequires: libudev-devel >= %{udev_version}
  33. BuildRequires: sg3_utils-devel >= %{sg3_utils_version}
  34. BuildRequires: lvm2-devel >= %{lvm2_version}
  35. # needed to pull in the system bus daemon
  36. Requires: dbus >= %{dbus_version}
  37. # needed to pull in the udev daemon
  38. Requires: udev >= %{udev_version}
  39. # we need at least this version for bugfixes / features etc.
  40. Requires: libatasmart >= %{libatasmart_version}
  41. Requires: mdadm >= %{mdadm_version}
  42. # for smp_rep_manufacturer
  43. Requires: smp_utils >= %{smp_utils_version}
  44. # for mount, umount, mkswap
  45. Requires: util-linux-ng
  46. # for mkfs.ext3, mkfs.ext3, e2label
  47. Requires: e2fsprogs
  48. # for mkfs.xfs, xfs_admin
  49. Requires: xfsprogs
  50. # for mkfs.vfat
  51. Requires: dosfstools
  52. # for mlabel
  53. Requires: mtools
  54. # for mkntfs - no ntfsprogs on ppc, though
  55. %ifnarch ppc ppc64
  56. Requires: ntfsprogs
  57. %endif
  58. # for /proc/self/mountinfo, only available in 2.6.26 or higher
  59. Conflicts: kernel < 2.6.26
  60. # we need liblvm2app at least this recent since the ABI changed (sizes
  61. # reported in number of bytes instead of number of sectors) without
  62. # the sonumber changing
  63. #
  64. Requires: lvm2-libs >= %{lvm2_version}
  65. # Obsolete and Provide DeviceKit-disks - udisks provides exactly the same
  66. # ABI just with a different name and versioning-scheme
  67. #
  68. Obsoletes: DeviceKit-disks <= 009
  69. Provides: DeviceKit-disks = 010
  70. %description
  71. udisks provides a daemon, D-Bus API and command line tools
  72. for managing disks and storage devices.
  73. %package devel
  74. Summary: D-Bus interface definitions for udisks
  75. Group: Development/Libraries
  76. Requires: %{name} = %{version}-%{release}
  77. Requires: gtk-doc
  78. # See comment above
  79. #
  80. Obsoletes: DeviceKit-disks-devel <= 009
  81. Provides: DeviceKit-disks-devel = 010
  82. %description devel
  83. D-Bus interface definitions and documentation for udisks.
  84. %prep
  85. %setup -q
  86. %patch0 -p1
  87. %build
  88. %configure --enable-gtk-doc
  89. make
  90. %install
  91. rm -rf $RPM_BUILD_ROOT
  92. make install DESTDIR=$RPM_BUILD_ROOT
  93. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  94. rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
  95. rm -f $RPM_BUILD_ROOT%{_libdir}/polkit-1/extensions/*.la
  96. rm -f $RPM_BUILD_ROOT%{_libdir}/polkit-1/extensions/*.a
  97. # for now, include a compat symlink for the command-line tool
  98. # and man page
  99. ln -s udisks $RPM_BUILD_ROOT%{_bindir}/devkit-disks
  100. ln -s udisks.1 $RPM_BUILD_ROOT%{_datadir}/man/man1/devkit-disks.1
  101. # TODO: should be fixed upstream
  102. chmod 0644 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/udisks-bash-completion.sh
  103. %find_lang %{name}
  104. %clean
  105. rm -rf $RPM_BUILD_ROOT
  106. %files -f %{name}.lang
  107. %defattr(-,root,root,-)
  108. %doc README AUTHORS NEWS COPYING HACKING doc/TODO
  109. %{_sysconfdir}/avahi/services/udisks.service
  110. %{_sysconfdir}/dbus-1/system.d/*.conf
  111. %{_sysconfdir}/profile.d/*.sh
  112. /lib/udev/rules.d/*.rules
  113. /lib/udev/udisks-part-id
  114. /lib/udev/udisks-dm-export
  115. /lib/udev/udisks-probe-ata-smart
  116. /lib/udev/udisks-probe-sas-expander
  117. /lib/udev/udisks-lvm-pv-export
  118. /sbin/umount.udisks
  119. %{_bindir}/*
  120. %{_libexecdir}/*
  121. %{_mandir}/man1/*
  122. %{_mandir}/man7/*
  123. %{_mandir}/man8/*
  124. %{_datadir}/polkit-1/actions/*.policy
  125. %{_libdir}/polkit-1/extensions/*.so
  126. %{_datadir}/dbus-1/system-services/*.service
  127. %attr(0700,root,root) %dir %{_localstatedir}/run/udisks
  128. %attr(0700,root,root) %dir %{_localstatedir}/lib/udisks
  129. %files devel
  130. %defattr(-,root,root,-)
  131. %{_datadir}/dbus-1/interfaces/*.xml
  132. %{_datadir}/pkgconfig/udisks.pc
  133. %dir %{_datadir}/gtk-doc/html/udisks
  134. %{_datadir}/gtk-doc/html/udisks/*
  135. # Note: please don't forget the %{?dist} in the changelog. Thanks
  136. #
  137. %changelog
  138. * Sun Aug 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
  139. - add Patch0 (10-ide-cd-support.patch) from ubuntu
  140. * Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
  141. - new upstream release
  142. * Tue Nov 9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1-2
  143. - rebuilt with parted 2.3
  144. * Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-1
  145. - new upstream release
  146. * Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.0-1
  147. - Initial build for Vine Linux
  148. * Tue Mar 30 2010 Richard W.M. Jones <rjones@redhat.com> - 1.0.0-2%{?dist}
  149. - Bump release and rebuild so we link to the new libparted.
  150. * Mon Mar 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-1%{?dist}
  151. - Update to release 1.0.0
  152. * Tue Feb 23 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100223.1%{?dist}
  153. - Update to new git snapshot
  154. * Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.3%{?dist}
  155. - Require lvm2-libs >= 2.02.61 to get the right ABI for liblvm2app
  156. * Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.2%{?dist}
  157. - Update for new liblvm2app library
  158. * Mon Feb 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.1%{?dist}
  159. - Update to git snapshot
  160. * Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.2%{?dist}
  161. - Rebuild
  162. * Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.1%{?dist}
  163. - New git snapshot with LVM support
  164. * Tue Jan 12 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.3%{?dist}
  165. - Rebuild for new libparted
  166. * Mon Dec 07 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.2%{?dist}
  167. - Rebuild
  168. * Fri Dec 04 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.1%{?dist}
  169. - Updated for package review (#543608)
  170. * Wed Dec 02 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202%{?dist}
  171. - Git snapshot for upcoming 1.0.0 release