self-build-ffmpeg2theora-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147
  1. %define pkgname ffmpeg2theora
  2. %define name self-build-%{pkgname}
  3. %define version 0.28
  4. %define release 1%{?_dist_release}
  5. %define sourceurl http://www.v2v.cc/~j/ffmpeg2theora/downloads/%{pkgname}-%{version}.tar.bz2
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. License: GPLv2+
  13. Group: Restricted Software
  14. Requires(post): self-build-setup >= 0.9.9
  15. # (build)requies of target package.
  16. Requires(post): scons
  17. Requires(post): libogg-devel >= 1.1
  18. Requires(post): libtheora-devel >= 1.1.0
  19. Requires(post): libvorbis-devel
  20. Requires(post): self-build-ffmpeg >= 0.6.1
  21. BuildArch: noarch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. Packager: munepi
  24. %description
  25. ffmpeg2theora is a tool to convert any file that ffmpeg can
  26. decode to theora.
  27. If you install this package, it automaticaly downloads source
  28. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  29. And the created rpm packages are automatically installed
  30. if installation is executed by apt-get command or synaptic
  31. package manager.
  32. [Note]
  33. This package requires many other packages to compile
  34. targetsoftware. So it consume more disk space than usual.
  35. Also installation takes logner time because of compilation.
  36. (This will take a few minutes to quarter or half of an hour,
  37. depends on building environment)
  38. [About self-build package]
  39. For some kind of software, distributing of binary package
  40. may viorate the patent or law. Therefore we chose self-build
  41. packge, create binary package on your machine, for such kind
  42. of softwares instead of distributing binary package.
  43. Please obey the national law when you use the created binary
  44. packages. And if you want to use the softwares using patented
  45. thechnology, it may be required to get a permission, make an
  46. agreement or purchas a license. Please consider it with your
  47. purpose or way of use and take appropriate action.
  48. %description -l ja
  49. ffmpeg2theora は ffmpeg がデコードできるファイルを theora 形式
  50. に変換するツールです。
  51. このパッケージをインストールすると、自動的にソースコードを
  52. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  53. パッケージを作成します。
  54. また apt-get コマンドや synaptic パッケージマネージャから実行
  55. した場合は、作成された rpm パッケージのインストールも自動的に
  56. 行います。
  57. [注意]
  58. コンパイルに必要な多くの関連パッケージを要求するので通常より
  59. ディスクの領域を多く消費します。
  60. またインストール時にコンパイルを行うため、通常より時間がかか
  61. る場合があります。(環境にもよりますが数分から数十分程度)
  62. [self-build パッケージについて]
  63. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  64. 違反する可能性があるものがあります。その為、このような問題が
  65. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  66. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  67. ジという方法を採っています。
  68. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  69. アのライセンス、および利用する国の各種法令に従ってください。
  70. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  71. センスの購入などが必要となる場合がありますので、利用する目的
  72. や形態に応じて各自で判断し適切な対応を取ってください。
  73. %prep
  74. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  75. %install
  76. %{__rm} -rf ${RPM_BUILD_ROOT}
  77. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  78. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  79. %clean
  80. %{__rm} -rf ${RPM_BUILD_ROOT}
  81. %posttrans
  82. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 11000
  83. #/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release}
  84. %files
  85. %defattr(-,root,root)
  86. %{_datadir}/%{name}
  87. %changelog
  88. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.28-1
  89. - new upstream release
  90. - License: GPLv2+
  91. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.27-1
  92. - new upstream release
  93. - fixed the location of %%sourceurl
  94. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.25-2
  95. - renamed %%{Source0} to ffmpeg2theora-vl.spec
  96. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.25-1
  97. - new upstream release
  98. - with recent ffmpeg
  99. * Sat Jun 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.24-1
  100. - new upstream release
  101. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.23-2
  102. - added BuildArch: noarch
  103. - avoided to execute self-build-rpm.sh on RPM transaction
  104. - moved %%post actions to %%posttrans
  105. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.23-1
  106. - new upstream release
  107. - dropped ffmpeg2theora-0.20-new_ffmpeg.patch
  108. - added PreReq: scons
  109. * Sat May 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.20-2
  110. - spec in utf8
  111. * Sat May 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.20-1
  112. - initial build for Vine Linux.