gnome-shell-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357
  1. %bcond_with systemd
  2. Summary: Window management and application launching for GNOME
  3. Summary(ja): GNOME 上でウィンドウの管理及びアプリケーションの起動を行うインターフェース
  4. Name: gnome-shell
  5. Version: 3.36.4
  6. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPLv2+
  10. URL: http://live.gnome.org/GnomeShell
  11. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  12. Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  13. Requires: mutter
  14. Requires: ca-certificates
  15. Requires: at-spi2-atk
  16. Requires: network-manager-applet
  17. Requires: gnome-tweak-tool
  18. BuildRequires: meson
  19. BuildRequires: pkgconfig
  20. BuildRequires: python3
  21. BuildRequires: sassc
  22. BuildRequires: libxslt
  23. BuildRequires: gnome-common
  24. BuildRequires: at-spi2-atk-devel
  25. BuildRequires: evolution-data-server-devel
  26. BuildRequires: gcr-devel
  27. BuildRequires: gtk3-devel
  28. BuildRequires: gdk-pixbuf-devel
  29. BuildRequires: gobject-introspection-devel
  30. BuildRequires: glib2-devel
  31. BuildRequires: gjs-devel
  32. BuildRequires: libxml2-devel
  33. BuildRequires: clutter-devel
  34. BuildRequires: cogl-devel
  35. BuildRequires: mutter-devel
  36. BuildRequires: polkit-devel
  37. BuildRequires: startup-notification-devel
  38. BuildRequires: ibus-devel
  39. BuildRequires: libX11-devel
  40. BuildRequires: gsettings-desktop-schemas-devel
  41. BuildRequires: gnome-desktop3-devel
  42. BuildRequires: gnome-bluetooth-devel
  43. BuildRequires: gstreamer1-devel
  44. BuildRequires: NetworkManager-libnm-devel
  45. BuildRequires: libsecret-devel
  46. %if %{with systemd}
  47. BuildRequires: systemd-devel
  48. %endif
  49. BuildRequires: pulseaudio-libs-devel
  50. BuildRequires: gnome-autoar-devel
  51. BuildRequires: json-glib-devel
  52. BuildRequires: bash-completion
  53. BuildRequires: asciidoc
  54. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  55. %description
  56. GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
  57. It provides core interface functions like switching to windows and launching
  58. applications. GNOME Shell takes advantage of the capabilities of modern graphics
  59. hardware and introduces innovative user interface concepts to provide a delightful
  60. and easy to use experience.
  61. %package docs
  62. Summary: Documentation for %{name}
  63. Summary(ja): %{name} 用のドキュメント
  64. Group: Documentation
  65. Requires: %{name} = %{version}-%{release}
  66. BuildArch: noarch
  67. %description docs
  68. This package contains documentation for %{name}.
  69. %prep
  70. %setup -q
  71. %build
  72. export LANG=ja_JP.UTF-8
  73. %meson \
  74. %if !%{with systemd}
  75. -Dsystemd=false \
  76. %endif
  77. -Dgtk_doc=true
  78. %meson_build
  79. %install
  80. export LANG=ja_JP.UTF-8
  81. %{__rm} -rf %{buildroot}
  82. %meson_install
  83. %find_lang %{name}
  84. %clean
  85. %{__rm} -rf ${RPM_BUILD_ROOT}
  86. %post
  87. /sbin/ldconfig
  88. touch --no-create %{_datadir}/icons/hicolor
  89. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  90. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  91. fi
  92. %postun
  93. /sbin/ldconfig
  94. touch --no-create %{_datadir}/icons/hicolor
  95. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  96. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  97. fi
  98. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  99. %posttrans
  100. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  101. %files -f %{name}.lang
  102. %defattr(-,root,root,-)
  103. %license COPYING
  104. %doc NEWS README.md
  105. %dir %{_sysconfdir}/xdg
  106. %dir %{_sysconfdir}/xdg/autostart
  107. %{_sysconfdir}/xdg/autostart/gnome-shell-overrides-migration.desktop
  108. %{_bindir}/gnome-*
  109. %{_libdir}/%{name}/*
  110. %{_libexecdir}/gnome-shell-calendar-server
  111. %{_libexecdir}/gnome-shell-hotplug-sniffer
  112. %{_libexecdir}/gnome-shell-overrides-migration.sh
  113. %{_libexecdir}/gnome-shell-perf-helper
  114. %{_libexecdir}/gnome-shell-portal-helper
  115. %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
  116. %{_datadir}/applications/*.desktop
  117. %{_datadir}/dbus-1/interfaces/*.xml
  118. %{_datadir}/dbus-1/services/*.service
  119. %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
  120. %{_datadir}/glib-2.0/schemas/00_org.gnome.shell.gschema.override
  121. %{_datadir}/%{name}/*
  122. %{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
  123. %dir %{_datadir}/xdg-desktop-portal
  124. %dir %{_datadir}/xdg-desktop-portal/portals
  125. %{_datadir}/xdg-desktop-portal/portals/gnome-shell.portal
  126. %{_mandir}/man1/*.1*
  127. %dir %{_datadir}/bash-completion
  128. %dir %{_datadir}/bash-completion/completions
  129. %{_datadir}/bash-completion/completions/gnome-extensions
  130. %{_datadir}/icons/hicolor/scalable/apps/*
  131. %{_datadir}/icons/hicolor/symbolic/apps/*
  132. %{_datadir}/metainfo/*
  133. %if %{with systemd}
  134. %{_userunitdir}/*
  135. %endif
  136. %files docs
  137. %defattr(-,root,root,-)
  138. %{_datadir}/gtk-doc/html/shell
  139. %{_datadir}/gtk-doc/html/st
  140. %changelog
  141. * Tue Aug 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.36.4-1
  142. - new upstream release.
  143. * Fri Jan 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.2-1
  144. - new upstream release.
  145. - dropped Patch102: session tracker was switched to elogind.
  146. - added Patch105.
  147. * Fri Jan 26 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.20.4-1
  148. - new upstream release.
  149. * Sun Jul 31 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.3-2
  150. - new upstream release
  151. - add Patch104 (gnome-shell-3.20.3-vine-themes.patch)
  152. * Mon Jul 18 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.3-1
  153. - new upstream release
  154. - update Patch104 (gnome-shell-3.20.0-vine-themes.patch)
  155. * Fri Nov 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.3-1
  156. - new upstream release
  157. * Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
  158. - new upstream release
  159. * Thu Nov 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
  160. - new upstream release
  161. - update Patch104 (gnome-shell-3.18.1-vine-themes.patch)
  162. * Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
  163. - new upstream release
  164. * Sun Jun 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-3
  165. - add Patch104 (gnome-shell-3.16.2-vine-themes.patch)
  166. * Sun May 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
  167. - add Patch103 (gnome-shell-3.16.2-disable-packagekit.patch)
  168. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
  169. - new upstream release
  170. * Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
  171. - new upstream release
  172. * Thu Apr 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
  173. - new upstream release
  174. - add BuildRequires: python3-devel
  175. - update Patch102 (gnome-shell-3.16.0-revert-loginManager.patch)
  176. * Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.3-2
  177. - rebuilt with libical 1.0.1
  178. * Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.3-1
  179. - new upstream release
  180. * Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
  181. - new upstream release
  182. * Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
  183. - new upstream release
  184. - update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
  185. - add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
  186. * Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
  187. - new upstream release
  188. * Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
  189. - new upstream release
  190. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  191. - new upstream release
  192. * Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
  193. - new upstream release
  194. * Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
  195. - new upstream release
  196. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
  197. - new upstream release
  198. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
  199. - new upstream release
  200. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
  201. - new upstream release
  202. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  203. - new upstream release
  204. * Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
  205. - new upstream release
  206. - update Patch101 (gnome-shell-vine-settings.patch)
  207. - add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
  208. - add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
  209. - create %%{name}-docs subpackage
  210. * Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
  211. - new upstream release
  212. - remove Source102 (gnome-shell.gnome-3-6.ja.po)
  213. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  214. - new upstream release
  215. - add Source102 (gnome-shell.gnome-3-6.ja.po)
  216. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  217. - new upstream release
  218. - remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
  219. * Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
  220. - rebuild with telepathy-logger-0.6.0
  221. - add Patch0 (gnome-shell-3.4.1-git20121031.patch)
  222. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
  223. - new upstream release
  224. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  225. - new upstream release
  226. - add Patch0 (gnome-shell-3.5.92-git20120921.patch)
  227. - update Patch101 (gnome-shell-vine-settings.patch)
  228. - change BuildRequires: ca-certificates instead of openssl
  229. - add BuildRequires: libcanberra-gtl3-devel
  230. * Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  231. - new upstream release
  232. - remove Patch103 (gnome-shell-ja.po-date.patch)
  233. * Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  234. - new upstream release
  235. - update Patch101,103
  236. - remove Patch0,102
  237. - add BuildRequires: gcr-devel
  238. - remove BuildRequires: GConf2-devel
  239. - add Requires: at-spi2-atk
  240. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
  241. - new upstream release
  242. - remove Patch1
  243. * Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
  244. - add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
  245. - add Patch1 (gnome-shell-3.2.1-ja.po.patch)
  246. - rename Patch103 (gnome-shell-ja.po-date.patch)
  247. - drop Patch102
  248. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  249. - new upstream release
  250. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  251. - new upstream release
  252. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  253. - new upstream release
  254. - update Patch101
  255. - update Patch102
  256. - update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
  257. - add BuildRequires: libgudev1-devel, openssl
  258. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
  259. - new upstream release
  260. - add BuildRequires: folks-devel, NetworkManager-glib-devel
  261. - add Requires: caribou
  262. - remove Patch0
  263. - update Patch101
  264. - update Patch102
  265. - update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
  266. * Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
  267. - rebuild with gnome-menus-3.1.5
  268. - add Patch0 (gnome-shell-git20110821.patch)
  269. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  270. - new upstream release
  271. - add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
  272. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  273. - remove BuildRequires: xulrunner-devel
  274. - add Patch101 (gnome-shell-vine-settings.patch)
  275. - add Patch102 (gnome-shell-vine-customize.patch)
  276. - add Patch103 (gnome-shell-3.1.4-ja.po.patch)
  277. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
  278. - add Requires: mutter
  279. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
  280. - new upstream release
  281. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  282. - initial build for Vine Linux