gnome-panel-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753
  1. %bcond_with systemd
  2. %define use_eds 1
  3. %define gettext_package gnome-panel-2.0
  4. %define gnome_desktop3_version 2.91.0
  5. %define glib2_version 2.25.2
  6. %define gtk3_version 3.22.0
  7. %define libgnome_version 2.32.0
  8. %define orbit_version 2.14.19
  9. %define libwnck3_version 3.4.6
  10. %define gconf_version 2.32.0
  11. %define gnome_menus_version 3.7.90
  12. %define evolution_data_server_version 3.5.3
  13. %define cairo_version 1.0.0
  14. %define dbus_version 1.4.0
  15. %define dbus_glib_version 0.88
  16. %define libgweather_version 3.17.1
  17. %define libcanberra_version 0.25
  18. %define gobject_introspection_version 0.9.8
  19. Summary: GNOME panel
  20. Summary(ja): GNOME パネル
  21. Name: gnome-panel
  22. Version: 3.36.2
  23. Release: 1%{_dist_release}%{?with_systemd:.systemd}
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. URL: http://www.gnome.org/
  27. License: GPL
  28. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  29. Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  30. # Remove this line and next line when upstream adopt Source1
  31. Source2: vine6-panel-default-setup.entries
  32. Source5: vine-panel-backwards-compat-config.schemas
  33. Source12: gnome-compiler-flags.m4
  34. Source13: panel-default-layout.layout.vine
  35. Patch1000: gnome-panel-3.30.0-elogind.patch
  36. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  37. Requires: %{name}-libs = %{version}-%{release}
  38. Requires: gnome-desktop3 >= %{gnome_desktop3_version}
  39. Requires: libwnck3 >= %{libwnck3_version}
  40. Requires: gnome-menus >= %{gnome_menus_version}
  41. Requires: vine-menus >= 1.1
  42. Requires(post,postun): gtk3
  43. %if %{use_eds}
  44. Requires: evolution-data-server >= %{evolution_data_server_version}
  45. %endif
  46. Requires: libSM
  47. #BuildRequires: libxml2-python
  48. BuildRequires: intltool
  49. BuildRequires: gettext
  50. BuildRequires: automake
  51. BuildRequires: autoconf
  52. BuildRequires: libtool
  53. BuildRequires: libxslt
  54. BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
  55. BuildRequires: gtk3-devel >= %{gtk3_version}
  56. BuildRequires: libwnck3-devel >= %{libwnck3_version}
  57. BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
  58. BuildRequires: cairo-devel >= %{cairo_version}
  59. BuildRequires: yelp-tools
  60. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  61. BuildRequires: gtk-doc
  62. BuildRequires: pango-devel
  63. BuildRequires: libX11-devel
  64. BuildRequires: libXau-devel
  65. %if %{use_eds}
  66. BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
  67. #BuildRequires: ORBit2-devel >= %{orbit_version}
  68. BuildRequires: dbus-devel >= %{dbus_version}
  69. %endif
  70. BuildRequires: libgweather-devel >= %{libgweather_version}
  71. BuildRequires: libcanberra-devel >= %{libcanberra_versino}
  72. BuildRequires: librsvg2-devel
  73. BuildRequires: libSM-devel
  74. BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
  75. BuildRequires: dconf-devel
  76. BuildRequires: polkit-devel
  77. #BuildRequires: telepathy-glib-devel
  78. BuildRequires: desktop-file-utils
  79. BuildRequires: gdm-devel
  80. %if %{with systemd}
  81. BuildRequires: systemd-devel
  82. %else
  83. BuildRequires: elogind-devel
  84. %endif
  85. Obsoletes: gnome-netstatus < 2.29
  86. %description
  87. The GNOME panel provides the window list, workspace switcher, menus, and other
  88. features for the GNOME desktop.
  89. %description -l ja
  90. GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
  91. 特徴を GNOME デスクトップに提供します。
  92. %package libs
  93. Summary: Libraries for use in panel applets of GNOME
  94. Summary(ja): GNOME のパネルアップレットで使用するライブラリ
  95. Group: System Environment/Libraries
  96. %description libs
  97. Libraries for use in panel applets of GNOME.
  98. %description libs -l ja
  99. GNOME のパネルアプレットで使用するライブラリ
  100. %package devel
  101. Summary: Development environment for panel applets of GNOME
  102. Summary(ja): GNOME のパネルアップレット用開発環境
  103. Group: Development/Libraries
  104. Requires: %{name}-libs = %{version}-%{release}
  105. Requires: pkgconfig
  106. Requires: glib2-devel >= %{glib2_version}
  107. Requires: gtk3-devel >= %{gtk3_version}
  108. %description devel
  109. Header files and libraries for building a panel applets of GNOME.
  110. %description devel -l ja
  111. GNOME のパネルアプレットをビルドするためのヘッダファイル及びライブラリ集
  112. %prep
  113. %setup -q
  114. %if !%{with systemd}
  115. %patch1000 -p1 -b .elogind
  116. %endif
  117. cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
  118. cp -f %{SOURCE12} m4
  119. cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
  120. cp -f %{SOURCE13} data/panel-default-layout.layout
  121. %build
  122. autoreconf -vif
  123. %configure \
  124. --disable-gtk-doc \
  125. --enable-introspection=yes \
  126. %if %{use_eds}
  127. --enable-eds=yes
  128. %else
  129. --enable-eds=no
  130. %endif
  131. %__make %{?_smp_mflags}
  132. %install
  133. rm -rf $RPM_BUILD_ROOT
  134. make install DESTDIR=$RPM_BUILD_ROOT
  135. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  136. /bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  137. %find_lang %{gettext_package} --all-name --with-gnome
  138. %clean
  139. rm -rf $RPM_BUILD_ROOT
  140. %post
  141. /sbin/ldconfig
  142. touch --no-create %{_datadir}/icons/hicolor
  143. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  144. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  145. fi
  146. %postun
  147. /sbin/ldconfig
  148. touch --no-create %{_datadir}/icons/hicolor
  149. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  150. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  151. fi
  152. update-desktop-database -q &> /dev/null ||:
  153. %posttrans
  154. update-desktop-database -q &> /dev/null ||:
  155. %files -f %{gettext_package}.lang
  156. %defattr(-,root,root)
  157. %license COPYING COPYING.LIB
  158. %doc AUTHORS COPYING-DOCS NEWS README
  159. %{_bindir}/*
  160. %{_libdir}/%{name}/modules/*.so
  161. %{_datadir}/applications/*.desktop
  162. %{_datadir}/icons/hicolor/*/*/*
  163. %{_datadir}/glib-2.0/schemas/*.xml
  164. %{_datadir}/gnome-panel
  165. %{_mandir}/man*/*
  166. %files libs
  167. %{_libdir}/*.so.*
  168. %files devel
  169. %{_libdir}/pkgconfig/*.pc
  170. %{_includedir}/gnome-panel*
  171. %{_libdir}/*.so
  172. %{_datadir}/gtk-doc
  173. %changelog
  174. * Tue Aug 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.36.2-1
  175. - new upstream release.
  176. * Sun Dec 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.0-1
  177. - new upstream release.
  178. * Sat Jan 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.20.1-1
  179. - new upstream release.
  180. * Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.0-1
  181. - new upstream release
  182. * Fri Nov 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
  183. - new upstream release
  184. - add Source13 (panel-default-layout.layout.vine)
  185. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  186. - new upstream release
  187. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  188. - new upstream release
  189. - remove Patch0 (gnome-panel-3.5.91-configure.patch)
  190. - change BuildRequires: yelp-tools instead of gnome-doc-utils
  191. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.1-1
  192. - new upstream release
  193. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  194. - new upstream release
  195. - add BuildRequires: polkit-devel
  196. * Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  197. - new upstream release
  198. * Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  199. - new upstream release
  200. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  201. - new upstream release
  202. - remove BuildRequires: polkit-gnome-devel
  203. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-2
  204. - rebuild with evolution-data-server-3.1.90
  205. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
  206. - new upstream release
  207. * Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
  208. - new upstream release
  209. - drop old Patches
  210. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  211. - change BuildRequires: libwnck3-devel instead of libwnck-devel
  212. - add BuildRequires: dconf-devel, telepathy-glib-devel
  213. - add Obsoletes: gnome-netstatus
  214. - add Patch0 (gnome-panel-3.0.2-configure.patch)
  215. * Thu Jun 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-4
  216. - update SOURCE2(vine6-panel-default-setup.entries)
  217. - remove bottom panel
  218. - move window_list and workspace_switcher applet to top panel
  219. * Sat Dec 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-3
  220. - update Source1 (clock.gnome-2.32.ja.po)
  221. * Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
  222. - remove Provides: gnome-panel-devel
  223. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
  224. - new upstream release
  225. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.2-1
  226. - new upstream release
  227. - add BuildRequires: gobject-introspection-devel
  228. - remove BuildRequires: libgnomeui-devel
  229. - remove SOURCE3 and SOURCE4
  230. - drop Patch11
  231. - add configure option (--enable-introspection=yes)
  232. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
  233. - rebuild with rpm-4.8.1 for pkg-config file
  234. * Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
  235. - create -libs and -devel package
  236. * Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  237. - new upstream release
  238. * Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
  239. - rebuild with evolution-data-server-2.30.2
  240. * Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  241. - new upstream release
  242. - update Patch8, Patch9 (from FC package)
  243. - add BuildRequires: libcanberra-devel
  244. * Sat Mar 27 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-4
  245. - update translation of clock applet manual
  246. - add translation of fish applet manual
  247. * Fri Mar 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-3
  248. - add libSM(-devel) to (Build)Requires
  249. - add desktop-file-utils to BuildRequires
  250. * Thu Mar 25 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-2
  251. - update translation of clock applet manual
  252. * Sun Nov 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
  253. - new upstream release
  254. - updated Patch0 and 2
  255. * Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  256. - new upstream release
  257. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
  258. - rebuild with gtk2-2.16.3
  259. * Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  260. - add empty gconf entries to vine-panel-default-setup.entries
  261. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  262. - new upstream release
  263. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  264. - new upstream release
  265. * Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
  266. - update vine-panel-default-setup.entries again..
  267. * Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
  268. - update vine-panel-default-setup.entries
  269. * Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
  270. - remove mixer applets from default panel setup
  271. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  272. - new upstream release
  273. * Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
  274. - new upstream release
  275. - added BuildRequires: PolicyKit-gnome-devel
  276. * Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  277. - new upstream release
  278. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  279. - new upstream release
  280. * Tue Jun 3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
  281. - new upstream release
  282. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
  283. - new upstream release
  284. * Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
  285. - new upstream release
  286. - removed Patch25,26,27,29 and 30 (merged into upstream)
  287. * Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
  288. - added Patches from FC
  289. * Fri Mar 28 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-8
  290. - Fix editing of locations in the clock applet
  291. * Fri Mar 28 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-7
  292. - Convert the edit and find location windows to dialogs
  293. * Thu Mar 27 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-6
  294. - Improve the time settings window
  295. * Thu Mar 27 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-5
  296. - Make the find-location window of the clock larger
  297. * Sat Mar 15 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-4
  298. - Only save the session when the users wants it
  299. * Fri Mar 14 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-3
  300. - Populate the location list before showing the preference window
  301. * Sat Mar 8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
  302. - Add "About This Computer" item to System menu if it exists
  303. * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
  304. - Try harder to avoid resizing the popup
  305. - updated BuildRequires
  306. * Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  307. - new upstream release
  308. - added BuildRequires: libgweather-devel
  309. * Tue Jan 8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
  310. - new upstream release
  311. - updated %post and %postun section
  312. - added %pre and %preun section
  313. - added Patches from Fedora
  314. * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
  315. - Sharper icons
  316. * Wed Oct 3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
  317. - Make it possible to start s-c-d from the clock menu again (#316921)
  318. * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
  319. - Don't pop up an error if an applet from the default
  320. configuration is missing
  321. * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
  322. - Turns out we need requires for applets in the default config (#293261)
  323. * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
  324. - Drop the requires for fast-user-switch-applet (#253831)
  325. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
  326. - new upstream release
  327. - dropped Patch22 (merged into upstream)
  328. * Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  329. - new upstream release
  330. * Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
  331. - add missing BuildRequires to gnome-menus-devel (<BTS:319>)
  332. * Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
  333. - new upstream release
  334. - fix panel-default-setup.entries to change the name of
  335. firefox desktopfile (<BTS:229>)
  336. * Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
  337. - add patch 11 to fix disappearing of recent documents list.
  338. <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
  339. * Sat Jun 3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
  340. - new upstream release
  341. * Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  342. - new upstream release
  343. * Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
  344. - run gtk-update-icon-cache in %%post script.
  345. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  346. - new upstream release
  347. * Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
  348. - update vine-panel-default-setup.entries
  349. - replace mozilla by firefox
  350. - remove nautilus
  351. - add notification area applet on top panel
  352. - add trashbox applet on bottom panel
  353. - cleanup %%post script
  354. * Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
  355. - new upstream release
  356. * Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
  357. - new upstream release
  358. - added Prereq: scroolkeeper, GConf2
  359. * Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
  360. - new upstream release
  361. * Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
  362. - new upstream release
  363. * Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
  364. - new upstream release
  365. * Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
  366. - new upstream release
  367. * Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
  368. - new upstream release
  369. * Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
  370. - disable evolution-data-server
  371. * Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
  372. - new upstream release
  373. * Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
  374. - add Patch10 to fix hard-coded desktop file name.
  375. * Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  376. - new upstream version
  377. * Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
  378. - new upstream release
  379. - run scrollkeeper at %post, %postun
  380. * Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
  381. - new upstream release
  382. * Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
  383. - add Patch10 to fix egg-recent-model.c.
  384. save old umask value before create ".recently-used" file.
  385. * Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
  386. - fix location of nautilus launcher in panel-default-setup.entries.
  387. - do not add wireless monitor in %%post when no interfaces are available.
  388. - add Japanese summary and description
  389. - add BuildRequires: startup-notification-devel, gcc-c++.
  390. - disable libtoolize: version mismatch is bad
  391. * Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
  392. - new upstream release
  393. * Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
  394. - new upstream release
  395. * Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
  396. - rebuilt against new toolchain
  397. * Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
  398. - add --disable-schemas-install option to %%configure
  399. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  400. - new upstream release
  401. * Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
  402. - add missing files
  403. - add vine default panel entries
  404. * Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
  405. - new upstream release
  406. * Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
  407. - new upstream release
  408. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
  409. - new upstream release
  410. * Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
  411. - remove vine's panel-per-panel-config.schemas
  412. This should be added again in a future version.
  413. * Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
  414. - new upstream release
  415. * Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
  416. - new upstream release
  417. - remove old ja.po
  418. * Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
  419. - new upstream release
  420. * Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
  421. - remove clockaddon, system-tray-applet
  422. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  423. - new upstream release
  424. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
  425. - add patch1 from rawhide package.
  426. * Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
  427. - new upstream release
  428. * Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
  429. - add system-tray-applet
  430. - modify default panel menu.
  431. - update ja.po
  432. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
  433. - add Requires: vine-menus
  434. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
  435. - new upstream release
  436. * Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
  437. - remove redhatize patch.
  438. * Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
  439. - build for Vine Linux
  440. - new upstream release from gnome-2.1.4
  441. * Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  442. - fix postun script
  443. * Tue Oct 8 2002 Havoc Pennington <hp@redhat.com>
  444. - 2.0.9 with menu edit stuff
  445. - system-tray-applet 0.15 that doesn't crash all the time
  446. - merge/remove patches as appropriate
  447. * Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
  448. - Fix problem with "hold down print screen" (71432)
  449. * Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
  450. - panel-properties OnlyShowIn=GNOME;
  451. - somehow the po file got screwed up. Works now
  452. - update po files
  453. * Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
  454. - fix from #71762 for clock applet popdown key
  455. - no WIN_POS_MOUSE fixes #72167
  456. - fix for #72540 from George
  457. * Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
  458. - system tray applet 0.11 with a small memleak fix and a couple translations
  459. * Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
  460. - menu tweaks
  461. * Wed Aug 14 2002 Tim Powers <timp@redhat.com>
  462. - bump release
  463. * Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
  464. - put battery applet on panel for laptops (#67296)
  465. * Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
  466. - 2.0.6 final from gnome 2.0.1
  467. - remove gnome-panel-screenshot patch now upstream
  468. * Thu Aug 8 2002 Jonathan Blandford <jrb@redhat.com>
  469. - new system-tray-applet version
  470. - Fix gnome-panel-screenshot
  471. * Tue Aug 6 2002 Havoc Pennington <hp@redhat.com>
  472. - 2.0.4
  473. - replace gnome-logo-icon-transparent.png with redhat-main-menu.png
  474. for the foot menu
  475. * Fri Aug 2 2002 Havoc Pennington <hp@redhat.com>
  476. - fix desktop (logout/lock) menu item location
  477. in Alt+F1 and in new menu applets
  478. - remove Screenshot... menu item
  479. * Fri Aug 2 2002 Havoc Pennington <hp@redhat.com>
  480. - move around default applets, remove some of them
  481. - system tray 0.9
  482. - change default menu flags
  483. - blow unpackaged files out of build root
  484. * Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
  485. - 2.0.3
  486. - own libexecdir stuff
  487. * Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
  488. - new system tray that's prettier and doesn't clip the icon
  489. * Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
  490. - system tray 0.7 that doesn't crash on startup
  491. - get Mozilla desktop file right so we get web browser launcher
  492. * Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
  493. - system tray 0.6 with server file fixed (work dammit)
  494. * Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
  495. - tweak applet positions but I think it's just broken
  496. - system tray 0.5 moved back to libdir not libexecdir
  497. * Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
  498. - remove ltmain.sh hack
  499. - new system-tray-applet that works
  500. * Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
  501. - put office suite stuff on the panel
  502. * Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
  503. - 2.0.2.90 cvs snap
  504. * Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
  505. - update the clock patch to be a little smarter in a couple ways
  506. * Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
  507. - Fix problem where system tray applet was being looked for in /unst
  508. - Fix a crash in the system tray applet
  509. * Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
  510. - Fix typo in the pt_BR translation that was causing GConf problems
  511. * Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
  512. - add the system tray applet
  513. - add system tray applet by default
  514. - add more launcher by default
  515. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  516. - automated rebuild
  517. * Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
  518. - use correct gettext package name, and add check for missing translations
  519. * Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
  520. - add the calendar and configuration patch
  521. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  522. - 2.0.0
  523. - add control center desktop file to file list
  524. - add gnome-panelrc to file list
  525. - try fixing panel size (blind, no text box at home)
  526. * Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
  527. - rebuild in different environment
  528. * Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
  529. - updates to default configuration
  530. * Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
  531. - fix schemas installation
  532. * Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
  533. - unset old panel schemas when installing new ones
  534. - put in a broken panel config to see errors about
  535. - add a patch to give some decent error messages about what's wrong
  536. with the default panel config
  537. * Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
  538. - rebuild in different environment
  539. * Sun Jun 9 2002 Havoc Pennington <hp@redhat.com>
  540. - don't provide/obsolete gnome-core
  541. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  542. - rebuild in different environment
  543. * Wed Jun 5 2002 Havoc Pennington <hp@redhat.com>
  544. - 1.5.24
  545. - ldconfig
  546. * Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
  547. - rebuild in different environment
  548. * Fri May 31 2002 Havoc Pennington <hp@redhat.com>
  549. - 1.5.23
  550. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  551. - automated rebuild
  552. * Tue May 21 2002 Havoc Pennington <hp@redhat.com>
  553. - rebuild in different environment
  554. * Tue May 21 2002 Havoc Pennington <hp@redhat.com>
  555. - 1.5.22
  556. - provide gnome-core
  557. - add a bunch of extra build requires so build system
  558. won't get confused
  559. * Fri May 3 2002 Havoc Pennington <hp@redhat.com>
  560. - 1.5.19
  561. * Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
  562. - add the keep-libtool-from-relinking hack so
  563. we get the gen util applet
  564. * Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
  565. - obsoletes gnome-core-devel
  566. - include libdir/*.so
  567. * Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
  568. - get libpanel-applet in the package
  569. * Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
  570. - Initial build.