chromium12-vl.spec 28 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761
  1. # Thanks to malcolmlewis for help with this script
  2. # Thanks to Tom "spot" Callaway for much of the patchwork
  3. # Thanks to jhaygood for most of the icu patch
  4. %define pkgname chromium
  5. #% define with_system_icu 1
  6. #% define with_system_v8 1
  7. #NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
  8. # libvpx doesn't currently supply a pkg-config file, so we assume that
  9. # -lvpx is sufficient.
  10. %define with_system_vpx 1
  11. #Name: chromium12
  12. Name: chromium
  13. Summary: Google's opens source browser project
  14. Summary(ja): Googleのオープンソースウェブブラウザ
  15. #'
  16. Version: 12.0.742.93
  17. Release: 1%{?_dist_release}
  18. License: BSD
  19. Group: Applications/Internet
  20. Source0: %{pkgname}-%{version}.tar.xz
  21. # Script used to create the %{pkgname}-%{version}.tar.xz archive from
  22. # a official tarball:
  23. # http://build.chromium.org/official/chromium-12.0.742.XXX.tar.bz2
  24. Source3: pack_chromium12_source-vine.sh
  25. # Official ffmpeg headers
  26. Source8: ffmpeg-0.6-headers.tar.xz
  27. #Source10: chromium.desktop
  28. #Source10: chromium-vine.desktop
  29. # Patch template which adds vendor to user agent
  30. ##!!Source20: chromium-vendor.patch.in
  31. Source20: chromium-vendor-vine.patch.in
  32. # Set default prefs
  33. ##!!Source30: master_preferences
  34. Source30: master_preferences.vine
  35. ##!!Source31: default_bookmarks.html
  36. #Source31: default_bookmarks.html.vine
  37. Source99: chrome-wrapper
  38. ##!!Source100: chromium-browser.sh
  39. Source100: chromium-browser-vine.sh
  40. ##!!Source101: chromium-browser.desktop
  41. Source101: chromium-browser-vine.desktop
  42. Source102: chromium-browser.xml
  43. Source103: chromium-browser-rpmlintrc
  44. ##!!Source104: chromium-icons.tar.bz2
  45. %{?nosrc:NoSource: 0}
  46. Provides: chromium-browser = %{version}
  47. ##Provides: chromium-based-browser = %{version}
  48. ##Obsoletes: chromium-browser < %{version}
  49. ##Conflicts: chromium
  50. ## Start Patches
  51. # Many changes to the gyp systems so we can use system libraries
  52. Patch4: chromium-no-sqlite-debug.patch
  53. Patch8: chromium-codechanges-zlib.patch
  54. Patch12: chromium-no-test-sources.patch
  55. Patch13: chromium-no-courgette.patch
  56. Patch14: chromium-master-prefs-path.patch
  57. Patch17: chromium-system-glew.patch
  58. Patch18: chromium-system-expat.patch
  59. Patch19: chromium-system-zlib.patch
  60. Patch20: chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
  61. Patch21: chromium-7.0.542.0-media-probe.patch
  62. Patch25: tcmalloc-factory.patch
  63. Patch26: chromium-remoting-build-fix.diff
  64. Patch28: chromium-7.0.500.0-system-speex.patch
  65. Patch29: chromium-7.0.510.0-system-ffmpeg.patch
  66. Patch32: chromium-7.0.542.0-system-libvpx.patch
  67. Patch34: chromium-7.0.542.0-codechanges-system-minizip-v8.patch
  68. Patch62: chromium-norpath.patch
  69. Patch63: chromium-6.0.406.0-system-gyp-v8.patch
  70. # Vine
  71. Patch100: chromium-12.0.742.6-no-tests.patch
  72. BuildRequires: gcc gcc-c++
  73. BuildRequires: libstdc++ libstdc++-devel
  74. BuildRequires: libevent
  75. ##!!BuildRequires: pkg-config
  76. BuildRequires: python
  77. ##!!BuildRequires: python-xml
  78. BuildRequires: python-pyxml
  79. BuildRequires: perl bison flex gperf
  80. ##!!BuildRequires: wdiff
  81. ##!!BuildRequires: update-desktop-files
  82. #BuildRequires: lzma
  83. BuildRequires: xz
  84. ##!!BuildRequires: mozilla-nss-devel
  85. BuildRequires: nss-devel
  86. ##!!BuildRequires: alsa-devel
  87. BuildRequires: alsa-lib-devel
  88. BuildRequires: gtk2-devel
  89. BuildRequires: glib2-devel
  90. BuildRequires: cairo-devel >= 1.6
  91. ##!!BuildRequires: mozilla-nspr-devel
  92. BuildRequires: nspr-devel
  93. ##!!BuildRequires: gconf2-devel
  94. BuildRequires: GConf2-devel
  95. BuildRequires: freetype2-devel
  96. ##!!BuildRequires: dbus-1-devel
  97. BuildRequires: dbus-devel
  98. BuildRequires: libxslt-devel
  99. BuildRequires: libxml2-devel
  100. BuildRequires: libjpeg-devel
  101. BuildRequires: zlib-devel
  102. ##!!BuildRequires: libbz2-devel
  103. BuildRequires: bzip2-devel
  104. BuildRequires: cups-devel
  105. BuildRequires: fdupes
  106. ##!!BuildRequires: libexpat-devel
  107. BuildRequires: expat-devel
  108. BuildRequires: libpng-devel
  109. BuildRequires: sqlite3-devel
  110. BuildRequires: gnutls-devel
  111. BuildRequires: desktop-file-utils
  112. %{?with_system_v8:BuildRequires: v8-devel = %{v8_ver}}
  113. %{?with_system_vpx:BuildRequires: libvpx-devel >= 0.9.5}
  114. BuildRequires: pam-devel
  115. BuildRequires: libgnome-keyring-devel
  116. BuildRequires: python-devel
  117. BuildRequires: glew-devel
  118. ##!!BuildRequires: Mesa-devel
  119. BuildRequires: mesa-libGLU-devel
  120. BuildRequires: hunspell-devel
  121. %{?with_system_icu:BuildRequires: libicu-devel >= 4.0}
  122. BuildRequires: libevent-devel
  123. #BuildRequires: libjingle-devel >= 0.4.0-7
  124. #BuildRequires: srtp-devel
  125. BuildRequires: speex-devel
  126. ##Vine Linux
  127. %{?with_system_v8:Requires: v8 = %{v8_ver}}
  128. BuildRequires: libpaper-devel
  129. BuildRequires: libXScrnSaver-devel
  130. BuildRequires: libXtst-devel
  131. BuildRequires: libXdamage-devel
  132. BuildRequires: libXt-devel
  133. #BuildRequires: gle-devel
  134. #BuildRequires: webkit-gtk-devel
  135. #BuildRequires: scons
  136. %ifarch x86_64
  137. Requires: nspluginwrapper
  138. %endif
  139. ##!!Requires: alsa
  140. Requires: alsa-lib
  141. Requires: xdg-utils
  142. # shouldn't be required to name all dependencies
  143. # Requires: mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
  144. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  145. %description
  146. Chromium is the open-source project behind Google Chrome.
  147. We invite you to join us in our effort to help build a safer, faster,
  148. and more stable way for all Internet users to experience the web,
  149. and to create a powerful platform for developing a new generation of
  150. web applications.
  151. %description -l ja
  152. Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
  153. ウェブを体験しているすべてのインターネットユーザに対して
  154. より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
  155. そして、ウェブアプリケーションの新しい世代を発展させ、
  156. 強力なプラットホームを作成するために、
  157. 私たちの取り組みにぜひ参加してください。
  158. %prep
  159. #%setup -q
  160. [ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
  161. xz -dc %{SOURCE0} | %__tar -xf - || exit 1
  162. %setup -D -T -n %{pkgname}-%{version}
  163. %patch62 -p1
  164. %{?with_system_v8:%patch63 -p1}
  165. %patch100 -p1 -b .vine
  166. %patch4 -p1
  167. %patch8 -p1
  168. %patch12 -p1
  169. %patch13 -p1
  170. %patch14 -p1
  171. %patch17 -p1
  172. %patch18 -p1
  173. %patch19 -p1
  174. %patch20 -p1
  175. %patch21 -p1
  176. %patch25 -p1
  177. %patch26 -p1
  178. %patch28 -p1
  179. %patch29 -p1
  180. %{?with_system_vpx:%patch32 -p1}
  181. %{?with_system_v8:%patch34 -p1}
  182. pushd src/third_party/ffmpeg/
  183. %__tar xf %{SOURCE8} || exit 1
  184. ## built header file: avconfig.h
  185. [ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
  186. cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
  187. /* Generated by ffconf */
  188. #ifndef AVUTIL_AVCONFIG_H
  189. #define AVUTIL_AVCONFIG_H
  190. #define AV_HAVE_BIGENDIAN 0
  191. #endif /* AVUTIL_AVCONFIG_H */
  192. EOF
  193. popd
  194. #%__rm -rf src/third_party/libvpx/
  195. %__rm -rf src/third_party/speex/
  196. %__rm -rf src/third_party/nss src/third_party/nspr
  197. # apply vendor patch after substitution
  198. %__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
  199. %build
  200. ## create make files
  201. PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
  202. for i in src/build/common.gypi; do
  203. %__sed -i "s|'-march=pentium4',||g" $i
  204. %__sed -i "s|'-mfpmath=sse',||g" $i
  205. %__sed -i "s|'-O<(debug_optimize)',||g" $i
  206. %__sed -i "s|'-m32',||g" $i
  207. %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
  208. %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
  209. done
  210. # '
  211. pushd src
  212. ./build/gyp_chromium -f make build/all.gyp \
  213. -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
  214. -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
  215. -Duse_openssl=0 \
  216. -Duse_system_ffmpeg=1 \
  217. -Duse_system_zlib=1 \
  218. -Duse_system_libpng=1 \
  219. -Duse_system_bzip2=1 \
  220. -Duse_system_libbz2=1 \
  221. -Duse_system_libjpeg=1 \
  222. -Duse_system_libxml=1 \
  223. -Duse_system_libxslt=1 \
  224. -Duse_system_libevent=1 \
  225. %{?with_system_vpx:-Duse_system_vpx=1} \
  226. %{!?with_system_vpx:-Duse_system_vpx=0} \
  227. -Dproprietary_codecs=1 \
  228. -Dlibrary=shared_library \
  229. -Djavascript_engine=v8 \
  230. -Dlinux_fpic=1 \
  231. %{?with_system_v8:-Duse_system_v8=1} \
  232. %{!?with_system_v8:-Duse_system_v8=0} \
  233. %{?with_system_icu:-Duse_system_icu=1} \
  234. %{!?with_system_icu:-Duse_system_icu=0} \
  235. %ifarch %{ix86}
  236. -Dtarget_arch=ia32 \
  237. -Ddisable_sse2=1 \
  238. %endif
  239. %ifarch x86_64
  240. -Dtarget_arch=x64 \
  241. %endif
  242. %if %{?_dist_release} == "vl6"
  243. -Dno_strict_aliasing=1 -Dgcc_version=44 \
  244. %endif
  245. -Drelease_extra_cflags=-fPIC \
  246. ;
  247. #make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
  248. #%__make -r -j5 chrome BUILDTYPE=Release
  249. %__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
  250. popd
  251. %install
  252. %{__rm} -rf %{buildroot}
  253. %__mkdir -p %{buildroot}%{_bindir}
  254. %__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
  255. # x86_64 capable systems need this
  256. %__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
  257. %__mkdir -p %{buildroot}%{_libdir}/chromium/
  258. %__mkdir -p %{buildroot}%{_mandir}/man1/
  259. pushd src/out/Release
  260. %__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
  261. %__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
  262. %__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
  263. %__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/
  264. %__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/
  265. %__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
  266. %__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
  267. fdupes %{buildroot}%{_mandir}/man1/
  268. popd
  269. %__mkdir_p %{buildroot}%{_datadir}/pixmaps/
  270. %__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
  271. for i in 16 22 24 32 48 64 128 256; do
  272. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
  273. %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
  274. done
  275. %__mkdir_p %{buildroot}%{_datadir}/applications/
  276. desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
  277. %__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
  278. %__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
  279. # # link to browser plugin path. Plugin patch doesn't work. Why?
  280. # %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
  281. # pushd %{buildroot}%{_libdir}/%{pkgname}
  282. # %{__ln_s} %{_libdir}/browser-plugins plugins
  283. # popd
  284. pushd %{buildroot}%{_libdir}/%{pkgname}
  285. %ifarch x86_64
  286. %{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
  287. %else
  288. %{__ln_s} %{_libdir}/mozilla/plugins plugins
  289. %endif
  290. ## support ffmpeg libs
  291. touch %{buildroot}%{_libdir}/libavcodec.so.52
  292. %{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
  293. touch %{buildroot}%{_libdir}/libavformat.so.52
  294. %{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
  295. touch %{buildroot}%{_libdir}/libavutil.so.50
  296. %{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
  297. popd
  298. # Install the master_preferences file
  299. %__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
  300. #%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
  301. %__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
  302. #%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
  303. %clean
  304. %{__rm} -rf %{buildroot}
  305. %post
  306. touch --no-create %{_datadir}/icons/hicolor
  307. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  308. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  309. fi
  310. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
  311. %postun
  312. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications
  313. touch --no-create %{_datadir}/icons/hicolor
  314. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  315. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  316. fi || :
  317. %files
  318. %defattr(-,root,root,-)
  319. %config %{_sysconfdir}/%{pkgname}
  320. %dir %{_datadir}/gnome-control-center
  321. %dir %{_datadir}/gnome-control-center/default-apps
  322. %{_bindir}/chromium
  323. %{_libdir}/chromium/chromium
  324. %{_libdir}/chromium/plugins/
  325. %{_libdir}/chromium/resources/
  326. %{_libdir}/chromium/xdg-settings
  327. %{_mandir}/man1/chrom*
  328. %{_datadir}/pixmaps/chromium-browser.png
  329. %{_datadir}/icons/hicolor/*/apps/chromium-browser.png
  330. %{_datadir}/applications/*.desktop
  331. %{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
  332. %{_libdir}/chromium/libavcodec.so.52
  333. %{_libdir}/chromium/libavutil.so.50
  334. %{_libdir}/chromium/libavformat.so.52
  335. %exclude %{_libdir}/libavcodec.so.52
  336. %exclude %{_libdir}/libavutil.so.50
  337. %exclude %{_libdir}/libavformat.so.52
  338. ## libs
  339. %dir %{_libdir}/chromium/
  340. %{_libdir}/chromium/chrome.pak
  341. %{_libdir}/chromium/resources.pak
  342. %{_libdir}/chromium/locales/
  343. %{_libdir}/chromium/lib*.so
  344. %changelog
  345. * Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
  346. - updated to 12.0.742.93
  347. - fixed icon field of chromium-browser-vine.desktop
  348. * Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
  349. - updated to 12.0.742.91
  350. * Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
  351. - updated to 12.0.742.77
  352. * Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
  353. - updated to 12.0.742.63
  354. * Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
  355. - updated to 12.0.742.42
  356. * Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
  357. - updated to 12.0.742.6
  358. - dropped/upstreamed patches
  359. - updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
  360. * Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
  361. - updated to 11.0.696.50
  362. - dropped some Patches for MeeGo Netbook
  363. * Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
  364. - updated to 11.0.696.35
  365. * Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
  366. - updated to 11.0.696.29
  367. - dropped "--no-first-run" in command line options of chromium-browser-vine.sh
  368. * Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
  369. - updated to 11.0.696.22
  370. - improved chromium-browser-vine.sh
  371. - merged from chromium-browser-vine.desktop of 11.0.696.17-1
  372. * Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
  373. - updated to 11.0.696.20
  374. - improved chromium-browser-vine.desktop
  375. * Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
  376. - updated to 11.0.696.17
  377. * Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
  378. - updated to 11.0.696.15
  379. - ready for Vine Linux 6 release
  380. - dropped BuildRequires: v8-devel, libicu-devel
  381. * Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
  382. - updated to 11.0.696.5 with v8 3.2.0
  383. - added BuildRequires: pam-devel
  384. * Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
  385. - rebuilt with libevent-2.0.10
  386. * Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
  387. - updated to 10.0.651.0 with v8 3.0.12
  388. - added BuildRequires:
  389. - libpaper-devel
  390. - python-devel
  391. - added built header file: libavutil/avconfig.h %%prep
  392. - unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
  393. * Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
  394. - updated to 10.0.622.0
  395. - added BuildRequires: libXt-devel
  396. * Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
  397. - updated to 10.0.605.0
  398. - added BuildRequires:
  399. - libXdamage-devel
  400. - hunspell-devel
  401. * Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
  402. - updated to 9.0.598
  403. * Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
  404. - updated to 9.0.593
  405. * Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
  406. - updated to 9.0.582
  407. - added Requires: xdg-utils
  408. * Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
  409. - updated to 9.0.578
  410. * Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
  411. - updated to 9.0.569
  412. * Mon Oct 25 2010 tittiatcoke@gmail.com
  413. - Update to 9.0.564 build
  414. * Added specific patches for MeeGo.
  415. * We are now using shared libraries for Chromium
  416. * Spec-file cleanup (Thanks to prusnak)
  417. * Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
  418. - updated to snapshot 8.0.556
  419. * Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
  420. - updated to snapshot 8.0.551
  421. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
  422. - updated to snapshot 7.0.527
  423. * Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
  424. - updated to snapshot 7.0.519
  425. * Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
  426. - updated to snapshot 7.0.513
  427. - updated chromium-vendor-vine.patch.in
  428. * Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
  429. - updated to snapshot 7.0.507
  430. * Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
  431. - updated to snapshot 7.0.498
  432. * Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
  433. - updated to snapshot 6.0.493
  434. - used with_system_icu (for vl6)
  435. - added BuildRequires: libicu-devel
  436. * Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
  437. - build for Vine Linux 5.x
  438. - add BuildRequires: gnome-keyring-devel
  439. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
  440. - updated to snapshot 6.0.454
  441. - added BuildRequires:
  442. - sqlite3-devel
  443. - gnutls-devel
  444. - libgnome-keyring-devel
  445. * Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
  446. - updated to snapshot 6.0.431.0 r49253
  447. - added BuildRequires: cups-devel
  448. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
  449. - updated to snapshot 6.0.405.0 r47263
  450. * Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
  451. - unused with_system_icu (for vl6)
  452. - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
  453. * Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
  454. - updated to snapshot 5.0.378.0 r44472
  455. - used with_system_icu (for vl6)
  456. - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
  457. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
  458. - updated to snapshot 5.0.372.0 r43947
  459. - added BuildRequires: glew-devel
  460. - changed Group tag to Applications/Internet
  461. - added Summary(ja) and %%description -l ja
  462. * Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
  463. - updated to snapshot 5.0.365.0 r42966
  464. - merged 5.0.353.0-4vl5
  465. * Fri Apr 2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
  466. - build on Vine Linux 5.1
  467. - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
  468. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
  469. - updated to snapshot 5.0.364.0 r42779
  470. * Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
  471. - updated to snapshot 5.0.359.0 r42116
  472. - dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
  473. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
  474. - fixed master_preferences.vine, little
  475. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
  476. - fixed to install master_preferences
  477. - dropped chromium-5.0.353-no-ffmpeg-vine.patch
  478. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
  479. - applied chromium-5.0.353-no-ffmpeg-vine.patch
  480. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
  481. - updated to snapshot 5.0.353.0 r41449
  482. * Wed Mar 10 2010 bgmerrell@novell.com
  483. - Add master_preferences source file and install it to /etc/chromium.
  484. - Create a new patch (chromium-master-prefs-path.patch) which tells
  485. chromium to look in /etc/chromium for the master_preferences file
  486. (instead of looking in the default directory, which is the same
  487. directory as the 'chrome' binary).
  488. * Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
  489. - updated to snapshot 5.0.335.0 r39556
  490. * Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
  491. - applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
  492. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
  493. - updated to snapshot 5.0.330.0 r39074
  494. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
  495. - use_system_ffmpeg
  496. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
  497. - added Requires: nspluginwrapper
  498. - fixed a symbolic link of plugins directory with nspluginwrapper
  499. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
  500. - replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
  501. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
  502. - added BuildRequires: mesa-libGLU-devel
  503. - added BuildRequires: libstdc++34 libstdc++34-devel for vl5
  504. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
  505. - built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
  506. * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
  507. - Update to 4.0.260
  508. * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
  509. - Update to 4.0.259
  510. * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
  511. - Update to 4.0.258
  512. * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
  513. - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
  514. changed to having an built-in v8
  515. * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
  516. - Re-base patches. Fixed a few patch errors. Rename some patches to better correspond with function. Removed some patches.
  517. - Minor SPEC changes. I changed the v8 requirement to be exact, instead of greater than a specific version.
  518. * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
  519. - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
  520. * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
  521. - update to newer svn snapshot
  522. + Obsoletes fwrite patch (included upstream)
  523. * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
  524. - update to newer svn snapshot
  525. + Requires newer version of v8
  526. * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
  527. - do not force SSE on x86 (drop-sse.patch)
  528. * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
  529. - Update to newer svn snapshot
  530. - Fixed spec file in order to build
  531. - Included patch to build with system zlib
  532. * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
  533. - package renamed to chromium
  534. - cleaned up spec file
  535. * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
  536. - v8 is now built as a separate package, and is required
  537. - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
  538. * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
  539. - included a newer DEP than is in svn, native_client@823. So things should compile cleanly now
  540. * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
  541. - initial build
  542. #% changelog
  543. * Sun Jan 24 2010 prusnak@suse.cz
  544. - added vendor to user agent (chromium-vendor.patch.in)
  545. * Sun Nov 29 2009 prusnak@suse.cz
  546. - added --enable-sync to wrapper to enable bookmark sync
  547. * Sun Nov 29 2009 tittiatcoke@gmail.com
  548. - Update to 4.0.260
  549. * Fri Nov 27 2009 tittiatcoke@gmail.com
  550. - Update to 4.0.259
  551. * Thu Nov 26 2009 tittiatcoke@gmail.com
  552. - Update to 4.0.258
  553. * Tue Nov 24 2009 tittatcoke@gmai.com
  554. - In order to complete prevent the wrong v8 version to be used,
  555. the Chromium build has been changed to having an built-in v8
  556. * Tue Nov 24 2009 dbuck@example.com
  557. - Re-base patches.
  558. - Fixed a few patch errors.
  559. - Rename some patches to better correspond with function.
  560. - Removed some patches.
  561. - Minor SPEC changes.
  562. - I changed the v8 requirement to be exact, instead of greater than a specific version.
  563. * Fri Nov 13 2009 tittiatcoke@gmail.com
  564. - update to 247.0 svn 31928
  565. * Fri Oct 30 2009 tittiatcoke@gmail.com
  566. - update to 229.0 svn 30454
  567. + Fix regression where popups and app frames lost their titlebars.
  568. + Makes it so that when a folder is open on the bookmark bar
  569. and the mouse moves over another folder, the menu for that
  570. folder is shown.
  571. + Lazily create the find bar.
  572. + Polish to the gmail checker sample.
  573. * New, crisper icons that are exactly 19x19
  574. * Add a loading animation at the beginning before Gmail
  575. responds.
  576. * Fix a bug where we sometimes don't update the UI after a
  577. logout/login cycle.
  578. + Refactor widget methods to support desktop notifications,
  579. including GTK stubs.
  580. + Find-in-page should not ding while deleting characters.
  581. + Add SSL wrapper for linux and mac. This allows notifier to
  582. use chrome's SSL layer instead of OpenSSL.
  583. + Add three of the six extensions to PAC that Internet Explorer supports.
  584. + WebSocket support in chromium. (Run with --enable-web-sockets
  585. enables WebSocket features.)
  586. + Do not allow GTK File Chooser dialogs to return directories.
  587. + Fix the notifier SSL layer to make notifications work for
  588. Linux Bookmark sync.
  589. + linux: don't override mouse selection behavior in omnibox
  590. * Sun Oct 25 2009 tittiatcoke@gmail.com
  591. - Update to 224.4 svn 30027
  592. + First cut at new page and browser action docs based
  593. on new API. Deleted old stuff.
  594. + Add suppression for new memory leak caused by WebKit merge 49830:49844
  595. + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
  596. + Minimize dependency of user scripts
  597. + Fixup the flip_framer eof-handling semantics now that we have
  598. the FIN bit in place
  599. + app depends on x11 because of active_window_watcher_x
  600. + Adding two images for the new Extension managment UI
  601. + Removing hard-coded Chrome Frame output path
  602. + Rearrange clipboard code
  603. + Fix crash bug when attempting to download a url with unsupported scheme,
  604. e.g. 'data:', by 'Alt + Click'
  605. + GTK: Change text for extension download UI
  606. + Ignore invalid urls on command line
  607. + Make dropped tabs animate from where they were dropped.
  608. + Make room for the full width of the tab placeholder.
  609. + Make tab dragging as smooth as glass.
  610. + Remove an annoying NOTIMPLEMNETED
  611. + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
  612. + If we're in the middle of a drag, don't allow the user to middle
  613. click to close or right click for the context menu
  614. + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
  615. + Remove +x bit from files that shouldn't have it
  616. + Fold first 3 channels of multichannel instead of 5. Use fixed point
  617. + Adding new image needed for the managment UI
  618. + Fix a race bug where content scripts would not apply to the first page load
  619. + Make escape remove a bookmark if it's just been added (but not if it already existed)
  620. + Fix bubbles deactivating the opaque frame
  621. + Allow ESC to cancel ALT+SHIFT+T in Toolbar
  622. + ake all pepper plugins default to windowless and transparent
  623. + Add styles for printing
  624. + Implement the new extension management UI
  625. + Add support for to automation interface load install and load extensions
  626. + GTK: theme the info bar border
  627. + Update V8 to version 1.3.16.1
  628. + Introduce WebSecurityPolicy for security related methods
  629. + New button scheme...borders are separate from the inner contents so
  630. that they can be highlighted / depressed independently
  631. + When opening Chrome maximized with an application window already
  632. running, the Chrome window was not activated
  633. + Fix compatibility problems with FileZilla FTP Server
  634. + Remove the extension shelf on Linux
  635. + Fix the proxy host and port string to start with http:// if it does not already
  636. + Enable HTML5 databases for all extension renderer processes
  637. * Sat Oct 24 2009 prusnak@opensuse.org
  638. - don't create desktop files in wrapper
  639. - fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
  640. * Tue Oct 20 2009 tittiatcoke@gmail.com
  641. - update to newer svn snapshot
  642. + Obsoletes fwrite patch (included upstream)
  643. * Fri Oct 16 2009 tittiatcoke@gmail.com
  644. - update to newer svn snapshot
  645. + Requires newer version of v8
  646. * Thu Oct 15 2009 prusnak@suse.cz
  647. - do not force SSE on x86 (drop-sse.patch)
  648. * Tue Oct 13 2009 tittiatcoke@gmail.com
  649. - Update to newer svn snapshot
  650. - Fixed spec file in order to build
  651. - Included patch to build with system zlib
  652. * Mon Oct 12 2009 prusnak@suse.cz
  653. - package renamed to chromium
  654. - cleaned up spec file
  655. * Tue Oct 6 2009 dbuck@example.com
  656. - v8 is now built as a separate package, and is required
  657. - included many patches to use system libraries:
  658. v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
  659. * Thu Oct 1 2009 dbuck@example.com
  660. - included a newer DEP than is in svn, native_client@823
  661. - things should compile cleanly now
  662. * Mon Aug 31 2009 dbuck@example.com
  663. - initial build