chromium-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708
  1. # Thanks to malcolmlewis for help with this script
  2. # Thanks to Tom "spot" Callaway for much of the patchwork
  3. # Thanks to jhaygood for most of the icu patch
  4. # norootforbuild
  5. %if %{?_dist_release} == "vl6"
  6. %define with_system_icu 1
  7. %endif
  8. %define svn_rev 67715
  9. %define v8_ver 2.5.9
  10. Name: chromium
  11. Summary: Google's opens source browser project
  12. Summary(ja): Googleのオープンソースウェブブラウザ
  13. #'
  14. Version: 9.0.598.0
  15. Release: 1%{?_dist_release}
  16. License: BSD
  17. Group: Applications/Internet
  18. Source0: %{name}.%{version}.svn%{svn_rev}.tar.lzma
  19. ## The following are included for source reasons only
  20. # Custom build tools for chromium, hammer is a fancy front-end for scons
  21. Source1: http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
  22. # Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
  23. Source2: repack_chromium_archive.sh
  24. # Script used to create the tar.lzma archive from a checked out source
  25. Source3: pack_chromium_source.sh
  26. # Official ffmpeg headers
  27. Source8: ffmpeg-0.6-headers.tar.bz2
  28. #Source10: chromium.desktop
  29. #Source10: chromium-vine.desktop
  30. # Patch template which adds vendor to user agent
  31. ##!!Source20: chromium-vendor.patch.in
  32. Source20: chromium-vendor-vine.patch.in
  33. # Set default prefs
  34. ##!!Source30: master_preferences
  35. Source30: master_preferences.vine
  36. #Source31: default_bookmarks.html
  37. #Source31: default_bookmarks.html.vine
  38. # icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
  39. Source50: icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
  40. Source99: chrome-wrapper
  41. ##!!Source100: chromium-browser.sh
  42. Source100: chromium-browser-vine.sh
  43. ##!!Source101: chromium-browser.desktop
  44. Source101: chromium-browser-vine.desktop
  45. Source102: chromium-browser.xml
  46. Source103: chromium-browser-rpmlintrc
  47. %{?nosrc:NoSource: 0}
  48. %{?nosrc:NoSource: 1}
  49. %{?nosrc:NoSource: 50}
  50. Provides: chromium-browser = %{version}
  51. ##Provides: chromium-based-browser
  52. ##Obsoletes: chromium-browser < %{version}
  53. ## Start Patches
  54. # Many changes to the gyp systems so we can use system libraries
  55. # My first ever patch set. I hope I did well.
  56. Patch3: chromium-gyp-system-icu.patch
  57. Patch4: chromium-no-sqlite-debug.patch
  58. Patch5: chromium-gyp-system-04-nss-nspr.patch
  59. Patch7: chromium-codechanges-nss-nspr.patch
  60. Patch8: chromium-codechanges-zlib.patch
  61. Patch12: chromium-no-test-sources.patch
  62. Patch13: chromium-no-courgette.patch
  63. Patch14: chromium-master-prefs-path.patch
  64. Patch17: chromium-system-glew.patch
  65. Patch18: chromium-system-expat.patch
  66. Patch19: chromium-system-zlib.patch
  67. Patch20: chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
  68. Patch21: chromium-7.0.542.0-media-probe.patch
  69. Patch23: chromium-disable-mmx.patch
  70. Patch25: tcmalloc-factory.patch
  71. Patch26: chromium-remoting-build-fix.diff
  72. #Patch27: chromium-7.0.542.0-system-libjingle.patch
  73. Patch28: chromium-7.0.500.0-system-speex.patch
  74. Patch29: chromium-7.0.510.0-system-ffmpeg.patch
  75. Patch30: chromium-7.0.510.0-fstat.patch
  76. #Patch31: chromium-7.0.542.0-system-srtp.patch
  77. Patch32: chromium-7.0.542.0-system-libvpx.patch
  78. #Patch33: chromium-20090807-gyp-system-minizip.patch
  79. Patch34: chromium-7.0.542.0-codechanges-system-minizip-v8.patch
  80. # Shared Library patches
  81. Patch60: chromium-sharedlibfixes.patch
  82. Patch61: chromium-shared-chromiumthreading.patch
  83. Patch62: chromium-norpath.patch
  84. Patch63: chromium-6.0.406.0-system-gyp-v8.patch
  85. # Patches for MeeGo Netbook
  86. Patch80: chromium-browser-window-focus.patch
  87. Patch81: chromium-20100319-default-browser-setting.patch
  88. Patch82: chromium-20100506-expose-chromium-browser-api.patch
  89. Patch83: chromium-fix-toolbar-icon-size.patch
  90. # Vine
  91. BuildRequires: gcc gcc-c++
  92. %if %{?_dist_release} == "vl5"
  93. BuildRequires: libstdc++34 libstdc++34-devel
  94. %elseif %{?_dist_release} == "vl6"
  95. BuildRequires: libstdc++ libstdc++-devel
  96. %endif
  97. BuildRequires: libevent
  98. ##!!BuildRequires: pkg-config
  99. BuildRequires: python
  100. ##!!BuildRequires: python-xml
  101. BuildRequires: python-pyxml
  102. BuildRequires: perl bison flex gperf
  103. ##!!BuildRequires: wdiff
  104. ##!!BuildRequires: update-desktop-files
  105. BuildRequires: lzma
  106. ##!!BuildRequires: mozilla-nss-devel
  107. BuildRequires: nss-devel
  108. ##!!BuildRequires: alsa-devel
  109. BuildRequires: alsa-lib-devel
  110. BuildRequires: gtk2-devel
  111. BuildRequires: glib2-devel
  112. BuildRequires: cairo-devel >= 1.6
  113. ##!!BuildRequires: mozilla-nspr-devel
  114. BuildRequires: nspr-devel
  115. ##!!BuildRequires: gconf2-devel
  116. BuildRequires: GConf2-devel
  117. BuildRequires: freetype2-devel
  118. ##!!BuildRequires: dbus-1-devel
  119. BuildRequires: dbus-devel
  120. BuildRequires: libxslt-devel
  121. BuildRequires: libxml2-devel
  122. BuildRequires: libjpeg-devel
  123. BuildRequires: zlib-devel
  124. ##!!BuildRequires: libbz2-devel
  125. BuildRequires: bzip2-devel
  126. BuildRequires: cups-devel
  127. %if %{?_dist_release} == "vl6"
  128. BuildRequires: fdupes
  129. %endif
  130. ##!!BuildRequires: libexpat-devel
  131. BuildRequires: expat-devel
  132. BuildRequires: libpng-devel
  133. BuildRequires: sqlite3-devel
  134. BuildRequires: gnutls-devel
  135. BuildRequires: desktop-file-utils
  136. BuildRequires: v8-devel = %{v8_ver}
  137. BuildRequires: libvpx-devel
  138. %if %{?_dist_release} == "vl5"
  139. BuildRequires: gnome-keyring-devel
  140. %elseif %{?_dist_release} == "vl6"
  141. BuildRequires: libgnome-keyring-devel
  142. %endif
  143. BuildRequires: glew-devel
  144. ##!!BuildRequires: Mesa-devel
  145. BuildRequires: mesa-libGLU-devel
  146. %{?with_system_icu:BuildRequires: libicu-devel >= 4.0}
  147. BuildRequires: libevent-devel
  148. #BuildRequires: libjingle-devel >= 0.4.0-7
  149. #BuildRequires: srtp-devel
  150. BuildRequires: speex-devel
  151. ##Vine Linux
  152. Requires: v8 = %{v8_ver}
  153. BuildRequires: libXScrnSaver-devel
  154. BuildRequires: libXtst-devel
  155. #BuildRequires: gle-devel
  156. #BuildRequires: webkit-gtk-devel
  157. #BuildRequires: scons
  158. %ifarch x86_64
  159. Requires: nspluginwrapper
  160. %endif
  161. ##!!Requires: alsa
  162. Requires: alsa-lib
  163. Requires: xdg-utils
  164. # shouldn't be required to name all dependencies
  165. # Requires: mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
  166. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  167. %description
  168. Chromium is the open-source project behind Google Chrome.
  169. We invite you to join us in our effort to help build a safer, faster,
  170. and more stable way for all Internet users to experience the web,
  171. and to create a powerful platform for developing a new generation of
  172. web applications.
  173. %description -l ja
  174. Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
  175. 私たちは、ウェブを体験しているすべてのインターネットユーザに対して
  176. より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
  177. そして、ウェブアプリケーションの新しい世代を発展させるように
  178. 強力なプラットホームを作成するために、
  179. 私たちの取り組みで私たちに加わるようにあなたを誘います。
  180. %package devel
  181. Summary: Header file for chromium browser
  182. Group: Development/Libraries
  183. Requires: chromium = %{version}-%{release}
  184. %description devel
  185. This package contains the header files and pc file of chromium browser for
  186. applications which will use chromium browser APIs.
  187. %prep
  188. [ -d %{name} ] && %__rm -rf %{name}
  189. lzma -cd %{SOURCE0} | tar xf -
  190. %setup -D -T -n %{name}
  191. # use static libicu
  192. %if %{?_dist_release} == "vl5"
  193. cd src/third_party || exit 1
  194. %__rm -rf icu || exit 1
  195. tar jxvf %{SOURCE50} || exit 1
  196. %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
  197. cd - || exit 1
  198. %endif
  199. %patch60 -p1
  200. %patch61 -p1
  201. %patch62 -p1
  202. %patch63 -p1
  203. %patch80 -p1
  204. %patch81 -p1
  205. %patch82 -p1
  206. %patch83 -p1
  207. # use system libicu only if >= 4.0
  208. %{?with_system_icu:%patch3 -p1}
  209. %patch4 -p1
  210. %patch5 -p1
  211. %patch7 -p1
  212. %patch8 -p1
  213. %patch12 -p1
  214. %patch13 -p1
  215. %patch14 -p1
  216. %patch17 -p1
  217. %patch18 -p1
  218. %patch19 -p1
  219. %patch20 -p1
  220. %patch21 -p1
  221. %patch25 -p1
  222. %ifarch %ix86
  223. %patch23 -p1
  224. %endif
  225. %patch26 -p1
  226. #%patch27 -p1
  227. %patch28 -p1
  228. %patch29 -p1
  229. %patch30 -p1
  230. #%patch31 -p1
  231. %patch32 -p1
  232. #%patch33 -p1
  233. %patch34 -p1
  234. pushd src/third_party/ffmpeg/
  235. tar xf %{SOURCE8}
  236. popd
  237. %__rm -rf src/third_party/libvpx/ src/third_party/speex/
  238. # apply vendor patch after substitution
  239. %__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
  240. %build
  241. ## create make files
  242. PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
  243. for i in src/build/common.gypi; do
  244. %__sed -i "s|'-march=pentium4',||g" $i
  245. %__sed -i "s|'-msse2',||g" $i
  246. %__sed -i "s|'-mfpmath=sse',||g" $i
  247. %__sed -i "s|'-O<(debug_optimize)',||g" $i
  248. %__sed -i "s|'-m32',||g" $i
  249. %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
  250. %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
  251. done
  252. # '
  253. pushd src
  254. ./build/gyp_chromium -f make build/all.gyp \
  255. -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
  256. -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
  257. -Duse_system_ffmpeg=1 \
  258. -Duse_system_zlib=1 \
  259. -Duse_system_libpng=1 \
  260. -Duse_system_bzip2=1 \
  261. -Duse_system_libbz2=1 \
  262. -Duse_system_libjpeg=1 \
  263. -Duse_system_libxml=1 \
  264. -Duse_system_libxslt=1 \
  265. -Duse_system_libevent=1 \
  266. -Duse_system_vpx=1 \
  267. -Dproprietary_codecs=1 \
  268. -Dlibrary=shared_library \
  269. -Djavascript_engine=v8 \
  270. -Dlinux_fpic=1 \
  271. %{?with_system_icu:-Duse_system_icu=1} \
  272. %{!?with_system_icu:-Duse_system_icu=0} \
  273. %ifarch %{ix86}
  274. -Dtarget_arch=ia32 \
  275. -Ddisable_sse2=1 \
  276. %endif
  277. %ifarch x86_64
  278. -Dtarget_arch=x64 \
  279. %endif
  280. %if %{?_dist_release} == "vl6"
  281. -Dno_strict_aliasing=1 -Dgcc_version=44 \
  282. %endif
  283. -Drelease_extra_cflags=-fPIC \
  284. ;
  285. #make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
  286. #%__make -r -j5 chrome BUILDTYPE=Release
  287. %__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
  288. popd
  289. %install
  290. %{__rm} -rf %{buildroot}
  291. %__mkdir -p %{buildroot}%{_bindir}
  292. %__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
  293. # x86_64 capable systems need this
  294. %__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
  295. %__mkdir -p %{buildroot}%{_libdir}/chromium/
  296. %__mkdir -p %{buildroot}%{_mandir}/man1/
  297. pushd src/out/Release
  298. %__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
  299. %__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
  300. %__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
  301. %__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/
  302. %__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/
  303. #%__cp -a chrome_sandbox %{buildroot}%{_libdir}/chromium/chrome-sandbox
  304. %__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
  305. %__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
  306. %if %{?_dist_release} == "vl6"
  307. fdupes %{buildroot}%{_mandir}/man1/
  308. %endif
  309. popd
  310. # devel package install
  311. mkdir -p %{buildroot}%{_libdir}/chromium/include
  312. pushd src
  313. find base -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  314. find app -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  315. find chrome -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  316. find skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  317. find build -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  318. find googleurl -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  319. find ipc -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  320. find testing -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  321. find net -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  322. find third_party/skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  323. find third_party/WebKit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  324. find webkit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  325. find gfx -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  326. popd
  327. find %{buildroot}%{_libdir}/chromium/include -name "*.h" -exec chmod 644 {} \;
  328. %if %{?_dist_release} == "vl6"
  329. fdupes %{buildroot}%{_libdir}/chromium/include
  330. %endif
  331. %__mkdir_p %{buildroot}/%{_libdir}/pkgconfig
  332. cat <<EOF > %{buildroot}/%{_libdir}/pkgconfig/chromium-browser.pc
  333. Name: Chromium browser
  334. Description: Chromium browser development package
  335. Version: 1.0.1
  336. Libs: -L%{_libdir}/chromium -lapp_base -lappcache -lbase_i18n -lbase -lblob -lbrowser -lcacheinvalidation -lchrome_gpu -lchromoting_base -lchromoting_client -lchromoting_host -lchromoting_jingle_glue -lchromoting_protocol -lchromotocol_proto_lib -lcld -lcommon_constants -lcommon_net -lcommon -ldatabase -ldebugger -ldefault_plugin -ldynamic_annotations -lffmpeg -lfileapi -lgfx -lglue -lgoogleurl -lgtest -lharfbuzz_interface -lharfbuzz -lhttp_listen_socket -lhunspell -liccjpeg -lil -linstaller_util -lipc -ljingle_p2p -ljingle -lmedia -lmodp_b64 -lnet_base -lnet -lnotifier -lomx_wrapper -lots -lpcre -lppapi_plugin -lplugin -lprinting -lprofile_import -lprotobuf_lite -lrenderer -lsandbox -lsdch -lservice -lskia_opts -lskia -lsqlite3 -lsrtp -lssl_host_info -lssl -lsymbolize -lsyncapi -lsync_notifier -lsync -ltrace_proto_lib -lundoview -lutility -lwebcore_bindings -lwebcore_html -lwebcore_platform -lwebcore_remaining -lwebcore_svg -lwebkit -lwebkit_user_agent -lwebp -lworker -lwtf -lxdg_mime -lzlib
  337. Cflags: -I%{_libdir}/chromium/include -I%{_libdir}/chromium/include/skia/config
  338. EOF
  339. %__mkdir_p %{buildroot}%{_datadir}/pixmaps/
  340. %__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
  341. %__mkdir_p %{buildroot}%{_datadir}/applications/
  342. desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
  343. %__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
  344. %__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
  345. # # link to browser plugin path. Plugin patch doesn't work. Why?
  346. # %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
  347. # pushd %{buildroot}%{_libdir}/%{name}
  348. # %{__ln_s} %{_libdir}/browser-plugins plugins
  349. # popd
  350. pushd %{buildroot}%{_libdir}/%{name}
  351. %ifarch x86_64
  352. %{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
  353. %else
  354. %{__ln_s} %{_libdir}/mozilla/plugins plugins
  355. %endif
  356. ## support ffmpeg libs
  357. touch %{buildroot}%{_libdir}/libavcodec.so.52
  358. %{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
  359. touch %{buildroot}%{_libdir}/libavformat.so.52
  360. %{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
  361. touch %{buildroot}%{_libdir}/libavutil.so.50
  362. %{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
  363. popd
  364. # Install the master_preferences file
  365. %__mkdir_p %{buildroot}%{_sysconfdir}/%{name}
  366. #%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
  367. %__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
  368. #%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{name}
  369. %clean
  370. %{__rm} -rf %{buildroot}
  371. %files
  372. %defattr(-,root,root,-)
  373. %config %{_sysconfdir}/%{name}
  374. %dir %{_datadir}/gnome-control-center
  375. %dir %{_datadir}/gnome-control-center/default-apps
  376. %{_bindir}/chromium
  377. %{_libdir}/chromium/chromium
  378. # These unique permissions are intentional and necessary for the sandboxing
  379. #%attr(4555, root, root) %{_libdir}/chromium/chrome-sandbox
  380. %{_libdir}/chromium/plugins/
  381. %{_libdir}/chromium/resources/
  382. %{_libdir}/chromium/xdg-settings
  383. %{_mandir}/man1/chrom*
  384. %{_datadir}/pixmaps/chromium-browser.png
  385. %{_datadir}/applications/*.desktop
  386. %{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
  387. %{_libdir}/chromium/libavcodec.so.52
  388. %{_libdir}/chromium/libavutil.so.50
  389. %{_libdir}/chromium/libavformat.so.52
  390. %exclude %{_libdir}/libavcodec.so.52
  391. %exclude %{_libdir}/libavutil.so.50
  392. %exclude %{_libdir}/libavformat.so.52
  393. ## libs
  394. %dir %{_libdir}/chromium/
  395. %{_libdir}/chromium/chrome.pak
  396. %{_libdir}/chromium/resources.pak
  397. %{_libdir}/chromium/locales/
  398. %{_libdir}/chromium/lib*.so
  399. %files devel
  400. %defattr(-,root,root,-)
  401. %{_libdir}/chromium/include/
  402. %{_libdir}/pkgconfig/chromium-browser.pc
  403. %changelog
  404. * Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
  405. - updated to 9.0.598
  406. * Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
  407. - updated to 9.0.593
  408. * Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
  409. - updated to 9.0.582
  410. - added Requires: xdg-utils
  411. * Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
  412. - updated to 9.0.578
  413. * Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
  414. - updated to 9.0.569
  415. * Mon Oct 25 2010 tittiatcoke@gmail.com
  416. - Update to 9.0.564 build
  417. * Added specific patches for MeeGo.
  418. * We are now using shared libraries for Chromium
  419. * Spec-file cleanup (Thanks to prusnak)
  420. * Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
  421. - updated to snapshot 8.0.556
  422. * Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
  423. - updated to snapshot 8.0.551
  424. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
  425. - updated to snapshot 7.0.527
  426. * Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
  427. - updated to snapshot 7.0.519
  428. * Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
  429. - updated to snapshot 7.0.513
  430. - updated chromium-vendor-vine.patch.in
  431. * Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
  432. - updated to snapshot 7.0.507
  433. * Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
  434. - updated to snapshot 7.0.498
  435. * Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
  436. - updated to snapshot 6.0.493
  437. - used with_system_icu (for vl6)
  438. - added BuildRequires: libicu-devel
  439. * Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
  440. - build for Vine Linux 5.x
  441. - add BuildRequires: gnome-keyring-devel
  442. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
  443. - updated to snapshot 6.0.454
  444. - added BuildRequires:
  445. - sqlite3-devel
  446. - gnutls-devel
  447. - libgnome-keyring-devel
  448. * Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
  449. - updated to snapshot 6.0.431.0 r49253
  450. - added BuildRequires: cups-devel
  451. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
  452. - updated to snapshot 6.0.405.0 r47263
  453. * Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
  454. - unused with_system_icu (for vl6)
  455. - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
  456. * Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
  457. - updated to snapshot 5.0.378.0 r44472
  458. - used with_system_icu (for vl6)
  459. - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
  460. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
  461. - updated to snapshot 5.0.372.0 r43947
  462. - added BuildRequires: glew-devel
  463. - changed Group tag to Applications/Internet
  464. - added Summary(ja) and %%description -l ja
  465. * Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
  466. - updated to snapshot 5.0.365.0 r42966
  467. - merged 5.0.353.0-4vl5
  468. * Fri Apr 2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
  469. - build on Vine Linux 5.1
  470. - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
  471. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
  472. - updated to snapshot 5.0.364.0 r42779
  473. * Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
  474. - updated to snapshot 5.0.359.0 r42116
  475. - dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
  476. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
  477. - fixed master_preferences.vine, little
  478. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
  479. - fixed to install master_preferences
  480. - dropped chromium-5.0.353-no-ffmpeg-vine.patch
  481. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
  482. - applied chromium-5.0.353-no-ffmpeg-vine.patch
  483. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
  484. - updated to snapshot 5.0.353.0 r41449
  485. * Wed Mar 10 2010 bgmerrell@novell.com
  486. - Add master_preferences source file and install it to /etc/chromium.
  487. - Create a new patch (chromium-master-prefs-path.patch) which tells
  488. chromium to look in /etc/chromium for the master_preferences file
  489. (instead of looking in the default directory, which is the same
  490. directory as the 'chrome' binary).
  491. * Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
  492. - updated to snapshot 5.0.335.0 r39556
  493. * Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
  494. - applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
  495. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
  496. - updated to snapshot 5.0.330.0 r39074
  497. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
  498. - use_system_ffmpeg
  499. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
  500. - added Requires: nspluginwrapper
  501. - fixed a symbolic link of plugins directory with nspluginwrapper
  502. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
  503. - replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
  504. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
  505. - added BuildRequires: mesa-libGLU-devel
  506. - added BuildRequires: libstdc++34 libstdc++34-devel for vl5
  507. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
  508. - built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
  509. * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
  510. - Update to 4.0.260
  511. * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
  512. - Update to 4.0.259
  513. * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
  514. - Update to 4.0.258
  515. * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
  516. - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
  517. changed to having an built-in v8
  518. * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
  519. - Re-base patches. Fixed a few patch errors. Rename some patches to better correspond with function. Removed some patches.
  520. - Minor SPEC changes. I changed the v8 requirement to be exact, instead of greater than a specific version.
  521. * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
  522. - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
  523. * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
  524. - update to newer svn snapshot
  525. + Obsoletes fwrite patch (included upstream)
  526. * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
  527. - update to newer svn snapshot
  528. + Requires newer version of v8
  529. * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
  530. - do not force SSE on x86 (drop-sse.patch)
  531. * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
  532. - Update to newer svn snapshot
  533. - Fixed spec file in order to build
  534. - Included patch to build with system zlib
  535. * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
  536. - package renamed to chromium
  537. - cleaned up spec file
  538. * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
  539. - v8 is now built as a separate package, and is required
  540. - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
  541. * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
  542. - included a newer DEP than is in svn, native_client@823. So things should compile cleanly now
  543. * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
  544. - initial build
  545. #% changelog
  546. * Sun Jan 24 2010 prusnak@suse.cz
  547. - added vendor to user agent (chromium-vendor.patch.in)
  548. * Sun Nov 29 2009 prusnak@suse.cz
  549. - added --enable-sync to wrapper to enable bookmark sync
  550. * Fri Nov 13 2009 tittiatcoke@gmail.com
  551. - update to 247.0 svn 31928
  552. * Fri Oct 30 2009 tittiatcoke@gmail.com
  553. - update to 229.0 svn 30454
  554. + Fix regression where popups and app frames lost their titlebars.
  555. + Makes it so that when a folder is open on the bookmark bar
  556. and the mouse moves over another folder, the menu for that
  557. folder is shown.
  558. + Lazily create the find bar.
  559. + Polish to the gmail checker sample.
  560. * New, crisper icons that are exactly 19x19
  561. * Add a loading animation at the beginning before Gmail
  562. responds.
  563. * Fix a bug where we sometimes don't update the UI after a
  564. logout/login cycle.
  565. + Refactor widget methods to support desktop notifications,
  566. including GTK stubs.
  567. + Find-in-page should not ding while deleting characters.
  568. + Add SSL wrapper for linux and mac. This allows notifier to
  569. use chrome's SSL layer instead of OpenSSL.
  570. + Add three of the six extensions to PAC that Internet Explorer supports.
  571. + WebSocket support in chromium. (Run with --enable-web-sockets
  572. enables WebSocket features.)
  573. + Do not allow GTK File Chooser dialogs to return directories.
  574. + Fix the notifier SSL layer to make notifications work for
  575. Linux Bookmark sync.
  576. + linux: don't override mouse selection behavior in omnibox
  577. * Sun Oct 25 2009 tittiatcoke@gmail.com
  578. - Update to 224.4 svn 30027
  579. + First cut at new page and browser action docs based
  580. on new API. Deleted old stuff.
  581. + Add suppression for new memory leak caused by WebKit merge 49830:49844
  582. + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
  583. + Minimize dependency of user scripts
  584. + Fixup the flip_framer eof-handling semantics now that we have
  585. the FIN bit in place
  586. + app depends on x11 because of active_window_watcher_x
  587. + Adding two images for the new Extension managment UI
  588. + Removing hard-coded Chrome Frame output path
  589. + Rearrange clipboard code
  590. + Fix crash bug when attempting to download a url with unsupported scheme,
  591. e.g. 'data:', by 'Alt + Click'
  592. + GTK: Change text for extension download UI
  593. + Ignore invalid urls on command line
  594. + Make dropped tabs animate from where they were dropped.
  595. + Make room for the full width of the tab placeholder.
  596. + Make tab dragging as smooth as glass.
  597. + Remove an annoying NOTIMPLEMNETED
  598. + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
  599. + If we're in the middle of a drag, don't allow the user to middle
  600. click to close or right click for the context menu
  601. + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
  602. + Remove +x bit from files that shouldn't have it
  603. + Fold first 3 channels of multichannel instead of 5. Use fixed point
  604. + Adding new image needed for the managment UI
  605. + Fix a race bug where content scripts would not apply to the first page load
  606. + Make escape remove a bookmark if it's just been added (but not if it already existed)
  607. + Fix bubbles deactivating the opaque frame
  608. + Allow ESC to cancel ALT+SHIFT+T in Toolbar
  609. + ake all pepper plugins default to windowless and transparent
  610. + Add styles for printing
  611. + Implement the new extension management UI
  612. + Add support for to automation interface load install and load extensions
  613. + GTK: theme the info bar border
  614. + Update V8 to version 1.3.16.1
  615. + Introduce WebSecurityPolicy for security related methods
  616. + New button scheme...borders are separate from the inner contents so
  617. that they can be highlighted / depressed independently
  618. + When opening Chrome maximized with an application window already
  619. running, the Chrome window was not activated
  620. + Fix compatibility problems with FileZilla FTP Server
  621. + Remove the extension shelf on Linux
  622. + Fix the proxy host and port string to start with http:// if it does not already
  623. + Enable HTML5 databases for all extension renderer processes