123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712 |
- %bcond_with docs
- ## set to 1 to enable bootstrap
- #global bootstrap 1
- # define to build docs, need to undef this for bootstrapping
- # where qt5-qttools builds are not yet available
- # only primary archs (for now), allow secondary to bootstrap
- %if ! 0%{?bootstrap}
- %ifarch %{arm} %{ix86} x86_64
- %if %{with docs}
- #define docs 1
- %endif
- %endif
- %endif
- #define prerelease
- %global qt_module qttools
- %global qt5_minorver 5.15
- %global qt5_version 5.15.2
- #global qt5_patchlevel 1
- Summary: Qt5 - QtTool components
- Name: qt5-qttools
- Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
- Release: 1%{?_dist_release}
- Group: system
- Vendor: Project Vine
- Distribution: Vine Linux
- License: LGPLv3 or LGPLv2
- Url: https://www.qt.io/
- Source0: https://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-everywhere-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
- # help lrelease/lupdate use/prefer qmake-qt5
- # https://bugzilla.redhat.com/show_bug.cgi?id=1009893
- Patch2: qttools-opensource-src-5.13.2-runqttools-with-qt5-suffix.patch
- # 32-bit MIPS needs explicit -latomic
- Patch4: qttools-opensource-src-5.7-add-libatomic.patch
- # Link against libclang-cpp.so
- # https://fedoraproject.org/wiki/Changes/Stop-Shipping-Individual-Component-Libraries-In-clang-lib-Package
- Patch5: 0001-Link-against-libclang-cpp.so-instead-of-the-clang-co.patch
- ## upstream patches
- Source20: assistant.desktop
- Source21: designer.desktop
- Source22: linguist.desktop
- Source23: qdbusviewer.desktop
- BuildRequires: cmake
- BuildRequires: qt5-rpm-macros
- BuildRequires: qt5-srpm-macros
- BuildRequires: desktop-file-utils
- ## optional (and deprecated), include in bootstrapping only for now
- %if ! 0%{?bootstrap}
- #BuildRequires: pkgconfig(Qt5WebKit)
- #global webkit 1
- %endif
- BuildRequires: qt5-qtbase-static >= %{version}
- BuildRequires: qt5-qtdeclarative-static >= %{version}
- %if 0%{?bootstrap}
- %global no_examples CONFIG-=compile_examples
- Obsoletes: %{name}-examples < %{version}-%{release}
- %else
- # for qdoc
- BuildRequires: clang-devel llvm-devel
- %endif
- Requires: %{name}-common = %{version}-%{release}
- %{?_qt5:Requires: %{_qt5}%{?_isa} >= %{_qt5_version}}
- %description
- %{summary}.
- %package common
- Summary: Common files for %{name}
- Group: system
- BuildArch: noarch
- Obsoletes: qt5-qttools-libs-clucene < 5.9.0
- %if ! 0%{?webkit}
- Obsoletes: qt5-designer-plugin-webkit < 5.9.0
- %endif
- %description common
- %{summary}.
- %package devel
- Summary: Development files for %{name}
- Group: programming
- Requires: %{name} = %{version}-%{release}
- Requires: %{name}-libs-designer%{?_isa} = %{version}-%{release}
- Requires: %{name}-libs-designercomponents%{?_isa} = %{version}-%{release}
- Requires: %{name}-libs-help%{?_isa} = %{version}-%{release}
- Requires: qt5-doctools = %{version}-%{release}
- Requires: qt5-designer = %{version}-%{release}
- Requires: qt5-linguist = %{version}-%{release}
- Requires: qt5-qtbase-devel%{?_isa}
- %description devel
- %{summary}.
- %package static
- Summary: Static library files for %{name}
- Group: programming
- Requires: %{name}-devel%{?_isa} = %{version}-%{release}
- %description static
- %{summary}.
- %package libs-designer
- Summary: Qt5 Designer runtime library
- Group: system
- Requires: %{name}-common = %{version}-%{release}
- %description libs-designer
- %{summary}.
- %package libs-designercomponents
- Summary: Qt5 Designer Components runtime library
- Group: system
- Requires: %{name}-common = %{version}-%{release}
- %description libs-designercomponents
- %{summary}.
- %package libs-help
- Summary: Qt5 Help runtime library
- Group: programming
- Requires: %{name}-common = %{version}-%{release}
- %description libs-help
- %{summary}.
- %package -n qt5-assistant
- Summary: Documentation browser for Qt5
- Group: programming
- Requires: %{name}-common = %{version}-%{release}
- %description -n qt5-assistant
- %{summary}.
- %package -n qt5-designer
- Summary: Design GUIs for Qt5 applications
- Group: programming
- Requires: %{name}-libs-designer%{?_isa} = %{version}-%{release}
- Requires: %{name}-libs-designercomponents%{?_isa} = %{version}-%{release}
- %description -n qt5-designer
- %{summary}.
- %if 0%{?webkit}
- %package -n qt5-designer-plugin-webkit
- Summary: Qt5 designer plugin for WebKit
- Group: programming
- BuildRequires: pkgconfig(Qt5WebKitWidgets)
- Requires: %{name}-libs-designer%{?_isa} = %{version}-%{release}
- %description -n qt5-designer-plugin-webkit
- %{summary}.
- %endif
- %package -n qt5-linguist
- Summary: Qt5 Linguist Tools
- Group: programming
- Requires: %{name}-common = %{version}-%{release}
- %description -n qt5-linguist
- Tools to add translations to Qt5 applications.
- %package -n qt5-qdbusviewer
- Summary: D-Bus debugger and viewer
- Group: programming
- Requires: %{name}-common = %{version}-%{release}
- %{?_qt5:Requires: %{_qt5}%{?_isa} >= %{_qt5_version}}
- %description -n qt5-qdbusviewer
- QDbusviewer can be used to inspect D-Bus objects of running programs
- and invoke methods on those objects.
- %package -n qt5-doctools
- Summary: Qt5 doc tools package
- Group: programming
- Provides: qt5-qdoc = %{version}
- Obsoletes: qt5-qdoc < 5.8.0
- Provides: qt5-qhelpgenerator = %{version}
- Obsoletes: qt5-qhelpgenerator < 5.8.0
- Provides: qt5-qtattributionsscanner = %{version}
- Obsoletes: qt5-qtattributionsscanner < 5.8.0
- Requires: qt5-qtattributionsscanner = %{version}
- %description -n qt5-doctools
- %{summary}.
- %if 0%{?docs}
- %package doc
- Summary: API documentation for %{name}
- Group: documentation
- BuildRequires: qt5-qdoc
- BuildRequires: qt5-qhelpgenerator
- BuildArch: noarch
- Conflicts: qt5-qtbase-doc < 5.6.0
- %description doc
- %{summary}.
- %endif
- %package examples
- Summary: Programming examples for %{name}
- Group: programming
- Requires: %{name}-common = %{version}-%{release}
- %description examples
- %{summary}.
- %debug_package
- %prep
- %setup -q -n %{qt_module}-everywhere-src-%{version}
- %patch2 -p1 -b .runqttools-with-qt5-suffix.patch
- #patch4 -p1 -b .libatomic
- %patch5 -p1 -b .libclang-cpp
- %build
- mkdir %{_target_platform}
- pushd %{_target_platform}
- %{qmake_qt5} %{?no_examples} ..
- make %{?_smp_mflags}
- %if 0%{?docs}
- make %{?_smp_mflags} docs
- %endif
- popd
- %install
- rm -rf %{buildroot}
- make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
- %if 0%{?docs}
- make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
- %endif
- # Add desktop files, --vendor=qt4 helps avoid possible conflicts with qt3/qt4
- desktop-file-install \
- --dir=%{buildroot}%{_datadir}/applications \
- --vendor="qt5" \
- %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23}
- # icons
- install -m644 -p -D src/assistant/assistant/images/assistant.png %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/assistant-qt5.png
- install -m644 -p -D src/assistant/assistant/images/assistant-128.png %{buildroot}%{_datadir}/icons/hicolor/128x128/apps/assistant-qt5.png
- install -m644 -p -D src/designer/src/designer/images/designer.png %{buildroot}%{_datadir}/icons/hicolor/128x128/apps/designer-qt5.png
- install -m644 -p -D src/qdbus/qdbusviewer/images/qdbusviewer.png %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/qdbusviewer-qt5.png
- install -m644 -p -D src/qdbus/qdbusviewer/images/qdbusviewer-128.png %{buildroot}%{_datadir}/icons/hicolor/128x128/apps/qdbusviewer-qt5.png
- # linguist icons
- for icon in src/linguist/linguist/images/icons/linguist-*-32.png ; do
- size=$(echo $(basename ${icon}) | cut -d- -f2)
- install -p -m644 -D ${icon} %{buildroot}%{_datadir}/icons/hicolor/${size}x${size}/apps/linguist-qt5.png
- done
- # hardlink files to %{_bindir}, add -qt5 postfix to not conflict
- mkdir %{buildroot}%{_bindir}
- pushd %{buildroot}%{_qt5_bindir}
- for i in * ; do
- case "${i}" in
- assistant|designer|lconvert|linguist|lrelease|lupdate|pixeltool|qcollectiongenerator|qdbus|qdbusviewer|qhelpconverter|qhelpgenerator|qtplugininfo|qtattributionsscanner)
- ln -v ${i} %{buildroot}%{_bindir}/${i}-qt5
- ln -sv ${i} ${i}-qt5
- ;;
- *)
- ln -v ${i} %{buildroot}%{_bindir}/${i}
- ;;
- esac
- done
- popd
- ## .prl/.la file love
- # nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
- pushd %{buildroot}%{_qt5_libdir}
- for prl_file in libQt5*.prl ; do
- sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
- if [ -f "$(basename ${prl_file} .prl).so" ]; then
- rm -fv "$(basename ${prl_file} .prl).la"
- sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
- fi
- done
- popd
- ## Qt5Designer.pc references non-existent Qt5UiPlugin.pc, remove the reference for now
- sed -i -e 's| Qt5UiPlugin||g' %{buildroot}%{_qt5_libdir}/pkgconfig/Qt5Designer.pc
- ## work-in-progress... -- rex
- %check
- # verify validity of Qt5Designer.pc
- export PKG_CONFIG_PATH=%{buildroot}%{_libdir}/pkgconfig
- pkg-config --print-requires --print-requires-private Qt5Designer
- export CMAKE_PREFIX_PATH=%{buildroot}%{_qt5_prefix}:%{buildroot}%{_prefix}
- export PATH=%{buildroot}%{_qt5_bindir}:%{_qt5_bindir}:$PATH
- export LD_LIBRARY_PATH=%{buildroot}%{_qt5_libdir}
- mkdir -p tests/auto/cmake/%{_target_platform}
- pushd tests/auto/cmake/%{_target_platform}
- cmake ..
- ctest --output-on-failure ||:
- popd
- # check icon resolutions
- pushd %{buildroot}%{_datadir}/icons
- for RES in $(ls hicolor); do
- for APP in designer assistant linguist qdbusviewer; do
- if [ -e hicolor/$RES/apps/${APP}*.* ]; then
- file hicolor/$RES/apps/${APP}*.* | grep "$(echo $RES | sed 's/x/ x /')"
- fi
- done
- done
- popd
- %files
- %{_bindir}/qdbus-qt5
- %{_bindir}/qtpaths
- %{_qt5_bindir}/qdbus
- %{_qt5_bindir}/qdbus-qt5
- %{_qt5_bindir}/qtpaths
- %files common
- %license LICENSE.LGPL*
- %files libs-designer
- %{_qt5_libdir}/libQt5Designer.so.5*
- %dir %{_qt5_libdir}/cmake/Qt5Designer/
- %files libs-designercomponents
- %{_qt5_libdir}/libQt5DesignerComponents.so.5*
- %files libs-help
- %{_qt5_libdir}/libQt5Help.so.5*
- %files -n qt5-assistant
- %{_bindir}/assistant-qt5
- %{_qt5_bindir}/assistant*
- %{_datadir}/applications/*assistant.desktop
- %{_datadir}/icons/hicolor/*/apps/assistant*.*
- %files -n qt5-doctools
- %{_bindir}/qdoc*
- %{_qt5_bindir}/qdoc*
- %{_bindir}/qdistancefieldgenerator*
- %{_bindir}/qhelpgenerator*
- %{_qt5_bindir}/qdistancefieldgenerator*
- %{_qt5_bindir}/qhelpgenerator*
- %{_bindir}/qtattributionsscanner-qt5
- %{_qt5_bindir}/qtattributionsscanner*
- %files -n qt5-designer
- %{_bindir}/designer*
- %{_qt5_bindir}/designer*
- %{_datadir}/applications/*designer.desktop
- %{_datadir}/icons/hicolor/*/apps/designer*.*
- %{_qt5_libdir}/cmake/Qt5DesignerComponents/Qt5DesignerComponentsConfig*.cmake
- %if 0%{?webkit}
- %files -n qt5-designer-plugin-webkit
- %{_qt5_plugindir}/designer/libqwebview.so
- %{_qt5_libdir}/cmake/Qt5Designer/Qt5Designer_QWebViewPlugin.cmake
- %endif
- %files -n qt5-linguist
- %{_bindir}/linguist*
- %{_qt5_bindir}/linguist*
- # phrasebooks used by linguist
- %{_qt5_datadir}/phrasebooks/
- %{_datadir}/applications/*linguist.desktop
- %{_datadir}/icons/hicolor/*/apps/linguist*.*
- # linguist friends
- %{_bindir}/lconvert*
- %{_bindir}/lrelease*
- %{_bindir}/lupdate*
- %{_bindir}/lprodump*
- %{_qt5_bindir}/lconvert*
- %{_qt5_bindir}/lrelease*
- %{_qt5_bindir}/lupdate*
- %{_qt5_bindir}/lprodump*
- # cmake config
- %dir %{_qt5_libdir}/cmake/Qt5LinguistTools/
- %{_qt5_libdir}/cmake/Qt5LinguistTools/Qt5LinguistToolsConfig*.cmake
- %{_qt5_libdir}/cmake/Qt5LinguistTools/Qt5LinguistToolsMacros.cmake
- %files -n qt5-qdbusviewer
- %{_bindir}/qdbusviewer*
- %{_qt5_bindir}/qdbusviewer*
- %{_datadir}/applications/*qdbusviewer.desktop
- %{_datadir}/icons/hicolor/*/apps/qdbusviewer*.*
- %files devel
- %{_bindir}/pixeltool*
- %{_bindir}/qcollectiongenerator*
- #{_bindir}/qhelpconverter*
- %{_bindir}/qtdiag*
- %{_bindir}/qtplugininfo*
- %{_qt5_bindir}/pixeltool*
- %{_qt5_bindir}/qtdiag*
- %{_qt5_bindir}/qcollectiongenerator*
- #{_qt5_bindir}/qhelpconverter*
- %{_qt5_bindir}/qtplugininfo*
- %{_qt5_headerdir}/QtDesigner/
- %{_qt5_headerdir}/QtDesignerComponents/
- %{_qt5_headerdir}/QtHelp/
- %{_qt5_headerdir}/QtUiPlugin
- %{_qt5_libdir}/libQt5Designer*.prl
- %{_qt5_libdir}/libQt5Designer*.so
- %{_qt5_libdir}/libQt5Help.prl
- %{_qt5_libdir}/libQt5Help.so
- %{_qt5_libdir}/Qt5UiPlugin.la
- %{_qt5_libdir}/libQt5UiPlugin.prl
- %{_qt5_libdir}/cmake/Qt5Designer/Qt5DesignerConfig*.cmake
- %dir %{_qt5_libdir}/cmake/Qt5Help/
- %{_qt5_libdir}/cmake/Qt5Help/Qt5HelpConfig*.cmake
- %{_qt5_libdir}/cmake/Qt5UiPlugin/
- %{_qt5_libdir}/pkgconfig/Qt5Designer.pc
- %{_qt5_libdir}/pkgconfig/Qt5Help.pc
- %{_qt5_libdir}/pkgconfig/Qt5UiPlugin.pc
- %{_qt5_archdatadir}/mkspecs/modules/qt_lib_designer.pri
- %{_qt5_archdatadir}/mkspecs/modules/qt_lib_designer_private.pri
- %{_qt5_archdatadir}/mkspecs/modules/qt_lib_designercomponents_private.pri
- %{_qt5_archdatadir}/mkspecs/modules/qt_lib_help.pri
- %{_qt5_archdatadir}/mkspecs/modules/qt_lib_help_private.pri
- %{_qt5_archdatadir}/mkspecs/modules/qt_lib_uiplugin.pri
- %{_qt5_libdir}/cmake/Qt5AttributionsScannerTools/
- %{_qt5_libdir}/cmake/Qt5DocTools/
- %files static
- %{_qt5_headerdir}/QtUiTools/
- %{_qt5_libdir}/libQt5UiTools.*a
- %{_qt5_libdir}/libQt5UiTools.prl
- %{_qt5_libdir}/cmake/Qt5UiTools/
- %{_qt5_libdir}/pkgconfig/Qt5UiTools.pc
- %{_qt5_archdatadir}/mkspecs/modules/qt_lib_uitools.pri
- %{_qt5_archdatadir}/mkspecs/modules/qt_lib_uitools_private.pri
- %if 0%{?docs}
- %files doc
- %license LICENSE.FDL
- %{_qt5_docdir}/qtassistant.qch
- %{_qt5_docdir}/qtassistant/
- %{_qt5_docdir}/qtdesigner.qch
- %{_qt5_docdir}/qtdesigner/
- %{_qt5_docdir}/qdoc.qch
- %{_qt5_docdir}/qdoc/
- %{_qt5_docdir}/qthelp.qch
- %{_qt5_docdir}/qthelp/
- %{_qt5_docdir}/qtlinguist.qch
- %{_qt5_docdir}/qtlinguist/
- %{_qt5_docdir}/qtuitools.qch
- %{_qt5_docdir}/qtuitools/
- %endif
- %if ! 0%{?bootstrap}
- %files examples
- %{_qt5_examplesdir}/
- %{_qt5_plugindir}/designer/*
- %dir %{_qt5_libdir}/cmake/Qt5Designer
- %{_qt5_libdir}/cmake/Qt5Designer/Qt5Designer_*
- %endif
- %changelog
- * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.8-1
- - new upstream release.
- - dropped scriptlets.
- - dropped Patch2.
- - imported Patch2-5 from rawhide.
- * Mon Mar 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.7-1
- - new upstream release.
- * Sun Oct 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.5-1
- - new upstream release.
- - dropped Patch1.
- * Tue Jan 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.3-1
- - new upstream release.
- * Sun Jul 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
- - new upstream release.
- - initial build for Vine Linux.
- * Fri Jun 10 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
- - drop BR: double-conversion (fix qtdeclarative instead)
- * Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.1-1
- - Update to 5.6.1
- * Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-3
- - rebuild
- * Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-2
- - rebuild
- * Wed Mar 16 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-2
- - 5.6.0 final release
- * Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-1
- - 5.6.0 final release
- * Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.12.rc
- - Update to final RC
- * Fri Feb 19 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.11.rc
- - workaround Qt5Designer.pc reference to non-existent Qt5UiPlugin.pc
- * Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.10
- - Update RC release
- * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.9.rc
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
- * Sun Jan 17 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.8.rc
- - port QTBUG-43057 workaround
- * Mon Dec 28 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.7.rc
- - update source URL, use %%license
- * Mon Dec 21 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.6
- - Update to final rc release
- * Fri Dec 11 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-0.5
- - (re)fix bootstrap macro
- - include qt5-qdoc/qt5-qhelpgenerator build dep deps in -doc subpkg only
- - fix whitespace
- * Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.4
- - Official rc release
- * Tue Dec 08 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-3
- - Reenable examples. Some interfaces marked as examples are needed from phonon
- - Update to second rc snapshot
- * Sun Dec 06 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.2
- - de-bootstrap
- * Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
- - Start to implement 5.6.0 rc, bootstrapped
- * Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
- - Update to final release 5.5.1
- * Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
- - Update to Qt 5.5.1 RC1
- * Sat Aug 08 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-4
- - qt5-linguist: move lconvert,lrelease,lupdate, cmake Qt5LinguistTools here
- * Wed Jul 29 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-3
- - de-bootstrap
- * Thu Jul 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-2
- - qt5-designer, qt5-linguist, qt5-qhelpgenerator subpkgs
- * Wed Jul 1 2015 Helio Chissini de Castro <helio@kde.org> 5.5.0-1
- - New final upstream release Qt 5.5.0
- * Mon Jun 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.4.rc
- - Second round of builds now with bootstrap enabled due new qttools
- * Sat Jun 27 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.3.rc
- - Disable bootstrap
- * Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
- - Update for official RC1 released packages
- * Mon Jun 15 2015 Daniel Vrátil <dvratil@redhat.com> - 5.5.0-0.1.rc
- - Qt 5.5.0 RC1
- * Wed Jun 03 2015 Jan Grulich <jgrulich@redhat.com> - 5.4.2-1
- - 5.4.2
- * Sat May 02 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.1-3
- - rebuild (gcc5)
- * Fri Feb 27 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.1-2
- - rebuild (gcc5)
- * Tue Feb 24 2015 Jan Grulich <jgrulich@redhat.com> 5.4.1-1
- - 5.4.1
- * Thu Feb 19 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.0-2
- - rebuild (gcc5)
- * Wed Dec 10 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-1
- - 5.4.0 (final)
- * Tue Dec 09 2014 Daniel Vrátil <dvratil@redhat.com> 5.4.0-0.10.rc
- - fix icon name in qdbusviewer-qt5.desktop
- * Sun Nov 30 2014 Kevin Kofler <Kevin@tigcc.ticalc.org> 5.4.0-0.9.rc
- - install Linguist icon as linguist-qt5.png, fixes file conflict (#1169127)
- * Fri Nov 28 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.8.rc
- - 5.4.0-rc
- * Mon Nov 03 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.7.rc
- - out-of-tree build, use %%qmake_qt5
- * Fri Oct 31 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.6.rc
- - respin system-clucene.patch
- * Sun Oct 26 2014 Kevin Kofler <Kevin@tigcc.ticalc.org> 5.4.0-0.5.rc
- - system-clucene patch: create path recursively in QtCLucene, CLucene can't
- * Sun Oct 26 2014 Kevin Kofler <Kevin@tigcc.ticalc.org> 5.4.0-0.4.rc
- - disable bootstrap (reenable -doc)
- - system-clucene patch: drop -fpermissive flag
- - system-clucene patch: use toLocal8Bit instead of toStdString
- - system_clucene: BR clucene09-core-devel >= 0.9.21b-12 (-11 was broken)
- * Sat Oct 25 2014 Rex Dieter <rdieter@fedoraproject.org> - 5.4.0-0.3.rc
- - libQt5Designer should be in a subpackage (#1156685)
- - -doc: disable(boostrap for new clucene), drop dep on main pkg
- * Sat Oct 25 2014 Kevin Kofler <Kevin@tigcc.ticalc.org> 5.4.0-0.2.rc
- - BR and rebuild against reference-counting-enabled clucene09 (#1128293)
- * Sat Oct 18 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.1.rc
- - 5.4.0-rc
- * Fri Oct 17 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-2
- - -devel: Requires: qt5-designer-plugin-webkit
- * Tue Sep 16 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-1
- - 5.3.2
- * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
- * Tue Jun 17 2014 Jan Grulich <jgrulich@redhat.com> - 5.3.1-1
- - 5.3.1
- * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.0-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
- * Thu May 29 2014 Kevin Kofler <Kevin@tigcc.ticalc.org> 5.3.0-2
- - restore system-clucene patch, rm the bundled copy
- * Wed May 21 2014 Jan Grulich <jgrulich@redhat.com> 5.3.0-1
- - 5.3.0
- * Wed Feb 05 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-1
- - 5.2.1
- * Mon Jan 27 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-3
- - -examples subpkg
- * Tue Jan 14 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-2
- - epel7 bootstrapped
- * Thu Dec 12 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-1
- - 5.2.0
- * Mon Dec 02 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.10.rc1
- - 5.2.0-rc1
- * Mon Nov 25 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.5.rc1
- - enable -doc only on primary archs (allow secondary bootstrap)
- * Sat Nov 09 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.4.rc1
- - rebuild (arm/qreal)
- * Thu Oct 24 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.3.rc1
- - 5.2.0-rc1
- * Wed Oct 16 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.2.alpha
- - bootstrap ppc
- * Tue Oct 01 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.1.alpha
- - 5.2.0-alpha
- - -doc subpkg
- * Sat Sep 21 2013 Rex Dieter <rdieter@fedoraproject.org> 5.1.1-6
- - lupdate can't find qmake configuration file default (#1009893)
- * Sat Sep 21 2013 Rex Dieter <rdieter@fedoraproject.org> 5.1.1-4
- - use upstream cmake fix(es) (QTBUG-32570, #1006254)
- * Wed Sep 11 2013 Rex Dieter <rdieter@fedoraproject.org> 5.1.1-3
- - wrong path to lrelease (#1006254)
- - %%check: first try
- * Tue Sep 10 2013 Rex Dieter <rdieter@fedoraproject.org> 5.1.1-2
- - ExclusiveArch: %{ix86} x86_64 %{arm}
- - epel-6 love
- * Wed Aug 28 2013 Rex Dieter <rdieter@fedoraproject.org> 5.1.1-1
- - qttools-5.1.1
- - qt5-assistant, qt5-qdbusviewer, qt5-designer-plugin-webkit subpkgs (to match qt4)
- * Mon Aug 19 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-4
- - use system clucene09-core
- * Mon Apr 29 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-3
- - drop deprecated Encoding= key from .desktop files
- - add justification for desktop vendor usage
- * Fri Apr 19 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-2
- - add .desktop/icons for assistant, designer, linguist, qdbusviewer
- * Thu Apr 11 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-1
- - 5.0.2
- * Mon Feb 25 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.1-2
- - BR: pkgconfig(zlib)
- - -static subpkg
- * Sat Feb 23 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.1-1
- - first try
|