readline-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373
  1. Summary: A library for editing typed in command lines.
  2. Summary(ja): Readline ライブラリ
  3. Name: readline
  4. Version: 8.1.2
  5. %global shortver %(echo %{version} | cut -d . -f 1-2)
  6. %global shortver_nodots %(echo %{shortver} | tr -d ".")
  7. Release: 1%{?_dist_release}
  8. Group: system
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: GPLv3+
  12. URL: http://tiswww.tis.case.edu/~chet/readline/rltop.html
  13. %global baseurl https://ftp.gnu.org/gnu/readline
  14. Source: %{baseurl}/readline-%{shortver}.tar.gz
  15. # upstream patches
  16. Patch1: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-001
  17. Patch2: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-002
  18. # fix file permissions, remove RPATH, use CFLAGS
  19. Patch100: readline-8.0-shlib.patch
  20. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
  21. BuildRequires: sed
  22. BuildRequires: ncurses-devel
  23. Requires(post): /sbin/install-info
  24. Requires(preun): /sbin/install-info
  25. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  26. %description
  27. The Readline library provides a set of functions that allow users to
  28. edit command lines. Both Emacs and vi editing modes are available. The
  29. Readline library includes additional functions for maintaining a list
  30. of previously-entered command lines for recalling or editing those
  31. lines, and for performing csh-like history expansion on previous
  32. commands.
  33. %description -l ja
  34. Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
  35. Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
  36. これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
  37. %package devel
  38. Summary: Files needed to develop programs which use the readline library.
  39. Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
  40. Group: programming
  41. Requires: readline = %{version}
  42. Requires: ncurses-devel
  43. %description devel
  44. The Readline library provides a set of functions that allow users to
  45. edit typed command lines. If you want to develop programs that will
  46. use the readline library, you need to have the readline-devel package
  47. installed. You also need to have the readline package installed.
  48. %package -n compat32-%{name}
  49. Summary: A library for editing typed in command lines.
  50. Summary(ja): Readline ライブラリ
  51. Group: system
  52. Requires: %{name} = %{version}-%{release}
  53. %description -n compat32-%{name}
  54. The Readline library provides a set of functions that allow users to
  55. edit command lines. Both Emacs and vi editing modes are available. The
  56. Readline library includes additional functions for maintaining a list
  57. of previously-entered command lines for recalling or editing those
  58. lines, and for performing csh-like history expansion on previous
  59. commands.
  60. %description -n compat32-%{name} -l ja
  61. Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
  62. Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
  63. これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
  64. %package -n compat32-%{name}-devel
  65. Summary: Files needed to develop programs which use the readline library.
  66. Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
  67. Group: programming
  68. Requires: %{name} = %{version}-%{release}
  69. Requires: %{name}-devel = %{version}-%{release}
  70. Requires: compat32-ncurses-devel
  71. %description -n compat32-%{name}-devel
  72. The Readline library provides a set of functions that allow users to
  73. edit typed command lines. If you want to develop programs that will
  74. use the readline library, you need to have the readline-devel package
  75. installed. You also need to have the readline package installed.
  76. %debug_package
  77. %prep
  78. %setup -q -n %{name}-%{shortver}
  79. # upstream patches
  80. %patch1 -p0 -b .001
  81. %patch2 -p0 -b .002
  82. %patch100 -p1 -b .shlib
  83. %build
  84. %configure --with-curses --disable-install-examples
  85. make %{?_smp_mflags}
  86. %install
  87. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  88. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  89. make DESTDIR=$RPM_BUILD_ROOT install
  90. mkdir $RPM_BUILD_ROOT/%{_lib}
  91. mv $RPM_BUILD_ROOT%{_libdir}/libreadline.so.* $RPM_BUILD_ROOT/%{_lib}
  92. for l in $RPM_BUILD_ROOT%{_libdir}/libreadline.so; do
  93. ln -sf $(echo %{_libdir} | \
  94. sed 's,\(^/\|\)[^/][^/]*,..,g')/%{_lib}/$(readlink $l) $l
  95. done
  96. rm -rf $RPM_BUILD_ROOT%{_docdir}/readline
  97. rm -rf $RPM_BUILD_ROOT%{_datadir}/readline
  98. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  99. %clean
  100. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  101. %post
  102. /sbin/install-info %{_infodir}/history.info.gz %{_infodir}/dir &> /dev/null
  103. /sbin/install-info %{_infodir}/rluserman.info.gz %{_infodir}/dir &> /dev/null
  104. :
  105. %preun
  106. if [ $1 = 0 ]; then
  107. /sbin/install-info --delete %{_infodir}/history.info.gz %{_infodir}/dir &> /dev/null
  108. /sbin/install-info --delete %{_infodir}/rluserman.info.gz %{_infodir}/dir &> /dev/null
  109. fi
  110. :
  111. %post devel
  112. /sbin/install-info %{_infodir}/readline.info.gz %{_infodir}/dir &> /dev/null
  113. :
  114. %preun devel
  115. if [ $1 = 0 ]; then
  116. /sbin/install-info --delete %{_infodir}/readline.info.gz %{_infodir}/dir &> /dev/null
  117. fi
  118. :
  119. %files
  120. %defattr(-,root,root)
  121. %license COPYING
  122. %doc CHANGES NEWS README USAGE
  123. /%{_lib}/libreadline*.so.*
  124. %{_libdir}/libhistory*.so.*
  125. %{_infodir}/history.info*
  126. %{_infodir}/rluserman.info*
  127. %files devel
  128. %defattr(-,root,root)
  129. %doc examples/*.c examples/*.h examples/rlfe
  130. %{_includedir}/readline
  131. %{_libdir}/lib*.a
  132. %{_libdir}/lib*.so
  133. %{_libdir}/pkgconfig/*.pc
  134. %{_infodir}/readline.info*
  135. %{_mandir}/man*/*
  136. %if %{build_compat32}
  137. %files -n compat32-%{name}
  138. %defattr(-,root,root)
  139. /%{_lib}/libreadline*.so.*
  140. %{_libdir}/libhistory*.so.*
  141. %files -n compat32-%{name}-devel
  142. %defattr(-,root,root)
  143. %{_libdir}/lib*.a
  144. %{_libdir}/lib*.so
  145. %{_libdir}/pkgconfig/*.pc
  146. %endif
  147. %changelog
  148. * Fri Jan 14 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.1.2-1
  149. - updated to patchlevel 002.
  150. * Fri May 07 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.1.1-1
  151. - updated to patchlevel 001.
  152. - dropped ldconfig scriptlets.
  153. * Thu Feb 25 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.1-1
  154. - new upstream release.
  155. - dropped Patch1-4.
  156. * Sat Sep 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0.4-1
  157. - updated to patchlevel 004.
  158. * Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0-1
  159. - new upstream release.
  160. - dropped all of official patches.
  161. - added Patch1.
  162. - dropped Patch9.
  163. - updated Patch10.
  164. * Sat Mar 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.3-1
  165. - new upstream release
  166. - update upstream patches (patch1-8)
  167. * Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2-5
  168. - rebuild with VineSeed environment
  169. * Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 5.2-4
  170. - add upstream patches 13,14 (Patch13,14)
  171. * Fri Mar 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.2-3
  172. - rebuilt with new toolchain
  173. - add Requires(post,pre): /sbin/ldconfig
  174. * Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2-2vl5
  175. - build with ncurses-devel
  176. - spec in utf8
  177. - move libncurses.so.* to %%_lib from %%_libdir
  178. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-1vl5
  179. - added upstream patches (patch8-12)
  180. * Fri Oct 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-0vl1
  181. - new upstream release
  182. - update upstream patches (patch1-7)
  183. * Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 5.1-0vl1
  184. - new upstream release
  185. - update upstream patches (patch1-4)
  186. - add doc/*.{html,pdf} instead of doc/
  187. * Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.3-5vl3
  188. - s/Copyright/License/
  189. - add URL
  190. - update source URL
  191. - add PreReq: ldconfig
  192. - move outdated.patch (patch1) to patch10
  193. - add upstream patches (patch1-5)
  194. - add no_rpath.patch (patch11)
  195. * Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 4.3-5vl2
  196. - added compat32- packages for x86_64 architecture support
  197. - fixed %files section (TODO* has been removed)
  198. * Sat Mar 8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3-5vl1
  199. - new upstream release 4.3
  200. - merged with rawhide package.
  201. * Wed Nov 20 2002 Tim Powers <timp@redhat.com>
  202. - rebuild in current collinst
  203. - BuildRequires autoconf only
  204. * Wed Aug 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-3
  205. - Fixed Esc-O-M stack overflow bug.
  206. * Mon Jul 22 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-1
  207. - Updated to latest readline release 4.3
  208. * Thu Jul 11 2002 Phil Knirsch <pknirsch@redhat.com> 4.2a-7
  209. - Fixed problem with alpha build.
  210. * Wed Jul 10 2002 Phil Knirsch <pknirsch@redhat.com>
  211. - Fixed utf8 problem (originally observed in bash).
  212. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 4.2a-6
  213. - automated rebuild
  214. * Thu May 23 2002 Tim Powers <timp@redhat.com> 4.2a-5
  215. - automated rebuild
  216. * Wed Mar 20 2002 Trond Eivind Glomsrod <teg@redhat.com> 4.2a-4
  217. - Use autoconf 2.53, not 2.52
  218. * Mon Mar 4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-3
  219. - Rebuild
  220. * Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 4.2a-2
  221. - removed the manual symlinking of .so, readline handles this by itself
  222. - call only %%makeinstall, not %%makeinstall install install-shared as
  223. this makes bogus .old files in the buildroot
  224. * Tue Nov 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-1
  225. - 4.2a
  226. * Tue Oct 2 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-4
  227. - Work around autoconf bug
  228. * Mon Oct 1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-3
  229. - Don't use readline's internal re-implementation of strpbrk on systems
  230. that have strpbrk - the system implementation is faster and better maintained.
  231. * Tue Aug 7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-2
  232. - Make sure headers can be included from C++ applications (#51131)
  233. (Patch based on Debian's with the bugs removed ;) )
  234. * Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  235. - update to 4.2 and adapt patches
  236. * Fri Apr 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  237. - change the paths listed for the header files in the man page to reflect
  238. the location changes from previous versions (#35073)
  239. - note that "on" is acceptable instead of "On" in the man page (#21327)
  240. * Thu Mar 8 2001 Preston Brown <pbrown@redhat.com>
  241. - fix reading of end key termcap value (@7 is correct, was kH) (#30884)
  242. * Tue Jan 30 2001 Nalin Dahyabhai <nalin@redhat.com>
  243. - mark the man page as currently out-of-date (#25294)
  244. * Tue Sep 4 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl5
  245. - remove texi2dvi and texi2html from doc/
  246. * Fri Jun 29 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl4
  247. - added doc and examples
  248. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  249. - 4.1-6vl3
  250. - rebuilt for VineSeed
  251. * Wed Dec 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  252. - 4.1-6vl2
  253. - Oops, spec was written in SJIS...
  254. * Sat Dec 9 2000 Jun Nishii <jun@vinelinux.org>
  255. - 4.1-6vl1
  256. - got i18n patch from Kondara
  257. * Thu Sep 7 2000 Jeff Johnson <jbj@redhat.com>
  258. - FHS packaging (64bit systems need to use libdir).
  259. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  260. - summaries from specspo.
  261. * Wed Aug 2 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  262. - use "rm -f" in specfile
  263. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  264. - automatic rebuild
  265. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  266. - FHS packaging.
  267. * Tue Mar 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  268. - 4.1
  269. * Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
  270. - update to 4.0
  271. * Fri Apr 09 1999 Michael K. Johnson <johnsonm@redhat.com>
  272. - added guard patch from Taneli Huuskonen <huuskone@cc.helsinki.fi>
  273. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  274. - auto rebuild in the new build environment (release 4)
  275. * Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
  276. - updated to 2.2.1
  277. * Wed May 06 1998 Prospector System <bugs@redhat.com>
  278. - translations modified for de, fr, tr
  279. * Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
  280. - don't package /usr/info/dir
  281. * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
  282. - devel package moved to Development/Libraries
  283. * Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
  284. - updated to 2.2
  285. * Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
  286. - spec file cleanups
  287. * Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
  288. - added proper sonames
  289. * Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
  290. - updated to readline 2.1
  291. * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
  292. - built against glibc