libomp-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. %define _unpackaged_files_terminate_build 1
  5. Summary: OpenMP runtime for clang
  6. Summary(ja): clang用OpenMPランタイム
  7. Name: libomp
  8. Version: 15.0.6
  9. Release: 1%{?_dist_release}
  10. Group: system
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: NCSA
  14. URL: https://llvm.org/
  15. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/openmp-%{version}.src.tar.xz
  16. Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/cmake-%{version}.src.tar.xz
  17. # patches
  18. Patch0: 0001-PATCH-openmp-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-.patch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  20. BuildRequires: cmake
  21. BuildRequires: ninja
  22. BuildRequires: libffi-devel >= 3.3
  23. BuildRequires: elfutils-libelf-devel
  24. BuildRequires: clang-tools-extra
  25. # The AMDGCN device RTL requires clang and llvm-link to build
  26. BuildRequires: clang
  27. BuildRequires: llvm
  28. # libomptarget needs the llvm cmake files
  29. BuildRequires: llvm-devel
  30. BuildRequires: llvm-static
  31. %description
  32. The package contains the OpenMP runtime for clang.
  33. %package devel
  34. Summary: OpenMP header files
  35. Summary(ja): OpenMPヘッダファイル
  36. Group: programming
  37. Requires: clang-devel%{?isa} = %{version}
  38. %description devel
  39. The package contains the OpenMP header files.
  40. %debug_package
  41. %prep
  42. %autosetup -p2 -n openmp-%{version}.src -a 1
  43. mv -f cmake-%{version}.src/Modules/* cmake/
  44. %build
  45. # LTO causes build failures in this package. Disable LTO for now
  46. %define _lto_cflags %{nil}
  47. %cmake \
  48. -GNinja \
  49. -DLIBOMP_INSTALL_ALIASES=OFF \
  50. -DLLVM_DIR=%{_libdir}/cmake/llvm \
  51. -DLIBOMP_HEADERS_INSTALL_PATH:PATH=%{_libdir}/clang/%{version}/include \
  52. %if 0%{?__isa_bits} == 64
  53. -DOPENMP_LIBDIR_SUFFIX=64 \
  54. %else
  55. -DOPENMP_LIBDIR_SUFFIX= \
  56. %endif
  57. -DCMAKE_SKIP_RPATH:BOOL=ON
  58. %cmake_build
  59. %install
  60. rm -rf %{buildroot}
  61. %cmake_install
  62. # Remove static libraries with equivalent shared libraries
  63. rm -f %{buildroot}%{_libdir}/libarcher_static.a
  64. %if %{with test}
  65. %check
  66. %cmake_build --target check-openmp
  67. %endif
  68. %clean
  69. rm -rf %{buildroot}
  70. %pre
  71. if [ -e %{_libdir}/libomptarget.so ]; then
  72. rm -f %{_libdir}/libomptarget.so
  73. fi
  74. %ifnarch %{ix86} %{arm}
  75. for f in \
  76. %{_libdir}/libomptarget.rtl.amdgpu.so \
  77. %{_libdir}/libomptarget.rtl.cuda.so \
  78. %{_libdir}/libomptarget.rtl.%{_arch}.so
  79. do
  80. if [ -e $f ]; then
  81. rm -f $f
  82. fi
  83. done
  84. %endif
  85. %files
  86. %license LICENSE.TXT
  87. %{_libdir}/libarcher.so
  88. %{_libdir}/libomp.so
  89. %{_libdir}/libompd.so
  90. %{_libdir}/libomptarget.so*
  91. %ifnarch %{ix86} %{arm}
  92. %{_libdir}/libomptarget-*.bc
  93. %{_libdir}/libomptarget.rtl.amdgpu.so*
  94. %{_libdir}/libomptarget.rtl.cuda.so*
  95. %{_libdir}/libomptarget.rtl.%{_arch}.so*
  96. %endif
  97. %files devel
  98. %ifnarch %{ix86} %{arm}
  99. %{_libdir}/libomptarget.devicertl.a
  100. %endif
  101. %{_libdir}/clang/%{version}/include/omp.h
  102. %{_libdir}/clang/%{version}/include/omp-tools.h
  103. %{_libdir}/clang/%{version}/include/ompt.h
  104. %{_includedir}/ompt-multiplex.h
  105. %{_libdir}/cmake/openmp/FindOpenMPTarget.cmake
  106. %changelog
  107. * Fri Dec 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.6-1
  108. - new upstream release.
  109. * Thu Oct 06 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.2-1
  110. - new upstream release.
  111. * Thu Sep 08 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.0-1
  112. - new upstream release.
  113. * Thu Jun 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.0.5-1
  114. - new upstream release.
  115. - updated Patch0.
  116. * Thu Feb 03 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.1-1
  117. - new upstream release.
  118. * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.0-1
  119. - new upstream release.
  120. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  121. - new upstream release.
  122. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  123. - devided libomp from llvm.
  124. - new upstream release.
  125. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  126. - enabled to build utils.
  127. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  128. - new upstream release.
  129. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  130. - new upstream release.
  131. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  132. - rebuilt with libffi-3.3.
  133. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  134. - new upstream release.
  135. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  136. - new upstream release.
  137. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  138. - dropped all patches.
  139. - switched build-system to ninja.
  140. - switched python to python3.
  141. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  142. - new upstream release.
  143. - added OpenMP.
  144. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  145. - fixed %%files.
  146. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  147. - new upstream release.
  148. - dropped Patch0, 4, 5, 100 and 200.
  149. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  150. - renamed a subpackage "llvm-libs".
  151. - added a subpackage "lld".
  152. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  153. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  154. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  155. - new upstream release.
  156. - dropped Patch1 and 2: fixed in upstream.
  157. - imported Patch0, 3-5, 100 and 200 from rawhide.
  158. - disabled Patch1002: no longer needed?
  159. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  160. - new upstream release.
  161. - switched to cmake.
  162. - disable ocaml binding as default.
  163. - updated Patch1000 and 1002.
  164. - disabled Patch1000 as default.
  165. - cleanup patches.
  166. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  167. - rebuild with gcc-5.4.0
  168. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  169. - new upstream release
  170. - added BR: ocaml-ctypes
  171. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  172. - new upstream release
  173. - dropt Patch 1, 201 and 1001
  174. - updated Patch 1000
  175. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  176. - updated to 3.5.1
  177. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  178. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  179. - obsoleted clang-doc
  180. - built with ocaml 4.02.1
  181. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  182. - fix <BTS:2832>
  183. - fix configure option "--with-c-include-dirs"
  184. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  185. - update Patch1001: clang-3.5.0-driver-lib64.patch
  186. - update Patch1002: clang-3.5.0-driver-vine.patch
  187. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  188. - update to 3.5.0
  189. - remove Patch11 (clang-hardfloat-hack.patch)
  190. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  191. - rebuild with libffi-3.0.13
  192. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  193. - update to 3.3
  194. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  195. - ld.gold (patch1000,1001)
  196. - add /%{_lib} to ld search path
  197. - add support *-vine-linux gcc (patch1002)
  198. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  199. - update to 3.1
  200. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  201. - updated to 3.0 release
  202. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  203. - added patch 2-4 to support -O4 link-time optimization
  204. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  205. - disable -fno-var-tracking-assignments on ppc
  206. (seems like gcc-4.4.5 still doesn't support this)
  207. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  208. - new upstream release
  209. - add BR: libffi-devel
  210. - add R: libffi-devel to -devel
  211. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  212. - initial build for Vine Linux
  213. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  214. - Update to final 2.7 release
  215. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  216. - Update to first 2.7 pre-release
  217. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  218. - Update to 2.6 pre-release2
  219. - -devel subpackage now virtually provides -static
  220. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  221. - Disable var tracking assignments on PPC
  222. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  223. - Don't adjust clang include dir; files there are noarch (bz#521893)
  224. - Enable clang unit tests
  225. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  226. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  227. - Package Clang's static analyzer tools
  228. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  229. - PIC is now enabled by default; explicitly disable on %%{ix86}
  230. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  231. - First 2.6 prerelease
  232. - Enable Clang front-end
  233. - Enable debuginfo generation
  234. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  235. - Disable assertions (needed by OpenGTL, bz#521261)
  236. - Align spec file with upstream build instructions
  237. - Enable unit tests
  238. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  239. - Only disable PIC on %%ix86; ppc actually needs it
  240. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  241. - Disable use of position-independent code on 32-bit platforms
  242. (buggy in LLVM <= 2.5)
  243. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  244. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  245. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  246. - Remove build scripts; they require the build directory to work
  247. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  248. - Update to 2.5
  249. - Package build scripts (bug #457881)
  250. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  251. - Patched build process for the OCaml binding
  252. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  253. - Update to 2.4
  254. - Package Ocaml binding
  255. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  256. - Add dependency on groff
  257. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  258. - LLVM 2.3
  259. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  260. - fix license tags
  261. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  262. - Fix compilation problems with gcc 4.3
  263. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  264. - Autorebuild for GCC 4.3
  265. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  266. - Fix review comments
  267. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  268. - Initial version