python-dns-vl.spec 9.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297
  1. Name: python-dns
  2. Version: 1.10.0
  3. Release: 2%{?_dist_release}
  4. Summary: DNS toolkit for Python
  5. Summary(ja): Python 用 DNS ツールキット
  6. Group: Development/Languages
  7. License: MIT
  8. URL: http://www.dnspython.org/
  9. Source0: http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz
  10. Source1: http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz.asc
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildArch: noarch
  13. BuildRequires: python-setuptools
  14. BuildRequires: python-devel
  15. %description
  16. dnspython is a DNS toolkit for Python. It supports almost all record
  17. types. It can be used for queries, zone transfers, and dynamic
  18. updates. It supports TSIG authenticated messages and EDNS0.
  19. dnspython provides both high and low level access to DNS. The high
  20. level classes perform queries for data of a given name, type, and
  21. class, and return an answer set. The low level classes allow direct
  22. manipulation of DNS zones, messages, names, and records.
  23. %prep
  24. %setup0 -q -n dnspython-%{version}
  25. # strip executable permissions so that we don't pick up dependencies
  26. # from documentation
  27. find examples -type f | xargs chmod a-x
  28. %build
  29. CFLAGS="%{optflags}" %{__python} -c 'import setuptools; execfile("setup.py")' build
  30. %install
  31. rm -rf %{buildroot}
  32. %{__python} -c 'import setuptools; execfile("setup.py")' install --skip-build --root %{buildroot}
  33. %check
  34. pushd tests
  35. # skip one test because it queries the network
  36. for py in *.py
  37. do
  38. if [ $py != resolver.py ]
  39. then
  40. PYTHONPATH=%{buildroot}%{python_sitelib} %{__python} $py
  41. fi
  42. done
  43. %clean
  44. rm -rf %{buildroot}
  45. %files
  46. %defattr(-,root,root,-)
  47. %doc ChangeLog LICENSE README examples
  48. %{python_sitelib}/*egg-info
  49. %{python_sitelib}/dns
  50. %changelog
  51. * Mon Apr 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
  52. - add BR: python-devel, python
  53. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
  54. - new upstream release
  55. * Thu Apr 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.4-1
  56. - initial build for Vine Linux
  57. * Mon Mar 28 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.4-1
  58. -
  59. - dnspython 1.9.4 has been released and is available at
  60. - http://www.dnspython.org/kits/1.9.4/
  61. -
  62. - There is no new functionality in this release; just a few bug fixes
  63. - in RRSIG and SIG code.
  64. -
  65. - I will be eliminating legacy code for earlier versions of DNSSEC in a
  66. - future release of dnspython.
  67. * Fri Mar 25 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.3-1
  68. -
  69. - New since 1.9.2:
  70. -
  71. - A boolean parameter, 'raise_on_no_answer', has been added to
  72. - the query() methods. In no-error, no-data situations, this
  73. - parameter determines whether NoAnswer should be raised or not.
  74. - If True, NoAnswer is raised. If False, then an Answer()
  75. - object with a None rrset will be returned.
  76. -
  77. - Resolver Answer() objects now have a canonical_name field.
  78. -
  79. - Rdata now have a __hash__ method.
  80. -
  81. - Bugs fixed since 1.9.2:
  82. -
  83. - Dnspython was erroneously doing case-insensitive comparisons
  84. - of the names in NSEC and RRSIG RRs.
  85. -
  86. - We now use "is" and not "==" when testing what section an RR
  87. - is in.
  88. -
  89. - The resolver now disallows metaqueries.
  90. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.2-2
  91. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  92. * Tue Nov 23 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.2-1
  93. - It's brown paper bag time :) The fix for the import problems was
  94. - actually bad, but didn't show up in testing because the test suite's
  95. - conditional importing code hid the problem.
  96. -
  97. - Any, 1.9.2 is out.
  98. -
  99. - Sorry for the churn!
  100. * Mon Nov 22 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.1-1
  101. - New since 1.9.0:
  102. -
  103. - Nothing.
  104. -
  105. - Bugs fixed since 1.9.0
  106. -
  107. - The dns.dnssec module didn't work with DSA due to namespace
  108. - contamination from a "from"-style import.
  109. -
  110. - New since 1.8.0:
  111. -
  112. - dnspython now uses poll() instead of select() when available.
  113. -
  114. - Basic DNSSEC validation can be done using dns.dnsec.validate()
  115. - and dns.dnssec.validate_rrsig() if you have PyCrypto 2.3 or
  116. - later installed. Complete secure resolution is not yet
  117. - available.
  118. -
  119. - Added key_id() to the DNSSEC module, which computes the DNSSEC
  120. - key id of a DNSKEY rdata.
  121. -
  122. - Added make_ds() to the DNSSEC module, which returns the DS RR
  123. - for a given DNSKEY rdata.
  124. -
  125. - dnspython now raises an exception if HMAC-SHA284 or
  126. - HMAC-SHA512 are used with a Python older than 2.5.2. (Older
  127. - Pythons do not compute the correct value.)
  128. -
  129. - Symbolic constants are now available for TSIG algorithm names.
  130. -
  131. - Bugs fixed since 1.8.0
  132. -
  133. - dns.resolver.zone_for_name() didn't handle a query response
  134. - with a CNAME or DNAME correctly in some cases.
  135. -
  136. - When specifying rdata types and classes as text, Unicode
  137. - strings may now be used.
  138. -
  139. - Hashlib compatibility issues have been fixed.
  140. -
  141. - dns.message now imports dns.edns.
  142. -
  143. - The TSIG algorithm value was passed incorrectly to use_tsig()
  144. - in some cases.
  145. * Fri Aug 13 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-3
  146. - Add a patch from upstream to fix a Python 2.7 issue.
  147. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.8.0-2.1
  148. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  149. * Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1.1
  150. - Fix error
  151. * Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1
  152. - New since 1.7.1:
  153. -
  154. - Support for hmac-sha1, hmac-sha224, hmac-sha256, hmac-sha384 and
  155. - hmac-sha512 has been contributed by Kevin Chen.
  156. -
  157. - The tokenizer's tokens are now Token objects instead of (type,
  158. - value) tuples.
  159. -
  160. - Bugs fixed since 1.7.1:
  161. -
  162. - Escapes in masterfiles now work correctly. Previously they were
  163. - only working correctly when the text involved was part of a domain
  164. - name.
  165. -
  166. - When constructing a DDNS update, if the present() method was used
  167. - with a single rdata, a zero TTL was not added.
  168. -
  169. - The entropy pool needed locking to be thread safe.
  170. -
  171. - The entropy pool's reading of /dev/random could cause dnspython to
  172. - block.
  173. -
  174. - The entropy pool did buffered reads, potentially consuming more
  175. - randomness than we needed.
  176. -
  177. - The entropy pool did not seed with high quality randomness on
  178. - Windows.
  179. -
  180. - SRV records were compared incorrectly.
  181. -
  182. - In the e164 query function, the resolver parameter was not used.
  183. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.1-2
  184. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  185. * Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-1
  186. - New since 1.7.0:
  187. -
  188. - Nothing
  189. -
  190. - Bugs fixed since 1.7.0:
  191. -
  192. - The 1.7.0 kitting process inadventently omitted the code for the
  193. - DLV RR.
  194. -
  195. - Negative DDNS prerequisites are now handled correctly.
  196. * Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.0-1
  197. - New since 1.6.0:
  198. -
  199. - Rdatas now have a to_digestable() method, which returns the
  200. - DNSSEC canonical form of the rdata, suitable for use in
  201. - signature computations.
  202. -
  203. - The NSEC3, NSEC3PARAM, DLV, and HIP RR types are now supported.
  204. -
  205. - An entropy module has been added and is used to randomize query ids.
  206. -
  207. - EDNS0 options are now supported.
  208. -
  209. - UDP IXFR is now supported.
  210. -
  211. - The wire format parser now has a 'one_rr_per_rrset' mode, which
  212. - suppresses the usual coalescing of all RRs of a given type into a
  213. - single RRset.
  214. -
  215. - Various helpful DNSSEC-related constants are now defined.
  216. -
  217. - The resolver's query() method now has an optional 'source' parameter,
  218. - allowing the source IP address to be specified.
  219. -
  220. - Bugs fixed since 1.6.0:
  221. -
  222. - On Windows, the resolver set the domain incorrectly.
  223. -
  224. - DS RR parsing only allowed one Base64 chunk.
  225. -
  226. - TSIG validation didn't always use absolute names.
  227. -
  228. - NSEC.to_text() only printed the last window.
  229. -
  230. - We did not canonicalize IPv6 addresses before comparing them; we
  231. - would thus treat equivalent but different textual forms, e.g.
  232. - "1:00::1" and "1::1" as being non-equivalent.
  233. -
  234. - If the peer set a TSIG error, we didn't raise an exception.
  235. -
  236. - Some EDNS bugs in the message code have been fixed (see the ChangeLog
  237. - for details).
  238. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-4
  239. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  240. * Sat Nov 29 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-3
  241. - Rebuild for Python 2.6
  242. * Fri Aug 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.0-2
  243. - fix license tag
  244. * Tue Dec 4 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-1
  245. - Update to 1.6.0
  246. * Tue Oct 9 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-2
  247. - Follow new Python egg packaging specs
  248. * Thu Jan 11 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-1
  249. - Update to 1.5.0
  250. * Fri Dec 8 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-3
  251. - Bump release for rebuild with Python 2.5
  252. * Mon Aug 14 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-2
  253. - No longer ghost *.pyo files, thus further simplifying the files section.
  254. * Sat Aug 5 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-1
  255. - Update to 1.4.0
  256. - Remove unneeded python-abi requires
  257. - Remove unneeded python_sitearch macro
  258. * Fri May 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3.5-1
  259. - First version for Fedora Extras