xorg-x11-drv-intel-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595
  1. %define moduledir %(pkg-config xorg-server --variable=moduledir )
  2. %define driverdir %{moduledir}/drivers
  3. %define gputoolsdate 20110817
  4. Summary: Xorg X11 Intel video driver
  5. Summary(ja): Xorg X11 Intel ビデオドライバ
  6. Name: xorg-x11-drv-intel
  7. Epoch: 1
  8. Version: 2.21.1
  9. Release: 1%{?_dist_release}
  10. URL: http://intellinuxgraphics.org/
  11. License: MIT
  12. Group: User Interface/X Hardware Support
  13. Source0: http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
  14. Source2: intel.xinf
  15. Source3: intel-gpu-tools-%{gputoolsdate}.tar.bz2
  16. # Clamp VGA pixel clock to 250MHz,
  17. # anything higher's going to look awful anyway. (#559426)
  18. Patch10: intel-2.11.0-vga-clock-max.patch
  19. # vine patch
  20. ExclusiveArch: %{ix86} x86_64 ia64
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  22. BuildRequires: autoconf, automake, libtool
  23. BuildRequires: xorg-x11-server-sdk >= 1.7.99
  24. BuildRequires: libXvMC-devel
  25. BuildRequires: libGL-devel >= 7.10
  26. BuildRequires: libdrm-devel >= 2.4.25
  27. BuildRequires: kernel-headers >= 2.6.33
  28. BuildRequires: libudev-devel
  29. BuildRequires: libxcb-devel >= 1.5
  30. BuildRequires: xcb-util-devel
  31. Requires: hwdata
  32. Requires: xorg-x11-server-Xorg
  33. Requires: xcb-util
  34. Obsoletes: xorg-x11-drv-i810
  35. Provides: xorg-x11-drv-i810
  36. #Conflicts: kudzu < 1.2.42-1
  37. Vendor: Project Vine
  38. Distribution: Vine Linux
  39. %description
  40. X.Org X11 Intel video driver.
  41. %package devel
  42. Summary: Xorg X11 Intel video driver XvMC development package
  43. Summary(ja): Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
  44. Group: Development/System
  45. Requires: %{name} = %{epoch}:%{version}-%{release}
  46. Provides: xorg-x11-drv-intel-devel = %{version}-%{release}
  47. %description devel
  48. X.Org X11 Intel video driver XvMC development package.
  49. %package -n intel-gpu-tools
  50. Summary: Debugging tools for Intel graphics chips
  51. Group: Development/Tools
  52. %description -n intel-gpu-tools
  53. Debugging tools for Intel graphics chips
  54. %prep
  55. %setup -q -n xf86-video-intel-%{version} -b3
  56. %patch10 -p1 -b .vga-clock
  57. %build
  58. autoreconf -vi
  59. %configure \
  60. --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
  61. --enable-dri --enable-xvmc \
  62. --enable-sna --enable-uxa \
  63. --with-default-accel=uxa
  64. make
  65. pushd ../intel-gpu-tools-%{gputoolsdate}
  66. autoreconf -v --install
  67. %configure
  68. make
  69. popd
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. make install DESTDIR=$RPM_BUILD_ROOT
  73. mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
  74. install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
  75. pushd ../intel-gpu-tools-%{gputoolsdate}
  76. make install DESTDIR=$RPM_BUILD_ROOT
  77. popd
  78. find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
  79. %clean
  80. rm -rf $RPM_BUILD_ROOT
  81. %triggerpostun -- XOrg < 7.0
  82. if (grep -q i810 /etc/X11/xorg.conf)
  83. then
  84. cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
  85. sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
  86. fi ||:
  87. %files
  88. %defattr(-,root,root,-)
  89. %{driverdir}/intel_drv.so
  90. %{_datadir}/hwdata/videoaliases/intel.xinf
  91. %{_libdir}/libI810XvMC.so.*
  92. %{_libdir}/libIntelXvMC.so.*
  93. %{_mandir}/man4/i*
  94. %files devel
  95. %defattr(-,root,root,-)
  96. %{_libdir}/libI810XvMC.so
  97. %{_libdir}/libIntelXvMC.so
  98. %files -n intel-gpu-tools
  99. %defattr(-,root,root,-)
  100. %{_bindir}/*
  101. %{_mandir}/man1/intel_*.1*
  102. %changelog
  103. * Mon Feb 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
  104. - new upstream release
  105. * Tue Dec 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.16-1
  106. - new upstream release
  107. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.15-1
  108. - new upstream release
  109. * Tue Oct 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-1
  110. - new upstream release
  111. * Sun Sep 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
  112. - new upstream release
  113. * Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
  114. - new upstream release
  115. * Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
  116. - new upstream release
  117. * Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
  118. - new upstream release
  119. * Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
  120. - rebuild with xcb-util-0.3.9
  121. * Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
  122. - disable sna, enable uxa
  123. * Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
  124. - new upstream release
  125. * Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
  126. - rebuild with xserver-1.12.0
  127. * Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
  128. - new upstream release
  129. - enable sna
  130. * Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
  131. - disable sna/vmap
  132. * Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
  133. - new upstram release
  134. - disable copy-fb patch
  135. * Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
  136. - rebuild with xserver-1.11.1.902
  137. * Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
  138. - add --enable-sna --enable-vmap
  139. * Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
  140. - new upstream release
  141. * Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
  142. - rebuild with xcb-util-0.3.8
  143. - drop Patch200
  144. * Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
  145. - update to disable copy_fb on sandybridge/ivybridge
  146. * Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
  147. - update intel.xinf
  148. - add patch10 from fedora
  149. - Clamp VGA pixel clock to 250MHz,
  150. anything higher's going to look awful anyway. (#559426)
  151. * Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
  152. - drop patch1-3 and replaced with new patch1 from git master
  153. - add Patch200 to disable DRI on SandyBridge/IvyBridge
  154. - update intel-gpu-tools
  155. * Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
  156. - add Patch1-3 from upstream
  157. * Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
  158. - new upstream release
  159. - drop upstream patches: 107-115
  160. - temporary disabled patch101
  161. - BR: libdrm >= 2.4.25
  162. * Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
  163. - add Patch101-115 from ubuntu/debian package
  164. - Patch101: Plymouth integration patch
  165. - Patch107: Check null return from uxa_acquire_solid()
  166. - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
  167. - Patch109: Fix font corruption (missing glyphs) on rotated screens.
  168. - Patch110,114: Cherry picks to fix a large number of build warnings.
  169. - Patch111: Fix clipped window plane offset
  170. - Patch112: Fix issue where vertical green line and strange colors
  171. shows up when playing gstreamer with certain videos,
  172. when dragged. (LP 460677)
  173. - Patch113: Fixes GPU lockup during login with
  174. "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
  175. error messages listed in the gpu dump text. (LP 710321)
  176. - Patch115: Don't fill up Xorg.0.log with
  177. "get vblank counter failed: Invalid argument" warnings.
  178. * Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
  179. - rebuild with xserver-1.10.0
  180. * Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
  181. - new upstream release
  182. * Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
  183. - new upstream release
  184. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
  185. - rebuild with xserver-1.9.2
  186. * Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
  187. - new upstream release
  188. - add Patch40: fix uxa planemask (backported)
  189. - add Patch61: add support for backlight on macbooks
  190. - add Patch62: disable page flipping for stability
  191. * Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
  192. - new upstream release
  193. - drop patch70
  194. * Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
  195. - rebuild again with xserver-1.8rc
  196. * Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
  197. - add intel-gpu-tools as sub-package
  198. - rebuild with libdrm-2.4.18
  199. * Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
  200. - new upstream release
  201. - import Patch1,2,60,70 from fedora
  202. - add BR: kernel-headers >= 2.6.33 (new drm header required)
  203. - add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
  204. - add BR; libudev-devel and autoreconf for Patch60
  205. * Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
  206. - rebuild with libdrm-2.4.17
  207. * Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
  208. - new upstream release
  209. * Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
  210. - new upstream release (hopefully fixes severe issues w/ efifb)
  211. - drop all patches already upstreamed; import Patch20/21 from Fedora
  212. * Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
  213. - import Patch121,122 from ubuntu
  214. - build with libdrm-2.4.12 which fixes vt switch crash
  215. * Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
  216. - apply patch114 to fix Xv with non-GEM kernel
  217. * Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
  218. - update to 2.6.3
  219. - add patch106,107,115,118,119,120 from ubuntu
  220. - add Patch106: remove triple buffering
  221. - add Patch107: remove page flipping
  222. - add Patch115: fix crash Xv overlay
  223. - add Patch118: drop legacy3d
  224. - add Patch119: fix crashes in drm bo
  225. - add Patch120: fix vt switch
  226. - add patch130-134 from upstream git
  227. - add Patch130: fix another vt switch leak
  228. - add Patch131: Create known output configuration at EnterVT time
  229. - add Patch132: fix leak of some 965 render state on VT switch
  230. - add Patch133: fix crash with fake bufmgr and UXA
  231. - add Patch134: fix EnterVT/LeaveVT
  232. - add Patch135: add new chip supoprt
  233. * Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
  234. - revert to 2.6.1, add Epoch
  235. - add Patch103-121 from ubuntu
  236. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
  237. - new upstream release
  238. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
  239. - new upstream release
  240. * Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
  241. - new upstream release
  242. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
  243. - add Patch5 - Dont die on irq handler failure
  244. * Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
  245. - new upstream release
  246. - add BR: libdrm-devel >= 2.4.0-3
  247. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
  248. - import Patch10,11,12 from ubuntu
  249. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
  250. - new upstream release
  251. - add triggerpostun script to replace i810 driver to intel driver
  252. * Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
  253. - new upstream release
  254. * Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
  255. - new upstream release
  256. - rename i810.xinf to intel.xinf
  257. - update intel.xinf (add Intel 4 series)
  258. * Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
  259. - rebuild with new xserver
  260. * Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
  261. - new upstream release
  262. * Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
  263. - new upstream release
  264. * Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
  265. - new upstream release
  266. * Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  267. - initial build for Vine Linux
  268. * Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
  269. - Rebuild for new server ABI.
  270. - intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
  271. * Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
  272. - hook up ch7017 (bz#408471)
  273. * Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
  274. - xf86-video-intel 2.2.0
  275. * Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
  276. - xf86-video-intel 2.1.99.
  277. - Drop the i810 driver. Time to move on.
  278. - Require xserver 1.4.99.1
  279. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
  280. - intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
  281. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
  282. - intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
  283. for textured Xv to use as an offscreen pixmap so xv actually works under
  284. compiz - granted it may be unusably slow but at least stuff shows up.
  285. * Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
  286. - intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
  287. - intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
  288. * Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
  289. - intel-2.1.1-quirk-update.patch - update quirks from master
  290. * Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
  291. - i810.xinf: Flip everything over to -intel by default now. Still install
  292. i810 driver just in case.
  293. * Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
  294. - intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
  295. * Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
  296. - xf86-video-intel 2.1.1.
  297. * Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
  298. - xf86-video-intel 2.1.0.
  299. * Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
  300. - Update Requires and BuildRequires.
  301. * Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
  302. - Update to git master. Many Xv and DVO fixes. Adds support for 945GME,
  303. 965GME, G33, Q33, and Q35 chips.
  304. * Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
  305. - intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
  306. DRI clients are active, for better battery life.
  307. * Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
  308. - Rebuild for final RANDR 1.2 ABI. Fixes segfault at startup. (#238575)
  309. * Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
  310. - xf86-video-intel 2.0.0. Change the version number to match, why not.
  311. - Add a Virtual provides for xorg-x11-drv-intel, since we should probably
  312. rename this at some point.
  313. * Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
  314. - i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
  315. 915GM.
  316. * Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
  317. - i810.xinf: More intel whitelisting (#214011, #234877)
  318. * Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
  319. - xf86-video-intel-1.9.94 (RC4). Adds support for 965GM.
  320. - i810.xinf: Point 965GM support at the intel driver since it's not present
  321. in old i810.
  322. * Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
  323. - xf86-video-intel-1.9.93 (RC3).
  324. * Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
  325. - fix typo with 945GM pci id from my laptop
  326. * Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
  327. - xf86-video-intel 1.9.92 (RC2).
  328. * Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
  329. - Updated modesetting driver to one that will actually work with a 1.3 server.
  330. * Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
  331. - Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
  332. - Remove ivch and ch7017 from the install since they aren't hooked up to the
  333. code anywhere
  334. - Disown the module
  335. * Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
  336. - update modesetting driver to git snapshot from today
  337. * Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
  338. - i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
  339. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
  340. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  341. * Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
  342. - Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
  343. actually require kudzu to run.
  344. * Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
  345. - i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
  346. * Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
  347. - i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
  348. - i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
  349. driver match the corresponding terrible heuristic in the server.
  350. * Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
  351. - intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
  352. correctly distinguish between Mac Mini and Macbook Pro.
  353. * Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
  354. - i810.xinf: PCI IDs for i965.
  355. * Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
  356. - i810.xinf: Uppercase PCI IDs.
  357. * Thu Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
  358. - Update i810 to 1.6.5, should fix DRI.
  359. - Add kuzdu requires.
  360. - i810.xinf: Start whitelisting devices over to intel.
  361. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
  362. - intel-driver-rename.patch: Fix the driver name in more places so it'll,
  363. you know, load.
  364. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
  365. - intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
  366. LFP special casing in favor of the blacklist.
  367. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
  368. - Admit defeat, kinda. Package both i810 stable and modesetting drivers.
  369. The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
  370. and is selected with Driver "intel" in xorg.conf. Individual devices will
  371. whitelist over to "intel" until that branch gets merged into head.
  372. - Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
  373. - intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
  374. the BIOS is known to lie.
  375. * Tue Aug 8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
  376. - Today's snapshot: I2C bus creation fix.
  377. * Wed Aug 2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
  378. - intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
  379. clock when computing the modes list.
  380. - intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
  381. in centimeters as the size of the display in pixels.
  382. * Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
  383. - Disable spread-spectrum LVDS, various crash and hang fixes, saner output
  384. probing.
  385. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
  386. - Update again for a mode comparison bugfix.
  387. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
  388. - Update to today's git; crash fixes, better pre-915 support, slightly better
  389. autoconfigurability.
  390. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
  391. - rebuild
  392. * Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
  393. - Fix Revision number to match naming policy.
  394. * Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
  395. - Add back modesetting changes.
  396. * Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
  397. - Roll back modesetting changes and build for fc5 aiglx repo.
  398. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
  399. - Snapshot of the git modesetting branch.
  400. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
  401. - Update i810.xinf to include entries for E7221 and 945GM.
  402. * Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
  403. - Add with_dri macro to spec file, and conditionalize build time DRI support
  404. * Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
  405. - Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
  406. to pick up proto-devel as well.
  407. * Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
  408. - Rebuild for 7.1 ABI fix.
  409. * Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
  410. - Bump for fc5-bling build.
  411. * Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
  412. - Update to 1.6.0 from 7.1RC1.
  413. * Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
  414. - Add patch to add missing #include's, specifically assert.h.
  415. * Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
  416. - Update to CVS snapshot of 20060322.
  417. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
  418. - rebuilt for new gcc4.1 snapshot and glibc changes
  419. * Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
  420. - Added 8086:2772 mapping to i810.xinf for bug (#178451)
  421. * Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
  422. - Added 8086:2592 mapping to i810.xinf for bug (#172884)
  423. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
  424. - Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
  425. * Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
  426. - Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
  427. - Removed 'x' suffix from manpage dirs to match RC4 upstream.
  428. * Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
  429. - Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
  430. * Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
  431. - Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
  432. - Fix *.la file removal.
  433. - Added 'devel' subpackage for XvMC .so
  434. - Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
  435. * Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
  436. - Update BuildRoot to use Fedora Packaging Guidelines.
  437. - Deglob file manifest.
  438. - Limit "ExclusiveArch" to x86, x86_64, ia64
  439. * Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
  440. - Initial spec file for i810 video driver generated automatically
  441. by my xorg-driverspecgen script.