yatex-vl.spec 9.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. Name: yatex
  4. Version: 1.75
  5. Release: 1%{?_dist_release}
  6. License: Distributable
  7. Source0: http://www.yatex.org/yatex%{version}.tar.gz
  8. #Source0: http://www.yatex.org/yatex10203151806.tar.gz
  9. Source1: %{name}-install.sh
  10. Source2: %{name}-remove.sh
  11. Source3: %{name}-init.el
  12. Source4: vine-default-%{name}.el
  13. Source5: vine-default-yahtml.el
  14. ## pre-formatted info files here
  15. Source10: yatexe
  16. Source11: yatexj
  17. Source12: yahtmle
  18. Source13: yahtmlj
  19. ## Vine Patch(es)
  20. Patch0: yatex-info.diff
  21. Patch1: yatexhlp-emacs.diff
  22. Patch2: yatex-make.diff
  23. # based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
  24. # and modified to suit 1.70 release
  25. Patch3: yahtml-1.70-timestamp.patch
  26. Patch10: yatex-1.74-vine-vl7.patch
  27. URL: http://www.yatex.org/
  28. Group: Applications/Editors/Emacs
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  30. Summary: YaTeX - Yet Another TeX mode for Emacs
  31. Summary(ja): 野鳥(YaTeX) - Yet Another TeX mode for Emacs
  32. BuildArch: noarch
  33. PreReq: emacsen
  34. %prereq_ge emacsen-common
  35. Requires(post): make
  36. BuildRequires: emacsen-common
  37. Obsoletes: yatex-xemacs
  38. Distribution: Vine Linux
  39. Vendor: Project Vine
  40. Packager: munepi
  41. %description
  42. YaTeX is an intelligent, acquisitive and integrated package which reduces
  43. your efforts of composing LaTeX source on GNU Emacs.
  44. If you are YaTeX user and you install both yatex and auctex on your system,
  45. you may add the following configure in your emacs init file
  46. %if %{?_dist_release} == "vl5"
  47. ~/.emacs.el:
  48. %else
  49. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
  50. %endif
  51. ;; I am YaTeX user!!!
  52. (setq vine-default-auctex nil
  53. vine-default-preview-latex nil)
  54. %description -l ja
  55. YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
  56. してくれる、LaTeX 入力支援環境です。
  57. yatex と auctex パッケージの両方をインストールする場合、
  58. %if %{?_dist_release} == "vl5"
  59. ~/.emacs.el:
  60. %else
  61. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
  62. %endif
  63. に以下の設定を追加するとよいでしょう。
  64. ;; YaTeX ユーザです!!!
  65. (setq vine-default-auctex nil
  66. vine-default-preview-latex nil)
  67. %prep
  68. %setup -n yatex%{version}
  69. %patch0 -p1
  70. %patch1 -p1
  71. %patch2 -p1
  72. %patch3 -p1
  73. %if %{?_dist_release} == "vl7"
  74. %patch10 -p1 -b .vine
  75. %endif
  76. %build
  77. (cd docs
  78. chmod 644 *
  79. %__install -v -m 644 %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} .
  80. )
  81. %install
  82. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  83. %__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
  84. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
  85. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
  86. %__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
  87. #
  88. # install el files
  89. #
  90. %__cp -a *.el makefile help \
  91. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
  92. %__cp -a %{SOURCE3} %{SOURCE4} %{SOURCE5} \
  93. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
  94. #
  95. # install info files
  96. #
  97. %__install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
  98. ${RPM_BUILD_ROOT}%{_infodir}
  99. #
  100. # install script (bytecompile el and install elc, remove)
  101. #
  102. %_installemacsenscript %{name} %{SOURCE1}
  103. %_removeemacsenscript %{name} %{SOURCE2}
  104. %clean
  105. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  106. %post
  107. #
  108. # bytecompile and install
  109. #
  110. if [ "$1" = 2 ] ; then
  111. %_emacsenPackageRemove %{name}
  112. fi
  113. %_addemacsenlist %{name}
  114. %_emacsenPackageInstall %{name}
  115. /sbin/install-info %{_infodir}/yatexe.gz %{_infodir}/dir \
  116. --section="Emacs"
  117. /sbin/install-info %{_infodir}/yatexj.gz %{_infodir}/dir \
  118. --section="Emacs"
  119. /sbin/install-info %{_infodir}/yahtmle.gz %{_infodir}/dir \
  120. --section="Emacs"
  121. /sbin/install-info %{_infodir}/yahtmlj.gz %{_infodir}/dir \
  122. --section="Emacs"
  123. %preun
  124. if [ "$1" = 0 ]; then
  125. %_emacsenPackageRemove %{name}
  126. %_removeemacsenlist %{name}
  127. /sbin/install-info --delete %{_infodir}/yatexe.gz %{_infodir}/dir \
  128. --section="Emacs"
  129. /sbin/install-info --delete %{_infodir}/yatexj.gz %{_infodir}/dir \
  130. --section="Emacs"
  131. /sbin/install-info --delete %{_infodir}/yahtmle.gz %{_infodir}/dir \
  132. --section="Emacs"
  133. /sbin/install-info --delete %{_infodir}/yahtmlj.gz %{_infodir}/dir \
  134. --section="Emacs"
  135. fi
  136. %files
  137. %defattr(-,root,root)
  138. %doc 00readme install manifest yatex.new
  139. %doc docs
  140. %{_datadir}/emacs/site-lisp/yatex/
  141. %{_infodir}/*
  142. %{emacsen_pkgdir}/install/%{name}
  143. %{emacsen_pkgdir}/remove/%{name}
  144. %changelog
  145. * Thu Feb 9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-1
  146. - new upstream release
  147. - updated vine-default-yatex.el
  148. * Sat Dec 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-9
  149. - support TeX Live 2011
  150. - applied yatex-1.74-vine-vl7.patch
  151. - updated vine-default-yatex.el
  152. * Thu Aug 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-8
  153. - added Requires(post): make
  154. * Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-7
  155. - updated vine-default-yatex.el
  156. - check 'YaTeX-inhibit-prefix-letter
  157. - used "pbibtex -kanji=utf8" as default bibtex-command
  158. - used "mendex -U" as default makeindex-command
  159. * Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-6
  160. - updated vine-default-{yatex,yahtml}.el
  161. - revived auto-fill-mode on {yatex,yahtml}-mode
  162. * Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-5
  163. - updated yatex-init.el
  164. - dropped all pathes of auctex and preview-latex from load-path
  165. * Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-4
  166. - updated vine-default-yatex.el
  167. - added (setq YaTeX-inhibit-prefix-letter t) [yatex:04567]
  168. - supported TeX Live
  169. - used "eplatex", "pxdvi", "pdvips" as default commands
  170. - updated yatex-init.el
  171. - output "Loading vine-default-yatex ..." to the buffer *Messages*
  172. - defined vine-default-yahtml
  173. - added vine-default-yahtml.el
  174. * Tue Jan 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-3
  175. - updated vine-default-yatex.el
  176. - added bbl extension in auto-mode-alist to run yatex-mode
  177. * Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-2
  178. - updated vine-default-yatex.el
  179. - supported new vine-default
  180. * Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
  181. - new upstream release
  182. * Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
  183. - updated vine-default-yatex.el
  184. - dropped (setq YaTeX-no-begend-shortcut t)
  185. - use %{emacsen_pkgdir}
  186. * Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
  187. - updated vine-default-yatex.el
  188. - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
  189. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
  190. - updated yatex-install.sh
  191. - *-init.el: changed from hard copy to symbolic link
  192. on /etc/emacs-XX.YY/site-start.d
  193. * Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
  194. - fixed yatex-init.el
  195. * Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
  196. - added yatex-init.el, vine-default-yatex.el
  197. - updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
  198. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
  199. - spec in utf8
  200. * Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
  201. - applied new versioning policy
  202. * Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
  203. - new upstream release
  204. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
  205. - s/Copyright/License/
  206. - changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
  207. * Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
  208. - update yatex-1.72
  209. * Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
  210. - update yatex-1.71
  211. * Fri Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
  212. - added Patch3 to add hhmts timestamp feature
  213. * Tue May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
  214. - update yatex-1.70
  215. * Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
  216. - update yatex10203151806
  217. * Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
  218. - fixed: bytecompile yatex19
  219. * Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
  220. - now emacsen-common aware
  221. - FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
  222. * Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
  223. - 1.68-0vl2
  224. - no kanji code conversion of documents
  225. * Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
  226. - 1.68-0vl1
  227. - update to 1.68
  228. * Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  229. - 1.67-6vl5
  230. - YATEXHLP.{jp,eng} moved to appropriate dir
  231. * Thu Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  232. - 1.67-6vl3
  233. - rebuilt for emacs-20.7
  234. * Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  235. - 1.67-6vl2
  236. - oops ... fixed target dir for help files
  237. * Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  238. - 1.67-6vl1
  239. - rebuilt for emacs-20.6
  240. * Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  241. - 1.67-6
  242. - included forgotten info file for YaHTML
  243. * Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  244. - 1.67-5
  245. - updated for emacs-20.5a release
  246. * Wed Dec 1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  247. - 1.67-4
  248. - change Group to Applications/Editors/EmacsLisp
  249. * Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  250. - 1.67-3
  251. - %post and %preun section modified
  252. * Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  253. - 1.67-2
  254. - fixed minor problem in the %files section
  255. * Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  256. - 1.67-1
  257. - updated to 1.67 release
  258. - rebuilt for emacs-20.4 on Vine Linux 1.9
  259. - updated URL for the new web site of YaTeX
  260. - some typo fix
  261. * Tue May 4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  262. - Initial Release