thunderbird-vl.spec 29 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867
  1. # do not include minor version number in MOZILLA_FIVE_HOME
  2. %define tbmajor 12.0.1
  3. #%define tbversion %{tbmajor}.10
  4. %define tbversion %{tbmajor}
  5. %define tbrelease 1%{?_dist_release}
  6. # The tarball is pretty inconsistent with directory structure.
  7. # Sometimes there is a top level directory. That goes here.
  8. #
  9. # IMPORTANT: If there is no top level directory, this should be
  10. # set to the cwd, ie: '.'
  11. #%define tarballdir .
  12. %define tarballdir comm-release
  13. %define mozappdir %{_libdir}/%{name}-%{version_internal}
  14. %define moz_objdir objdir-tb
  15. %define version_internal %{tbmajor}
  16. %define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
  17. %define desktop_file_utils_version 0.6
  18. %define nspr_version 4.9
  19. %define nss_version 3.13.2
  20. %define cairo_version 1.6.0
  21. %define freetype_version 2.1.9
  22. %define sqlite_version 3.6.14
  23. %define libnotify_version 0.4
  24. %define build_vine7 0
  25. %define build_vine6 0
  26. %define build_vine5 0
  27. %if "%{?_dist_release}" >= "vl7"
  28. %define build_vine7 1
  29. %endif
  30. %if "%{?_dist_release}" == "vl6"
  31. %define build_vine6 1
  32. %endif
  33. %if "%{?_dist_release}" == "vl5"
  34. %define build_vine5 1
  35. %endif
  36. Summary: Thunderbird Community Edition, Mail/newsgroup client
  37. Summary(ja): Thunderbirdコミュニティエディション, メール・ニュースクライアント
  38. Name: thunderbird
  39. Version: %{tbversion}
  40. Release: %{tbrelease}
  41. URL: http://www.mozilla.org/projects/thunderbird/
  42. License: MPL
  43. Group: Applications/Internet
  44. Source0: ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
  45. Source1: ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
  46. Source1010: mozconfig-thunderbird-vine5
  47. Source1020: mozconfig-thunderbird-vine6
  48. Source1030: mozconfig-thunderbird-vine7
  49. Source12: thunderbird-vine-default-prefs.js
  50. Source20: thunderbird.desktop
  51. Source21: thunderbird.vine.sh.in
  52. Source30: thunderbird-open-browser.sh
  53. Source40: thunderbird-unofficial-brandig-tb-brand.properties
  54. Source41: thunderbird-unofficial-brandig-tb-brand.dtd
  55. Source42: thunderbird-unofficial-brandig-tb-ja-brand.properties
  56. Source43: thunderbird-unofficial-brandig-tb-ja-brand.dtd
  57. Source100: find-external-requires
  58. # locale sources
  59. #%define MOZ_BUILD_LOCALES "ja"
  60. # get from mercurial repository with command,
  61. # mkdir l10n
  62. # hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
  63. #Source1000: thunderbird-%{tbversion}-ja.tar.bz2
  64. # upstream patch
  65. # Fix for version issues
  66. Patch0: thunderbird-version.patch
  67. # customization patches
  68. Patch1: firefox-1.5-default-a4-paper.patch
  69. # Linux specific
  70. Patch100: thunderbird-9.0-enable-addons.patch
  71. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  72. BuildRequires: pango-devel
  73. BuildRequires: cairo-devel >= %{cairo_version}
  74. %if %{build_vine7}
  75. BuildRequires: nspr-devel >= %{nspr_version}
  76. BuildRequires: nss-devel >= %{nss_version}
  77. BuildRequires: hunspell-devel
  78. %endif
  79. %if %{build_vine6}
  80. BuildRequires: hunspell-devel
  81. %endif
  82. BuildRequires: pixman-devel
  83. BuildRequires: libpng-devel
  84. %if %{build_vine5}
  85. BuildRequires: libjpeg-devel
  86. %else
  87. BuildRequires: libjpeg-turbo-devel
  88. %endif
  89. BuildRequires: gtk2-devel
  90. BuildRequires: zlib-devel, gzip, zip, unzip
  91. BuildRequires: libIDL-devel
  92. BuildRequires: freetype2-devel >= %{freetype_version}
  93. ## disabled libnotify support
  94. ## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
  95. BuildRequires: libnotify-devel >= %{libnotify_version}
  96. BuildRequires: bzip2-devel
  97. BuildRequires: gnome-vfs2-devel
  98. BuildRequires: libgnome-devel
  99. BuildRequires: libgnomeui-devel
  100. BuildRequires: krb5-devel
  101. BuildRequires: pango-devel
  102. BuildRequires: libXt-devel
  103. BuildRequires: libXrender-devel
  104. # hunspell is in plus category for vine
  105. #BuildRequires: hunspell-devel
  106. BuildRequires: sqlite3-devel >= %{sqlite_version}
  107. BuildRequires: startup-notification-devel
  108. BuildRequires: desktop-file-utils
  109. BuildRequires: alsa-lib-devel
  110. BuildRequires: yasm
  111. Requires: sqlite3 >= %{sqlite_version}
  112. Requires(post): desktop-file-utils >= %{desktop_file_utils_version}
  113. Requires(postun): desktop-file-utils >= %{desktop_file_utils_version}
  114. Obsoletes: MozillaThunderbird
  115. Provides: MozillaThunderbird = %{version}
  116. Vendor: Project Vine
  117. Distribution: Vine Linux
  118. Packager: daisuke, ryoichi, kazutaka
  119. AutoProv: 0
  120. %define _use_internal_dependency_generator 0
  121. %define __find_requires %{SOURCE100}
  122. %description
  123. Thunderbird is a standalone mail and newsgroup client.
  124. %description -l ja
  125. Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
  126. #===============================================================================
  127. %prep
  128. %setup -q %{name}-%{version} -c
  129. cd %{tarballdir}
  130. # Fix for version issue
  131. sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
  132. > version.patch
  133. %{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
  134. cd mozilla
  135. %patch1 -p1 -b .default-a4
  136. cd -
  137. %{__rm} -f .mozconfig
  138. %if %{build_vine5}
  139. %{__cp} %{SOURCE1010} .mozconfig
  140. %endif
  141. %if %{build_vine6}
  142. %{__cp} %{SOURCE1020} .mozconfig
  143. %endif
  144. %if %{build_vine7}
  145. %{__cp} %{SOURCE1030} .mozconfig
  146. %endif
  147. # setup unofficial branding name
  148. %{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
  149. %{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
  150. %patch100 -p1 -b .addons
  151. #===============================================================================
  152. %build
  153. cd %{tarballdir}
  154. INTERNAL_GECKO=%{version_internal}
  155. MOZ_APP_DIR=%{mozappdir}
  156. %if %{build_vine7}
  157. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
  158. %else
  159. %ifarch x86_64
  160. #MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
  161. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2//' -e 's/-Wall//')
  162. %else
  163. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
  164. %endif
  165. %endif
  166. export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
  167. export CFLAGS="$RPM_OPT_FLAGS"
  168. #export CFLAGS=""
  169. export CXXFLAGS="$CFLAGS"
  170. export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
  171. %ifarch ppc ppc64 s390 s390x
  172. %define moz_make_flags -j1
  173. %else
  174. %define moz_make_flags %{?_smp_mflags}
  175. %endif
  176. export PREFIX='%{_prefix}'
  177. export LIBDIR='%{_libdir}'
  178. export LDFLAGS="-Wl,-rpath,%{mozappdir}"
  179. export MAKE="gmake %{moz_make_flags}"
  180. %{__make} -f client.mk build
  181. ## build locales
  182. #LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
  183. # sed -e 's|\./\(.*\)/locales/.*|\1|g'`
  184. #for dir in $LOCALEDIRS
  185. #do
  186. # for lang in %{MOZ_BUILD_LOCALES} ; do
  187. # make -C $dir/locales AB_CD=$lang
  188. # done
  189. #done
  190. #===============================================================================
  191. %install
  192. %{__rm} -rf $RPM_BUILD_ROOT
  193. cd %{tarballdir}
  194. INTERNAL_GECKO=%{version_internal}
  195. INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
  196. MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
  197. cd %{moz_objdir}
  198. DESTDIR=$RPM_BUILD_ROOT make install
  199. # install unofficial icons
  200. cd -
  201. %{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
  202. %{__cp} mail/branding/aurora/mailicon16.png \
  203. $RPM_BUILD_ROOT/%{mozappdir}/icons/
  204. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
  205. %{__cp} mail/branding/aurora/mailicon16.png \
  206. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
  207. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
  208. %{__cp} mail/branding/aurora/mailicon22.png \
  209. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
  210. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
  211. %{__cp} mail/branding/aurora/mailicon24.png \
  212. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
  213. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
  214. %{__cp} mail/branding/aurora/mailicon32.png \
  215. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
  216. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
  217. %{__cp} mail/branding/aurora/mailicon48.png \
  218. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
  219. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
  220. %{__cp} mail/branding/aurora/mailicon256.png \
  221. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
  222. desktop-file-install --vendor vine \
  223. --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
  224. # set up the thunderbird start script
  225. rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
  226. %{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
  227. $RPM_BUILD_ROOT%{_bindir}/thunderbird
  228. %{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
  229. install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
  230. %{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
  231. %{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
  232. -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
  233. $RPM_BUILD_ROOT/vine-default-prefs
  234. %{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
  235. %{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
  236. %{__rm} $RPM_BUILD_ROOT/vine-default-prefs
  237. %{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
  238. # own mozilla plugin dir (#135050)
  239. %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
  240. # own extension directories
  241. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
  242. %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
  243. # install locales
  244. #for lang in %{MOZ_BUILD_LOCALES} ; do
  245. # %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
  246. #done
  247. # install ja.xpi to langpacks directory
  248. #%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
  249. #unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
  250. # also setup unofficial branding name
  251. #%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
  252. #%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
  253. # install ja.xpi to langpack file
  254. %{__mkdir_p} lang_tmp
  255. unzip %{SOURCE1} -d lang_tmp
  256. # also setup unofficial branding name
  257. %{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
  258. %{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
  259. %{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
  260. cd lang_tmp; \
  261. zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
  262. %clean
  263. %{__rm} -rf $RPM_BUILD_ROOT
  264. #===============================================================================
  265. %post
  266. update-desktop-database &> /dev/null || :
  267. touch --no-create %{_datadir}/icons/hicolor
  268. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  269. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  270. fi
  271. %postun
  272. update-desktop-database &> /dev/null || :
  273. touch --no-create %{_datadir}/icons/hicolor
  274. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  275. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  276. fi
  277. %files
  278. %defattr(-,root,root,-)
  279. %attr(755,root,root) %{_bindir}/thunderbird
  280. %attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
  281. %{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
  282. %{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
  283. %{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
  284. %{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
  285. %{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
  286. %{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
  287. %{mozappdir}
  288. #%{_libdir}/mozilla
  289. %exclude %{_libdir}/%{name}-%{version_internal}/removed-files
  290. %exclude %{_datadir}/idl/%{name}-%{version_internal}
  291. %exclude %{_includedir}/%{name}-%{version_internal}
  292. %exclude %{_libdir}/%{name}-devel-%{version_internal}
  293. #===============================================================================
  294. %changelog
  295. * Tue May 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0.1-1
  296. - new upstream release
  297. * Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0-1
  298. - new upstream release
  299. - update Source1030 (mozconfig-thunderbird-vine7)
  300. * Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 11.0-1
  301. - new upstream release
  302. - update Source1020 (mozconfig-thunderbird-vine6)
  303. * Fri Feb 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.2-1
  304. - new upstream release
  305. * Mon Feb 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.1-1
  306. - new upstream release
  307. * Wed Feb 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0-1
  308. - new upstream release
  309. * Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0.1-1
  310. - new upstream release
  311. - update Source1
  312. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0-1
  313. - new upstream release
  314. - update Source1
  315. - add Source1030 (mozconfig-thunderbird-vine7)
  316. - add Patch100 (thunderbird-9.0-enable-addons.patch)
  317. * Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
  318. - fix %%version_internal
  319. * Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
  320. - new upstream release
  321. - update Source1
  322. * Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
  323. - new upstream release
  324. - update Source1,21,1010,1020
  325. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
  326. - rebuild with libnotify-0.7
  327. * Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
  328. - enable-install-strip
  329. * Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
  330. - new upstream release
  331. - drop obsolete patch and renumber patch26 to patch1
  332. - add BuildRequires: yasm
  333. - enable libnotify support
  334. - add --disable-updater and --disable-installer to mozconfig
  335. - use ja.xpi instead of l10n source
  336. - update Source21: add step to setup langpack plugin
  337. - update Source20: add japanese translation
  338. - add Source42 & Source43 for localized branding
  339. - add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
  340. for mozconfig-thunderbird-vine5
  341. * Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
  342. - new upstream release with security fix
  343. * Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
  344. - new upstream release with security fix
  345. * Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
  346. - new upstream release with security fix
  347. * Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
  348. - new upstream release with security fix
  349. - add patch5 to fix build failure
  350. * Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
  351. - new upstream release
  352. * Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
  353. - new upstream release with security fix
  354. - add Patch1030 to fix compilation error
  355. * Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
  356. - change mozconfig (Source1030 & 1040): add --enable-jsd
  357. * Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
  358. - new upstream release
  359. * Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
  360. - new upstream release with security fix
  361. - add Patch0 from fedora development: fix version issue
  362. - remove BuildRequires: hunspell-devel
  363. - update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
  364. * Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
  365. - add BuildRequires: alsa-lib-devel
  366. - remove BuildRequires: libnotify-devel
  367. (workaround for known bug)
  368. - update mozconfig to add --disable-libnotify option
  369. * Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
  370. - new upstream release
  371. - update spec entirely
  372. - import patches from fedora (Patch1, 2 & 4)
  373. - drop outdated patches (Patch22, 24)
  374. - update Sources:
  375. - mozconfig (Source1030 & Source1040)
  376. - default prefs.js (Source12)
  377. - unofficial branding (Source40 & Source41)
  378. - japanese translation (Source1000)
  379. - update Patch1000 (sjis-alias)
  380. * Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
  381. - new upstream release
  382. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
  383. - new upstream release
  384. * Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
  385. - don't install official branding logos
  386. * Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
  387. - add necessary icons in %%{tbdir}/chrome/icons/default
  388. - add Packager tag
  389. * Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
  390. - new upstream release
  391. * Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
  392. - new upstream release
  393. * Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
  394. - new upstream release
  395. * Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
  396. - new upstream release
  397. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
  398. - rebuilt for VineSeed
  399. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
  400. - new upstream release
  401. * Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
  402. - new upstream release
  403. - built for Vine Linux 4.x
  404. - dropped Patch1020 (merged into upstream)
  405. * Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
  406. - added Patch1020 for workaround gcc visibility hidden bugs
  407. * Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
  408. - build with new environment/toolchain
  409. - add build options to build with external nss/nspr libraries
  410. ac_add_options --with-system-nspr
  411. ac_add_options --with-system-nss
  412. * Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
  413. - new upstream release
  414. * Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
  415. - new upstream release
  416. * Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
  417. - new upstream release
  418. * Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
  419. - new upstream release
  420. * Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
  421. - new upstream release
  422. - merge changes from firefox
  423. - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
  424. * Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
  425. - new upstream release
  426. - build en-US locale
  427. - merge changes from firefox
  428. - add upstream patches
  429. - disable pango rendering by default
  430. (workaround fix slow rendering in some page)
  431. * Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
  432. - initial build for Vine Linux based on FC package
  433. - update to 1.5RC2
  434. * Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
  435. - Fix issue with popup dialogs and other actions causing lockups
  436. * Sat Nov 5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
  437. - Update to 1.5 rc1
  438. * Sat Oct 8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
  439. - Update to 1.5 beta2
  440. * Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
  441. - Update to 1.5 beta1
  442. - Bring the install phase of the spec file up to speed
  443. * Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
  444. - Rebuild
  445. * Sat Aug 6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
  446. - Add patch to make file chooser dialog modal
  447. * Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
  448. - Update to 1.0.6
  449. * Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
  450. - 1.0.6 Release Candidate
  451. * Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
  452. - Use system NSPR
  453. - Fix crash on 64bit platforms (#160330)
  454. * Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com> 1.0.2-7
  455. - Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
  456. references, fixing the "no fonts" problem.
  457. * Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
  458. - Change the Exec line in the desktop file to `thunderbird`
  459. * Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
  460. - Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
  461. * Mon May 9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
  462. - Add temporary workaround to not create files in the user's $HOME (#149664)
  463. * Wed May 4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
  464. - Don't have downloads "disappear" when downloading to desktop (#139015)
  465. - Fix for some more cursor issues in textareas (149991, 150002, 152089)
  466. - Add upstream patch to fix bidi justification of pango
  467. - Add patch to fix launching of helper applications
  468. - Add patch to properly link against libgfxshared_s.a
  469. - Fix multilib conflicts
  470. * Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
  471. - correct confusing PANGO vars in startup script
  472. * Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
  473. - Thunderbird 1.0.2
  474. * Tue Mar 8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
  475. - Add patch to compile against new fortified glibc macros
  476. * Sat Mar 5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
  477. - Rebuild against GCC 4.0
  478. - Add execshield patches
  479. - Minor specfile cleanup
  480. * Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
  481. - Rebuild
  482. * Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
  483. - Add RPM version to useragent
  484. * Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
  485. - Port over pango patches from firefox
  486. * Wed Dec 8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
  487. - Thunderbird 1.0
  488. * Mon Dec 6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
  489. - Fix advanced prefs
  490. * Fri Dec 3 2004 Christopher Aillon <caillon@redhat.com>
  491. - Make this run on s390(x) now for real
  492. * Wed Dec 1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
  493. - Update to 1.0 rc1
  494. * Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
  495. - Add patches to build and run on s390(x)
  496. * Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
  497. - Rebuild to fix file chooser
  498. * Fri Nov 5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
  499. - Update to 0.9
  500. * Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
  501. - Prevent inlining of stack direction detection (#135255)
  502. * Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
  503. - More file chooser fixes (same as in firefox)
  504. - Fix for upstream 28327.
  505. * Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
  506. - Update the pango patch
  507. * Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
  508. - Pull over patches from firefox build:
  509. - disable default application dialog
  510. - don't include software update since it doesn't work
  511. - make external app support work
  512. * Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
  513. - Use pango for rendering
  514. * Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
  515. - Fix for 64 bit crash at startup (b.m.o #256603)
  516. * Sat Oct 9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
  517. - Add patches to fix xremote (#135036)
  518. * Fri Oct 8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
  519. - Add patch to fix button focus issues (#133507)
  520. - Add patch for fix IMAP race issues (bmo #246439)
  521. * Fri Oct 1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
  522. - filter out library Provides: and internal Requires:
  523. * Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
  524. - Backport the GTK+ File Chooser.
  525. - Add fix for JS math on x86_64 systems
  526. - Add pkgconfig patch
  527. * Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
  528. - Update to 0.8.0
  529. - Remove enigmail
  530. - Update BuildRequires
  531. - Remove gcc34 and extension manager patches -- they are upstreamed.
  532. - Fix for gnome-vfs2 error at component registration
  533. * Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
  534. - Build with --disable-xprint
  535. * Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
  536. - remove all Xvfb-related hacks
  537. * Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
  538. - actually apply psfonts
  539. - add mozilla gnome-uriloader patch to prevent build failure
  540. * Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
  541. - rawhide import
  542. - apply NetBSD's freetype 2.1.8 patch
  543. - apply psfonts patch
  544. - remove BR on /usr/bin/ex, breaks beehive
  545. * Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
  546. - oops, fix %%install
  547. * Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
  548. - update to Thunderbird 0.7.3 and Enigmail 0.85.0
  549. - remove XUL.mfasl on startup, add Debian enigmail patches
  550. - add Xvfb hack for -install-global-extension
  551. * Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
  552. - update to 0.7.2, just because it's there
  553. - update gcc-3.4 patch (Kaj Niemi)
  554. - add EM registration patch and remove instdir hack
  555. * Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
  556. - re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
  557. * Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
  558. - update to 0.7.1
  559. - remove Enigmail
  560. * Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
  561. - re-enable Enigmail 0.84.1
  562. - add gcc-3.4 patch (Kaj Niemi)
  563. - use official branding (with permission)
  564. * Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
  565. - update to 0.7
  566. - temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
  567. - specify libdir, change BR for apt (V. Skytt辰, #1617)
  568. * Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
  569. - temporary workaround for enigmail skin "modern" bug
  570. * Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
  571. - update to Enigmail 0.84.0
  572. - update launch script
  573. * Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
  574. - installation directory now versioned
  575. - allow root to run the program (for installing extensions)
  576. - remove unnecessary %%pre and %%post
  577. - remove separators, update mozconfig and launch script (M. Schwendt, #1460)
  578. * Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
  579. - include Enigmail, re-add release notes
  580. - delete %{_libdir}/thunderbird in %%pre
  581. * Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
  582. - update to Thunderbird 0.6
  583. * Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
  584. - update to Thunderbird 0.6 RC1
  585. - add new icon, remove release notes
  586. * Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
  587. - update to latest CVS, update mozconfig and %%build accordingly
  588. - update to Enigmail 0.83.6
  589. - remove x-remote and x86_64 patches
  590. - build with -Os
  591. * Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
  592. - update x-remote patch
  593. - more startup script fixes
  594. * Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
  595. - startup script fixes, and a minor cleanup
  596. * Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
  597. - Minor cleanups
  598. * Sun Apr 04 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.8
  599. - minor improvements to open-browser.sh and startup script
  600. - update to latest version of Blizzard's x-remote patch
  601. * Thu Mar 25 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.7
  602. - update open-browser.sh, startup script, and BuildRequires
  603. * Sun Mar 14 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.6
  604. - update open-browser script, modify BuildRequires (Warren)
  605. - add Blizzard's x-remote patch
  606. - initial attempt at x-remote-enabled startup script
  607. * Sun Mar 07 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.5
  608. - refuse to run with excessive privileges
  609. * Fri Feb 27 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.4
  610. - add Mozilla x86_64 patch (Oliver Sontag)
  611. - Enigmail source filenames now include the version
  612. - modify BuildRoot
  613. * Thu Feb 26 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.3
  614. - use the updated official tarball
  615. * Wed Feb 18 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.2
  616. - fix %%prep script
  617. * Mon Feb 16 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.1
  618. - update Enigmail to 0.83.3
  619. - use official source tarball (after removing the CRLFs)
  620. - package renamed to thunderbird
  621. * Mon Feb 09 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.0
  622. - update to 0.5
  623. - check for lockfile before launching
  624. * Fri Feb 06 2004 David Hill <djh[at]ii.net>
  625. - update to latest cvs
  626. - update to Enigmail 0.83.2
  627. * Thu Jan 29 2004 David Hill <djh[at]ii.net> 0:0.4-0.fdr.5
  628. - update to Enigmail 0.83.1
  629. - removed Mozilla/Firebird script patching
  630. * Sat Jan 03 2004 David Hill <djh[at]ii.net> 0:0.4-0.fdr.4
  631. - add startup notification to .desktop file
  632. * Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
  633. - open-browser.sh release 3
  634. - patch broken /usr/bin/mozilla script during install
  635. - dir ownership
  636. - XXX: Source fails build on x86_64... fix later
  637. * Tue Dec 23 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.2
  638. - update to Enigmail 0.82.5
  639. - add Warren's open-browser.sh (#1113)
  640. * Tue Dec 09 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.1
  641. - use Thunderbird's mozilla-xremote-client to launch browser
  642. * Sun Dec 07 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.0
  643. - update to 0.4
  644. - make hyperlinks work (with recent versions of Firebird/Mozilla)
  645. * Thu Dec 04 2003 David Hill <djh[at]ii.net>
  646. - update to 0.4rc2
  647. * Wed Dec 03 2003 David Hill <djh[at]ii.net>
  648. - update to 0.4rc1 and Enigmail 0.82.4
  649. * Thu Nov 27 2003 David Hill <djh[at]ii.net>
  650. - update to latest CVS and Enigmail 0.82.3
  651. * Sun Nov 16 2003 David Hill <djh[at]ii.net>
  652. - update to latest CVS (0.4a)
  653. - update Enigmail to 0.82.2
  654. - alter mozconfig for new build requirements
  655. - add missing BuildReq (#987)
  656. * Thu Oct 16 2003 David Hill <djh[at]ii.net> 0:0.3-0.fdr.0
  657. - update to 0.3
  658. * Sun Oct 12 2003 David Hill <djh[at]ii.net> 0:0.3rc3-0.fdr.0
  659. - update to 0.3rc3
  660. - update Enigmail to 0.81.7
  661. * Thu Oct 02 2003 David Hill <djh[at]ii.net> 0:0.3rc2-0.fdr.0
  662. - update to 0.3rc2
  663. * Wed Sep 17 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.2
  664. - simplify startup script
  665. * Wed Sep 10 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.1
  666. - add GPG support (Enigmail 0.81.6)
  667. - specfile fixes (#679)
  668. * Thu Sep 04 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.0
  669. - update to 0.2
  670. * Mon Sep 01 2003 David Hill <djh[at]ii.net>
  671. - initial RPM
  672. (based on the fedora MozillaFirebird-0.6.1 specfile)