texlive-collection-documentation-ukrainian-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250
  1. ## -*- coding: utf-8-unix -*-
  2. ## NOTE: This spec file is generated by tlpdb2rpmspec 2011-1:
  3. ## tlpdb2rpmspec collection-documentation-ukrainian
  4. %global _use_internal_dependency_generator 0
  5. %global __find_provides %{nil}
  6. %global __find_requires %{nil}
  7. %bcond_with firstbuild
  8. %define tex_destdir %{_datadir}
  9. %define texmf %{tex_destdir}/texmf
  10. %define texlive_src %{tex_destdir}/texlive-sources
  11. %define build_tex_destdir %{buildroot}%{tex_destdir}
  12. %define build_texmf %{buildroot}%{texmf}
  13. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  14. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  15. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys
  16. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
  17. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  18. %define vartexfonts %{_var}/lib/texmf/fonts
  19. Summary: TeX Live: Ukrainian documentation
  20. Summary(ja): TeX Live: Ukrainian documentation
  21. Name: texlive-collection-documentation-ukrainian
  22. Version: 2011
  23. Release: 1%{?_dist_release}
  24. License: Freely redistributable without restriction
  25. Group: Applications/Publishing
  26. URL:http://www.tug.org/texlive/
  27. Requires: texlive = %{version}
  28. Requires(post): texlive = %{version}
  29. Requires(postun): texlive = %{version}
  30. BuildRequires: texlive-sources = %{version}
  31. BuildArch: noarch
  32. Buildroot: %{_tmppath}/%{name}-%{version}-root
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. Packager: munepi
  36. %description
  37. The TeX Live software distribution offers a complete TeX system for a
  38. variety of Unix, Macintosh, Windows and other platforms. It
  39. encompasses programs for editing, typesetting, previewing and printing
  40. of TeX documents in many different languages, and a large collection
  41. of TeX macros and font libraries.
  42. The distribution includes extensive general documentation about TeX,
  43. as well as the documentation for the included software packages.
  44. This package is a collection of Ukrainian documentation:
  45. This package contains the following CTAN packages:
  46. lshort-ukr: Ukrainian version of the LaTeX introduction.
  47. %description -l ja
  48. TeX Live ソフトウェアディストリビューションは、
  49. さまざまな Unix, Macintosh, Windows、および
  50. 他のプラットホームに対して完全な TeX システムを提供します。
  51. 多くの異なった言語を含む TeX ドキュメントの
  52. 編集、組版、閲覧、印刷するためのプログラム、
  53. そして、TeX マクロやフォントライブラリの大きなコレクションを
  54. 同梱しています。
  55. このディストリビューションは
  56. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  57. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  58. このパッケージは以下のようなパッケージ集です。
  59. Ukrainian documentation:
  60. このパッケージは以下の CTAN パッケージを含んでいます:
  61. lshort-ukr: Ukrainian version of the LaTeX introduction.
  62. %prep
  63. %build
  64. %install
  65. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  66. PREF=%{buildroot}%{tex_destdir}
  67. manifest=(
  68. texmf-dist/doc/latex/lshort-ukr/lshort-ukr-4.12.src.tar.gz
  69. texmf-dist/doc/latex/lshort-ukr/lshort-ukr.pdf
  70. )
  71. %__mkdir_p ${PREF}/texmf-dist
  72. for i in "${manifest[@]}"; do
  73. %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
  74. done
  75. ## make symlinks of core script utils
  76. mk_symlinks=(
  77. texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
  78. texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
  79. texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
  80. texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
  81. texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
  82. texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
  83. texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
  84. texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
  85. texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
  86. texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
  87. texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
  88. texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
  89. texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
  90. texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
  91. texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
  92. texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
  93. texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
  94. texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
  95. texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
  96. texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
  97. texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
  98. texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
  99. texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
  100. texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
  101. texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
  102. texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
  103. texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
  104. texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
  105. texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
  106. texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
  107. texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
  108. texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
  109. texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
  110. texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
  111. texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
  112. texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
  113. texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
  114. texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
  115. texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
  116. texlive-collection-fontutils,/usr/bin/cmap2enc,/usr/share/texmf-dist/scripts/fontools/cmap2enc
  117. texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
  118. texlive-collection-fontutils,/usr/bin/font2afm,/usr/share/texmf-dist/scripts/fontools/font2afm
  119. texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
  120. texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
  121. texlive-collection-fontutils,/usr/bin/pfm2kpx,/usr/share/texmf-dist/scripts/fontools/pfm2kpx
  122. texlive-collection-fontutils,/usr/bin/showglyphs,/usr/share/texmf-dist/scripts/fontools/showglyphs
  123. texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
  124. texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
  125. texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
  126. texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
  127. texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
  128. texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
  129. texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
  130. texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
  131. texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
  132. texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
  133. texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
  134. texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
  135. texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
  136. texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
  137. texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
  138. texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
  139. texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
  140. texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
  141. texlive-collection-latexextra,/usr/bin/pdfthumb,/usr/share/texmf-dist/scripts/ppower4/pdfthumb.tlu
  142. texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
  143. texlive-collection-latexextra,/usr/bin/ppower4,/usr/share/texmf-dist/scripts/ppower4/ppower4.tlu
  144. texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
  145. texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
  146. texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
  147. texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
  148. texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
  149. texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
  150. texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
  151. texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
  152. texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
  153. texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
  154. texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
  155. texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
  156. texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
  157. texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
  158. texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
  159. )
  160. %__mkdir_p %{buildroot}%{_bindir}
  161. pushd %{buildroot}%{_bindir}
  162. for i in "${mk_symlinks[@]}"; do
  163. tlc=$(echo $i | cut -f 1 -d",")
  164. lnk=$(echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
  165. rlnk=$(echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
  166. [ "%{name}" = "$tlc" ] || continue
  167. [ -f $rlnk ] || exit 1
  168. %__ln_s $rlnk $lnk || exit 1
  169. done
  170. popd
  171. ## Files list
  172. find %{buildroot} -type f -or -type l | \
  173. %__sed -e "s|%{buildroot}||g" > filelist.full
  174. find %{buildroot}%{texmf}-dist -type d | \
  175. %__sed -e "s|^%{buildroot}|%dir |" \
  176. -e "s|$|/|" >> filelist.full
  177. %clean
  178. %__rm -rf %{buildroot}
  179. %post
  180. %{exec_texhash}
  181. exit 0
  182. %postun
  183. if [ "$1" = 0 ]; then
  184. %{exec_texhash}
  185. fi
  186. exit 0
  187. %files -f filelist.full
  188. %defattr(-,root,root,-)
  189. %changelog
  190. * Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
  191. - generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-documentation-ukrainian
  192. * Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
  193. - generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-documentation-ukrainian
  194. - make symlinks of core script utils (texlive-collection-binextra,
  195. texlive-collection-context, texlive-collection-fontutils,
  196. texlive-collection-langgreek, texlive-collection-langindic,
  197. texlive-collection-latex, texlive-collection-latexextra,
  198. texlive-collection-latexrecommended, texlive-collection-pictures,
  199. texlive-collection-pstricks, texlive-collection-science)
  200. * Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  201. - generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-documentation-ukrainian
  202. - improved %%post
  203. * Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  204. - generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-documentation-ukrainian
  205. - removed arch dependent binaries (texlive-collection-latexextra)
  206. - fixed perl path
  207. - improved updmap process in %%post and %%postun
  208. * Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  209. - generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-ukrainian