123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457 |
- ###############################################################################
- ###############################################################################
- ##
- ## Copyright (C) 2004-2010 Red Hat, Inc. All rights reserved.
- ##
- ## This copyrighted material is made available to anyone wishing to use,
- ## modify, copy, or redistribute it subject to the terms and conditions
- ## of the GNU General Public License v.2.
- ##
- ###############################################################################
- ###############################################################################
- # keep around ready for later user
- ## global alphatag rc4
- # When downloading directly from Mercurial, it will automatically add this prefix
- # Invoking 'hg archive' wont but you can add one with:
- # hg archive -t tgz -p "Cluster-Resource-Agents-" -r $altversion $altversion.tar.gz
- %global altprefix Cluster-Resource-Agents-
- %global altversion a7c0f35916bf
- Name: resource-agents
- Summary: Open Source HA Resource Agents
- Summary(ja): Open Source HA Resource Agents
- Version: 3.0.13
- Release: 1%{?_dist_release}
- License: GPLv2+ and LGPLv2+
- Group: System Environment/Base
- URL: http://sources.redhat.com/cluster/wiki/
- Source0: https://fedorahosted.org/releases/c/l/cluster/%{name}-%{version}.tar.bz2
- Source1: http://hg.linux-ha.org/agents/archive/%{altversion}.tar.bz2
- ## Runtime deps
- # system tools shared by several agents
- Requires: bash grep sed gawk
- Requires: procps net-tools
- Requires: psmisc
- Requires: util-linux-ng
- # fs.sh
- Requires: quota
- Requires: util-linux-ng
- Requires: e2fsprogs
- Requires: xfsprogs
- # ip.sh
- Requires: iproute ethtool
- Requires: iputils
- # lvm.sh
- Requires: lvm2
- # netfs.sh
- Requires: nfs-utils samba-client
- ## Setup/build bits
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- # Build dependencies
- BuildRequires: cluster-glue-libs-devel glib2-devel
- BuildRequires: automake autoconf pkgconfig
- BuildRequires: libxslt docbook-style-xsl
- BuildRequires: python perl
- BuildRequires: libnet-devel
- %description
- A set of scripts to interface with several services to operate in a
- High Availability environment for both Pacemaker and rgmanager
- service managers.
- %package -n ldirectord
- Summary: Monitor daemon for maintaining high availability resources
- Summary(ja): Monitor daemon for maintaining high availability resources
- Group: System Environment/Daemons
- Requires: ipvsadm
- Requires(post): /sbin/chkconfig
- Requires(preun): /sbin/chkconfig
- # We were originally ldirectord, then renamed with a heartbeat- prefix.
- # Upstream maintainer wishes to use no prefix, which is consistent with
- # how it is packaged for other distributions
- Provides: ldirectord = 3.0.0-15
- Obsoletes: ldirectord < 3.0.0-15
- Provides: heartbeat-ldirectord = 3.0.0-15
- Obsoletes: heartbeat-ldirectord < 3.0.0-15
- # removed for now until it's in Fedora
- #Requires: perl(Net::IMAP::Simple::SSL)
- %description -n ldirectord
- ldirectord is a stand-alone daemon to monitor services of real
- for virtual services provided by The Linux Virtual Server
- (http://www.linuxvirtualserver.org/). It is simple to install
- and works with the heartbeat code (http://www.linux-ha.org/).
- # we inherit configure from cluster project. Configure it for vars we need.
- # building from source directly without those parameters will NOT work.
- # See http://www.redhat.com/archives/cluster-devel/2009-February/msg00003.html
- %prep
- %setup -q -n %{name}-%{version} -a 1
- # prepare rgmanager RAs
- %{_configure} \
- --sbindir=%{_sbindir} \
- --initddir=%{_sysconfdir}/rc.d/init.d \
- --libdir=%{_libdir} \
- --without_fence_agents \
- --disable_kernel_check
- # prepare pacemaker RAs
- cd %{altprefix}%{altversion}
- ./autogen.sh
- %{configure} --enable-fatal-warnings=no --with-rsctmpdir=%{_var}/run/heartbeat/rsctmp
- %build
- ##CFLAGS="$(echo '%{optflags}')" make %{_smp_mflags}
- # %{_smp_mflags} is broken from upstream and unrequired for this project.
- CFLAGS="$(echo '%{optflags}')" make -C rgmanager/src/resources
- make -C %{altprefix}%{altversion} %{_smp_mflags}
- %install
- rm -rf %{buildroot}
- make -C rgmanager/src/resources install DESTDIR=%{buildroot}
- make -C %{altprefix}%{altversion} install DESTDIR=%{buildroot}
- # tree fixup
- rm %{buildroot}/%{_libdir}/heartbeat/ocf-*
- find %{buildroot} -type f -name '.ocf-*' -exec chmod 644 {} \;
- find %{buildroot} -type f -name 'ocf-*' -exec chmod 644 {} \;
- find %{buildroot} -type f -name '*.dtd' -exec chmod 644 {} \;
- chmod 755 %{buildroot}/%{_sbindir}/ocf-tester
- chmod 755 %{buildroot}/%{_datadir}/cluster/ocf-shellfuncs
- # Strange location, remove until we can confirm
- rm -f %{buildroot}%{_libdir}/heartbeat/tickle_tcp
- # Test harness, worth creating a devel package for?
- rm -rf %{buildroot}%{_datadir}/resource-agents/ocft
- rm -f %{buildroot}%{_sbindir}/ocft
- # symlink to allow pacemaker to use rgmanager RAs
- cd %{buildroot}/usr/lib/ocf/resource.d/ && \
- ln -sf %{_datadir}/cluster/ vine
- %clean
- rm -rf %{buildroot}
- %post -n ldirectord
- /sbin/chkconfig --add ldirectord
- %postun -n ldirectord -p /sbin/ldconfig
- %preun -n ldirectord
- /sbin/chkconfig --del ldirectord
- %files
- %defattr(-,root,root,-)
- %doc doc/COPYING.* doc/COPYRIGHT doc/README.licence
- %doc %{altprefix}%{altversion}/AUTHORS
- %{_datadir}/cluster
- %dir /usr/lib/ocf
- %dir /usr/lib/ocf/resource.d
- /usr/lib/ocf/resource.d/heartbeat
- /usr/lib/ocf/resource.d/vine
- %{_sbindir}/ocf-tester
- %{_sbindir}/sfex_init
- %dir %{_datadir}/resource-agents
- %doc %{_datadir}/resource-agents/ra-api-1.dtd
- %{_mandir}/man7/*.7*
- %dir %{_sysconfdir}/ha.d
- %{_sysconfdir}/ha.d/shellfuncs
- %dir %{_libdir}/heartbeat
- %{_libdir}/heartbeat/findif
- %{_libdir}/heartbeat/send_arp
- %{_libdir}/heartbeat/sfex_daemon
- %{_includedir}/heartbeat/agent_config.h
- %files -n ldirectord
- %defattr(-,root,root,-)
- %doc %{altprefix}%{altversion}/COPYING
- %doc %{altprefix}%{altversion}/ldirectord/ldirectord.cf
- %{_sbindir}/ldirectord
- %config(noreplace) %{_sysconfdir}/logrotate.d/ldirectord
- %{_sysconfdir}/init.d/ldirectord
- %{_sysconfdir}/ha.d/resource.d/ldirectord
- %{_mandir}/man8/ldirectord.8*
- /usr/lib/ocf/resource.d/heartbeat/ldirectord
- %changelog
- * Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.13-1
- - initial build for Vine Linux
- * Mon Jun 7 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.13-1
- - new upstream release
- Resolves: rhbz#592103, rhbz#593108, rhbz#578617, rhbz#594626
- Resolves: rhbz#594511, rhbz#596046, rhbz#594111, rhbz#597002
- Resolves: rhbz#599643
- * Tue May 18 2010 Andrew Beekhof <andrew@beekhof.net> - 3.0.12-2
- - libnet is not available on RHEL
- - Do not package ldirectord on RHEL
- Resolves: rhbz#577264
- * Mon May 10 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.12-1
- - new upstream release
- Resolves: rhbz#585217, rhbz#586100, rhbz#581533, rhbz#582753
- Resolves: rhbz#582754, rhbz#585083, rhbz#587079, rhbz#588890
- Resolves: rhbz#588925, rhbz#583789, rhbz#589131, rhbz#588010
- Resolves: rhbz#576871, rhbz#576871, rhbz#590000, rhbz#589823
- * Mon May 10 2010 Andrew Beekhof <andrew@beekhof.net> - 3.0.12-1
- - New pacemaker agents upstream release: a7c0f35916bf
- + High: pgsql: properly implement pghost parameter
- + High: RA: mysql: fix syntax error
- + High: SAPInstance RA: do not rely on op target rc when monitoring clones (lf#2371)
- + High: set the HA_RSCTMP directory to /var/run/resource-agents (lf#2378)
- + Medium: IPaddr/IPaddr2: add a description of the assumption in meta-data
- + Medium: IPaddr: return the correct code if interface delete failed
- + Medium: nfsserver: rpc.statd as the notify cmd does not work with -v (thanks to Carl Lewis)
- + Medium: oracle: reduce output from sqlplus to the last line for queries (bnc#567815)
- + Medium: pgsql: implement "config" parameter
- + Medium: RA: iSCSITarget: follow changed IET access policy
- * Wed Apr 21 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.11-1
- - new upstream release
- Resolves: rhbz#583945, rhbz#581047, rhbz#576330, rhbz#583017
- Resolves: rhbz#583019, rhbz#583948, rhbz#584003, rhbz#582017
- Resolves: rhbz#555901, rhbz#582754, rhbz#582573, rhbz#581533
- - Switch to file based Requires.
- Also address several other problems related to missing runtime
- components in different agents.
- With the current Requires: set, we guarantee all basic functionalities
- out of the box for lvm/fs/clusterfs/netfs/networking.
- Resolves: rhbz#570008
- * Sat Apr 17 2010 Andrew Beekhof <andrew@beekhof.net> - 3.0.10-2
- - New pacemaker agents upstream release
- + High: RA: vmware: fix set_environment() invocation (LF 2342)
- + High: RA: vmware: update to version 0.2
- + Medium: Filesystem: prefer /proc/mounts to /etc/mtab for non-bind mounts (lf#2388)
- + Medium: IPaddr2: don't bring the interface down on stop (thanks to Lars Ellenberg)
- + Medium: IPsrcaddr: modify the interface route (lf#2367)
- + Medium: ldirectord: Allow multiple email addresses (LF 2168)
- + Medium: ldirectord: fix setting defaults for configfile and ldirectord (lf#2328)
- + Medium: meta-data: improve timeouts in most resource agents
- + Medium: nfsserver: use default values (lf#2321)
- + Medium: ocf-shellfuncs: don't log but print to stderr if connected to a terminal
- + Medium: ocf-shellfuncs: don't output to stderr if using syslog
- + Medium: oracle/oralsnr: improve exit codes if the environment isn't valid
- + Medium: RA: iSCSILogicalUnit: fix monitor for STGT
- + Medium: RA: make sure that OCF_RESKEY_CRM_meta_interval is always defined (LF 2284)
- + Medium: RA: ManageRAID: require bash
- + Medium: RA: ManageRAID: require bash
- + Medium: RA: VirtualDomain: bail out early if config file can't be read during probe (Novell 593988)
- + Medium: RA: VirtualDomain: fix incorrect use of __OCF_ACTION
- + Medium: RA: VirtualDomain: improve error messages
- + Medium: RA: VirtualDomain: spin on define until we definitely have a domain name
- + Medium: Route: add route table parameter (lf#2335)
- + Medium: sfex: don't use pid file (lf#2363,bnc#585416)
- + Medium: sfex: exit with success on stop if sfex has never been started (bnc#585416)
- * Fri Apr 9 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.10-1
- - New rgmanager resource agents upstream release
- Resolves: rhbz#519491, rhbz#570525, rhbz#571806, rhbz#574027
- Resolves: rhbz#574215, rhbz#574886, rhbz#576322, rhbz#576335
- Resolves: rhbz#575103, rhbz#577856, rhbz#577874, rhbz#578249
- Resolves: rhbz#578625, rhbz#578626, rhbz#578628, rhbz#578626
- Resolves: rhbz#579621, rhbz#579623, rhbz#579625, rhbz#579626
- Resolves: rhbz#579059
- * Wed Mar 24 2010 Andrew Beekhof <andrew@beekhof.net> - 3.0.9-2
- - Resolves: rhbz#572993 - Patched build process to correctly generate ldirectord man page
- - Resolves: rhbz#574732 - Add libnet-devel as a dependancy to ensure IPaddrv6 is built
- * Mon Mar 1 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.9-1
- - New rgmanager resource agents upstream release
- Resolves: rhbz#455300, rhbz#568446, rhbz#561862, rhbz#536902
- Resolves: rhbz#512171, rhbz#519491
- * Mon Feb 22 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.8-1
- - New rgmanager resource agents upstream release
- Resolves: rhbz#548133, rhbz#565907, rhbz#545602, rhbz#555901
- Resolves: rhbz#564471, rhbz#515717, rhbz#557128, rhbz#536157
- Resolves: rhbz#455300, rhbz#561416, rhbz#562237, rhbz#537201
- Resolves: rhbz#536962, rhbz#553383, rhbz#556961, rhbz#555363
- Resolves: rhbz#557128, rhbz#455300, rhbz#557167, rhbz#459630
- Resolves: rhbz#532808, rhbz#556603, rhbz#554968, rhbz#555047
- Resolves: rhbz#554968, rhbz#555047
- - spec file update:
- * update spec file copyright date
- * use bz2 tarball
- * Fri Jan 15 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.7-2
- - Add python as BuildRequires
- * Mon Jan 11 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.7-1
- - New rgmanager resource agents upstream release
- Resolves: rhbz#526286, rhbz#533461
- * Mon Jan 11 2010 Andrew Beekhof <andrew@beekhof.net> - 3.0.6-2
- - Update Pacameker agents to upstream version: c76b4a6eb576
- + High: RA: VirtualDomain: fix forceful stop (LF 2283)
- + High: apache: monitor operation of depth 10 for web applications (LF 2234)
- + Medium: IPaddr2: CLUSTERIP/iptables rule not always inserted on failed monitor (LF 2281)
- + Medium: RA: Route: improve validate (LF 2232)
- + Medium: mark obsolete RAs as deprecated (LF 2244)
- + Medium: mysql: escalate stop to KILL if regular shutdown doesn't work
- * Mon Dec 7 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.6-1
- - New rgmanager resource agents upstream release
- - spec file update:
- * use global instead of define
- * use new Source0 url
- * use %name macro more aggressively
- * Mon Dec 7 2009 Andrew Beekhof <andrew@beekhof.net> - 3.0.5-2
- - Update Pacameker agents to upstream version: bc00c0b065d9
- + High: RA: introduce OCF_FUNCTIONS_DIR, allow it to be overridden (LF2239)
- + High: doc: add man pages for all RAs (LF2237)
- + High: syslog-ng: new RA
- + High: vmware: make meta-data work and several cleanups (LF 2212)
- + Medium: .ocf-shellfuncs: add ocf_is_probe function
- + Medium: Dev: make RAs executable (LF2239)
- + Medium: IPv6addr: ifdef out the ip offset hack for libnet v1.1.4 (LF 2034)
- + Medium: add mercurial repository version information to .ocf-shellfuncs
- + Medium: build: add perl-MailTools runtime dependency to ldirectord package (LF 1469)
- + Medium: iSCSITarget, iSCSILogicalUnit: support LIO
- + Medium: nfsserver: use check_binary properly in validate (LF 2211)
- + Medium: nfsserver: validate should not check if nfs_shared_infodir exists (thanks to eelco@procolix.com) (LF 2219)
- + Medium: oracle/oralsnr: export variables properly
- + Medium: pgsql: remove the previous backup_label if it exists
- + Medium: postfix: fix double stop (thanks to Dinh N. Quoc)
- + RA: LVM: Make monitor operation quiet in logs (bnc#546353)
- + RA: Xen: Remove instance_attribute "allow_migrate" (bnc#539968)
- + ldirectord: OCF agent: overhaul
- * Fri Nov 20 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.5-1
- - New rgmanager resource agents upstream release
- - Allow pacemaker to use rgmanager resource agents
- * Wed Oct 28 2009 Andrew Beekhof <andrew@beekhof.net> - 3.0.4-2
- - Update Pacameker agents to upstream version: e2338892f59f
- + High: send_arp - turn on unsolicited mode for compatibilty with the libnet version's exit codes
- + High: Trap sigterm for compatibility with the libnet version of send_arp
- + Medium: Bug - lf#2147: IPaddr2: behave if the interface is down
- + Medium: IPv6addr: recognize network masks properly
- + Medium: RA: VirtualDomain: avoid needlessly invoking "virsh define"
- * Wed Oct 21 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.4-1
- - New rgmanager resource agents upstream release
- * Mon Oct 12 2009 Andrew Beekhof <andrew@beekhof.net> - 3.0.3-3
- - Update Pacameker agents to upstream version: 099c0e5d80db
- + Add the ha_parameter function back into .ocf-shellfuncs.
- + Bug bnc#534803 - Provide a default for MAILCMD
- + Fix use of undefined macro @HA_NOARCHDATAHBDIR@
- + High (LF 2138): IPsrcaddr: replace 0/0 with proper ip prefix (thanks to Michael Ricordeau and Michael Schwartzkopff)
- + Import shellfuncs from heartbeat as badly written RAs use it
- + Medium (LF 2173): nfsserver: exit properly in nfsserver_validate
- + Medium: RA: Filesystem: implement monitor operation
- + Medium: RA: VirtualDomain: loop on status if libvirtd is unreachable
- + Medium: RA: VirtualDomain: loop on status if libvirtd is unreachable (addendum)
- + Medium: RA: iSCSILogicalUnit: use a 16-byte default SCSI ID
- + Medium: RA: iSCSITarget: be more persistent deleting targets on stop
- + Medium: RA: portblock: add per-IP filtering capability
- + Medium: mysql-proxy: log_level and keepalive parameters
- + Medium: oracle: drop spurious output from sqlplus
- + RA: Filesystem: allow configuring smbfs mounts as clones
- * Wed Sep 23 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.3-1
- - New rgmanager resource agents upstream release
- * Thu Aug 20 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.1-1
- - New rgmanager resource agents upstream release
- * Tue Aug 18 2009 Andrew Beekhof <andrew@beekhof.net> - 3.0.0-16
- - Create an ldirectord package
- - Update Pacameker agents to upstream version: 2198dc90bec4
- + Build: Import ldirectord.
- + Ensure HA_VARRUNDIR has a value to substitute
- + High: Add findif tool (mandatory for IPaddr/IPaddr2)
- + High: IPv6addr: new nic and cidr_netmask parameters
- + High: postfix: new resource agent
- + Include license information
- + Low (LF 2159): Squid: make the regexp match more precisely output of netstat
- + Low: configure: Fix package name.
- + Low: ldirectord: add dependency on $remote_fs.
- + Low: ldirectord: add mandatory required header to init script.
- + Medium (LF 2165): IPaddr2: remove all colons from the mac address before passing it to send_arp
- + Medium: VirtualDomain: destroy domain shortly before timeout expiry
- + Medium: shellfuncs: Make the mktemp wrappers work.
- + Remove references to Echo function
- + Remove references to heartbeat shellfuncs.
- + Remove useless path lookups
- + findif: actually include the right header. Simplify configure.
- + ldirectord: Remove superfluous configure artifact.
- + ocf-tester: Fix package reference and path to DTD.
- * Tue Aug 11 2009 Ville Skyttä <ville.skytta@iki.fi> - 3.0.0-15
- - Use bzipped upstream hg tarball.
- * Wed Jul 29 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-14
- - Merge Pacemaker cluster resource agents:
- * Add Source1.
- * Drop noarch. We have real binaries now.
- * Update BuildRequires.
- * Update all relevant prep/build/install/files/description sections.
- * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.0-13
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Wed Jul 8 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-12
- - spec file updates:
- * Update copyright header
- * final release.. undefine alphatag
- * Thu Jul 2 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-11.rc4
- - New upstream release.
- * Sat Jun 20 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-10.rc3
- - New upstream release.
- * Wed Jun 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-9.rc2
- - New upstream release + git94df30ca63e49afb1e8aeede65df8a3e5bcd0970
- * Tue Mar 24 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-8.rc1
- - New upstream release.
- - Update BuildRoot usage to preferred versions/names
- * Mon Mar 9 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-7.beta1
- - New upstream release.
- * Fri Mar 6 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-6.alpha7
- - New upstream release.
- * Tue Mar 3 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-5.alpha6
- - New upstream release.
- * Tue Feb 24 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-4.alpha5
- - Drop Conflicts with rgmanager.
- * Mon Feb 23 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-3.alpha5
- - New upstream release.
- * Thu Feb 19 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-2.alpha4
- - Add comments on how to build this package.
- * Thu Feb 5 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-1.alpha4
- - New upstream release.
- - Fix datadir/cluster directory ownership.
- * Tue Jan 27 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.0.0-1.alpha3
- - Initial packaging
|