gnuplot-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225
  1. %define gpmainver 4.4
  2. %define gpver %{gpmainver}.3
  3. Summary: A program for plotting mathematical expressions and data.
  4. Summary(ja): 数学系の関数やデータのプロット・プログラム
  5. Name: gnuplot
  6. Version: %{gpver}
  7. Release: 1%{?_dist_release}
  8. License: gnuplot and GPLv2
  9. Group: Applications/Engineering
  10. URL: http://gnuplot.sourceforge.net/
  11. Source: http://prdownloads.sourceforge.net/gnuplot/gnuplot-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-root
  13. BuildRequires: gd-devel >= 2.0.27, libpng-devel, zlib-devel
  14. BuildRequires: libX11-devel, libXt-devel, wx-gtk2-devel
  15. BuildRequires: readline-devel
  16. BuildRequires: lua-devel cairo-devel pango-devel
  17. BuildRequires: texlive
  18. BuildRequires: texlive-collection-latexextra
  19. BuildRequires: texinfo, emacsen
  20. Requires(post): install-info
  21. Requires(preun): install-info
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: daisuke, inagaki
  25. %description
  26. Gnuplot is a command-line driven, interactive function plotting
  27. program especially suited for scientific data representation. Gnuplot
  28. can be used to plot functions and data points in both two and three
  29. dimensions and in many different formats.
  30. Install gnuplot if you need a graphics package for scientific data
  31. representation.
  32. %description -l ja
  33. Gnuplotはとりわけ科学データ・プレゼンテーションに適した、コマンド
  34. 操作によるインタラクティブな関数プロット・プログラムです。
  35. Gnuplotは関数や座標データを同時にプロットしたり、3次元化やさまざ
  36. まな形式で表現するのに利用することができます。
  37. 科学データプレゼンテーション用のグラフィック・パッケージが必要な
  38. 場合、gnuplotをインストールしてください。
  39. %prep
  40. %setup -q
  41. %build
  42. #autoreconf -f -i
  43. %ifarch alpha
  44. %define optflags -O0
  45. %endif
  46. %configure --with-readline=gnu --with-png --without-linux-vga --enable-history-file
  47. make %{?_smp_mflags}
  48. %install
  49. rm -rf $RPM_BUILD_ROOT
  50. make install DESTDIR=$RPM_BUILD_ROOT
  51. rm -f demo/Makefile* tutorial/Makefile*
  52. # move app-dafaults to %%_datadir
  53. #mv $RPM_BUILD_ROOT%{_libdir}/X11 $RPM_BUILD_ROOT%{_datadir}/
  54. # move texmf config
  55. mv $RPM_BUILD_ROOT%{_datadir}/texmf-local $RPM_BUILD_ROOT%{_datadir}/texmf
  56. # remove unneeded files
  57. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  58. %clean
  59. rm -rf $RPM_BUILD_ROOT
  60. %post
  61. /sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/gnuplot.info.gz
  62. %preun
  63. if [ $1 = 0 ]; then
  64. /sbin/install-info --quiet --info-dir=%{_infodir} \
  65. --delete %{_infodir}/gnuplot.info.gz
  66. fi
  67. %files
  68. %defattr(-,root,root)
  69. %doc demo tutorial
  70. %doc README README.1ST INSTALL Copyright TODO
  71. %doc PATCHLEVEL VERSION BUGS ChangeLog
  72. %{_bindir}/gnuplot
  73. %{_libexecdir}/gnuplot/%{gpmainver}/*
  74. %{_datadir}/gnuplot/%{gpmainver}/*
  75. #{_datadir}/X11/app-defaults/Gnuplot
  76. %{_datadir}/texmf/tex/latex/gnuplot
  77. %{_datadir}/emacs/site-lisp/*
  78. %{_infodir}/gnuplot.info*
  79. %{_mandir}/man1/gnuplot.*
  80. %changelog
  81. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
  82. - update to gnuplot-4.4.3
  83. - use BR: texlive instead of tetex
  84. * Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.5-1
  85. - update to gnuplot-4.2.5
  86. - drop plus patch (merged in upstream)
  87. - update URL: to new upstream homepage
  88. - fix License:
  89. - build with wxGTK
  90. - add BR: libX11-devel, libXt-devel, wx-gtk2-devel
  91. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.0.0-1vl5
  92. - applied new versioning policy, spec in utf-8
  93. * Tue Aug 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl6
  94. - add BuildRequires: texinfo, emacsen
  95. * Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl5
  96. - rebuild with readline-5.1
  97. * Wed Jun 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.0-0vl4
  98. - update Patch0 to fix 'Invalid char in eps file'
  99. (thanks to HANAWA Toshihiro)
  100. - add BuildRequires: autoconf, automake
  101. * Sat Nov 20 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.0-0vl2
  102. - enabled history-file
  103. * Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.0-0vl1
  104. - source update
  105. * Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.8k.3-0vl1
  106. - source update
  107. - patch update and modified
  108. - add info
  109. * Wed Mar 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl3
  110. - rebuild
  111. - fix license
  112. - remove -DUSE_SYSTEM_TIME ([VinePlus:01805])
  113. * Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl2
  114. - rebuild with readline-4.3
  115. * Thu Feb 20 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl1
  116. - syncd with RH 3.7.3-2
  117. - modified Yamaga-san's gnuplot3.7.2+1.2.0rc2.patch for 3.7.3
  118. * Fri Jan 25 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 16vl1
  119. - added pathes (patch1,2) from RH
  120. * Sat Aug 25 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 12vl1
  121. - syncd rawhide
  122. - updated to 3.7.1-1.2.0
  123. * Mon Jun 5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  124. - updated to 3.7.1
  125. - updated gnuplot+ patch to 1.1.9 for gnuplot 3.7.1.
  126. - remake SPEC from rawhide.
  127. * Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  128. - rebuild with new gd, changing gif terminal to jpeg terminal (release 7)
  129. * Mon May 08 2000 Preston Brown <pbrown@redhat.com>
  130. - build for 7.0
  131. * Thu Apr 6 2000 Bill Nottingham <notting@redhat.com>
  132. - use gnu readline, not built-in version
  133. * Mon Apr 3 2000 Bill Nottingham <notting@redhat.com>
  134. - add latex tutorial, demo files, other docs (#10508)
  135. * Wed Mar 1 2000 Bill Nottingham <notting@redhat.com>
  136. - update to 3.7.1. Oops.
  137. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  138. - handle compressed man pages
  139. * Thu Nov 4 1999 Bill Nottingham <notting@redhat.com>
  140. - update to 3.7.1
  141. * Mon Oct 11 1999 Bill Nottingham <notting@redhat.com>
  142. - ship some docs.
  143. * Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
  144. - add a patch to fix postscript output from Bernd Kischnick
  145. (kisch@die-herrmanns.de)
  146. * Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
  147. - fix license
  148. * Thu Jul 15 1999 Bill Nottingham <notting@redhat.com>
  149. - rebuild without svgalib
  150. * Tue Jun 15 1999 Bill Nottingham <notting@redhat.com>
  151. - update to 3.7.0.1
  152. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  153. - auto rebuild in the new build environment (release 2)
  154. * Tue Feb 2 1999 Jeff Johnson <jbj@redhat.com>
  155. - update to 3.7.
  156. * Thu Dec 17 1998 Michael Maher <mike@redhat.com>
  157. - built package for 6.0
  158. * Fri Sep 11 1998 Jeff Johnson <jbj@redhat.com>
  159. - update to 2.6beta347
  160. * Sat Aug 15 1998 Jeff Johnson <jbj@redhat.com>
  161. - build root
  162. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  163. - translations modified for de, fr, tr
  164. * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
  165. - spec file cleanups
  166. * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
  167. - built against glibc