mplayer-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435
  1. %define with_vaapi 1
  2. %define with_libvpx 1
  3. %define name mplayer
  4. %define version 1.0
  5. %define extver rc3
  6. #% define release 4%{?extver:.%{extver}}%{?_dist_release}
  7. %define svndate 20100709
  8. %define release 38.%{svndate}%{?_dist_release}
  9. %if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl5"
  10. %define ttfontdir /usr/share/fonts
  11. %define ttfontlist TrueType-vlgothic/VL-PGothic-Regular \\\
  12. TrueType-sazanami-gothic/sazanami-gothic
  13. %endif
  14. Summary: The Movie Player
  15. Summary(ja): 動画プレイヤー
  16. Name: %{name}
  17. Version: %{version}
  18. Release: %{release}
  19. #Source0: http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
  20. Source0: mplayer-export-%{svndate}.tar.bz2
  21. Source1: http://www.mplayerhq.hu/MPlayer/skins/Blue-1.7.tar.bz2
  22. Source10: mplayer-snapshot-vine.sh
  23. Patch2: %{name}-config.patch
  24. Patch8: %{name}-manlinks.patch
  25. Patch14: %{name}-nodvdcss.patch
  26. ## Vine
  27. Patch50: mplayer-20100709-fixed-vo_x11_create_vo_window.patch
  28. License: GPLv2+
  29. Group: Applications/Multimedia
  30. URL: http://www.mplayerhq.hu/
  31. BuildRequires: gtk2-devel
  32. BuildRequires: freetype2-devel
  33. BuildRequires: SDL-devel
  34. BuildRequires: alsa-lib-devel
  35. BuildRequires: esound-devel
  36. BuildRequires: cdparanoia-devel
  37. BuildRequires: libvorbis-devel
  38. BuildRequires: pulseaudio-lib-devel
  39. BuildRequires: libjpeg-devel
  40. BuildRequires: libpng-devel
  41. BuildRequires: giflib-devel
  42. BuildRequires: zlib-devel
  43. BuildRequires: libdvdread
  44. BuildRequires: libmpcdec-devel
  45. BuildRequires: twolame-devel
  46. BuildRequires: yasm
  47. BuildRequires: libvdpau-devel
  48. %{?with_vaapi:BuildRequires:libva-devel}
  49. %{?with_libvpx:BuildRequires: libvpx-devel >= 0.9.1}
  50. BuildRequires: libXinerama-devel
  51. BuildRequires: libXScrnSaver-devel
  52. # *-devel packages provided by other self-build-* should only be listed
  53. # in self-build-%{name}.spec as PreReq.
  54. ##Requires: self-build-mplayer-codecs
  55. ##BuildRequires: self-build-libdvdcss
  56. ##BuildRequires: self-build-libdvdnav
  57. ##BuildRequires: self-build-faac
  58. ##BuildRequires: self-build-lame
  59. ##BuildRequires: self-build-libdca
  60. ##BuildRequires: self-build-x264 >= 0.0.0-4.20090110
  61. ##BuildRequires: self-build-xvidcore >= 0.9.2
  62. ##BuildRequires: self-build-faad2 >= 2.6
  63. ##BuildRequires: self-build-libmad
  64. ##BuildRequires: self-build-libmpeg2
  65. Requires: TrueType-vlgothic
  66. %if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl5"
  67. Requires: mesa-libGL
  68. BuildRequires: xorg-x11-devel
  69. BuildRequires: mesa-libGL-devel
  70. %endif
  71. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  72. %description
  73. MPlayer can play most standard video formats out of the box and almost
  74. all others with the help of external codecs.
  75. MPlayer currently works best from the command line, but visual feedback
  76. for many functions is available from its onscreen status display (OSD),
  77. which is also used for displaying subtitles.
  78. MPlayer also has a GUI with skin support and several unofficial alternative
  79. graphical frontends are available.
  80. MEncoder is a command line video encoder for advanced users that can
  81. be built from the MPlayer source tree. Unofficial graphical frontends
  82. exist but arenot included.
  83. MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
  84. support for some newer codecs are not yet inpmlemented.
  85. You should install mplayer-codecs package if you want to play videos
  86. using those new codecs.
  87. %description -l ja
  88. MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
  89. またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
  90. で生できます。
  91. 現在の MPlayer はコマンドラインから使うのが一番便利ですが、多くの操作
  92. は字幕と同様に、オンスクリーン・ディスプレイ (OSD) によりその結果が画
  93. 面上で確認できます。
  94. MPlayer には スキンを変更できる GUI も用意されていますし、また複数の
  95. 非公式なフロントエンドも利用できます。
  96. MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
  97. 非公式な GUI フロントエンドもありますが、このパッケージには含まれて
  98. いません。
  99. MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
  100. を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
  101. いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
  102. をインストールする必要があります。
  103. %prep
  104. #% setup -q -n MPlayer-%{version}%{extver}
  105. %setup -q -n mplayer-export-%{svndate}
  106. %patch2 -p1 -b .config
  107. %patch8 -p1 -b .manlinks
  108. %patch14 -p1 -b .nodvdcss
  109. %patch50 -p1 -b .x11
  110. %build
  111. ./configure \
  112. --prefix=%{_prefix} \
  113. --confdir=%{_sysconfdir}/mplayer \
  114. --enable-runtime-cpudetection \
  115. --extra-cflags="$RPM_OPT_FLAGS" \
  116. --disable-libdvdcss-internal \
  117. --disable-dvdread-internal \
  118. --enable-dvdread \
  119. --enable-dvdnav \
  120. \
  121. --disable-faac-lavc \
  122. --disable-mp3lame-lavc \
  123. --disable-x264-lavc \
  124. \
  125. --disable-faad-internal \
  126. \
  127. --disable-libopenjpeg \
  128. \
  129. --disable-bitmap-font \
  130. --disable-termcap \
  131. --enable-xvmc \
  132. --with-xvmclib=XvMCW \
  133. \
  134. --enable-largefiles \
  135. --enable-menu \
  136. --enable-gui \
  137. --language=ja,en \
  138. ;
  139. %{__make} %{?_smp_mflags}
  140. %install
  141. %{__rm} -rf ${RPM_BUILD_ROOT}
  142. %{__make} install INSTALLSTRIP= \
  143. prefix=${RPM_BUILD_ROOT}%{_prefix} \
  144. BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
  145. DATADIR=${RPM_BUILD_ROOT}%{_datadir}/mplayer \
  146. CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer \
  147. LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
  148. MANDIR=${RPM_BUILD_ROOT}%{_mandir} \
  149. ;
  150. ## install some default config files
  151. %{__install} -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  152. %{__install} -pm 644 etc/example.conf \
  153. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer/mplayer.conf
  154. %{__install} -pm 644 etc/{input,menu,codecs}.conf \
  155. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  156. # install default skin
  157. %{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  158. pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  159. %{__tar} xjf %{SOURCE1}
  160. %{__ln_s} Blue default
  161. popd
  162. # make sybolic link to ttf font for subtitle
  163. for i in %{ttfontlist}; do
  164. if [ -e %{ttfontdir}/$i.ttf ];then
  165. %__ln_s -f %{ttfontdir}/$i.ttf ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
  166. break;
  167. fi;
  168. done
  169. ## install TOOLS
  170. for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
  171. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
  172. done
  173. for file in calcbpp.pl countquant.pl dvd2divxscript.pl ; do
  174. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .pl`
  175. done
  176. for file in vobshift.py ; do
  177. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .py`
  178. done
  179. %__mkdir -p $RPM_BUILD_ROOT%{_datadir}/mplayer
  180. %__install -pm 644 TOOLS/*.fp $RPM_BUILD_ROOT%{_datadir}/mplayer/
  181. %clean
  182. %{__rm} -rf ${RPM_BUILD_ROOT}
  183. %files
  184. %defattr(-,root,root)
  185. %doc AUTHORS Changelog Copyright LICENSE README
  186. %config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
  187. %config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
  188. %config(noreplace) %{_sysconfdir}/mplayer/input.conf
  189. %config(noreplace) %{_sysconfdir}/mplayer/menu.conf
  190. %{_bindir}/mplayer
  191. %{_bindir}/gmplayer
  192. %{_bindir}/mencoder
  193. %{_datadir}/mplayer/skins/Blue
  194. %{_datadir}/mplayer/skins/default
  195. %{_datadir}/mplayer/subfont.ttf
  196. %{_datadir}/applications/mplayer.desktop
  197. %{_datadir}/pixmaps/mplayer.xpm
  198. %{_mandir}/man1/mplayer.1*
  199. %{_mandir}/man1/mencoder.1*
  200. ## TOOLS
  201. %{_bindir}/aconvert
  202. %{_bindir}/calcbpp
  203. %{_bindir}/countquant
  204. %{_bindir}/divx2svcd
  205. %{_bindir}/dvd2divxscript
  206. %{_bindir}/mencvcd
  207. %{_bindir}/midentify
  208. %{_bindir}/mpconsole
  209. %{_bindir}/qepdvcd
  210. %{_bindir}/subsearch
  211. %{_bindir}/vobshift
  212. %{_datadir}/mplayer/*.fp
  213. %changelog
  214. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
  215. - change release to sync with self-build-mplayer
  216. * Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
  217. - updated source snapshot 20100709
  218. - renamed %%Source10 to mplayer-snapshot-vine.sh
  219. - applied mplayer-20100709-fixed-vo_x11_create_vo_window.patch
  220. - added BuildRequires: libvpx-devel >= 0.9.1
  221. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
  222. - updated source snapshot 20100621
  223. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-35.20100615
  224. - updated source snapshot 20100615
  225. - added BuildRequires: libXinerama-devel
  226. - dropped vl4 support
  227. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-34.20100410
  228. - updated source snapshot 20100410
  229. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
  230. - updated source snapshot 20100401
  231. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-32.20100326
  232. - updated source snapshot 20100326
  233. * Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
  234. - updated source snapshot 20100317
  235. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
  236. - updated source snapshot 20100216
  237. - moved scripts from TOOLS
  238. - added --disable-libopenjpeg in configure options
  239. * Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-29.20100201
  240. - updated source snapshot 20100201
  241. - dropped obsolete patches
  242. - added BuildRequires:
  243. - libvdpau-devel
  244. - libXScrnSaver-devel
  245. * Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
  246. - update mplayer-config-20091215-vine.patch
  247. - update mplayer-20091215-x86_32-compile.patch
  248. - added --enable-runtime-cpudetection in configure options
  249. * Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
  250. - source snapshot 20091031
  251. - updated mplayer-20091031-x86_32-compile.patch
  252. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
  253. - source snapshot 20091003
  254. * Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
  255. - change release to sync with self-build-mplayer
  256. * Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
  257. - source snapshot 20090905
  258. - added settings for vl6
  259. * Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
  260. - source snapshot 20090821
  261. - replaced BR: libungif-devel with BR: giflib-devel
  262. * Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
  263. - source snapshot 20090722
  264. * Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
  265. - source snapshot 20090702
  266. * Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
  267. - source snapshot 20090611
  268. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
  269. - added Requires: TrueType-vlgothic
  270. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
  271. - source snapshot 20090522
  272. - build with x264 >= 0.0.0-9.20090522
  273. - updated mplayer-20090522-nodvdcss.patch
  274. * Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
  275. - change release to sync with self-build-mplayer
  276. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
  277. - source snapshot 20090502
  278. - updated mplayer-20090503-x86_32-compile.patch
  279. - updated mplayer-20090502-nodvdcss.patch
  280. * Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
  281. - applied mplayer-config-vine.patch
  282. * Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
  283. - source snapshot 20090327
  284. - updated mplayer-20090327-x86_32-compile.patch
  285. - updated mplayer-20090325-nodvdcss.patch
  286. - dropped gmplayer-about-vine.patch
  287. - install some default config files
  288. - added configure options:
  289. - --disable-termcap
  290. - --enable-xvmc
  291. - --with-xvmclib=XvMCW
  292. - archived doc/mplayer-1.0/TOOLS directory to doc/TOOLS.tar.bz2
  293. - fixed %%files for *.conf
  294. * Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-13.20090305
  295. - source snapshot 20090305
  296. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-12.20090227
  297. - source snapshot 20090227
  298. * Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-11.20090216
  299. - source snapshot 20090216
  300. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
  301. - source snapshot 20090206
  302. - dropped mplayer-man-zh_CN.patch
  303. - updated mplayer-20090206-nodvdcss.patch
  304. - changed to PreReq: self-build-faad2 from faad2-devel
  305. - added PreReq: self-build-libmad
  306. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
  307. - source snapshot 20090131
  308. * Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
  309. - change release to sync with self-build-mplayer
  310. * Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
  311. - source snapshot
  312. - update mplayer-20090122-nodvdcss.patch
  313. - added BuildRequires:
  314. - faad2-devel
  315. - libmpcdec-devel
  316. - twolame-devel
  317. - yasm
  318. - faac-devel (as PreReq in self-build-%{name})
  319. - lame-devel (as PreReq in self-build-%{name})
  320. - libdca-devel (as PreReq in self-build-%{name})
  321. - x264-devel >= 0.0.0-4.20090110 (as PreReq in self-build-%{name})
  322. - xvidcore-devel >= 0.9.2 (as PreReq in self-build-%{name})
  323. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
  324. - source snapshot
  325. - added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
  326. --disable-faad-internal in configure options
  327. - dropped gmplayer-add-flv-extension.patch
  328. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
  329. - source snapshot
  330. - fixed License
  331. - added some patches from RPM Fusion
  332. - updated gmplayer-about-vine.patch for 20081001 snapshot
  333. - added BuildRequires: libdvdread
  334. - added BuildRequires: self-build-libdvdcss self-build-libdvdnav
  335. - added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
  336. in configure options
  337. #- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
  338. * Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
  339. - fixed License
  340. - added some devel packages to support OpenGL
  341. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
  342. - spec in utf8
  343. - fix sybolic link of subfont for vl5
  344. * Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
  345. - add "Patch105: CVE-2008-1558.patch".
  346. * Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
  347. - build with new versioning policy.
  348. - fix Source[01] URLs.
  349. - add "Patch200: gmplayer-about-vine.patch".
  350. - add "Patch201: gmplayer-add-flv-extension.patch".
  351. * Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
  352. - add four official security patches (CVE-2008-0485, CVE-2008-0486,
  353. CVE-2008-0629, CVE-2008-0630)
  354. - add mplayer-1.0rc2-20080211-stream_cddb.patch
  355. * Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
  356. - change source download URL. <BTS:VineLinux:603>
  357. * Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
  358. - fix CONFDIR for make install. <BTS:wishes:33>
  359. * Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
  360. - initial build for Vine Linux