gnome-shell-vl.spec 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177
  1. %define pkg_version 3.1.4
  2. %define pkg_release 2%{?_dist_release}
  3. Summary: Window management and application launching for GNOME
  4. Name: gnome-shell
  5. Version: %{pkg_version}
  6. Release: %{pkg_release}
  7. Source0: %{name}-%{version}.tar.xz
  8. Patch0: gnome-shell-git20110821.patch
  9. # settings for Vine
  10. Patch101: gnome-shell-vine-settings.patch
  11. Patch102: gnome-shell-vine-customize.patch
  12. Patch103: gnome-shell-3.1.4-ja.po.patch
  13. License: GPLv2+
  14. Group: User Interface/Desktops
  15. URL: http://live.gnome.org/GnomeShell
  16. Requires(post,postun): scrollkeeper >= 0.1.4
  17. Requires(post,pre,preun): GConf2 >= 2.14
  18. Requires: mutter
  19. BuildRequires: gnome-common
  20. BuildRequires: libtool
  21. BuildRequires: automake
  22. BuildRequires: autoconf
  23. BuildRequires: pkgconfig
  24. BuildRequires: gtk2-devel
  25. BuildRequires: clutter-devel
  26. BuildRequires: mutter-devel
  27. BuildRequires: gjs-devel
  28. BuildRequires: gnome-desktop3-devel
  29. BuildRequires: gnome-menus-devel
  30. BuildRequires: libSM-devel
  31. BuildRequires: libffi-devel
  32. BuildRequires: GConf2-devel
  33. BuildRequires: startup-notification-devel
  34. BuildRequires: gnome-doc-utils
  35. BuildRequires: desktop-file-utils
  36. BuildRequires: libcroco-devel
  37. BuildRequires: librsvg2-devel
  38. BuildRequires: gobject-introspection-devel
  39. BuildRequires: gstreamer-devel
  40. BuildRequires: dbus-glib-devel
  41. BuildRequires: telepathy-logger-devel
  42. BuildRequires: polkit-devel
  43. BuildRequires: pulseaudio-libs-devel
  44. BuildRequires: evolution-data-server-devel
  45. BuildRequires: intltool
  46. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  47. Vendor: Project Vine
  48. Distribution: Vine Linux
  49. Packager: Takemikaduchi
  50. %description
  51. GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
  52. It provides core interface functions like switching to windows and launching
  53. applications. GNOME Shell takes advantage of the capabilities of modern graphics
  54. hardware and introduces innovative user interface concepts to provide a delightful
  55. and easy to use experience.
  56. %prep
  57. %setup -q
  58. %patch0 -p1
  59. %patch101 -p1 -b .vine
  60. %patch102 -p1 -b .vine
  61. %patch103 -p1 -b .old_po
  62. %build
  63. libtoolize --copy --force
  64. autoreconf
  65. %configure --disable-static
  66. %{__make} %{?_smp_mflags}
  67. %install
  68. %{__rm} -rf ${RPM_BUILD_ROOT}
  69. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  70. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  71. %find_lang %{name}
  72. %clean
  73. %{__rm} -rf ${RPM_BUILD_ROOT}
  74. %post
  75. /sbin/ldconfig
  76. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  77. gconftool-2 --makefile-install-rule \
  78. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  79. > /dev/null || :
  80. touch --no-create %{_datadir}/icons/hicolor
  81. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  82. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  83. fi
  84. %pre
  85. if [ "$1" -gt 1 ]; then
  86. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  87. gconftool-2 --makefile-uninstall-rule \
  88. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  89. > /dev/null || :
  90. fi
  91. %preun
  92. if [ "$1" -eq 0 ]; then
  93. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  94. gconftool-2 --makefile-uninstall-rule \
  95. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  96. > /dev/null || :
  97. fi
  98. %postun
  99. scrollkeeper-update -q || :
  100. /sbin/ldconfig
  101. touch --no-create %{_datadir}/icons/hicolor
  102. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  103. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  104. fi
  105. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  106. %posttrans
  107. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  108. %files -f %{name}.lang
  109. %defattr(-,root,root)
  110. %doc COPYING NEWS README
  111. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas
  112. %{_bindir}/gnome-shell
  113. %{_bindir}/gnome-shell-extension-tool
  114. %{_libdir}/gnome-shell/*
  115. %{_libexecdir}/gnome-shell-calendar-server
  116. %{_libexecdir}/gnome-shell-hotplug-sniffer
  117. %{_libexecdir}/gnome-shell-perf-helper
  118. %{_datadir}/applications/gnome-shell.desktop
  119. %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
  120. %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
  121. %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
  122. %{_datadir}/gnome-shell/*
  123. %{_datadir}/man/man1/*.1.gz
  124. %changelog
  125. * Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
  126. - rebuild with gnome-menus-3.1.5
  127. - add Patch0 (gnome-shell-git20110821.patch)
  128. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  129. - new upstream release
  130. - add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
  131. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  132. - remove BuildRequires: xulrunner-devel
  133. - add Patch101 (gnome-shell-vine-settings.patch)
  134. - add Patch102 (gnome-shell-vine-customize.patch)
  135. - add Patch103 (gnome-shell-3.1.4-ja.po.patch)
  136. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
  137. - add Requires: mutter
  138. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
  139. - new upstream release
  140. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  141. - initial build for Vine Linux