rhythmbox-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619
  1. # -*- coding: utf-8-unix -*-
  2. %define desktop_file_utils_version 0.9
  3. %define enable_DLNA_UPnP 0
  4. Summary: Music Management Application
  5. Summary(ja): 音楽管理アプリケーション
  6. Name: rhythmbox
  7. Version: 2.99.1
  8. Release: 1%{?_dist_release}
  9. License: GPL2+ with exceptions and GFDL
  10. Group: Applications/Multimedia
  11. URL: http://projects.gnome.org/rhythmbox/
  12. Source0: http://download.gnome.org/sources/rhythmbox/2.99/%{name}-%{version}.tar.xz
  13. Source101: rhythmbox-png.tar.bz2
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gtk3-devel
  16. BuildRequires: avahi-glib-devel >= 0.6
  17. BuildRequires: brasero-devel >= 2.32.0
  18. BuildRequires: dbus-glib-devel
  19. BuildRequires: gstreamer1-plugins-base-devel
  20. BuildRequires: json-glib-devel
  21. BuildRequires: libSM-devel
  22. BuildRequires: libgnome-keyring-devel >= 2.30.0
  23. BuildRequires: libgpod-devel
  24. BuildRequires: libgudev1-devel
  25. BuildRequires: libmusicbrainz3-devel >= 3.0.2
  26. BuildRequires: libnotify-devel
  27. BuildRequires: libsoup-devel
  28. BuildRequires: pygobject3-devel
  29. BuildRequires: totem-pl-parser-devel
  30. BuildRequires: WebKit3-gtk-devel
  31. BuildRequires: libpeas-devel
  32. BuildRequires: clutter-gtk-devel
  33. BuildRequires: clutter-gst-devel
  34. BuildRequires: libmx-devel
  35. BuildRequires: check-devel
  36. BuildRequires: libmtp-devel
  37. BuildRequires: libtdb-devel
  38. BuildRequires: grilo-devel
  39. BuildRequires: libdmapsharing-devel
  40. BuildRequires: lirc
  41. BuildRequires: gnome-doc-utils >= 0.3.2
  42. BuildRequires: yelp-tools
  43. Requires: libgpod
  44. Requires: libnotify
  45. Requires: lirc
  46. Requires: libmtp
  47. Requires: brasero
  48. Requires: libgnome-keyring
  49. %if %{enable_DLNA_UPnP}
  50. Requires: python-Coherence
  51. %endif
  52. Requires: desktop-file-utils >= %{desktop_file_utils_version}
  53. # # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
  54. # # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
  55. # # respectively.
  56. # Requires: self-build-gstreamer-plugins-ffmpeg
  57. # Requires: self-build-gstreamer-plugins-ugly
  58. Vendor: Project Vine
  59. Distribution: Vine Linux
  60. %description
  61. Rhythmbox is an integrated music management application based on the powerful
  62. GStreamer media framework. It has a number of features, including an easy to
  63. use music browser, searching and sorting, comprehensive audio format support
  64. through GStreamer, Internet Radio support, playlists and more.
  65. Rhythmbox is extensible through a plugin system.
  66. %description -l ja
  67. Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
  68. 統合音楽管理アプリケーションです。
  69. 見やすいユーザインターフェースを備え、検索や整列ができ、
  70. GStreamer により数多くの音声フォーマットをサポート、
  71. インターネットラジオをサポート、プレイリスト管理などの
  72. 数多くの特徴を持ちます。
  73. %package devel
  74. Summary: Development tools for rhythmbox applications.
  75. Summary(ja): rhythmbox アプリケーションの開発用ファイル
  76. Group: Development/Libraries
  77. Requires: %{name} = %{version}-%{release}
  78. Requires: pkgconfig
  79. Requires: libxml2-devel
  80. Requires: glib2-devel
  81. Requires: gtk3-devel
  82. Requires: libsoup-devel
  83. Requires: totem-pl-parser-devel
  84. Requires: gstreamer1-devel
  85. %description devel
  86. Header files and libraries for building a extension library for the rhythmbox.
  87. %description devel -l ja
  88. %prep
  89. %setup -q
  90. tar xjf %{SOURCE101}
  91. %build
  92. libtoolize --force --copy
  93. autoreconf
  94. %configure --with-ipod \
  95. --with-mtp \
  96. --enable-lirc \
  97. --enable-python \
  98. --disable-vala \
  99. --disable-browser-plugin \
  100. --disable-static \
  101. --enable-browser-plugin \
  102. --without-hal
  103. %__make %{?_smp_mflags}
  104. %install
  105. %__rm -rf $RPM_BUILD_ROOT
  106. %__make install DESTDIR=$RPM_BUILD_ROOT
  107. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
  108. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
  109. %__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  110. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
  111. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
  112. %__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
  113. %__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
  114. ## Don't package DLNA/UPnP plugin
  115. %if !%{enable_DLNA_UPnP}
  116. %__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
  117. %endif
  118. %find_lang %{name} --all-name --with-gnome
  119. # Don't package api docs
  120. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
  121. # And don't package vala
  122. %__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
  123. %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
  124. # remove sample plugins
  125. rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
  126. %clean
  127. %__rm -rf $RPM_BUILD_ROOT
  128. %post
  129. /sbin/ldconfig
  130. update-desktop-database -q
  131. touch --no-create %{_datadir}/icons/hicolor
  132. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  133. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  134. fi
  135. %postun
  136. /sbin/ldconfig
  137. update-desktop-database -q
  138. touch --no-create %{_datadir}/icons/hicolor
  139. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  140. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  141. fi
  142. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  143. %posttrans
  144. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  145. %files -f %{name}.lang
  146. %defattr(-, root, root)
  147. %doc AUTHORS COPYING ChangeLog README NEWS
  148. %{_bindir}/*
  149. %{_libdir}/girepository-1.0/*.typelib
  150. %{_libdir}/lib*.so.*
  151. %{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
  152. %{_libdir}/rhythmbox/plugins
  153. %{_datadir}/applications/rhythmbox.desktop
  154. %{_datadir}/applications/rhythmbox-device.desktop
  155. %{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
  156. %{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
  157. %{_datadir}/icons/*
  158. %{_datadir}/rhythmbox
  159. %{_mandir}/man1/*
  160. %{_libexecdir}/rhythmbox-metadata
  161. %files devel
  162. %defattr(-, root, root)
  163. %{_includedir}/%{name}/*
  164. %{_libdir}/*.so
  165. %{_libdir}/pkgconfig/*.pc
  166. %{_datadir}/gir-1.0/*.gir
  167. %changelog
  168. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.1-1
  169. - new upstream release
  170. - add BuildRequies: yelp-tools
  171. - change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
  172. * Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-2
  173. - rebuild with libimobiledevice-1.1.5
  174. * Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
  175. - new upstream release
  176. - add BuildRequires: grilo-devel, libdmapsharing-devel
  177. * Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
  178. - new upstream release
  179. * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
  180. - new upstream release
  181. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
  182. - new upstream release
  183. - add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
  184. - remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
  185. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
  186. - rebuild with cogl-0.8.0
  187. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
  188. - rebuild with libnotify-0.7
  189. - change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
  190. - change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
  191. - add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
  192. - add Patch0 (rhythmbox-0.13.3-git20110809.patch)
  193. - add Source101 (rhythmbox-png.tar.bz2)
  194. * Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
  195. - add BuildRequires: json-glib-devel
  196. - remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
  197. * Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
  198. - new upstream release
  199. - change BuildRequires: gstreamer-python-devel instead of gstreamer-python
  200. * Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
  201. - new upstream release
  202. * Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
  203. - rebuild with brasero-2.32.0
  204. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
  205. - rebuild with rpm-4.8.1 for pkg-config file
  206. * Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
  207. - new upstream release
  208. - fix %files (add rhythmbox-device.desktop)
  209. * Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
  210. - new upstream release
  211. - change BuildRequires: gnome-media-devel instead of gnome-media
  212. - add devel package
  213. - drop Patch0
  214. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
  215. - new upstream release
  216. - drop Patch1, Patch2, Patch3
  217. - change BuildRequires: nautilus-cd-burner -> brasero-devel
  218. - change Requires: nautilus-cd-burner -> brasero
  219. - change BuildRequires: hal-devel -> libgudev1-devel
  220. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  221. - change Requires: gnome-keyring -> libgnome-keyring
  222. - add configure option (--without-hal)
  223. * Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
  224. - rebuilt with new environment
  225. * Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
  226. - new upstream release
  227. - dropped upstreamed/obsolete patches
  228. - added patches applied Fedora development
  229. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
  230. - new upstream release
  231. - added configure options:
  232. --disable-vala
  233. --disable-browser-plugin
  234. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
  235. - added Japanese description
  236. * Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
  237. - new upstream release
  238. - dropped rb-disable-power-plugin-by-default.patch
  239. - added BuildRequires:
  240. - libSM-devel
  241. - gnome-media
  242. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
  243. - rebuild with libgpod-0.7.2
  244. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
  245. - new upstream release
  246. - corrected License tag
  247. - dropped rhythmbox-0.11.6-libmtp.patch
  248. - added BuildRequires:
  249. - sqlite3-devel
  250. - libffi-devel
  251. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
  252. - defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
  253. - applied rhythmbox-0.11.6-libmtp.patch
  254. - added Requires:
  255. - libgpod
  256. - libnotify
  257. - libsexy
  258. - lirc
  259. - libmtp
  260. - libgnomeui
  261. - nautilus-cd-burner
  262. - gstreamer-python
  263. - gnome-vfs2
  264. - gnome-themes
  265. - gnome-keyring
  266. - python-Coherence, if enable_DLNA_UPnP = 1
  267. - added BuildRequires:
  268. - libnotify-devel
  269. - libsexy-devel
  270. - lirc
  271. - libmtp-devel
  272. - gnome-vfs2-devel, instead of gnome-vfs2
  273. - gnome-keyring-devel
  274. - dropped --with-internal-libsexy in configure options
  275. - added in configure options:
  276. --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
  277. - added %%preun to remove the schema
  278. * Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
  279. - new upstream release
  280. - changed to --with-metadata-helper in configure options
  281. - added BuildRequires:
  282. - gstreamer-python
  283. - intltool >= 0.35.0
  284. - popt-devel
  285. * Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
  286. - added BuildRequires: totem-pl-parser-devel, instead of totem-devel
  287. - rebuilt with python-2.5.2
  288. - applied new versioning policy
  289. - spec in utf-8
  290. * Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
  291. - rebuilt with libgpod-0.6.0
  292. * Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
  293. - new upstream release
  294. * Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
  295. - new upstream release
  296. * Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
  297. - rebuilt with new toolchain and libgpod-0.4.2
  298. - add BuildRequires: dbus-glib-devel
  299. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
  300. - new upstream release
  301. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
  302. - rebuilt for VineSeed
  303. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
  304. - new upstream release
  305. - added --enable-python option to %%configure
  306. - added Requires: gnome-python
  307. * Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
  308. - new upstream release
  309. - built with libsoup 2.2.99
  310. * Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
  311. - added --with-cd-burner to configure
  312. - added BuildRequires: libsexy-devel hal-devel libsoup-devel
  313. * Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
  314. - add BuildRequires:
  315. - gnome-doc-utils >= 0.3.2
  316. - python-devel
  317. - pygtk2-devel
  318. - check >= 0.8.2
  319. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
  320. - rebuild with gnutls-1.4.1
  321. * Sun Oct 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
  322. - new upstream release
  323. * Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
  324. - new upstream release
  325. - run scrollkeeper-update at %post and %postun
  326. - added BuildRequires: libnotify-devel
  327. * Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
  328. - new upstream release (dropped patch0)
  329. - added --without-metadata-helper at configure
  330. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
  331. - Initial build for Vine Linux based on FC pacakge
  332. * Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
  333. - add patch from James "Doc" Livingston to stop a hang
  334. for new users (bug 183883)
  335. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
  336. - bump again for double-long bug on ppc(64)
  337. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
  338. - rebuilt for new gcc4.1 snapshot and glibc changes
  339. * Sat Feb 4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
  340. - Update to 0.9.3.1
  341. - Use gstreamer (0.10)
  342. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
  343. - Remove hack for 173869, as its no longer needed.
  344. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
  345. - 0.9.3
  346. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
  347. - Newer CVS snapshot
  348. * Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
  349. - Update to latest CVS
  350. - Add hack to workaround bug #173869
  351. * Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
  352. - Rebuild, now that gstreamer08-plugins has been fixed
  353. * Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
  354. - bonobo multilib issue (bug 156982)
  355. * Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
  356. - rebuild with ipod support
  357. * Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
  358. - rebuilt again
  359. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  360. - rebuilt
  361. * Mon Dec 5 2005 Matthias Clasen <mclasen@redhat.com>
  362. - rebuild
  363. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
  364. - rebuild for new dbus
  365. * Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
  366. - Update to 0.9.2
  367. * Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
  368. - Update to 0.9.1
  369. * Fri Sep 02 2005 Colin Walters <walters@redhat.com>
  370. - Add configure flags --with-bonobo --with-dbus
  371. - BR nautilus-cd-burner-devel
  372. - New upstream CVS snapshot for testing
  373. - Drop IDL file and ui .xml
  374. - Add dbus service file
  375. - Drop upstreamed rhythmbox-bluecurve.tar.gz
  376. - Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
  377. * Mon Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
  378. - Add Bluecurve-ized icons from Jeff Schroeder (157716)
  379. - Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
  380. cell renderer for playback icon (no longer necessary) and
  381. changes the rating renderer to work with non-b&w icons
  382. * Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
  383. - Rebuild for GCC4
  384. * Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
  385. - New upstream version
  386. - Remove librb-nautilus-context-menu.so, killed upstream
  387. * Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
  388. - PreReq desktop-file-utils >= 0.9
  389. * Wed Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
  390. - New upstream version
  391. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
  392. - Fix postun to use correct syntax, thanks Nils Philippsen
  393. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
  394. - New upstream version
  395. - Call update-desktop-database in post and postun
  396. * Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
  397. - New upstream version
  398. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  399. - rebuilt
  400. * Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
  401. - New upstream version
  402. - Remove backported patches
  403. - Gratuitiously bump various BuildRequires versions
  404. * Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
  405. - Remove code to unregister GConf schema for now (Closes: #122532)
  406. * Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
  407. - Apply tiny patch from 0.8 arch to fix GConf key used
  408. for initial sorting
  409. * Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
  410. - Apply patch from 0.8 arch tree to fix a number of memleaks
  411. * Sun May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
  412. - Update to 0.8.3: fixes showstopper bug with internet radio
  413. * Fri Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
  414. - Update to 0.8.2
  415. - Fix Source url
  416. - Add smp_mflags
  417. - Bump BuildRequires on gstreamer to 0.8.1
  418. * Fri Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
  419. - Uninstall GConf schemas on removal
  420. * Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
  421. - Update to 0.8.1
  422. * Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
  423. - Update to 0.8.0
  424. * Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
  425. - Update to 0.7.2
  426. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
  427. - Remove BuildRequires on autoconf and libvorbis-devel
  428. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
  429. - New major version - I know we are past major version slush, but
  430. this should have been done two weeks ago along with the GNOME 2.6
  431. upload. As upstream author as well, I believe this version is
  432. good enough for FC2.
  433. - Remove --disable-mp3
  434. - Remove id3, flac variables
  435. - Remove GStreamer major version patch
  436. - Fix typo in description
  437. * Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
  438. - rebuild for new gstreamer
  439. * Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
  440. - update to 0.6.8
  441. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  442. - rebuilt
  443. * Mon Mar 1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
  444. - update to 0.6.7
  445. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  446. - rebuilt
  447. * Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
  448. - New upstream version
  449. - Don't re-run the autotools; upstream incorporates newer versions.
  450. * Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
  451. - new version
  452. - remove smp_flags
  453. * Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
  454. - remove the initial iradio channels as they all are mp3 based.
  455. * Wed Oct 8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
  456. - Fix category from Development/Libraries to Applications/Multimedia.
  457. - Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
  458. - Fix SCHEMES vs. SCHEMAS in the post scriplet.
  459. - Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
  460. - Removed unnecessary date expansion define.
  461. - Updated description, including mp3 reference removal.
  462. - Added libid3tag and flac optional support for convenient rebuild.
  463. - Removed obsolete omf.make and xmldocs.make (included ones are the same now).
  464. * Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
  465. - new version
  466. - use %{_sysconfdir} instead of /etc
  467. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  468. - rebuilt
  469. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  470. - gave up on other archs for the Beta
  471. - new version
  472. - remove werror and add missing files
  473. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  474. - update to newer cvs snap
  475. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  476. - update to cvs snap
  477. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  478. - use %%(lang)
  479. * Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
  480. - fix post to actually install the schema
  481. * Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  482. - Added gconf file
  483. - Added i18n directory
  484. * Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  485. - Updated for new rewrite of rhythmbox, thanks to Jeroen
  486. * Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
  487. - removed bonobo dependency
  488. * Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
  489. - created new spec file