libgda-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575
  1. %define major 5
  2. %define minor 1
  3. %define micro 2
  4. %define version %{major}.%{minor}.%{micro}
  5. %define __libtoolize :
  6. # Default provider build options (MySQL, Postgres & unixODBC)
  7. #
  8. # Package build options:
  9. # --with tds
  10. # --with db2
  11. # --with oracle
  12. # --without sqlite
  13. # --with sybase
  14. # --with mdb
  15. # --without ldap
  16. # --without mysql
  17. # --without odbc
  18. # --without postgres
  19. #
  20. %define FREETDS 0
  21. %define IBMDB2 0
  22. %define MYSQL 1
  23. %define ODBC 0
  24. %define ORACLE 0
  25. %define POSTGRES 1
  26. %define SQLITE 1
  27. %define SYBASE 0
  28. %define MDB 0
  29. %define LDAP 0
  30. %{?_with_tds:%define FREETDS 1}
  31. %{?_with_db2:%define IBMDB2 1}
  32. %{?_without_ldap:%define LDAP 0}
  33. %{?_with_mdb:%define MDB 1}
  34. %{?_with_oracle:%define ORACLE 1}
  35. %{?_without_sqlite:%define SQLITE 0}
  36. %{?_with_sybase:%define SYBASE 1}
  37. %{?_without_mysql:%define MYSQL 0}
  38. %{?_without_odbc:%define ODBC 0}
  39. %{?_without_postgres:%define POSTGRES 0}
  40. %define libver 5.0
  41. Summary: A (relatively small) database access library
  42. Name: libgda
  43. Version: %{version}
  44. Release: 1%{?_dist_release}
  45. Source: %{name}-%{version}.tar.xz
  46. URL: http://www.gnome-db.org/
  47. Group: System Environment/Libraries
  48. License: LGPL
  49. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  50. Summary(ja): 比較的小規模なデータベース接続ライブラリ
  51. Patch0: libgda-4.2.0-disable-mdb.patch
  52. Vendor: Project Vine
  53. Distribution: Vine Linux
  54. Packager: yasumichi
  55. BuildRequires: pkgconfig >= 0.8
  56. BuildRequires: intltool >= 0.35.5
  57. BuildRequires: glib2-devel >= 2.12.0
  58. BuildRequires: gtk3-devel
  59. BuildRequires: gobject-introspection-devel
  60. BuildRequires: libxml2-devel
  61. BuildRequires: libxslt-devel >= 1.0.9
  62. BuildRequires: db4-devel ncurses-devel
  63. BuildRequires: gamin-devel >= 0.1.8
  64. BuildRequires: libgcrypt-devel >= 1.1.42
  65. BuildRequires: gtksourceview3-devel
  66. BuildRequires: libsoup-devel
  67. BuildRequires: libsecret-devel
  68. BuildRequires: iso-codes
  69. %if %{FREETDS}
  70. BuildRequires: freetds-devel
  71. %endif
  72. %if %{MYSQL}
  73. BuildRequires: MySQL-devel
  74. %endif
  75. %if %{POSTGRES}
  76. BuildRequires: postgresql-devel
  77. %endif
  78. %if %{ODBC}
  79. BuildRequires: unixODBC-devel
  80. %endif
  81. %if %{SQLITE}
  82. BuildRequires: sqlite3-devel
  83. %endif
  84. %if %{MDB}
  85. BuildRequires: mdbtools-devel
  86. %endif
  87. %if %{LDAP}
  88. BuildRequires: openldap-devel
  89. %endif
  90. %description
  91. Libgda is a (relatively small) database access library:
  92. - a wrapper like ODBC but with more features to access several database
  93. engines
  94. - a meta data extractor (to know all about database objects in a common
  95. way)
  96. - comes with an SQL console application (like mysql, psql or sqlite3
  97. consoles)
  98. - relies on GLib, coded in C, its API is easy to use
  99. - at the moment supports SQLite, MySQL, PostgreSQL, MSAccess and Bdb, work
  100. is in progress for other database types (such as Firebird and Oracle) and
  101. to wrap JDBC for more wider usage.
  102. Build option is:
  103. --with mysql postgres sqlite
  104. --without tds ibmdb2 ldap mdb odbc oracle sybase
  105. %package devel
  106. Summary: Development libraries and header files for libgda.
  107. Group: Development/Libraries
  108. Requires: %{name} = %{version}
  109. Requires: glib2-devel >= 2.12.0
  110. Requires: libxml2-devel
  111. Requires: libxslt-devel >= 1.0.9
  112. %description devel
  113. This package contains the header files and libraries needed to write
  114. or compile programs that use libgda.
  115. #%package sharp
  116. #Summary: Mono bindings for libgda
  117. #Group: System Environment/Libraries
  118. #Requires: %{name} = %{version}-%{release}
  119. #Requires: mono-core
  120. #
  121. #%description sharp
  122. #This package contains the dll files needed to run (and compile) Mono
  123. #applications which use libgda.
  124. %if %{FREETDS}
  125. %package -n gda-freetds
  126. Summary: GDA FreeTDS Provider
  127. Group: System Environment/Libraries
  128. %description -n gda-freetds
  129. This package includes the GDA FreeTDS provider.
  130. %endif
  131. %if %{IBMDB2}
  132. %package -n gda-ibmdb2
  133. Summary: GDA IBM DB2 Provider
  134. Group: System Environment/Libraries
  135. %description -n gda-ibmdb2
  136. This package includes the GDA IBM DB2 provider.
  137. %endif
  138. %if %{MYSQL}
  139. %package -n gda-mysql
  140. Summary: GDA MySQL Provider
  141. Group: System Environment/Libraries
  142. %description -n gda-mysql
  143. This package includes the GDA MySQL provider.
  144. %endif
  145. %if %{ODBC}
  146. %package -n gda-odbc
  147. Summary: GDA ODBC Provider
  148. Group: System Environment/Libraries
  149. %description -n gda-odbc
  150. This package includes the GDA ODBC provider.
  151. %endif
  152. %if %{ORACLE}
  153. %package -n gda-oracle
  154. Summary: GDA Oracle Provider
  155. Group: System Environment/Libraries
  156. %description -n gda-oracle
  157. This package includes the GDA Oracle provider.
  158. %endif
  159. %if %{POSTGRES}
  160. %package -n gda-postgres
  161. Summary: GDA PostgreSQL Provider
  162. Group: System Environment/Libraries
  163. %description -n gda-postgres
  164. This package includes the GDA PostgreSQL provider.
  165. %endif
  166. %if %{SQLITE}
  167. %package -n gda-sqlite
  168. Summary: GDA SQLite Provider
  169. Group: System Environment/Libraries
  170. %description -n gda-sqlite
  171. This package includes the GDA SQLite provider.
  172. %endif
  173. %if %{SYBASE}
  174. %package -n gda-sybase
  175. Summary: GDA Sybase Provider
  176. Group: System Environment/Libraries
  177. %description -n gda-sybase
  178. This package includes the GDA Sybase provider.
  179. %endif
  180. %if %{MDB}
  181. %package -n gda-mdb
  182. Summary: GDA MDB Provider
  183. Group: System Environment/Libraries
  184. %description -n gda-mdb
  185. This package includes the GDA MDB provider.
  186. %endif
  187. %if %{LDAP}
  188. %package -n gda-ldap
  189. Summary: GDA LDAP Provider
  190. Group: System Environment/Libraries
  191. %description -n gda-ldap
  192. This package includes the GDA LDAP provider.
  193. %endif
  194. %prep
  195. %setup -q -n %{name}-%{version}
  196. %patch0 -p1 -b .mdb
  197. %build
  198. %if %{FREETDS}
  199. CONFIG="$CONFIG --with-tds"
  200. %else
  201. CONFIG="$CONFIG --without-tds"
  202. %endif
  203. %if %{IBMDB2}
  204. CONFIG="$CONFIG --with-ibmdb2"
  205. %else
  206. CONFIG="$CONFIG --without-ibmdb2"
  207. %endif
  208. %if %{MYSQL}
  209. CONFIG="$CONFIG --with-mysql"
  210. %else
  211. CONFIG="$CONFIG --without-mysql"
  212. %endif
  213. %if %{POSTGRES}
  214. CONFIG="$CONFIG --with-postgres"
  215. %else
  216. CONFIG="$CONFIG --without-postgres"
  217. %endif
  218. %if %{ODBC}
  219. CONFIG="$CONFIG --with-odbc"
  220. %else
  221. CONFIG="$CONFIG --without-odbc"
  222. %endif
  223. %if %{ORACLE}
  224. CONFIG="$CONFIG --with-oracle"
  225. %else
  226. CONFIG="$CONFIG --without-oracle"
  227. %endif
  228. %if %{SQLITE}
  229. CONFIG="$CONFIG --with-sqlite"
  230. %else
  231. CONFIG="$CONFIG --without-sqlite"
  232. %endif
  233. %if %{SYBASE}
  234. CONFIG="$CONFIG --with-sybase"
  235. %else
  236. CONFIG="$CONFIG --without-sybase"
  237. %endif
  238. %if %{MDB}
  239. CONFIG="$CONFIG --with-mdb"
  240. %else
  241. CONFIG="$CONFIG --without-mdb"
  242. %endif
  243. %if %{LDAP}
  244. CONFIG="$CONFIG --with-ldap"
  245. %else
  246. CONFIG="$CONFIG --without-ldap"
  247. %endif
  248. %configure $CONFIG \
  249. --disable-static \
  250. --enable-introspection \
  251. --disable-gtk-doc \
  252. --with-libdir-name=%{_lib}
  253. make
  254. %install
  255. rm -rf $RPM_BUILD_ROOT
  256. #makeinstall LIBGDA_DTDDIR=%{buildroot}%{_datadir}/libgda/dtd
  257. make install DESTDIR=$RPM_BUILD_ROOT
  258. #fixup mono / sharp related files install
  259. #mkdir -p %{buildroot}/%{_datadir}/gapi-2.0
  260. #mv %{buildroot}/%{_libdir}/libgda/gda-api.xml %{buildroot}/%{_datadir}/gapi-2.0
  261. #mkdir -p %{buildroot}/usr/lib/mono/gda-sharp-2.0
  262. #mv %{buildroot}/%{_libdir}/libgda/* %{buildroot}/usr/lib/mono/gda-sharp-2.0
  263. #rmdir %{buildroot}/%{_libdir}/libgda
  264. # Cleanup unnecessary, unpackaged files
  265. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  266. rm -f %{buildroot}/%{_sysconfdir}/libgda-%{libver}/sales_test.db
  267. %find_lang libgda-%{libver}
  268. %post -p /sbin/ldconfig
  269. %postun -p /sbin/ldconfig
  270. %clean
  271. rm -rf $RPM_BUILD_ROOT
  272. %files
  273. %defattr(-,root,root)
  274. %doc AUTHORS COPYING COPYING.LIB ChangeLog README NEWS
  275. %dir %{_sysconfdir}/libgda-%{libver}
  276. %config(noreplace) %{_sysconfdir}/libgda-%{libver}/config
  277. %{_bindir}/*
  278. %{_libdir}/*.so.*
  279. #%{_libdir}/girepository-1.0/*.typelib
  280. %dir %{_libdir}/libgda-%{libver}
  281. %dir %{_libdir}/libgda-%{libver}/plugins
  282. %{_libdir}/libgda-%{libver}/plugins/*.xml
  283. %{_libdir}/libgda-%{libver}/plugins/libgda-ui-plugins.so
  284. %dir %{_libdir}/libgda-%{libver}/providers
  285. %{_libdir}/libgda-%{libver}/providers/libgda-bdb.so
  286. %{_libdir}/libgda-%{libver}/providers/libgda-sqlcipher.so
  287. %{_libdir}/libgda-%{libver}/providers/libgda-web.so
  288. %{_datadir}/applications/*.desktop
  289. %{_datadir}/icons/hicolor/*/*/*
  290. %{_datadir}/gnome/help/gda-sql/C/gda-sql-help.xml
  291. %{_datadir}/pixmaps/gda-browser-5.0.png
  292. %dir %{_datadir}/libgda-%{libver}
  293. %{_datadir}/libgda-%{libver}/demo
  294. %{_datadir}/libgda-%{libver}/dtd
  295. %{_datadir}/libgda-%{libver}/gda_trml2html
  296. %{_datadir}/libgda-%{libver}/gda_trml2pdf
  297. %{_datadir}/libgda-%{libver}/icons
  298. %{_datadir}/libgda-%{libver}/language-specs/gda-sql.lang
  299. %{_datadir}/libgda-%{libver}/php
  300. %{_datadir}/libgda-%{libver}/pixmaps
  301. %{_datadir}/libgda-%{libver}/server_operation.glade
  302. %{_datadir}/libgda-%{libver}/ui
  303. %{_datadir}/libgda-%{libver}/*.xml
  304. %{_datadir}/libgda-%{libver}/web
  305. %{_mandir}/man1/*
  306. %{_datadir}/locale/*/LC_MESSAGES/*
  307. %files devel
  308. %defattr(-,root,root)
  309. %{_includedir}/libgda-%{libver}
  310. %{_libdir}/*.so
  311. %{_libdir}/pkgconfig/*
  312. #%{_datadir}/gir-1.0/*.gir
  313. %{_datadir}/gtk-doc/html/*
  314. #files sharp
  315. #defattr(-,root,root)
  316. #{_datadir}/gapi-2.0
  317. #/usr/lib/mono/gda-sharp-2.0
  318. #{_libdir}/pkgconfig/gda-sharp-2.0.pc
  319. %if %{FREETDS}
  320. %files -n gda-freetds
  321. %{_libdir}/libgda-%{libver}/providers/libgda-freetds.so
  322. %endif
  323. %if %{IBMDB2}
  324. %files -n gda-ibmdb2
  325. %{_libdir}/libgda-%{libver}/providers/libgda-ibmdb2.so
  326. %endif
  327. %if %{MYSQL}
  328. %files -n gda-mysql
  329. %{_libdir}/libgda-%{libver}/providers/libgda-mysql.so
  330. %{_datadir}/libgda-%{libver}/mysql_*.xml
  331. %endif
  332. %if %{ODBC}
  333. %files -n gda-odbc
  334. %{_libdir}/libgda-%{libver}/providers/libgda-odbc.so
  335. %{_datadir}/libgda-%{libver}/odbc_*.xml
  336. %endif
  337. %if %{ORACLE}
  338. %files -n gda-oracle
  339. %{_libdir}/libgda-%{libver}/providers/libgda-oracle.so
  340. %endif
  341. %if %{POSTGRES}
  342. %files -n gda-postgres
  343. %{_libdir}/libgda-%{libver}/providers/libgda-postgres.so
  344. %{_datadir}/libgda-%{libver}/postgres_*.xml
  345. %endif
  346. %if %{SQLITE}
  347. %files -n gda-sqlite
  348. %{_libdir}/libgda-%{libver}/providers/libgda-sqlite.so
  349. %{_datadir}/libgda-%{libver}/sqlite_*.xml
  350. %endif
  351. %if %{SYBASE}
  352. %files -n gda-sybase
  353. %{_libdir}/libgda-%{libver}/providers/libgda-sybase.so
  354. %endif
  355. %if %{MDB}
  356. %files -n gda-mdb
  357. %{_libdir}/libgda-%{libver}/providers/libgda-mdb.so
  358. %endif
  359. %if %{LDAP}
  360. %files -n gda-ldap
  361. %{_libdir}/libgda-%{libver}/providers/libgda-ldap.so
  362. %{_datadir}/libgda-%{libver}/ldap_*.xml
  363. %endif
  364. %changelog
  365. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.1.2-1
  366. - new upstream release
  367. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.1.1-1
  368. - new upstream release
  369. - add BuildRequires: gtksourceview3-devel, libsoup-devel, libsecret-devel
  370. - remove BuildRequires: gcr-devel
  371. * Tue Apr 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0.3-1
  372. - new upstream release
  373. - add BuildRequires: gtk3-devel, gobject-introspection-devel, gcr-devel, iso-codes
  374. * Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.12-1
  375. - new upstream release
  376. * Mon Nov 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.11-1
  377. - new upstream release
  378. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.9-1
  379. - new upstream release
  380. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.8-1
  381. - new upstream release
  382. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.0-1
  383. - new upstream release
  384. - add Patch0 (libgda-4.2.0-disable-mdb.patch)
  385. - change %%{libver}
  386. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.9-2
  387. - rebuild with rpm-4.8.1 for pkg-config file
  388. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.9-1
  389. - new upstream release
  390. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.8-1
  391. - new upstream release
  392. * Mon Nov 02 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 4.0.5-1
  393. - new upstream release
  394. - remove gnome-vfs2-devel from BR.(use gio-2.0)
  395. - add Vendor, Distribution and Packager.
  396. - update summary and description.
  397. * Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 4.0.2-3
  398. - rebuilt with postgresql-8.4.0
  399. * Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.2-2
  400. - added intltool to BuildRequires.
  401. - rebuilt with MySQL-5.1.34.
  402. * Wed Apr 29 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 4.0.2-1
  403. - update from upstream.
  404. - update description and files.
  405. - ODBC,LDAP outdated
  406. * Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.4-2
  407. - rebuilt with postgresql-8.3.3
  408. * Sun Jun 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.4-1
  409. - new upstream release
  410. - not build sharp subpackage
  411. - built with db4-4.6.21, MySQL-5.0.51a
  412. * Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.100-0vl8
  413. - rebuilt with postgresql-8.2.6
  414. * Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 1.9.100-0vl7
  415. - rebuilt with postgresql-8.2.5
  416. * Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl6
  417. - rebuilt with new toolchain
  418. * Wed Nov 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl5
  419. - rebuilt with openldap 2.3.27, MySQL 5.0.27
  420. - added Patch0 from Fedora
  421. * Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl4
  422. - rebuilt with openldap-devel-2.3.24-0vl4
  423. * Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.100-0vl3
  424. - rebuilt with gamin-devel in place of fam-devel
  425. * Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl2
  426. - rebuilt with readline 5.1
  427. - added subpackage for Mono binding
  428. * Mon Jan 9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl1
  429. - new upstream release
  430. * Tue May 31 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
  431. - new upstream release
  432. - rebuild with postgresql-devel-8.0.3-0vl2 and sqlite3-devel
  433. * Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
  434. - new upstream release
  435. - fixed %files on devel package
  436. * Sun Aug 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.6-0vl1
  437. - new upstream release
  438. - re-define __libtoolize to compile shared object
  439. - updated summary
  440. - make sqlite package by default
  441. * Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
  442. - new upstream release
  443. - build with new MySQL
  444. - make ldap package by default
  445. * Sat Dec 6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
  446. - new upstream release
  447. * Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-0vl1
  448. - new upstream release
  449. * Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-1vl1
  450. - updated to 1.0.0
  451. - based on original spec
  452. - disabled smp_flag at compile time
  453. * Sun Apr 20 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.96-0vl3
  454. - added BuildPreReq: bonobo >= 1.0.9
  455. (0.2.96-0vl2 seems to be lost by accident, so putting again here)
  456. * Sun Mar 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.96-0vl1
  457. - New upstream release.
  458. - use gcc-2.95.3 and g++-2.95.3
  459. * Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.2.94-0vl1
  460. - New upstream release.
  461. * Fri Jan 4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.2.93-0vl1
  462. - Rebuild for Vine.
  463. * Thu May 31 2001 Serge Pavlovsky <pal@re.com.ua>
  464. - Cleaned
  465. * Sat Sep 2 2000 Rodrigo Moya <rodrigo@linuxave.net>
  466. - Initial spec imported from old GNOME-DB spec