xorg-x11-drv-intel-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579
  1. %define moduledir %(pkg-config xorg-server --variable=moduledir )
  2. %define driverdir %{moduledir}/drivers
  3. %define gputoolsdate 20110817
  4. Summary: Xorg X11 Intel video driver
  5. Summary(ja): Xorg X11 Intel ビデオドライバ
  6. Name: xorg-x11-drv-intel
  7. Epoch: 1
  8. Version: 2.20.6
  9. Release: 1%{?_dist_release}
  10. URL: http://intellinuxgraphics.org/
  11. License: MIT
  12. Group: User Interface/X Hardware Support
  13. Source0: http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
  14. Source2: intel.xinf
  15. Source3: intel-gpu-tools-%{gputoolsdate}.tar.bz2
  16. # Clamp VGA pixel clock to 250MHz,
  17. # anything higher's going to look awful anyway. (#559426)
  18. Patch10: intel-2.11.0-vga-clock-max.patch
  19. # vine patch
  20. ExclusiveArch: %{ix86} x86_64 ia64
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  22. BuildRequires: autoconf, automake, libtool
  23. BuildRequires: xorg-x11-server-sdk >= 1.7.99
  24. BuildRequires: libXvMC-devel
  25. BuildRequires: libGL-devel >= 7.10
  26. BuildRequires: libdrm-devel >= 2.4.25
  27. BuildRequires: kernel-headers >= 2.6.33
  28. BuildRequires: libudev-devel
  29. BuildRequires: libxcb-devel >= 1.5
  30. BuildRequires: xcb-util-devel
  31. Requires: hwdata
  32. Requires: xorg-x11-server-Xorg
  33. Requires: xcb-util
  34. Obsoletes: xorg-x11-drv-i810
  35. Provides: xorg-x11-drv-i810
  36. #Conflicts: kudzu < 1.2.42-1
  37. Vendor: Project Vine
  38. Distribution: Vine Linux
  39. %description
  40. X.Org X11 Intel video driver.
  41. %package devel
  42. Summary: Xorg X11 Intel video driver XvMC development package
  43. Summary(ja): Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
  44. Group: Development/System
  45. Requires: %{name} = %{epoch}:%{version}-%{release}
  46. Provides: xorg-x11-drv-intel-devel = %{version}-%{release}
  47. %description devel
  48. X.Org X11 Intel video driver XvMC development package.
  49. %package -n intel-gpu-tools
  50. Summary: Debugging tools for Intel graphics chips
  51. Group: Development/Tools
  52. %description -n intel-gpu-tools
  53. Debugging tools for Intel graphics chips
  54. %prep
  55. %setup -q -n xf86-video-intel-%{version} -b3
  56. %patch10 -p1 -b .vga-clock
  57. %build
  58. autoreconf -vi
  59. %configure \
  60. --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
  61. --enable-dri --enable-xvmc \
  62. --enable-uxa
  63. make
  64. pushd ../intel-gpu-tools-%{gputoolsdate}
  65. autoreconf -v --install
  66. %configure
  67. make
  68. popd
  69. %install
  70. rm -rf $RPM_BUILD_ROOT
  71. make install DESTDIR=$RPM_BUILD_ROOT
  72. mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
  73. install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
  74. pushd ../intel-gpu-tools-%{gputoolsdate}
  75. make install DESTDIR=$RPM_BUILD_ROOT
  76. popd
  77. find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
  78. %clean
  79. rm -rf $RPM_BUILD_ROOT
  80. %triggerpostun -- XOrg < 7.0
  81. if (grep -q i810 /etc/X11/xorg.conf)
  82. then
  83. cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
  84. sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
  85. fi ||:
  86. %files
  87. %defattr(-,root,root,-)
  88. %{driverdir}/intel_drv.so
  89. %{_datadir}/hwdata/videoaliases/intel.xinf
  90. %{_libdir}/libI810XvMC.so.*
  91. %{_libdir}/libIntelXvMC.so.*
  92. %{_mandir}/man4/i*
  93. %files devel
  94. %defattr(-,root,root,-)
  95. %{_libdir}/libI810XvMC.so
  96. %{_libdir}/libIntelXvMC.so
  97. %files -n intel-gpu-tools
  98. %defattr(-,root,root,-)
  99. %{_bindir}/intel_*
  100. %{_mandir}/man1/intel_*.1*
  101. %changelog
  102. * Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
  103. - new upstream release
  104. * Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
  105. - new upstream release
  106. * Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
  107. - new upstream release
  108. * Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
  109. - rebuild with xcb-util-0.3.9
  110. * Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
  111. - disable sna, enable uxa
  112. * Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
  113. - new upstream release
  114. * Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
  115. - rebuild with xserver-1.12.0
  116. * Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
  117. - new upstream release
  118. - enable sna
  119. * Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
  120. - disable sna/vmap
  121. * Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
  122. - new upstram release
  123. - disable copy-fb patch
  124. * Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
  125. - rebuild with xserver-1.11.1.902
  126. * Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
  127. - add --enable-sna --enable-vmap
  128. * Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
  129. - new upstream release
  130. * Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
  131. - rebuild with xcb-util-0.3.8
  132. - drop Patch200
  133. * Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
  134. - update to disable copy_fb on sandybridge/ivybridge
  135. * Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
  136. - update intel.xinf
  137. - add patch10 from fedora
  138. - Clamp VGA pixel clock to 250MHz,
  139. anything higher's going to look awful anyway. (#559426)
  140. * Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
  141. - drop patch1-3 and replaced with new patch1 from git master
  142. - add Patch200 to disable DRI on SandyBridge/IvyBridge
  143. - update intel-gpu-tools
  144. * Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
  145. - add Patch1-3 from upstream
  146. * Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
  147. - new upstream release
  148. - drop upstream patches: 107-115
  149. - temporary disabled patch101
  150. - BR: libdrm >= 2.4.25
  151. * Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
  152. - add Patch101-115 from ubuntu/debian package
  153. - Patch101: Plymouth integration patch
  154. - Patch107: Check null return from uxa_acquire_solid()
  155. - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
  156. - Patch109: Fix font corruption (missing glyphs) on rotated screens.
  157. - Patch110,114: Cherry picks to fix a large number of build warnings.
  158. - Patch111: Fix clipped window plane offset
  159. - Patch112: Fix issue where vertical green line and strange colors
  160. shows up when playing gstreamer with certain videos,
  161. when dragged. (LP 460677)
  162. - Patch113: Fixes GPU lockup during login with
  163. "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
  164. error messages listed in the gpu dump text. (LP 710321)
  165. - Patch115: Don't fill up Xorg.0.log with
  166. "get vblank counter failed: Invalid argument" warnings.
  167. * Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
  168. - rebuild with xserver-1.10.0
  169. * Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
  170. - new upstream release
  171. * Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
  172. - new upstream release
  173. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
  174. - rebuild with xserver-1.9.2
  175. * Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
  176. - new upstream release
  177. - add Patch40: fix uxa planemask (backported)
  178. - add Patch61: add support for backlight on macbooks
  179. - add Patch62: disable page flipping for stability
  180. * Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
  181. - new upstream release
  182. - drop patch70
  183. * Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
  184. - rebuild again with xserver-1.8rc
  185. * Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
  186. - add intel-gpu-tools as sub-package
  187. - rebuild with libdrm-2.4.18
  188. * Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
  189. - new upstream release
  190. - import Patch1,2,60,70 from fedora
  191. - add BR: kernel-headers >= 2.6.33 (new drm header required)
  192. - add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
  193. - add BR; libudev-devel and autoreconf for Patch60
  194. * Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
  195. - rebuild with libdrm-2.4.17
  196. * Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
  197. - new upstream release
  198. * Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
  199. - new upstream release (hopefully fixes severe issues w/ efifb)
  200. - drop all patches already upstreamed; import Patch20/21 from Fedora
  201. * Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
  202. - import Patch121,122 from ubuntu
  203. - build with libdrm-2.4.12 which fixes vt switch crash
  204. * Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
  205. - apply patch114 to fix Xv with non-GEM kernel
  206. * Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
  207. - update to 2.6.3
  208. - add patch106,107,115,118,119,120 from ubuntu
  209. - add Patch106: remove triple buffering
  210. - add Patch107: remove page flipping
  211. - add Patch115: fix crash Xv overlay
  212. - add Patch118: drop legacy3d
  213. - add Patch119: fix crashes in drm bo
  214. - add Patch120: fix vt switch
  215. - add patch130-134 from upstream git
  216. - add Patch130: fix another vt switch leak
  217. - add Patch131: Create known output configuration at EnterVT time
  218. - add Patch132: fix leak of some 965 render state on VT switch
  219. - add Patch133: fix crash with fake bufmgr and UXA
  220. - add Patch134: fix EnterVT/LeaveVT
  221. - add Patch135: add new chip supoprt
  222. * Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
  223. - revert to 2.6.1, add Epoch
  224. - add Patch103-121 from ubuntu
  225. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
  226. - new upstream release
  227. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
  228. - new upstream release
  229. * Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
  230. - new upstream release
  231. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
  232. - add Patch5 - Dont die on irq handler failure
  233. * Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
  234. - new upstream release
  235. - add BR: libdrm-devel >= 2.4.0-3
  236. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
  237. - import Patch10,11,12 from ubuntu
  238. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
  239. - new upstream release
  240. - add triggerpostun script to replace i810 driver to intel driver
  241. * Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
  242. - new upstream release
  243. * Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
  244. - new upstream release
  245. - rename i810.xinf to intel.xinf
  246. - update intel.xinf (add Intel 4 series)
  247. * Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
  248. - rebuild with new xserver
  249. * Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
  250. - new upstream release
  251. * Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
  252. - new upstream release
  253. * Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
  254. - new upstream release
  255. * Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  256. - initial build for Vine Linux
  257. * Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
  258. - Rebuild for new server ABI.
  259. - intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
  260. * Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
  261. - hook up ch7017 (bz#408471)
  262. * Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
  263. - xf86-video-intel 2.2.0
  264. * Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
  265. - xf86-video-intel 2.1.99.
  266. - Drop the i810 driver. Time to move on.
  267. - Require xserver 1.4.99.1
  268. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
  269. - intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
  270. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
  271. - intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
  272. for textured Xv to use as an offscreen pixmap so xv actually works under
  273. compiz - granted it may be unusably slow but at least stuff shows up.
  274. * Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
  275. - intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
  276. - intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
  277. * Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
  278. - intel-2.1.1-quirk-update.patch - update quirks from master
  279. * Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
  280. - i810.xinf: Flip everything over to -intel by default now. Still install
  281. i810 driver just in case.
  282. * Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
  283. - intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
  284. * Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
  285. - xf86-video-intel 2.1.1.
  286. * Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
  287. - xf86-video-intel 2.1.0.
  288. * Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
  289. - Update Requires and BuildRequires.
  290. * Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
  291. - Update to git master. Many Xv and DVO fixes. Adds support for 945GME,
  292. 965GME, G33, Q33, and Q35 chips.
  293. * Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
  294. - intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
  295. DRI clients are active, for better battery life.
  296. * Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
  297. - Rebuild for final RANDR 1.2 ABI. Fixes segfault at startup. (#238575)
  298. * Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
  299. - xf86-video-intel 2.0.0. Change the version number to match, why not.
  300. - Add a Virtual provides for xorg-x11-drv-intel, since we should probably
  301. rename this at some point.
  302. * Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
  303. - i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
  304. 915GM.
  305. * Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
  306. - i810.xinf: More intel whitelisting (#214011, #234877)
  307. * Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
  308. - xf86-video-intel-1.9.94 (RC4). Adds support for 965GM.
  309. - i810.xinf: Point 965GM support at the intel driver since it's not present
  310. in old i810.
  311. * Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
  312. - xf86-video-intel-1.9.93 (RC3).
  313. * Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
  314. - fix typo with 945GM pci id from my laptop
  315. * Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
  316. - xf86-video-intel 1.9.92 (RC2).
  317. * Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
  318. - Updated modesetting driver to one that will actually work with a 1.3 server.
  319. * Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
  320. - Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
  321. - Remove ivch and ch7017 from the install since they aren't hooked up to the
  322. code anywhere
  323. - Disown the module
  324. * Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
  325. - update modesetting driver to git snapshot from today
  326. * Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
  327. - i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
  328. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
  329. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  330. * Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
  331. - Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
  332. actually require kudzu to run.
  333. * Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
  334. - i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
  335. * Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
  336. - i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
  337. - i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
  338. driver match the corresponding terrible heuristic in the server.
  339. * Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
  340. - intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
  341. correctly distinguish between Mac Mini and Macbook Pro.
  342. * Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
  343. - i810.xinf: PCI IDs for i965.
  344. * Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
  345. - i810.xinf: Uppercase PCI IDs.
  346. * Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
  347. - Update i810 to 1.6.5, should fix DRI.
  348. - Add kuzdu requires.
  349. - i810.xinf: Start whitelisting devices over to intel.
  350. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
  351. - intel-driver-rename.patch: Fix the driver name in more places so it'll,
  352. you know, load.
  353. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
  354. - intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
  355. LFP special casing in favor of the blacklist.
  356. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
  357. - Admit defeat, kinda. Package both i810 stable and modesetting drivers.
  358. The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
  359. and is selected with Driver "intel" in xorg.conf. Individual devices will
  360. whitelist over to "intel" until that branch gets merged into head.
  361. - Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
  362. - intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
  363. the BIOS is known to lie.
  364. * Tue Aug 8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
  365. - Today's snapshot: I2C bus creation fix.
  366. * Wed Aug 2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
  367. - intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
  368. clock when computing the modes list.
  369. - intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
  370. in centimeters as the size of the display in pixels.
  371. * Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
  372. - Disable spread-spectrum LVDS, various crash and hang fixes, saner output
  373. probing.
  374. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
  375. - Update again for a mode comparison bugfix.
  376. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
  377. - Update to today's git; crash fixes, better pre-915 support, slightly better
  378. autoconfigurability.
  379. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
  380. - rebuild
  381. * Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
  382. - Fix Revision number to match naming policy.
  383. * Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
  384. - Add back modesetting changes.
  385. * Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
  386. - Roll back modesetting changes and build for fc5 aiglx repo.
  387. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
  388. - Snapshot of the git modesetting branch.
  389. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
  390. - Update i810.xinf to include entries for E7221 and 945GM.
  391. * Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
  392. - Add with_dri macro to spec file, and conditionalize build time DRI support
  393. * Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
  394. - Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
  395. to pick up proto-devel as well.
  396. * Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
  397. - Rebuild for 7.1 ABI fix.
  398. * Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
  399. - Bump for fc5-bling build.
  400. * Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
  401. - Update to 1.6.0 from 7.1RC1.
  402. * Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
  403. - Add patch to add missing #include's, specifically assert.h.
  404. * Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
  405. - Update to CVS snapshot of 20060322.
  406. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
  407. - rebuilt for new gcc4.1 snapshot and glibc changes
  408. * Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
  409. - Added 8086:2772 mapping to i810.xinf for bug (#178451)
  410. * Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
  411. - Added 8086:2592 mapping to i810.xinf for bug (#172884)
  412. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
  413. - Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
  414. * Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
  415. - Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
  416. - Removed 'x' suffix from manpage dirs to match RC4 upstream.
  417. * Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
  418. - Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
  419. * Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
  420. - Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
  421. - Fix *.la file removal.
  422. - Added 'devel' subpackage for XvMC .so
  423. - Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
  424. * Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
  425. - Update BuildRoot to use Fedora Packaging Guidelines.
  426. - Deglob file manifest.
  427. - Limit "ExclusiveArch" to x86, x86_64, ia64
  428. * Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
  429. - Initial spec file for i810 video driver generated automatically
  430. by my xorg-driverspecgen script.