loudmouth-vl.spec 7.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264
  1. %define with_ssl 1
  2. %define gnutls_ver 1.4.0
  3. Summary: Loudmouth is a Jabber programming library written in C
  4. Name: loudmouth
  5. Version: 1.4.3
  6. Release: 2%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: LGPLv2+
  9. URL: http://www.loudmouth-project.org/
  10. Source0: http://ftp.imendio.com/pub/imendio/%{name}/src/%{name}-%{version}.tar.bz2
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildRequires: glib2-devel >= 2.4.0
  13. BuildRequires: check-devel
  14. BuildRequires: libidn-devel
  15. BuildRequires: libasyncns-devel
  16. %if %{with_ssl}
  17. BuildRequires: gnutls-devel >= %{gnutls_ver}
  18. %endif
  19. %description
  20. Loudmouth is a lightweight and easy-to-use C library for programming
  21. with the Jabber protocol. It's designed to be easy to get started with
  22. and yet extensible to let you do anything the Jabber protocol allows.
  23. %package devel
  24. Summary: Development files for %{name}
  25. Summary(ja): Development files for %{name}
  26. Group: Development/Libraries
  27. Requires: %{name} = %{version}-%{release}
  28. Requires: glib2-devel
  29. Requires: libidn-devel
  30. Requires: pkgconfig
  31. %if %{with_ssl}
  32. Requires: gnutls-devel
  33. %endif
  34. %description devel
  35. The %{name}-devel package contains libraries and header files for
  36. developing applications that use %{name}.
  37. %prep
  38. %setup -q
  39. %build
  40. %configure --enable-static=no \
  41. --with-asyncns=yes \
  42. %if %{with_ssl}
  43. --with-ssl=gnutls
  44. %else
  45. --with-ssl=no
  46. %endif
  47. make %{?_smp_mflags}
  48. %install
  49. rm -rf $RPM_BUILD_ROOT
  50. make install DESTDIR=$RPM_BUILD_ROOT
  51. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  52. # Copy the files from the tarball to avoid the IDs generated by gtk-doc being
  53. # different on different builds
  54. mkdir -p $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/%{name}/
  55. cp -a docs/reference/html/* $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/%{name}/
  56. %check
  57. make check
  58. %clean
  59. rm -rf $RPM_BUILD_ROOT
  60. %post -p /sbin/ldconfig
  61. %postun -p /sbin/ldconfig
  62. %files
  63. %defattr(-,root,root,-)
  64. %doc ChangeLog NEWS README COPYING
  65. %{_libdir}/libloudmouth*.so.*
  66. %files devel
  67. %defattr(-,root,root,-)
  68. %{_libdir}/libloudmouth*.so
  69. %{_libdir}/pkgconfig/%{name}-1.0.pc
  70. %{_includedir}/%{name}-1.0
  71. %{_datadir}/gtk-doc/html/%{name}
  72. %changelog
  73. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.4.3-2
  74. - rebuilt with rpm-4.8.1 for pkg-config
  75. * Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.3-1
  76. - Update to 1.4.3
  77. - build with new gnutls
  78. * Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-1
  79. - initial build for Vine Linux
  80. * Thu Aug 28 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.4.2-1
  81. - Update to 1.4.2.
  82. - Enable libasyncns support.
  83. * Sat Aug 2 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.4.1-1
  84. - Update to 1.4.1.
  85. * Wed Jun 25 2008 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
  86. - rebuild with new gnutls
  87. * Tue Jun 10 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.4.0-1
  88. - Update to 1.4.0.
  89. * Wed Apr 2 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.3.4-1
  90. - Update to 1.3.4.
  91. - Run check test.
  92. - Bump min version needed for gnutls-devel.
  93. - Drop stream-error.patch. Fixed upstream.
  94. - Drop eai-nodata.patch. Fixed upstream.
  95. - Drop connect-fail-sync.patch. Fixed upstream.
  96. - Drop connect-fail-async patch. Fixed upstream.
  97. - Update URL & Source URL.
  98. - Don't generate the gtk-doc docs, and use the ones in the tarball
  99. to avoid having different files in different builds, fixes
  100. multilib problems (#342551)
  101. * Thu Feb 21 2008 Owen Taylor <otaylor@redhat.com> - 1.3.3-4
  102. - Fix build with recent GNU libc
  103. * Thu Feb 7 2008 Owen Taylor <otaylor@redhat.com> - 1.3.3-3
  104. - Add patches fixing reentrancy problems on connection failure
  105. * Wed Jan 30 2008 Owen Taylor <otaylor@redhat.com> - 1.3.3-2
  106. - Add back stream-error patch, it wasn't fixed in the 1.3 branch
  107. * Fri Jan 18 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.3.3-1
  108. - Update to 1.3.3.
  109. - Drop reconnect-failure patch.
  110. - Drop gnutls compression patch. fixed upstream.
  111. * Thu Nov 15 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-6
  112. - Ugh. Let's acutally use a valid e-mail addy.
  113. * Thu Nov 15 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-5
  114. - Add patch to use gnutls compression.
  115. * Mon Nov 12 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-4
  116. - Add reconnect-failure patch. Thanks to Robert McQueen.
  117. * Tue Aug 21 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-3
  118. - Rebuild.
  119. * Sun Aug 5 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-2
  120. - Update license tag.
  121. * Sun Jun 10 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-1
  122. - Update to 1.2.3.
  123. - Drop stream-error patch. fixed upstream.
  124. * Wed May 16 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.2-3
  125. - Add patch to fix stream error.
  126. * Tue May 15 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.2-2
  127. - Drop BR on libtasn1-devel.
  128. * Mon May 14 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.2-1
  129. - Update to 1.2.2.
  130. * Sat Feb 24 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.1-2
  131. - Fix typo.
  132. * Sat Feb 24 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.1-1
  133. - Update to 1.2.1.
  134. * Tue Feb 20 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.0-3
  135. - Add necessary requires to devel package. D'Oh!
  136. * Tue Feb 20 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.0-2
  137. - Add BR on libidn-devel.
  138. - Specify which ssl implementation to use.
  139. * Mon Feb 5 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.0-1
  140. - Update to 1.2.0.
  141. - Drop mono config option since it's been dropped from the tarball.
  142. * Mon Sep 11 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.5-2
  143. - Change source to .gz.
  144. * Mon Sep 11 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.5-1
  145. - Update to 1.0.5.
  146. * Tue Aug 29 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.4-3
  147. - Rebuild for FC6.
  148. - Simplify devel description.
  149. * Thu Jun 29 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.4-2
  150. - Update to 1.0.4.
  151. - Add devel requires on pkgconfig.
  152. - Drop reentrancy patch, fixed upstream.
  153. * Thu Jun 15 2006 Jeremy Katz <katzj@redhat.com> - 1.0.3-5
  154. - rebuild for new gnutls
  155. * Fri May 26 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.3-4
  156. - Add patch to fix some reentrancy crashes. (Thanks, Havoc)
  157. * Wed Apr 5 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.3-3
  158. - Update to 1.0.3.
  159. - Add BR for gnutls-devel to devel package.
  160. - Disable static libs.
  161. - Add BR for check-devel.
  162. * Thu Feb 16 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-6
  163. - Remove unnecessary BR (libgcrypt-devel).
  164. * Mon Feb 13 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-5
  165. - rebuilt for new gcc4.1 snapshot and glibc changes
  166. * Mon Dec 26 2005 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-4
  167. - Rebuild.
  168. * Wed Aug 31 2005 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-3
  169. - Update to 1.0.1.
  170. * Sun Aug 14 2005 Brian Pepple <bdpepple@ameritech.net> - 1.0-2
  171. - Update to 1.0.
  172. * Mon Aug 8 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-5
  173. - Rebuild due to new gnutls.
  174. * Sat Jul 30 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-4
  175. - Fix description.
  176. * Fri May 13 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-2
  177. - Add dist tag.
  178. * Fri May 13 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-1
  179. - Update to 0.9.
  180. * Thu May 5 2005 Brian Pepple <bdpepple@ameritech.net> - 0.17.2-3
  181. - Adde glib2-devel requires.
  182. * Thu May 5 2005 Brian Pepple <bdpepple@ameritech.net> - 0.17.2-2
  183. - added %%{_includedir}.
  184. - Add libgcrypt-devel BR.
  185. * Sun May 1 2005 Brian Pepple <bdpepple@ameritech.net> - 0.17.2-1
  186. - Initial Fedora build.