SysVinit-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366
  1. Summary: Programs which control basic system processes.
  2. Summary(ja): 基本的なシステムプロセスを制御するプログラム
  3. Name: SysVinit
  4. Version: 2.86
  5. Release: 1%{_dist_release}
  6. License: GPL
  7. Group: System Environment/Base
  8. Source: ftp://ftp.cistron.nl/pub/people/miquels/sysvinit/sysvinit-%{version}.tar.gz
  9. Patch1: sysvinit-2.78-man.patch
  10. Patch2: sysvinit-2.77-md5-be.patch
  11. Patch3: sysvinit-2.78-halt.patch
  12. Patch4: sysvinit-2.86-autofsck.patch
  13. Patch5: sysvinit-2.86-loginshell.patch
  14. Patch6: sysvinit-2.86-makefile.patch
  15. Patch7: sysvinit-2.86-chroot.patch
  16. Patch8: sysvinit-2.86-inittab.patch
  17. Patch9: sysvinit-2.86-environ.patch
  18. Patch10: sysvinit-2.86-pidof.patch
  19. Patch11: sysvinit-2.86-haltname.patch
  20. Patch12: sysvinit-2.86-haltman.patch
  21. Patch13: sysvinit-2.86-single.patch
  22. Patch14: sysvinit-2.86-maxproclen.patch
  23. Patch15: sysvinit-2.86-ipv6.patch
  24. Patch16: sysvinit-2.86-quiet.patch
  25. Patch17: sysvinit-2.86-godot.patch
  26. Patch18: sysvinit-2.86-timeval.patch
  27. Patch19: sysvinit-2.86-console-open.patch
  28. Patch22: 81_killall_avoid_init.dpatch
  29. Source1: change_console
  30. Source2: change_console.8
  31. Buildroot: %{_tmppath}/%{name}-%{version}-root
  32. Requires: pam >= 0.66-5
  33. %description
  34. The SysVinit package contains a group of processes that control
  35. the very basic functions of your system. SysVinit includes the init
  36. program, the first program started by the Linux kernel when the
  37. system boots. Init then controls the startup, running, and shutdown
  38. of all other programs.
  39. %description -l ja
  40. SysVinit パッケージには,システムの非常に基本的な機能を制御する
  41. プロセスが収められています.例えば,システム起動時に Linux カーネルに
  42. よって最初に起動されるプログラムである init 等です.init はその後
  43. システムの起動や,他のプログラムの起動/終了を制御します.
  44. %prep
  45. %setup -q -n sysvinit-%{version}
  46. # We use a shell, not sulogin. Other random man fixes go here (such as #192804)
  47. %patch1 -p1 -b .manpatch
  48. # Handle bigendian MD5
  49. %patch2 -p1 -b .be
  50. # Create /halt or /poweroff on shutdown
  51. %patch3 -p1 -b .halt
  52. # Unlink /.autofsck on shutdown -f
  53. %patch4 -p1 -b .autofsck
  54. # Invoke single-user shell as a login shell (#105653)
  55. %patch5 -p1 -b .loginshell
  56. # Various makefile adjustments
  57. %patch6 -p1 -b .makefile
  58. # Add -c option for only matching processes with the same root
  59. %patch7 -p1 -b .chroot
  60. # Adjust examples in inittab(5) to more accurately reflect RH/Fedora
  61. # usage (#173572)
  62. %patch8 -p1 -b .inittabdocs
  63. # Assumedly, if we're passing an environment as the last arg, we
  64. # want execle, not execl.
  65. %patch9 -p1 -b .environ
  66. # Fix various things in pidof - pidof /x/y matching /z/y, pidof -x
  67. # for scripts, etc.
  68. %patch10 -p1 -b .pidof
  69. # Fix halt when called by login
  70. %patch11 -p1 -b .haltname
  71. # Document pam_console usage
  72. %patch12 -p1 -b .haltman
  73. # Fix single user mode (#176348)
  74. %patch13 -p1 -b .single
  75. # Fix under-copy of proc title (#188160)
  76. %patch14 -p1 -b .maxproclen
  77. # ipv6 support in last
  78. %patch15 -p1 -b .ipv6
  79. # Be less verbose when booted with 'quiet'
  80. %patch16 -p1 -b .quiet
  81. # Preserve 'waiting' across re-exec (#199305, #201146, #143289)
  82. %patch17 -p1 -b .godot
  83. # Don't overwrite ut_addr_v6 on 64-bit platforms (#176494)
  84. %patch18 -p1 -b .timeval
  85. # Allow some time for failed opens to resolve themselves (#181546)
  86. %patch19 -p1 -b .console-open
  87. %patch22 -p1 -b .nopid1
  88. %build
  89. make %{?_smp_mflags} CC=%{__cc} -C src
  90. %install
  91. rm -rf $RPM_BUILD_ROOT
  92. for I in sbin %{_bindir} %{_mandir}/man{1,3,5,8} etc var/run dev %{_includedir}; do
  93. mkdir -p $RPM_BUILD_ROOT/$I
  94. done
  95. install -d $RPM_BUILD_ROOT/bin
  96. make -C src ROOT=$RPM_BUILD_ROOT MANDIR=%{_mandir} \
  97. BIN_OWNER=`id -nu` BIN_GROUP=`id -ng` install
  98. # If this already exists, just do nothing (the ||: part)
  99. mknod --mode=0600 $RPM_BUILD_ROOT/dev/initctl p ||:
  100. ln -snf killall5 $RPM_BUILD_ROOT/sbin/pidof
  101. chmod 755 $RPM_BUILD_ROOT%{_bindir}/utmpdump
  102. install -m 755 %{SOURCE1} $RPM_BUILD_ROOT/sbin/change_console
  103. install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/change_console.8
  104. install -m 644 src/initreq.h $RPM_BUILD_ROOT%{_includedir}
  105. %post
  106. [ -e /var/run/initrunlvl ] && ln -s ../var/run/initrunlvl /etc/initrunlvl
  107. [ -x /sbin/telinit -a -p /dev/initctl -a -f /proc/1/exe -a -d /proc/1/root ] && /sbin/telinit u
  108. exit 0
  109. %clean
  110. rm -rf $RPM_BUILD_ROOT
  111. %files
  112. %defattr(-,root,root)
  113. %doc doc/Changelog doc/Install
  114. %doc doc/sysvinit-%{version}.lsm contrib/start-stop-daemon.*
  115. /sbin/halt
  116. /sbin/init
  117. /sbin/killall5
  118. /sbin/pidof
  119. /sbin/poweroff
  120. /sbin/reboot
  121. /sbin/runlevel
  122. /sbin/shutdown
  123. /sbin/sulogin
  124. /sbin/telinit
  125. /sbin/change_console
  126. %{_includedir}/initreq.h
  127. %{_bindir}/last
  128. %{_bindir}/lastb
  129. %{_bindir}/mesg
  130. %{_bindir}/utmpdump
  131. %{_sysbindir}/mountpoint
  132. %attr(2555,root,tty) %{_bindir}/wall
  133. %{_mandir}/*/*
  134. /dev/initctl
  135. %changelog
  136. * Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.86-1
  137. - new upstream release
  138. * Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 2.85-5vl3
  139. - add script to create $RPM_BUILD_ROOT/bin in %%install section
  140. * Wed Dec 10 2003 <tkoba@vinelinux.org> 2.85-5vl2
  141. - install initreq.h
  142. * Fri Nov 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.85-5vl1
  143. - new upstream release
  144. - merged with fedora package.
  145. * Tue Jul 17 2001 <sagami@vinelinux.org>
  146. - 2.78-10vl3: fix orphan symlink in %%doc
  147. * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  148. - 2.78-10vl1
  149. - rebuilt under new %%{_mandir} definition
  150. - added Japanese summary and description
  151. * Sat Nov 18 2000 Satoshi MACHINO <machino@vinelinux.org> 2.78-10vl1
  152. - build with gcc-2.95.3
  153. - partially used rpmmacros
  154. * Mon Sep 22 2003 Bill Nottingham <notting@redhat.com> 2.85-5
  155. - add change_console, for changing console used by init
  156. * Wed Jun 25 2003 Bill Nottingham <notting@redhat.com> 2.85-4
  157. - block signals when calling syslog() (#97534, <joden@lee.k12.nc.us>)
  158. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  159. - rebuilt
  160. * Fri May 23 2003 Bill Nottingham <notting@redhat.com> 2.85-2
  161. - clean up killall5 some
  162. * Thu May 22 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  163. - update to 2.85, remove already applied patches
  164. * Mon Feb 10 2003 Bill Nottingham <notting@redhat.com> 2.84-13
  165. - fix s390x build
  166. - fix silly warning (#83943)
  167. * Mon Feb 10 2003 Arjan van de Ven <arjanv@redhat.com>
  168. - fix wait() handling wrt setting SIGCHLD to SIG_IGN in shutdown
  169. - fix segfault in spawn() function in shutdown
  170. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  171. - rebuilt
  172. * Thu Dec 05 2002 Elliot Lee <sopwith@redhat.com> 2.84-7
  173. - Pass __cc macro to build, to facilitate cross-compiling
  174. - _smp_mflags
  175. * Mon Dec 2 2002 Bill Nottingham <notting@redhat.com> 2.84-6
  176. - rebuild on all arches
  177. - change sulogin message to be slightly more correct (#65828)
  178. * Thu Jul 18 2002 Bill Nottingham <notting@redhat.com>
  179. - don't strip binaries
  180. - have wall not write to non-ttys (#65412)
  181. - update usage for halt/reboot (#57753)
  182. - allow '-t' argument to last for checking state at certain times (#56863)
  183. - make 'pidof /foo/bar' not match /baz/bar (#53918)
  184. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  185. - automated rebuild
  186. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  187. - automated rebuild
  188. * Thu Mar 12 2002 Bill Nottingham <notting@redhat.com> 2.84-2
  189. - add patch to log messages on shutdown/reboot
  190. * Fri Feb 22 2002 Bill Nottingham <notting@redhat.com> 2.84-1
  191. - update to 2.84
  192. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  193. - automated rebuild
  194. * Fri Nov 9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.79-2
  195. - Fix pidof -o (#55954)
  196. - Handle RPM_OPT_FLAGS
  197. - s/Copyright/License/
  198. * Mon Sep 17 2001 Bill Nottingham <notting@redhat.com>
  199. - update to 2.79
  200. * Tue Aug 28 2001 Bill Nottingham <notting@redhat.com>
  201. - unlink /.autofsck on shutdown -f
  202. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  203. - Bump release + rebuild.
  204. * Thu Jun 21 2001 Bill Nottingham <notting@redhat.com>
  205. - update 'no logout' patch
  206. - fix setting of CREAD to work with 2.4.3+ kernels (#45284)
  207. * Tue Jun 12 2001 Bill Nottingham <notting@redhat.com>
  208. - show users with no login pid but no logout record as gone (#42550,
  209. <cwolf@starclass.com>)
  210. - fix sulogin to *always* work without a tty (#40934)
  211. * Tue Apr 3 2001 Bill Nottingham <notting@redhat.com>
  212. - set umask 022 on startup
  213. - manpage tweaks (#21628, #27173)
  214. * Mon Apr 2 2001 Bill Nottingham <notting@redhat.com>
  215. - fix dangling symlink in %%doc (#34383)
  216. * Thu Mar 15 2001 Bill Nottingham <notting@redhat.com>
  217. - don't run telinit u if we don't appear to be on the root fs
  218. * Fri Feb 16 2001 Bill Nottingham <notting@redhat.com>
  219. - run telinit u on upgrade
  220. * Wed Jan 31 2001 Bill Nottingham <notting@redhat.com>
  221. - document '-n' option to wall, make it root-only (#18672)
  222. - don't open files in sulogin unless they're really ttys (#21862)
  223. * Tue Aug 8 2000 Bill Nottingham <notting@redhat.com>
  224. - set SHLVL in sulogin so /etc/profile.d stuff isn't run by default
  225. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  226. - automatic rebuild
  227. * Thu Jun 8 2000 Bill Nottingham <notting@redhat.com>
  228. - fix the md5 code (#11534)
  229. - rebuild for FHS & the like
  230. * Wed Apr 19 2000 Bill Nottingham <notting@redhat.com>
  231. - ignore sigint in sulogin (#9803)
  232. - touch file in root directory if powering off (#7318)
  233. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  234. - rebuild for sparc baud rates > 38400.
  235. * Thu Feb 24 2000 Bill Nottingham <notting@redhat.com>
  236. - update to 2.78-final
  237. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  238. - handle compressed manpages
  239. * Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
  240. - build to fix dependency problem
  241. * Tue Jan 10 2000 Bill Nottingham <notting@redhat.com>
  242. - update to 2.78
  243. * Mon Sep 06 1999 Jakub Jelinek <jj@ultra.linux.cz>
  244. - on big endian machines use a kludge for broken pam md5 passwords
  245. * Fri Aug 27 1999 Bill Nottingham <notting@redhat.com>
  246. - update to 2.77
  247. * Tue Jul 06 1999 Bill Nottingham <notting@redhat.com>
  248. - move pam_console stuff to usermode package
  249. * Fri Jul 02 1999 Cristian Gafton <gafton@redhat.com>
  250. - requires usermode to express the dependency on /usr/bin/consolehelper
  251. (#2813)
  252. * Wed Jun 23 1999 Bill Nottingham <notting@redhat.com>
  253. - make man page references to single-user mode consistent with RH usage
  254. * Sat Apr 17 1999 Jeff Johnson <jbj@redhat.com>
  255. - remove /etc/initlvl compatibility symlink from file list (#2236).
  256. * Fri Mar 26 1999 Michael Johnson <johnsonm@redhat.com>
  257. - pam.d files marked noreplace
  258. - added poweroff as a console application
  259. * Mon Mar 22 1999 Michael Johnson <johnsonm@redhat.com>
  260. - marked config files as such in consolehelper part of filelist
  261. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  262. - auto rebuild in the new build environment (release 8)
  263. * Fri Mar 19 1999 Michael Johnson <johnsonm@redhat.com>
  264. - consolehelper support
  265. * Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
  266. - glibc 2.1
  267. * Sun Aug 23 1998 Jeff Johnson <jbj@redhat.com>
  268. - poweroff symlink not included (problem #762)
  269. * Thu Jul 09 1998 Chris Evans <chris@ferret.lmh.ox.ac.uk>
  270. - Fix a securelevel releated security hole. Go on, try and break append
  271. only files + securelevel now ;-)
  272. * Wed Jul 8 1998 Jeff Johnson <jbj@redhat.com>
  273. - remove /etc/nologin at end of shutdown.
  274. - compile around missing SIGPWR on sparc
  275. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  276. - translations modified for de, fr, tr
  277. * Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
  278. - upgraded to 2.74
  279. - fixed the package source url... (yeah, it was wrong !)
  280. * Wed Oct 1 1997 Cristian Gafton <gafton@redhat.com>
  281. - fixed the MD5 check in sulogin (128 hash bits encoded with base64 gives
  282. 22 bytes, not 24...). Fix in -md5.patch
  283. * Thu Sep 11 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
  284. - /etc/initrunlvl gets linked to /tmp/init-root/var/run/initrunlvl which is
  285. just plain wrong..
  286. - /usr/bin/utmpdump was missing in the files section, although it was
  287. explicitly patched into PROGS.
  288. - added attr's to the files section.
  289. - various small fixes.
  290. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  291. - updated to 2.71
  292. - built against glibc 2.0.4
  293. * Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
  294. - Added sulogin.8 man page to file list.