libgit2-vl.spec 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115
  1. Summary: C implementation of the Git core methods as a library with a solid API
  2. Name: libgit2
  3. Version: 1.0.0
  4. Release: 1%{?_dist_release}
  5. Group: System Environment/Libraries
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: GPLv2
  9. URL: https://libgit2.org/
  10. Source0: https://github.com/libgit2/libgit2/releases/download/v%{version}/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: cmake
  13. BuildRequires: openssl-devel
  14. BuildRequires: http-parser-devel
  15. BuildRequires: curl-devel
  16. BuildRequires: libssh2-devel
  17. BuildRequires: zlib-devel
  18. %description
  19. libgit2 is a portable, pure C implementation of the Git core methods
  20. provided as a re-entrant linkable library with a solid API, allowing
  21. you to write native speed custom Git applications in any language
  22. which supports C bindings.
  23. %package devel
  24. Summary: Development tools for %{name}
  25. Summary(ja): %{name} の開発環境
  26. Group: Development/Libraries
  27. Requires: %{name} = %{version}-%{release}
  28. Requires: pkgconfig
  29. Requires: openssl-devel
  30. Requires: http-parser-devel
  31. Requires: libssh2-devel
  32. Requires: zlib-devel
  33. %description devel
  34. Header files and libraries for building a extension library for the %{name}.
  35. %prep
  36. %setup -q
  37. %build
  38. rm -rf build && mkdir build && pushd build
  39. %cmake -DINSTALL_DOCS=OFF \
  40. ../
  41. make %{?_smp_mflags}
  42. popd
  43. %install
  44. rm -rf ${RPM_BUILD_ROOT}
  45. pushd build
  46. make install DESTDIR=${RPM_BUILD_ROOT}
  47. popd
  48. find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
  49. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  50. %clean
  51. %{__rm} -rf ${RPM_BUILD_ROOT}
  52. %post -p /sbin/ldconfig
  53. %postun -p /sbin/ldconfig
  54. %files
  55. %defattr(-,root,root,-)
  56. %license COPYING
  57. %doc AUTHORS README.md
  58. %{_libdir}/%{name}.so.*
  59. %files devel
  60. %defattr(-,root,root,-)
  61. %{_includedir}/git2/
  62. %{_includedir}/git2.h
  63. %{_libdir}/%{name}.so
  64. %{_libdir}/pkgconfig/%{name}.pc
  65. %changelog
  66. * Tue May 05 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.0-1
  67. - new upstream release.
  68. * Mon Mar 25 2019 Toshiaki Ara <ara_t@384.jp> 0.27.8-2
  69. - correct date
  70. * Mon Mar 25 2019 Toshiaki Ara <ara_t@384.jp> 0.27.8-1
  71. - update to 0.27.8
  72. - add BuildRequires: curl-devel
  73. * Thu Nov 01 2018 Toshiaki Ara <ara_t@384.jp> 0.27.4-2
  74. - rebuild with openssl-1.1.1
  75. * Mon Aug 20 2018 Toshiaki Ara <ara_t@384.jp> 0.27.4-1
  76. - new upstream release
  77. * Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.24.1-1
  78. - new upstream release
  79. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.23.3-1
  80. - new upstream release
  81. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.2-2
  82. - add BuildRequires: openssl-devel, http-parser-devel, libssh2-devel, zlib-devel
  83. * Wed Apr 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.2-1
  84. - initial build