texlive-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702
  1. # -*- coding: utf-8-unix -*-
  2. %bcond_with firstbuild
  3. %global _use_internal_dependency_generator 0
  4. %global __find_provides %{SOURCE99}
  5. %global __find_requires %{SOURCE98}
  6. %global texlivesrcver 20140525
  7. %global tlptexlivesrcver 20140507
  8. Summary: The TeX text formatting system
  9. Summary(ja): TeX 文書整形システム
  10. Name: texlive
  11. Version: 2014
  12. Release: 2%{?_dist_release}
  13. License: distributable
  14. Group: Applications/Publishing
  15. URL: http://www.tug.org/texlive/
  16. ## original TeX Live source
  17. Source: ftp://tug.org/historic/systems/texlive/%{version}/%{name}-%{texlivesrcver}-source.tar.xz
  18. ## snapshot
  19. # $ rsync -a --delete --exclude=.svn tug.org::tldevsrc/Build/source/ texlive-source-YYYYMMDD
  20. # $ tar -cf - texlive-source-YYYYMMDD | pxz -9 > texlive-source-YYYYMMDD.tar.xz
  21. # Source: %{name}-source-%{texlivesrcver}.tar.xz
  22. ## tlptexlive: pmetapost
  23. Source1: http://www.preining.info/software/build-tlptexlive-%{tlptexlivesrcver}.zip
  24. Source2: http://www.tug.org/texlive/updmap-kanji.html
  25. ## our updmap{,-hdr}.cfg from collection-basic 20140524
  26. # NOTE: fmtutil.cnf, texmf.cnf: use the conf files generated from Source0
  27. Source6: updmap-hdr.cfg.texlive-%{texlivesrcver}
  28. Source7: updmap.cfg.texlive-%{texlivesrcver}
  29. ## desktop files
  30. Source11: texdoctk.desktop
  31. Source98: find-requires-texlive.sh
  32. ## find library sonames for libkpathsea and libptexenc
  33. Source99: find-provides-texlive.sh
  34. ######
  35. # TeX patches
  36. ######
  37. ## vine
  38. #Patch0: reautoconf-parallel.diff
  39. #Patch1: texlive-%{texlivesrcver}-vine.patch
  40. Patch2: texlive-%{texlivesrcver}-texmfcnf-vine.patch
  41. Patch3: texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
  42. #Patch4: texlive-%{texlivesrcver}-fmtutilcnf-vine.patch
  43. #Patch10: texlive-%{texlivesrcver}-pxdvik-vine.patch
  44. ## security
  45. Requires: perl-Tk perl-Tk-TableMatrix
  46. Requires: ghostscript >= 8.71
  47. Requires: nkf
  48. Requires(post,postun): fontconfig
  49. Requires(post): ed mktemp
  50. Requires(post): vutils >= 7.1
  51. %{!?with_firstbuild:Requires: texlive-common = %{version}}
  52. BuildRequires: bison flex
  53. BuildRequires: bzip2-devel
  54. BuildRequires: zlib-devel
  55. BuildRequires: libpng-devel >= 1.6
  56. BuildRequires: gd-devel
  57. BuildRequires: ncurses-devel
  58. BuildRequires: libjpeg-devel
  59. BuildRequires: XOrg-devel
  60. BuildRequires: freetype2-devel >= 2.1.10
  61. BuildRequires: autoconf >= 2.68
  62. BuildRequires: openMotif-devel
  63. BuildRequires: poppler-devel >= 0.20
  64. BuildRequires: openssl-devel
  65. BuildRequires: fontconfig-devel
  66. # BuildRequires: libpaper-devel >= 1.1.24-2
  67. BuildRequires: nkf
  68. ## needs to build pxdvi
  69. #BuildRequires: t1lib-devel
  70. BuildRequires: texlive-vtlpkg = %{version}
  71. Buildroot: %{_tmppath}/%{name}-%{version}-root
  72. Vendor: Project Vine
  73. Distribution: Vine Linux
  74. Packager: munepi
  75. %description
  76. The TeX Live software distribution offers a complete TeX system for a
  77. variety of Unix, Macintosh, Windows and other platforms. It
  78. encompasses programs for editing, typesetting, previewing and printing
  79. of TeX documents in many different languages, and a large collection
  80. of TeX macros and font libraries.
  81. The distribution includes extensive general documentation about TeX,
  82. as well as the documentation for the included software packages.
  83. %description -l ja
  84. TeX Live ソフトウェアディストリビューションは、
  85. さまざまな Unix, Macintosh, Windows、および
  86. 他のプラットホームに対して完全な TeX システムを提供します。
  87. 多くの異なった言語を含む TeX ドキュメントの
  88. 編集、組版、閲覧、印刷するためのプログラム、
  89. そして、TeX マクロやフォントライブラリの大きなコレクションを
  90. 同梱しています。
  91. このディストリビューションは
  92. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  93. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  94. %package doc
  95. Summary: TeX Live: Documentation files of %{name}
  96. Group: Applications/Publishing
  97. Requires: %{name} = %{version}-%{release}
  98. BuildArch: noarch
  99. %description doc
  100. This package contains documentation files of %{name}.
  101. %package -n libkpathsea
  102. Summary: path search library for the TeX Live
  103. Summary(ja): TeX Live 用パス検索ライブラリ
  104. Group: System Environment/Libraries
  105. %description -n libkpathsea
  106. This package includes runtime part of the Kpathsea library.
  107. %package -n libkpathsea-devel
  108. Summary: path search libary and header files for the TeX Live
  109. Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
  110. Group: Development/Libraries
  111. Requires: libkpathsea = %{version}-%{release}
  112. %description -n libkpathsea-devel
  113. This package includes static library and header files of the Kpathsea library.
  114. %package -n libptexenc
  115. Summary: Kanji code convert library for Japanese pTeX
  116. Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
  117. Group: System Environment/Libraries
  118. Requires: libkpathsea = %{version}-%{release}
  119. %description -n libptexenc
  120. This package includes runtime part of the ptexenc library.
  121. %package -n libptexenc-devel
  122. Summary: Kanji code convert library and header files for Japanese pTeX
  123. Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
  124. Group: Development/Libraries
  125. Requires: libptexenc = %{version}-%{release}
  126. %description -n libptexenc-devel
  127. This package includes header files of the ptexenc library.
  128. %prep
  129. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  130. %setup -q -n %{name}-%{texlivesrcver}-source -a 1
  131. # %setup -q -n %{name}-source-%{texlivesrcver} -a 1
  132. # %patch0 -p0 -b .parallel
  133. # %patch1 -p1 -b .vine
  134. %patch2 -p1 -b .vine
  135. %patch3 -p1 -b .vine
  136. # %patch4 -p1 -b .vine
  137. ## Applying tlptexlive that provides pxdvi(k) and pmpost
  138. echo "applying patches"
  139. cat "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/series" | while read p r ; do
  140. echo $p | grep '^#' >/dev/null || \
  141. patch -p1 $r < "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/$p" || exit 1
  142. done
  143. ## Avoid pollution from internal libraries.
  144. %__rm -rf ./libs/{cairo,expat,freetype,freetype2,gd,jpeg,libpng,libttf,ncurses,paper,pixman,poppler,t1lib,unzip,xpdf,zlib} || exit 1
  145. # ./reautoconf || exit 1
  146. %build
  147. set -x
  148. unset TEXINPUTS || :
  149. unset HOME || :
  150. export CFLAGS="$RPM_OPT_FLAGS" \
  151. CXXFLAGS="$RPM_OPT_FLAGS" \
  152. LANG=C
  153. PREFIX=$(pwd)/work
  154. TL_CONF_XDVI_TOOLKIT=--with-xdvi-x-toolkit=motif
  155. TL_MAKE_FLAGS=-j$(/usr/bin/getconf _NPROCESSORS_ONLN)
  156. TL_CONFIGURE_ARGS=" \
  157. --disable-multiplatform \
  158. --disable-native-texlive-build \
  159. --with-banner-add=\"/Vine Linux\" \
  160. --enable-shared --disable-static \
  161. --enable-compiler-warnings=max \
  162. --without-cxx-runtime-hack \
  163. \
  164. --with-system-xpdf \
  165. --with-system-gd \
  166. --with-system-t1lib \
  167. --with-system-libpng \
  168. --with-system-zlib \
  169. --with-system-freetype2 \
  170. --with-system-pixman \
  171. --with-system-poppler \
  172. --with-system-cairo \
  173. --with-freetype2-include=$(freetype-config --cflags | %__sed -e 's/-I//' -e 's/ .*//') \
  174. --with-pic \
  175. \
  176. --disable-xindy --disable-xindy-docs --disable-xindy-make-rules \
  177. --disable-dvi2tty \
  178. --disable-t1utils --disable-psutils --disable-detex \
  179. --disable-dvipng --disable-lcdf-typetools \
  180. "
  181. export TL_CONF_XDVI_TOOLKIT TL_MAKE_FLAGS TL_CONFIGURE_ARGS
  182. TL_MAKE=%__make ./Build || exit 1
  183. %install
  184. ## prepare %%install session
  185. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  186. ## copy inst directory to /usr
  187. %__mkdir_p %{buildroot}
  188. %__cp -a inst %{buildroot}%{_prefix} || exit 1
  189. %ifarch x86_64
  190. %__mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir} || exit 1
  191. %endif
  192. ## make some fundamental texmf trees
  193. %__mkdir_p %{buildroot}%{_tl_texmfvine}
  194. %__mkdir_p %{buildroot}%{_tl_texmfdist}
  195. %__mkdir_p %{buildroot}%{_tl_texmflocal}
  196. %__mkdir_p %{buildroot}%{_tl_texmfsysconfig}
  197. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}
  198. %__mkdir_p %{buildroot}%{_tl_vartexfonts}
  199. %__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/{truetype,opentype}
  200. %__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/cmap
  201. cat<<EOF>%{buildroot}%{_tl_texmfdist}/README.vine || exit 1
  202. The directory %{_tl_texmfdist} is the texmf tree of the TeX Live
  203. distribution wide.
  204. You must not do any changes in this directory.
  205. EOF
  206. cat<<EOF>%{buildroot}%{_tl_texmfvine}/README.vine || exit 1
  207. The directory %{_tl_texmfvine} is the texmf tree of our distribution wide.
  208. You should not use this directory to manage any other packages because
  209. we Project Vine use this directory to manage non-CTAN packages, some
  210. enhancement packages and so on.
  211. EOF
  212. cat<<EOF>%{buildroot}%{_tl_texmflocal}/README.vine || exit 1
  213. The directory %{_tl_texmflocal} is the texmf tree of the system wide.
  214. If you are a privileged user of this system,
  215. you can use this directory to manage your local packages.
  216. EOF
  217. ## our texmf-dist/web2c/updmap{,-hdr}.cfg
  218. %__mkdir_p %{buildroot}%{_tl_texmfdist}/web2c
  219. %__cp -a %{SOURCE6} %{buildroot}%{_tl_texmfdist}/web2c/updmap-hdr.cfg || exit 1
  220. %__cp -a %{SOURCE7} %{buildroot}%{_tl_texmfdist}/web2c/updmap.cfg || exit 1
  221. ## our map files for dvipdfmx
  222. %__mkdir_p %{buildroot}%{_tl_aliasttfdir}
  223. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine
  224. for x in ptex uptex otf otf-up; do
  225. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/${x}-vine.map
  226. done
  227. for x in FutoGo-Bold FutoMin-Bold Gothic-Medium MaruGo-Medium Mincho-Medium; do
  228. touch %{buildroot}%{_tl_aliasttfdir}/${x}.ttf
  229. done
  230. ## desktop things
  231. %__mkdir_p %{buildroot}%{_datadir}/applications
  232. # %__install -m0644 -c %{SOURCE10} %{buildroot}%{_datadir}/applications/
  233. %__install -m0644 -c %{SOURCE11} %{buildroot}%{_datadir}/applications/
  234. # for created fonts
  235. %__mkdir_p %{buildroot}%{_tl_vartexfonts}
  236. # %__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
  237. # %__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
  238. ## set executable bit for the library
  239. %__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
  240. %__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
  241. # configure ConTeXt
  242. for x in context luatools texexec texmfstart; do
  243. %__sed -i -e 's|mtxrun|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; mtxrun|' %{buildroot}%{_bindir}/${x} || exit 1
  244. done
  245. # touch ghosts
  246. touch %{buildroot}%{_tl_texmfvine}/ls-R
  247. touch %{buildroot}%{_tl_texmfdist}/ls-R
  248. touch %{buildroot}%{_tl_texmfsysconfig}/ls-R
  249. touch %{buildroot}%{_tl_texmfsysvar}/ls-R
  250. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/
  251. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/
  252. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/
  253. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/
  254. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/builtin35.map
  255. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_t1.map
  256. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_pk.map
  257. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/download35.map
  258. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/ps2pk.map
  259. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts.map
  260. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/kanjix.map
  261. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/xdvi-ptex.map
  262. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_dl14.map
  263. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex.map
  264. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_ndl14.map
  265. ## remove unpackaging files
  266. find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f || exit 1
  267. find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f || exit 1
  268. %__rm -f %{buildroot}%{_bindir}/tlmgr || exit 1
  269. find %{buildroot}%{_tl_texmfvine}/fonts/map -type d | %__grep "updmap" | xargs %__rm -rf || exit 1
  270. find %{buildroot} -type d | grep asymptote | xargs %__rm -rf || exit 1
  271. %__rm -f %{buildroot}%{_tl_texmfvine}/dvipdfm/config/config-win32 || exit 1
  272. %__rm -f %{buildroot}%{_infodir}/*
  273. ## use external packages
  274. %__rm %{buildroot}/usr/bin/latexmk || exit 1
  275. ### Files list
  276. find %{buildroot} -type f -or -type l | \
  277. %__sed -e "s|%{buildroot}||g" | \
  278. %__grep -v -e ".patch$" -e "\.diff$" -e "\.orig$" | \
  279. %__grep -v "%{_includedir}" | \
  280. %__grep -v "%{_libdir}" | \
  281. %__grep -v "%{_infodir}" | \
  282. %__sed -e "s|.*ls-R$|%ghost &|" \
  283. -e "s|%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/.*\.map$|%ghost &|" \
  284. -e "s|%{_tl_aliasttfdir}/.*\.ttf$|%ghost &|" \
  285. -e "s|.*/updmap.*\.cfg$|%config(noreplace) &|" \
  286. -e "s|.*/dvipdfmx\.cfg$|%config(noreplace) &|" \
  287. -e "s|.*xdvi\.cfg$|%config(noreplace) &|" \
  288. -e "s|.*\.cnf$|%config(noreplace) &|" \
  289. -e "s|%{_tl_texmfvine}*/xdvi/XDvi|%config(noreplace) &|" \
  290. -e "s|%{_tl_texmfvine}*/web2c/texmfcnf\.lua$|%config(noreplace) &|" \
  291. -e "s|^.*/updmap/$|%config &|" \
  292. -e "s|%{_tl_texmfvine}*/texconfig/tcfmgr.map$|%config &|" \
  293. -e "s|%{_tl_texmfvine}*/dvips/config/.*$|%config &|" \
  294. -e "s|%{_tl_texmfvine}*/dvips/tetex/config.*$|%config &|" \
  295. -e "s|%{_tl_texmfvine}*/dvipdfm/config/config$|%config &|" \
  296. -e "s|%{_tl_texmfvine}*/fonts/map/dvips/tetex/.*.map$|%config &|" \
  297. -e "s|%{_tl_texmfvine}*/fonts/map/dvipdfmx/.*.map$|%config &|" \
  298. -e "s|%{_tl_texmfvine}*/tex/generic/config/.*|%config &|" \
  299. -e "s|%{_tl_texmfvine}*/ttf2pk/ttf2pk\.cfg$|%config &|" \
  300. -e "s|%{_tl_texmfvine}*/hbf2gf/.*\.cfg$|%config &|" \
  301. -e "s|%{_tl_texmfvine}*/chktex/chktexrc$|%config &|" \
  302. -e "s|%{_mandir}/.*|&*|" \
  303. > %{_builddir}/filelist.full
  304. find %{buildroot}%{_tl_texmfvine}* -type d | \
  305. %__sed -e "s|^%{buildroot}|%dir |" \
  306. -e "s|$|/|" >> %{_builddir}/filelist.full
  307. ## subpackages
  308. %__grep -e "/texmf/doc/" -e "/texmf-dist/doc/" -e "/texdoc" %{_builddir}/filelist.full > %{_builddir}/filelist.doc
  309. cat %{_builddir}/filelist.doc \
  310. %{_builddir}/filelist.full | \
  311. sort | uniq -u > %{_builddir}/filelist.tmp
  312. %__mv -f %{_builddir}/filelist.tmp %{_builddir}/filelist.full
  313. %clean
  314. %__rm -rf %{buildroot}
  315. %pretrans
  316. rpm -q texlive | grep -q -e 2009 -e 2011 -e 2012 -e 2013
  317. [ $? -eq 1 ] && exit 0
  318. _trans_time=$(date +%Y%m%d)
  319. echo "Running some transitional processes on your TeX system ... "
  320. x=(
  321. /usr/share/texmf-local
  322. /usr/share/texmf-var
  323. /usr/share/texmf-config
  324. )
  325. for dir in ${x[@]}; do
  326. _trans_dir=${dir}.${_trans_time}.rpmorig
  327. [ -d ${_trans_dir}.old ] && \
  328. echo -n " " && \
  329. echo "Found ${_trans_dir}.old: " && \
  330. echo -n " " && \
  331. %__rm -rvf ${_trans_dir}.old
  332. [ -d ${_trans_dir} ] && \
  333. echo -n " " && \
  334. echo "Found ${_trans_dir}: " && \
  335. echo -n " " && \
  336. %__mv -v ${_trans_dir} ${_trans_dir}.old
  337. [ -d ${dir} ] && \
  338. echo -n " " && \
  339. echo "Found ${dir}: " && \
  340. echo -n " " && \
  341. %__mv -v ${dir} ${_trans_dir}
  342. done
  343. echo "done."
  344. %postun
  345. if [ "$1" = 0 ]; then
  346. %__rm -rf %{_tl_vartexfonts}
  347. fi
  348. exit 0
  349. %post
  350. %_tl_touch_run texhash
  351. %_tl_touch_run updmap
  352. %_tl_touch_run mtxrun
  353. %_tl_touch_run fmtutil
  354. exit 0
  355. %posttrans
  356. %__mkdir_p %{_tl_vartexfonts}
  357. %__chmod 1777 %{_tl_vartexfonts}
  358. ## create our map files {ptex,uptex,otf,otf-up}-vine.map
  359. ( %{_tl_exec_upddeffont} ) ||:
  360. %{_tl_exec_texhash}
  361. %{_tl_exec_mtxrun}
  362. %{_tl_exec_updmap}
  363. %{_tl_exec_fmtutil}
  364. exit 0
  365. %post -n libkpathsea
  366. /sbin/ldconfig
  367. # for x in kpathsea tds web2c; do
  368. # /sbin/install-info %{_infodir}/${x}.info.* %{_infodir}/dir
  369. # done
  370. # %preun -n libkpathsea
  371. # if [ "$1" = 0 ]; then
  372. # for x in kpathsea tds web2c; do
  373. # /sbin/install-info --delete %{_infodir}/${x}.info.* %{_infodir}/dir
  374. # done
  375. # fi
  376. %postun -n libkpathsea
  377. /sbin/ldconfig
  378. %post -n libptexenc
  379. /sbin/ldconfig
  380. %postun -n libptexenc
  381. /sbin/ldconfig
  382. %triggerin -- ghostscript
  383. %__rm -f %{_tl_texmfvine}/fonts/cmap/ghostscript
  384. if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
  385. %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
  386. elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
  387. %__ln_s %{_datadir}/ghostscript/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
  388. fi
  389. %_tl_touch_run texhash
  390. exit 0
  391. %files -f %{_builddir}/filelist.full
  392. %defattr(-,root,root)
  393. %dir %{_tl_aliasttfdir}
  394. %attr(1777,root,root) %dir %{_tl_vartexfonts}
  395. # %config %{_sysconfdir}/cron.daily/texlive.cron
  396. %files doc -f %{_builddir}/filelist.doc
  397. %defattr(-,root,root)
  398. %files -n libkpathsea
  399. %defattr(-,root,root)
  400. %{_libdir}/libkpathsea.so.*
  401. # %{_infodir}/kpathsea.info*
  402. %files -n libkpathsea-devel
  403. %defattr(-,root,root)
  404. %{_libdir}/libkpathsea.so
  405. %dir %{_includedir}/kpathsea
  406. %{_includedir}/kpathsea/*
  407. %files -n libptexenc
  408. %defattr(-,root,root)
  409. %{_libdir}/libptexenc.so.*
  410. %files -n libptexenc-devel
  411. %defattr(-,root,root)
  412. %{_libdir}/libptexenc.so
  413. %dir %{_includedir}/ptexenc
  414. %{_includedir}/ptexenc/*
  415. %changelog
  416. * Thu Jul 3 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-2
  417. - texlive-source-20140525 + tlptexlive 20140507
  418. - dropped texlive-20140524-vine.patch: built with libpng >= 1.6
  419. * Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
  420. - upgrade to TeX Live 2014
  421. - texlive-source-20140524 + tlptexlive 20140507
  422. * Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2013-7
  423. - rebuild with poppler-0.24.5
  424. * Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-6
  425. - rebuilt
  426. * Fri Nov 1 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-5
  427. - texlive-source-20131101 2014/dev + tlptexlive 20130815
  428. - added BuildRequires: libpaper-devel >= 1.1.24-2 :-(
  429. * Mon Oct 7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-4
  430. - updated texlive-20131002-texmfcnf-vine.patch:
  431. texmf.cnf (shell_escape_commands): added some programs
  432. * Wed Oct 2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
  433. - texlive-source-20131002 2014/dev + tlptexlive 20130815
  434. - defined %%global __find_requires find-requires-texlive.sh
  435. - dropped unused dependencies of Requires
  436. * Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
  437. - texlive-source-20130919 2014/dev + tlptexlive 20130815
  438. - correct some scripts of README.vine for each texmf trees
  439. * Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
  440. - upgrade to TeX Live 2013
  441. - texlive-source-20130823 2014/dev + tlptexlive 20130815
  442. - dropped Requires: jvf
  443. * Thu May 16 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-4
  444. - update enhancement binaries TeX Live 2013/dev 20130106 snapshot (tlptexlive-20130106)
  445. - fixed duplicated lw35 for updmap.pl
  446. - updated updmap.cfg.texlive-20120701: use ipaex as kanjiEmbed
  447. * Sat Mar 9 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-3
  448. - touch the map files generated by updmap-sys
  449. * Mon Nov 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-2
  450. - fixed Source7: updmap.cfg.texlive-20120701
  451. (upto /etc/texmf/web2c/updmap.cfg)
  452. - fixex %%triggerin -- ghostscript
  453. - replaced %%exec_texhash with %%touch_run texhash
  454. * Wed Nov 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
  455. - TeX Live 2012 + tlptexlive 20121107
  456. * Tue Oct 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-7
  457. - drop BR: poppler-devel temporaly
  458. - modify tl11supp-120120-vine.patch, texlive-20110705-vine.patch to do that
  459. * Mon May 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-6
  460. - build with poppler-0.18.4
  461. - remove tlmgr
  462. * Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-5
  463. - updated to tl11supp-120120
  464. - run %%{exec_fmtutil} at %%post when upgrading
  465. * Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-4
  466. - updated to tl11supp-111214
  467. * Sat Dec 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
  468. - added BuildRequires: texlive-common
  469. - Babel needs docstrip.tex, which is contained in texlive-collection-latex
  470. - check japanese.ldf
  471. - updated tl11supp-111120-vine.patch
  472. - added the following options to $$TL_CONFIGURE_ARGS:
  473. --disable-detex
  474. --disable-dvipng
  475. --disable-lcdf-typetools
  476. - remove some files of asymptote
  477. - remove a man file of latexmk
  478. - remove man files of lcdf-typetools
  479. - remove man files of dvipng
  480. - remove a man file of detex
  481. * Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
  482. - added find-provides-texlive.sh and set it to %%__find_provides
  483. - use to find library sonames for libkpathsea and libptexenc
  484. - added cmex.enc (%%{SOURCE110})
  485. - do not install cmex.enc in our TDS, yet
  486. - removed some unused directories in texmf/fonts/map
  487. - removed man files of lcdf-typetools
  488. - moved texdoc{,tk} and its related files to texlive-doc
  489. * Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
  490. - TeX Live 2011 + tl11supp-111120
  491. * Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
  492. - make the directory VARTEXFONTS (%%posttrans)
  493. - dropped %%triggerpostun -- texlive < 2009-17vl6
  494. * Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
  495. - fixed ptexlive-20100711-dvipdfmx-vine.patch
  496. - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
  497. * Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
  498. - added %%pre to avoid conflictions of texmf-{config,var}
  499. * Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
  500. - dropped Requires: texlive-common
  501. - added perl-Tk-TableMatrix
  502. - supported texdoctk
  503. - removed broken symbolic links in /usr/bin
  504. - for each these symbolic links, the package of its real file/path
  505. should be its owner.
  506. * Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
  507. - added %%triggerpostun -- texlive < 2009-17vl6
  508. - make the directory VARTEXFONTS
  509. * Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
  510. - fixed %%dir VARTEXFONTS around in %%files
  511. - dropped BuildRequires: t1utils
  512. * Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
  513. - updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
  514. - changed VARTEXFONTS to /var/lib/texmf/fonts
  515. * Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
  516. - fixed updmap.cfg
  517. * Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
  518. - dropped Requires: texlive-macros
  519. * Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
  520. - updated ptexlive-20100711-pxdvik-vine.patch
  521. and added texlive-20091107-xdvik-vine.patch
  522. - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
  523. * Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
  524. - supported Vine Linux 5
  525. - for vl5, changed a requirement of Japanese VF package
  526. - added Requires: texlive-jvf = 2009 (vl5)
  527. - dropped dependencies of Provides:/Obsoletes: tags
  528. - merged these dependencies in texlive-common-vl.spec
  529. * Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
  530. - rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
  531. * Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
  532. - applied some security patches from Debian
  533. - texlive-2009-CVE-2010-0827.patch
  534. - texlive-2009-CVE-2010-1440.patch
  535. - applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
  536. - applied texlive-2009-luatexdir-libpoppler-0.12.patch
  537. based on texlive-2009-pdftexdir-libpoppler-0.12.patch
  538. - fixed some dependencies
  539. * Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
  540. - added BuildArch: noarch in %%package doc
  541. - removed some comment-out sentences
  542. * Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
  543. - separeted texmf-dist to texlive-common package
  544. * Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
  545. - unpacked texlive-20091107-source.tar.xz
  546. - babel is available now
  547. - applied eptex-100420 and some patches:
  548. - eptex-100420-vine.patch
  549. - eptex-100420-patch1.diff
  550. * Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
  551. - updated ptexlive-20100711
  552. * Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
  553. - customized updmap.cfg to correspond installed fonts
  554. * Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
  555. - fixed insttexfont()
  556. * Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  557. - added jvf of MORISAWA basic 5 fonts
  558. - added cm-super, mathdesign in fntlst
  559. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  560. - define insttexfont() in %%install
  561. - copy almost compatible tetex-3.0
  562. * Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  563. - ptexlive-20090322 + TeXLive 2009
  564. - added BuildRequires: openssl-devel
  565. * Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
  566. - ptexlive-20091009 + TeXLive 2008