at-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435
  1. %bcond_without pam
  2. Summary: Job spooling tools.
  3. Summary(ja): ジョブスプーリングツール
  4. Name: at
  5. Version: 3.1.13
  6. Release: 3%{?_dist_release}
  7. License: GPLv2+ and ISC
  8. Group: System Environment/Daemons
  9. URL: http://ftp.debian.org/debian/pool/main/a/at
  10. Source: http://ftp.debian.org/debian/pool/main/a/at/at_%{version}.orig.tar.gz
  11. Source1: pam_atd
  12. Source2: atd.init
  13. Source3: atd.sysconf
  14. Patch1: at-3.1.13-makefile.patch
  15. Patch2: at-3.1.12-opt_V.patch
  16. Patch3: at-3.1.12-shell.patch
  17. Patch4: at-3.1.13-nitpicks.patch
  18. Patch5: at-3.1.13-pam.patch
  19. Patch6: at-3.1.13-selinux.patch
  20. Patch7: at-3.1.12-nowrap.patch
  21. Patch8: at-3.1.12-fix_no_export.patch
  22. Patch9: at-3.1.13-mailwithhostname.patch
  23. # Patch10: at-3.1.13-usePOSIXtimers.patch
  24. Patch11: at-3.1.13-help.patch
  25. BuildRequires: fileutils
  26. BuildRequires: chkconfig
  27. BuildRequires: flex
  28. BuildRequires: bison
  29. BuildRequires: autoconf
  30. %if %{with pam}
  31. BuildRequires: pam-devel
  32. %endif
  33. Conflicts: crontabs <= 1.5
  34. # No, I'm not kidding
  35. BuildRequires: smtpdaemon
  36. Buildroot: %{_tmppath}/%{name}-%{version}-root
  37. %description
  38. At and batch read commands from standard input or from a specified
  39. file. At allows you to specify that a command will be run at a
  40. particular time. Batch will execute commands when the system load
  41. levels drop to a particular level. Both commands use /bin/sh.
  42. You should install the at package if you need a utility for
  43. time-oriented job control. Note: If it is a recurring job that will
  44. need to be repeated at the same time every day/week, etc. you should
  45. use crontab instead.
  46. %description -l ja
  47. at と batch は標準入力や指定されたファイルからコマンドを読み取ります。
  48. at を使用して特定の時間にコマンドを実行するように指定することが可能です。
  49. batch はシステムの負荷レベルが特定のレベルを下回るとコマンドを実行します。
  50. 両コマンドとも /bin/sh を使います。
  51. あなたが時間志向のジョブ管理のためのユーティリティを必要とするならば、at
  52. パッケージをインストールしてください。
  53. メモ: もし毎日/週などの同じ時間にくり返される必要があるジョブであれば、
  54. 代わりに crontab を使うべきでしょう。
  55. %prep
  56. %setup -q
  57. cp %{SOURCE1} .
  58. %patch1 -p1 -b .make
  59. %patch2 -p1 -b .opt_V
  60. %patch3 -p1 -b .shell
  61. %patch4 -p1 -b .nit
  62. %patch5 -p1 -b .pam
  63. %patch6 -p1 -b .selinux
  64. %patch7 -p1 -b .nowrap
  65. %patch8 -p1 -b .export
  66. %patch9 -p1 -b .mail
  67. #patch10 -p1 -b .posix
  68. %patch11 -p1 -b .help
  69. %build
  70. # patch10 touches configure.in
  71. autoconf
  72. # for patch11
  73. rm -f lex.yy.* y.tab.*
  74. %configure --with-atspool=%{_localstatedir}/spool/at/spool \
  75. --with-jobdir=%{_localstatedir}/spool/at \
  76. --with-daemon_username=root \
  77. --with-daemon_groupname=root \
  78. %if %{with pam}
  79. --with-pam
  80. %endif
  81. make
  82. %check
  83. # don't run "make test" by default
  84. %{?_without_check: %define _without_check 1}
  85. %{!?_without_check: %define _without_check 1}
  86. %if ! %{_without_check}
  87. LANG=C make test > /dev/null
  88. %endif
  89. %install
  90. rm -rf %{buildroot}
  91. make install \
  92. DAEMON_USERNAME=`id -nu`\
  93. DAEMON_GROUPNAME=`id -ng` \
  94. DESTDIR=%{buildroot}\
  95. sbindir=%{buildroot}%{_prefix}/sbin\
  96. bindir=%{buildroot}%{_bindir}\
  97. prefix=%{buildroot}%{_prefix}\
  98. exec_prefix=%{buildroot}%{_prefix}\
  99. docdir=%{buildroot}/usr/doc\
  100. mandir=%{buildroot}%{_mandir}\
  101. etcdir=%{buildroot}%{_sysconfdir} \
  102. ATJOB_DIR=%{buildroot}%{_localstatedir}/spool/at \
  103. ATSPOOL_DIR=%{buildroot}%{_localstatedir}/spool/at/spool \
  104. INSTALL_ROOT_USER=`id -nu` \
  105. INSTALL_ROOT_GROUP=`id -nu`;
  106. echo > %{buildroot}%{_sysconfdir}/at.deny
  107. mkdir docs
  108. cp $RPM_BUILD_ROOT/%{_prefix}/doc/at/* docs/
  109. mkdir -p %{buildroot}%{_sysconfdir}/pam.d
  110. install -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/pam.d/atd
  111. mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
  112. install -m 755 %{SOURCE2} %{buildroot}%{_sysconfdir}/rc.d/init.d/atd
  113. mkdir -p %{buildroot}/etc/sysconfig
  114. install -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/atd
  115. # remove unpackaged files from the buildroot
  116. rm -r %{buildroot}%{_prefix}/doc
  117. %clean
  118. rm -rf %{buildroot}
  119. %post
  120. touch %{_localstatedir}/spool/at/.SEQ
  121. chmod 600 %{_localstatedir}/spool/at/.SEQ
  122. chown daemon.daemon %{_localstatedir}/spool/at/.SEQ
  123. # must be in chkconfig on
  124. /sbin/chkconfig --add atd
  125. %preun
  126. if [ "$1" = 0 ] ; then
  127. /sbin/service atd stop
  128. /sbin/chkconfig --del atd
  129. fi
  130. %postun
  131. if [ "$1" -ge "1" ]; then
  132. /sbin/service atd condrestart
  133. fi
  134. %files
  135. %defattr(-,root,root)
  136. %doc docs/*
  137. %config %{_sysconfdir}/at.deny
  138. %attr(0700,root,root) %{_sysconfdir}/rc.d/init.d/atd
  139. %attr(0700,root,root) %{_sysconfdir}/sysconfig/atd
  140. %attr(0700,daemon,daemon) %dir %{_localstatedir}/spool/at
  141. %attr(0600,daemon,daemon) %verify(not md5 size mtime) %ghost %{_localstatedir}/spool/at/.SEQ
  142. %attr(0700,daemon,daemon) %dir %{_localstatedir}/spool/at/spool
  143. %attr(0640,root,daemon) %config(noreplace) /etc/pam.d/atd
  144. %{_sbindir}/atrun
  145. %attr(0755,root,root) %{_sbindir}/atd
  146. %{_mandir}/man*/*
  147. %{_bindir}/batch
  148. %{_bindir}/atrm
  149. %{_bindir}/atq
  150. %attr(4755,root,root) %{_bindir}/at
  151. %changelog
  152. * Sat Nov 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.13-3
  153. - remove Patch10
  154. - atd doesn't execute queued job until the next jobs is queued.
  155. * Thu Nov 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.13-2
  156. - fix pam_atd to use system-auth instead of password-auth
  157. * Tue Nov 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.13-1
  158. - update to 3.1.13
  159. - update patches to sync with fedora 3.1.13-10.
  160. * Mon Sep 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10.1-17
  161. - rebuild with rpm-4.8.1
  162. * Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.10.1-16
  163. - spec in utf-8
  164. * Tue May 27 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.1.10.1-15
  165. - new upstream release
  166. - apply new versioning policy
  167. * Thu Jul 12 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.1.10-14vl1
  168. - update based on fedora development 3.1.10-14.
  169. - build with new toolchains.
  170. * Tue Jul 9 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-14
  171. - feature: add configuration file
  172. - fix -V option
  173. - fix init script
  174. * Tue Jul 3 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-13
  175. - Resolves: rhbz#243064
  176. * Tue Jul 3 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-12
  177. - crashing atd
  178. - work only for root, still broken some functions
  179. - Resolves: rhbz#243064
  180. * Tue Mar 27 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-11
  181. - mistake in pam_atd
  182. - rhbz#234120
  183. * Tue Mar 05 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-10
  184. - rhbz#224597
  185. * Mon Mar 03 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-9
  186. - review
  187. * Wed Feb 20 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-8
  188. - review
  189. - rhbz#225288
  190. * Tue Jan 30 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-7
  191. - no debug file - useless
  192. - new pam configuration
  193. - rhbz#224597
  194. * Tue Oct 27 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-6
  195. - fix daylight-saving again
  196. - fix #214759 - problem with seteuid
  197. * Wed Oct 25 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-5
  198. - daylight-saving
  199. * Tue Oct 24 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-3
  200. - new version from upstream 3.1.10
  201. * Thu Aug 23 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.8-82.fc6
  202. - #176486 don't fork option added (patch from Enrico Scholz)
  203. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.1.8-81.2
  204. - rebuild
  205. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.1.8-81.1
  206. - bump again for double-long bug on ppc(64)
  207. * Tue Feb 07 2006 Jason Vas Dias <jvdias@redhat.com> - 3.1.8-81
  208. - rebuild for new gcc, glibc, glibc-kernheaders
  209. - workaround new refusal of /usr/bin/install to chown
  210. * Fri Dec 18 2005 Jason Vas Dias<jvdias@redhat.com> - 3.1.8-80.2
  211. - rebuild for new flex
  212. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  213. - rebuilt for new gcj
  214. * Fri Oct 14 2005 Dan Walsh <dwalsh@redhat.com> - 3.1.8-80
  215. - Add seuserbyname support
  216. * Fri Sep 30 2005 Tomas Mraz <tmraz@redhat.com> - 3.1.8-79
  217. - use include instead of pam_stack in pam config
  218. * Fri Jun 03 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-78
  219. - fix bug 159220: add pam_loginuid to pam session stack in /etc/pam.d/atd
  220. - fix bug 102341: add '-r' synonym for '-d' / atrm for POSIX / SuS conformance
  221. * Fri Apr 08 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-77
  222. - always call pam_setcred(pamh, PAM_DELETE_CRED) before session
  223. - close
  224. * Tue Apr 05 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-70
  225. - always call pam_close_session on PAM_FAIL or pam_end
  226. * Tue Mar 08 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-68
  227. - Put PAM authentication check in 'check_permissions()', so
  228. - user can know when using at(1) if PAM permission is denied.
  229. * Tue Mar 08 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-67
  230. - better fix for bug 150131: change DAEMON_USERNAME and
  231. - DAEMON_GROUPNAME to 'root' .
  232. * Mon Mar 07 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-66
  233. - fix bug 150131: atd should not relinquish root privilege if
  234. - doing su(1) equivalent with PAM .
  235. * Tue Jan 25 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-64
  236. - bugs 5160/146132: add PAM authentication control to atd
  237. * Tue Nov 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.8-60vl1
  238. - based on Fedora development 3.1.8-60
  239. * Tue Oct 05 2004 Jason Vas Dias <jvdias@redhat.com> 3.1.8-60
  240. - fix bug 131510: no_export env. var. blacklisting should not
  241. - remove 'SHELL' when only 'SHELLOPTS' is blacklisted.
  242. - at(1) man-page should not say 'commands are run with /bin/sh'
  243. - and should explain usage of SHELL environement variable and
  244. - details of blacklisted variables.
  245. * Tue Sep 28 2004 Rik van Riel <riel@redhat.com> 3.1.8-58
  246. - fix typo in man page, bug 112303
  247. - (regenerated at-3.1.8-man-timespec-path.patch with fix)
  248. * Tue Aug 03 2004 Jason Vas Dias <jvdias@redhat.com>
  249. - fixed bug 125634 - made usage() agree with manpage
  250. * Thu Jul 29 2004 Jason Vas Dias <jvdias@redhat.com>
  251. - Added POSIX.2 -t option for RFE 127485
  252. * Fri Jun 20 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-46
  253. - add at-3.1.8-atrun.8-typo-97697.patch to fix typo in atrun.8 (#97697)
  254. - update at.1 description of shell behaviour (#91233)
  255. * Tue Jun 17 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-45
  256. - make the job shell default to SHELL instead of "/bin/sh" (#91233)
  257. * Tue Jun 3 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-43
  258. - Replace redundant at-3.1.7-paths.patch by at-3.1.8-man-timespec-path.patch
  259. to fix timespec path
  260. * Tue Jun 3 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-41
  261. - update source to at_3.1.8-11 from debian upstream
  262. - update source url
  263. - at-debian.patch no longer needed
  264. - at-3.1.7-paths.patch: the patch to "at.1.in" no longer needed
  265. - replace at-3.1.8-lexer.patch with at-3.1.8-11-lexer-parser.diff
  266. - at-3.1.8-dst.patch no longer needed
  267. - at-3.1.8-lsbdoc.patch no longer needed
  268. - at-3.1.8-o_excl.patch no longer needed
  269. - bump release number
  270. - added Japanese summary and description from vinedocs.sf.jp :)
  271. - rebuild with new toolchains
  272. * Wed Jan 23 2002 Toru Sagami <sagami@vinelinux.org> 3.1.8-23vl1
  273. - follow 3.1.8-23 (RHSA-2002:015-13)
  274. - apply docpath patch instead of patch16 (due to brute-force patch2 unrevised)
  275. - Replace sendmail with /usr/sbin/sendmail (postfix) for BuildPreReq
  276. * Sat Jun 09 2001 <sagami@vinelinux.org>
  277. - 3.1.8-12vl3: rebuilt for %%{_mandir}
  278. * Tue Dec 12 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.8-12vl2
  279. - remove /etc/init.d from PreReq
  280. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 3.1.8-12vl1
  281. - build on Vine Linux with gcc-2.95.3
  282. * Wed Aug 23 2000 Crutcher Dunnavant <crutcher@redhat.com>
  283. - Well, we will likely never really close the UTC issues,
  284. - because of 1) fractional timezones, and 2) daylight savigns time.
  285. - but there is a slight tweak to the handling of dst in the UTC patch.
  286. * Wed Aug 23 2000 Crutcher Dunnavant <crutcher@redhat.com>
  287. - fixed bug #15685
  288. - which had at miscaluclating UTC times.
  289. * Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
  290. - move initscript back
  291. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  292. - automatic rebuild
  293. * Thu Jul 6 2000 Bill Nottingham <notting@redhat.com>
  294. - prereq /etc/init.d
  295. * Sat Jul 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  296. - fix syntax error in init script
  297. * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
  298. - don't prereq, only require initscripts
  299. * Mon Jun 26 2000 Preston Brown <pbrown@redhat.com>
  300. - move init script
  301. - add condrestart directive
  302. - fix post/preun/postun scripts
  303. - prereq initscripts >= 5.20
  304. * Sat Jun 17 2000 Bill Nottingham <notting@redhat.com>
  305. - fix verify of /var/spool/at/.SEQ (#12262)
  306. * Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
  307. - fix status checking and syntax error in init script
  308. * Fri Jun 9 2000 Bill Nottingham <notting@redhat.com>
  309. - fix for long usernames (#11321)
  310. - add some bugfixes from debian
  311. * Mon May 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  312. - 3.1.8
  313. * Wed Mar 1 2000 Bill Nottingham <notting@redhat.com>
  314. - fix a couple of more typos, null-terminate some strings
  315. * Thu Feb 10 2000 Bill Nottingham <notting@redhat.com>
  316. - fix many-years-old typo in atd.c
  317. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  318. - handle compressed man pages
  319. * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
  320. - initscript munging, build as non-root user
  321. * Sun Jun 13 1999 Jeff Johnson <jbj@redhat.com>
  322. - correct perms for /var/spool/at after defattr.
  323. * Mon May 24 1999 Jeff Johnson <jbj@redhat.com>
  324. - reset SIGCHLD before exec (#3016).
  325. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  326. - auto rebuild in the new build environment (release 8)
  327. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  328. - fix handling the 12:00 time
  329. * Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
  330. - configure fix for arm
  331. * Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
  332. - build for glibc 2.1
  333. * Tue May 05 1998 Prospector System <bugs@redhat.com>
  334. - translations modified for de, fr, tr
  335. * Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
  336. - enhanced initscript
  337. * Sun Nov 09 1997 Michael K. Johnson <johnsonm@redhat.com>
  338. - learned to spell
  339. * Wed Oct 22 1997 Michael K. Johnson <johnsonm@redhat.com>
  340. - updated to at version 3.1.7
  341. - updated lock and sequence file handling with %ghost
  342. - Use chkconfig and atd, now conflicts with old crontabs packages
  343. * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
  344. - built against glibc