perl-Net-SSLeay-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181
  1. %define real_name Net-SSLeay
  2. Summary: Perl module for using OpenSSL via Network
  3. Summary(ja): OpenSSL を Network にて用いる為の perl モジュール
  4. Name: perl-Net-SSLeay
  5. Version: 1.64
  6. Release: 1%{?_dist_release}
  7. License: BSDish
  8. Group: Development/Libraries
  9. Source0: ftp://ftp.cpan.org/pub/CPAN/modules/by-module/Net/%{real_name}-%{version}.tar.gz
  10. Source1: COPYRIGHT.SSLeay-0.9.0
  11. BuildRequires: perl, openssl-devel >= 0.9.6b
  12. BuildRequires: zlib-devel
  13. Requires: perl, openssl >= 0.9.6b
  14. Buildroot: %{_tmppath}/%{name}-%{version}-root
  15. Obsoletes: perl-Net_SSLeay < 1.64
  16. Provides: perl-Net_SSLeay
  17. %description
  18. Perl module for using OpenSSL via Network, Net::SSLeay.
  19. %description -l ja
  20. OpenSSL を Network にて用いる為の perl モジュール, Net::SSLeay
  21. %prep
  22. %setup -q -n %{real_name}-%{version}
  23. cp -p %{SOURCE1} .
  24. # openssl_path is /usr here, therefore don't -I/usr/include and
  25. # especially don't (badly) hardcode standard library search path
  26. # /usr/lib
  27. if [[ "%{_prefix}" = "/usr" ]]; then
  28. perl -pi -e "s@-[LI]\\\$openssl_path[^\s\"]*@@g" Makefile.PL INSTALLDIRS=vendor
  29. fi
  30. %build
  31. # note the %{_prefix} which must passed to Makefile.PL, weird but necessary :-(
  32. perl Makefile.PL %{_prefix} INSTALLDIRS=vendor << EOI
  33. n
  34. EOI
  35. make OPTIMIZE="$RPM_OPT_FLAGS" PREFIX=%{_prefix}
  36. perl -p -i -e 's|/usr/local/bin|/usr/bin|g;' *.pm examples/*
  37. %install
  38. rm -rf %{buildroot}
  39. #mkdir -p %{buildroot}%{perl_archlib}
  40. #make install PREFIX=%{buildroot}%{_prefix} \
  41. # SITEPREFIX=%{buildroot}%{_prefix} \
  42. # VENDORPREFIX=%{buildroot}%{_prefix} \
  43. # INSTALLPRIVLIB=%{buildroot}%{perl_privlib} \
  44. # INSTALLSITELIB=%{buildroot}%{perl_sitelib} \
  45. # INSTALLVENDORLIB=%{buildroot}%{perl_vendorlib} \
  46. # INSTALLARCHLIB=%{buildroot}%{perl_archlib} \
  47. # INSTALLSITEARCH=%{buildroot}%{perl_sitearch} \
  48. # INSTALLVENDORARCH=%{buildroot}%{perl_vendorarch} \
  49. # INSTALLBIN=%{buildroot}%{_bindir} \
  50. # INSTALLSITEBIN=%{buildroot}%{_bindir} \
  51. # INSTALLVENDORBIN=%{buildroot}%{_bindir} \
  52. # INSTALLSCRIPT=%{buildroot}%{_bindir} \
  53. # INSTALLMAN1DIR=%{buildroot}%{_mandir}/man1 \
  54. # INSTALLSITEMAN1DIR=%{buildroot}%{_mandir}/man1 \
  55. # INSTALLVENDORMAN1DIR=%{buildroot}%{_mandir}/man1 \
  56. # INSTALLMAN3DIR=%{buildroot}%{_mandir}/man3 \
  57. # INSTALLSITEMAN3DIR=%{buildroot}%{_mandir}/man3 \
  58. # INSTALLVENDORMAN3DIR=%{buildroot}%{_mandir}/man3
  59. make install DESTDIR=%{buildroot}
  60. sed -e "s@^%{buildroot}@@g" < %{buildroot}/%{perl_vendorarch}/auto/Net/SSLeay/.packlist > .packlist
  61. mv -f .packlist %{buildroot}/%{perl_vendorarch}/auto/Net/SSLeay/.packlist
  62. #if [ -f %{buildroot}%{perl_archlib}/perllocal.pod ] ; then
  63. # mv %{buildroot}%{perl_archlib}/perllocal.pod .
  64. #else
  65. # touch perllocal.pod
  66. #fi
  67. perllocalfile=`find %{buildroot} -name perllocal.pod`
  68. echo "mv $perllocalfile ."
  69. mv $perllocalfile .
  70. {
  71. find %{buildroot} \
  72. -type f -o -type l | sed -e "s@^%{buildroot}@@g" -e 's@^\(.*/man/.*\)$@\1*@g'
  73. } > %{name}.files
  74. %clean
  75. rm -rf %{buildroot}
  76. #check
  77. #make test
  78. %files -f %{name}.files
  79. %defattr(-,root,root)
  80. %doc Changes Credits QuickRef README COPYRIGHT.SSLeay-0.9.0 perllocal.pod
  81. #%dir %{perl_vendorarch}/auto/Net
  82. #%dir %{perl_vendorarch}/auto/Net/SSLeay
  83. #%dir %{perl_vendorarch}/Net
  84. #%dir %{perl_vendorarch}/Net/SSLeay
  85. %changelog
  86. * Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.64-1
  87. - new upstream release.
  88. - renamed from "perl-Net_SSLeay".
  89. - added "Obsoletes: perl-Net_SSLeay" and "Provides: perl-Net_SSLeay".
  90. * Sun Feb 26 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.42-1
  91. - new upstream release
  92. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36-2
  93. - rebuild with perl-5.12.3
  94. * Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36-1
  95. - new upstream release
  96. - change BuildRequires: openssl-devel instead of openssl
  97. - add BuildRequires: zlib-devel
  98. * Wed Jul 8 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.35-1
  99. - new upstream release
  100. * Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.30-2
  101. - spec in utf-8
  102. * Tue Apr 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-1
  103. - rebuilt with perl-5.10.0
  104. - applied new versioning policy
  105. * Sun Jun 3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-0vl2
  106. - rebuilt with openssl-0.9.8e
  107. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-0vl1
  108. - updated to 1.30
  109. * Sat Sep 9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.25-0vl4
  110. - installed files to vendor_perl
  111. - changed Group to Development/Libraries
  112. * Mon Nov 29 2004 IWAI, Masaharu <iwai@alib.jp> 1.25-0vl3
  113. - build on perl-5.8.6-0vl1
  114. * Wed Dec 10 2003 IWAI, Masaharu <iwai@alib.jp> 1.25-0vl2
  115. - build with perl-5.8.2
  116. - add %%{perl_sitearch}/{Net,Net/SSLeay} directories in %%files
  117. * Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.25-0vl1
  118. - new upstream version
  119. - built on perl-5.8.1
  120. * Thu May 08 2003 Tomoya TAKA <taka@vinelinux.org> 1.22-0vl5
  121. - fixed install man dir, again
  122. * Tue May 06 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl4
  123. - fixed install dir of perllocal.pod
  124. * Mon May 05 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl3
  125. - fixed install man dir
  126. * Thu May 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl2
  127. - comment out "make test"
  128. * Thu May 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl1
  129. - updated to 1.22
  130. * Fri Feb 15 2002 Toru Sagami <sagami@vinelinux.org> 1.13-0vl1
  131. - updated to 1.13
  132. - BuildPreReq/Requires: perl, openssl-0.9.6b
  133. - rewrite a better spec with License/Group
  134. * Mon Jul 16 2001 <sagami@vinelinux.org>
  135. - 1.07-0vl3: rebuilt with openssl-0.9.6b
  136. - erase unneeeded files from %%doc
  137. - use _prefix, not prefix
  138. * Thu Jul 05 2001 <sagami@vinelinux.org>
  139. - 1.07-0vl2: built with perl-5.6.1
  140. * Thu Jun 7 2001 Yasuhide OMORI <omori@m-t.com>
  141. - 1.07
  142. * Fri Sep 1 2000 Yoshishiro Kajiki <kajiki@ylug.org>
  143. - first version of rpm.