incron-vl.spec 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157
  1. Summary: Inotify cron system
  2. Name: incron
  3. Version: 0.5.12
  4. Release: 4%{?_dist_release}
  5. Group: System Environment/Base
  6. License: GPLv2
  7. URL: https://github.com/ar-/incron
  8. Source0: https://github.com/ar-/incron/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
  9. Source1: incrond.init
  10. Patch0: incron-0.5.10-gcc.patch
  11. Patch1: incron-0.5.12-prevent-zombies.patch
  12. # https://github.com/ar-/incron/pull/45/commits/134900ea1dd19834ba6e6c7e7e07611a0e0d78a0
  13. Patch2: incron-fix-segv-on-mkdir.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  15. Requires(post): /sbin/chkconfig
  16. Requires(preun): /sbin/chkconfig, /sbin/service
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: tomop
  20. %description
  21. This program is an "inotify cron" system.
  22. It consists of a daemon and a table manipulator.
  23. You can use it a similar way as the regular cron.
  24. The difference is that the inotify cron handles
  25. filesystem events rather than time periods.
  26. %prep
  27. %setup -q
  28. %patch0 -p1 -b .gcc
  29. %patch1 -p1 -b .zombie
  30. %patch2 -p1 -b .mkdir
  31. %build
  32. make %{?_smp_mflags} CXXFLAGS="%{optflags}"
  33. %install
  34. rm -rf %{buildroot}
  35. #install files manually since source Makefile tries to do it as root
  36. install -D -p incrond %{buildroot}%{_sbindir}/incrond
  37. install -D -p -m 4755 incrontab %{buildroot}%{_bindir}/incrontab
  38. install -d %{buildroot}%{_localstatedir}/spool/%{name}
  39. install -d %{buildroot}%{_sysconfdir}/%{name}.d
  40. install -D -p -m 0755 %{SOURCE1} %{buildroot}%{_initdir}/incrond
  41. install -D -p -m 0644 incron.conf.example %{buildroot}%{_sysconfdir}/%{name}.conf
  42. # install manpages
  43. make install-man MANPATH="%{buildroot}%{_mandir}" INSTALL="install -D -p"
  44. %post
  45. if [ $1 -eq 1 ]; then
  46. /sbin/chkconfig --add incrond
  47. fi
  48. %preun
  49. if [ $1 -eq 0 ]; then
  50. /sbin/service %{name} stop >/dev/null 2>&1 || :
  51. /sbin/chkconfig --del incrond
  52. fi
  53. %postun
  54. if [ $1 -ge 1 ]; then
  55. /sbin/service incrond condrestart >/dev/null 2>&1 || :
  56. fi
  57. %clean
  58. rm -rf %{buildroot}
  59. %files
  60. %defattr(-,root,root,-)
  61. %license COPYING LICENSE*
  62. %doc CHANGELOG README TODO
  63. %attr(4755,root,root) %{_bindir}/incrontab
  64. %{_sbindir}/incrond
  65. %{_initdir}/incrond
  66. %config(noreplace) %{_sysconfdir}/%{name}.conf
  67. %{_mandir}/man1/incrontab.1.gz
  68. %{_mandir}/man5/incrontab.5.gz
  69. %{_mandir}/man5/incron.conf.5.gz
  70. %{_mandir}/man8/incrond.8.gz
  71. %dir %{_localstatedir}/spool/%{name}
  72. %dir %{_sysconfdir}/%{name}.d
  73. %changelog
  74. * Mon Dec 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.12-4
  75. - imported Patch2.
  76. * Mon Nov 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.12-3
  77. - replaced Patch1.
  78. * Sat Jul 9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.12-2
  79. - added Patch1.
  80. * Thu Jul 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.12-1
  81. - new upstream release.
  82. * Sun Jan 12 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.10-2
  83. - rebuilt with current environment.
  84. * Fri May 04 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.10-1
  85. - new upstream release.
  86. - built for Vine Linux.
  87. * Thu Feb 16 2012 Jon Ciesla <limburgher@gmail.com> - 0.5.9-4
  88. - Migrate to systemd, BZ 789688.
  89. - gcc47 patch.
  90. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.9-3
  91. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  92. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.9-2
  93. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  94. * Mon Dec 21 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> 0.5.9-1
  95. - Upstream released new version
  96. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.8-2
  97. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  98. * Wed Feb 25 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> 0.5.8-1
  99. - Upstream released new version
  100. - GCC 4.4 fixes
  101. - Drop GCC 4.3 patch, fixed upstream
  102. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.7-2
  103. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  104. * Sat Feb 09 2008 Ruben Kerkhof <ruben@rubenkerkhof.com> - 0.5.7-1
  105. - Sync with upstream
  106. * Tue Mar 13 2007 <ruben@rubenkerkhof.com> 0.5.5-1
  107. - Sync with upstream
  108. * Mon Feb 12 2007 <ruben@rubenkerkhof.com> 0.5.4-1
  109. - Update to new upstream version
  110. - Upstream fixed permissions on pidfile
  111. - New manpage for incron.conf
  112. - Upstream fixed example conf file
  113. * Sun Feb 04 2007 <ruben@rubenkerkhof.com> 0.5.1-1
  114. - Updated to new upstream version
  115. - Upstream fixed the incorrect encoding of the LICENSE-GPL file
  116. * Sat Jan 27 2007 <ruben@rubenkerkhof.com> 0.5.0-1
  117. - Updated to new upstream version
  118. - Changed the service name in the scriptlets
  119. - Added a configuration file
  120. - Included GPL License
  121. * Sat Jan 27 2007 <ruben@rubenkerkhof.com> 0.4.0-1
  122. - First try at packaging it up