123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548 |
- # Copyright (c) 2000-2005, JPackage Project
- # All rights reserved.
- #
- # Redistribution and use in source and binary forms, with or without
- # modification, are permitted provided that the following conditions
- # are met:
- #
- # 1. Redistributions of source code must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- # 2. Redistributions in binary form must reproduce the above copyright
- # notice, this list of conditions and the following disclaimer in the
- # documentation and/or other materials provided with the
- # distribution.
- # 3. Neither the name of the JPackage Project nor the names of its
- # contributors may be used to endorse or promote products derived
- # from this software without specific prior written permission.
- #
- # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
- # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
- # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
- # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
- # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
- # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
- # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
- # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
- # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
- # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- #
- %define section free
- %define cvs_version 2_7_1
- Name: xalan-j2
- Summary: Java XSLT processor
- Summary(ja): Java XSLT プロセッサ
- Version: 2.7.1
- Release: 4%{?_dist_release}
- Group: Development/Libraries
- # src/org/apache/xpath/domapi/XPathStylesheetDOM3Exception.java is W3C
- License: ASL 2.0 and W3C
- URL: http://xalan.apache.org/
- # using binary for bootstrap
- Source0: http://archive.apache.org/dist/xml/xalan-j/xalan-j_2_7_1-src.tar.gz
- Source1: %{name}-serializer-MANIFEST.MF
- Source2: http://repo1.maven.org/maven2/xalan/xalan/2.7.1/xalan-2.7.1.pom
- Source3: http://repo1.maven.org/maven2/xalan/serializer/2.7.1/serializer-2.7.1.pom
- Source4: xsltc-%{version}.pom
- Source5: %{name}-MANIFEST.MF
- Patch0: %{name}-noxsltcdeps.patch
- # Fix CVE-2014-0107: insufficient constraints in secure processing
- # feature (oCERT-2014-002). Generated form upstream revisions 1581058
- # and 1581426.
- Patch2: %{name}-CVE-2014-0107.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildArch: noarch
- BuildRequires: javapackages-tools
- BuildRequires: java-devel
- BuildRequires: ant
- BuildRequires: bcel
- BuildRequires: java_cup
- BuildRequires: regexp
- BuildRequires: sed
- #BuildRequires: tomcat-servlet-3.1-api
- BuildRequires: xerces-j2 >= 2.7.1
- BuildRequires: xml-commons-apis >= 1.3
- BuildRequires: xml-stylebook
- BuildRequires: zip
- Requires: xerces-j2
- Requires(post): /sbin/update-alternatives
- Requires(preun): /sbin/update-alternatives
- Provides: jaxp_transform_impl
- %description
- Xalan is an XSLT processor for transforming XML documents into HTML,
- text, or other XML document types. It implements the W3C Recommendations
- for XSL Transformations (XSLT) and the XML Path Language (XPath). It can
- be used from the command line, in an applet or a servlet, or as a module
- in other program.
- %package xsltc
- Summary: XSLT compiler
- Summary(ja): XSLT コンパイラ
- Group: Development/Libraries
- Requires: java_cup
- Requires: bcel
- Requires: regexp
- Requires: xerces-j2
- %description xsltc
- The XSLT Compiler is a Java-based tool for compiling XSLT stylesheets into
- lightweight and portable Java byte codes called translets.
- %package manual
- Summary: Manual for %{name}
- Group: Documentation
- %description manual
- Documentation for %{name}.
- %package javadoc
- Summary: Javadoc for %{name}
- Group: Documentation
- BuildRequires: java-javadoc
- %description javadoc
- Javadoc for %{name}.
- %package demo
- Summary: Demo for %{name}
- Requires: %{name} = %{epoch}:%{version}-%{release}
- #Requires: tomcat-servlet-3.1-api
- %description demo
- Demonstrations and samples for %{name}.
- %prep
- %setup -q -n xalan-j_%{cvs_version}
- %patch0 -p0
- %patch2 -p1
- find . -name '*.jar' -delete
- find . -name '*.class' -delete
- # this tar.gz contains bundled software, some of which has unclear
- # licensing terms (W3C Software/Document license) . We could probably
- # replicate this with our jars but it's too much work so just generate
- # non-interlinked documentation
- rm src/*tar.gz
- sed -i '/<!-- Expand jaxp sources/,/<delete file="${xml-commons-srcs.tar}"/{d}' build.xml
- # Remove classpaths from manifests
- sed -i '/class-path/I d' $(find -iname '*manifest*')
- # Convert CR-LF to LF-only
- sed -i s/
// KEYS LICENSE.txt NOTICE.txt xdocs/style/resources/script.js \
- xdocs/sources/xsltc/README* `find -name '*.sh'`
- %build
- if [ ! -e "$JAVA_HOME" ] ; then export JAVA_HOME="%{java_home}" ; fi
- pushd lib
- ln -sf $(build-classpath java_cup-runtime) runtime.jar
- ln -sf $(build-classpath bcel) BCEL.jar
- ln -sf $(build-classpath regexp) regexp.jar
- ln -sf $(build-classpath xerces-j2) xercesImpl.jar
- ln -sf $(build-classpath xml-commons-apis) xml-apis.jar
- popd
- pushd tools
- ln -sf $(build-classpath java_cup) java_cup.jar
- ln -sf $(build-classpath ant) ant.jar
- ln -sf $(build-classpath xml-stylebook) stylebook-1.0-b3_xalan-2.jar
- popd
- export CLASSPATH=$(build-classpath servlet)
- ant \
- -Djava.awt.headless=true \
- -Dapi.j2se=%{_javadocdir}/java \
- -Dbuild.xalan-interpretive.jar=build/xalan-interpretive.jar \
- xalan-interpretive.jar\
- xsltc.unbundledjar \
- samples \
- docs
- # javadocs \
- # servlet
- %install
- rm -rf $RPM_BUILD_ROOT
- # inject OSGi manifests
- mkdir -p META-INF
- cp -p %{SOURCE1} META-INF/MANIFEST.MF
- touch META-INF/MANIFEST.MF
- zip -u build/serializer.jar META-INF/MANIFEST.MF
- cp -p %{SOURCE5} META-INF/MANIFEST.MF
- touch META-INF/MANIFEST.MF
- zip -u build/xalan-interpretive.jar META-INF/MANIFEST.MF
- # jars
- install -d -m 755 $RPM_BUILD_ROOT%{_javadir}
- install -p -m 644 build/xalan-interpretive.jar \
- $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
- install -p -m 644 build/xsltc.jar \
- $RPM_BUILD_ROOT%{_javadir}/xsltc.jar
- install -p -m 644 build/serializer.jar \
- $RPM_BUILD_ROOT%{_javadir}/%{name}-serializer.jar
- # POMs
- #install -d -m 755 $RPM_BUILD_ROOT%{_mavenpomdir}
- #install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_mavenpomdir}/JPP-%{name}.pom
- #install -p -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_mavenpomdir}/JPP-%{name}-serializer.pom
- #install -p -m 644 %{SOURCE4} $RPM_BUILD_ROOT%{_mavenpomdir}/JPP-xsltc.pom
- #add_maven_depmap JPP-%{name}.pom %{name}.jar
- #add_maven_depmap JPP-%{name}-serializer.pom %{name}-serializer.jar
- #add_maven_depmap -f xsltc JPP-xsltc.pom xsltc.jar
- # javadoc
- #install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}
- #cp -pr build/docs/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}
- #rm -rf build/docs/apidocs
- # demo
- install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/%{name}
- install -p -m 644 build/xalansamples.jar \
- $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}-samples.jar
- #install -p -m 644 build/xalanservlet.war \
- # $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}-servlet.war
- cp -pr samples $RPM_BUILD_ROOT%{_datadir}/%{name}
- # fix link between manual and javadoc
- (cd build/docs; ln -sf %{_javadocdir}/%{name} apidocs)
- # jaxp_transform_impl ghost symlink
- ln -s %{_sysconfdir}/alternatives \
- $RPM_BUILD_ROOT%{_javadir}/jaxp_transform_impl.jar
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post
- /sbin/update-alternatives \
- --install %{_javadir}/jaxp_transform_impl.jar \
- jaxp_transform_impl %{_javadir}/%{name}.jar 30
- %preun
- if [ $1 -eq 0 ] ; then
- /sbin/update-alternatives --remove jaxp_transform_impl %{_javadir}/%{name}.jar
- fi
- %post javadoc
- rm -f %{_javadocdir}/%{name}
- ln -s %{name}-%{version} %{_javadocdir}/%{name}
- %postun javadoc
- if [ "$1" = "0" ]; then
- rm -f %{_javadocdir}/%{name}
- fi
- %files
- %defattr(-,root,root,-)
- %doc KEYS readme.html
- %doc LICENSE.txt NOTICE.txt
- %{_javadir}/%{name}.jar
- %{_javadir}/%{name}-serializer.jar
- %ghost %{_javadir}/jaxp_transform_impl.jar
- %files xsltc
- %defattr(-,root,root,-)
- %doc LICENSE.txt NOTICE.txt
- %{_javadir}/xsltc.jar
- %files manual
- %defattr(-,root,root,-)
- %doc LICENSE.txt NOTICE.txt
- %doc build/docs/*
- #files javadoc
- #defattr(-,root,root,-)
- #doc LICENSE.txt NOTICE.txt
- #doc %{_javadocdir}/%{name}
- %files demo
- %defattr(-,root,root,-)
- %{_datadir}/%{name}
- %changelog
- * Fri Mar 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.7.1-4
- - rebuilt with current VineSeed
- * Sat Feb 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.7.1-3
- - rebuild with Vine6 environment
- * Mon Aug 30 2010 Ryoichic INAGAKI <ryo1@bc.wakwak.com> 2.7.1-2
- - Initial build for VineLinux
- - using binary package for bootstrap
- * Wed Apr 7 2010 Alexander Kurtakov <akurtako@redhat.com> 0:2.7.1-1
- - Update to 2.7.1.
- - Drop gcj_support.
- * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.0-9.5
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.0-8.5
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Tue Feb 3 2009 Alexander Kurtakov <akurtako@redhat.com> 0:2.7.0-7.5
- - Add osgi manifest.
- * Sat Sep 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0:2.7.0-7.4
- - fix license tag
- * Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:2.7.0-7.3
- - drop repotag
- - fix license tag
- * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:2.7.0-7jpp.2
- - Autorebuild for GCC 4.3
- * Fri Apr 20 2007 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-6jpp.2.fc7
- - Rebuild to fix incomplete .db/so files due to broken aot-compile-rpm
- * Fri Aug 18 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-6jpp.1
- - Resync with latest from JPP.
- * Fri Aug 11 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-5jpp.3
- - Rebuild.
- * Thu Aug 10 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-5jpp.2
- - Rebuild.
- * Thu Aug 10 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-5jpp.1
- - Resync with latest from JPP.
- - Partially adopt new naming convention (.1 suffix).
- - Use ln and rm explicitly instead of core-utils in Requires(x).
- * Thu Aug 10 2006 Karsten Hopp <karsten@redhat.de> 2.7.0-4jpp_5fc
- - Requires(post): coreutils
- * Wed Jul 26 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-4jpp_4fc
- - Extend patch to cover all applicable MANIFEST files in src directory.
- * Wed Jul 26 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-4jpp_3fc
- - Apply patch to replace serializer.jar in MANIFEST file with
- xalan-j2-serializer.jar.
- * Sat Jul 22 2006 Jakub Jelinek <jakub@redhat.com> - 0:2.7.0-4jpp_2fc
- - Rebuilt
- * Fri Jul 21 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-4jpp_1fc
- - Resync with latest JPP version.
- * Wed Jul 19 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-3jpp_1fc
- - Merge with latest version from jpp.
- - Undo ExcludeArch since eclipse available for all arch-es.
- - Remove jars from sources for new upstream version.
- - Purge unused patches from previous release.
- - Conditional native compilation with GCJ.
- - Use NVR macros wherever possible.
- * Wed Mar 8 2006 Rafael Schloming <rafaels@redhat.com> - 0:2.6.0-3jpp_10fc
- - excluded s390[x] and ppc64 due to eclipse
- * Mon Mar 6 2006 Jeremy Katz <katzj@redhat.com> - 0:2.6.0-3jpp_9fc
- - stop scriptlet spew
- * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.0-3jpp_8fc
- - bump again for double-long bug on ppc(64)
- * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.0-3jpp_7fc
- - rebuilt for new gcc4.1 snapshot and glibc changes
- * Wed Dec 21 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.0-3jpp_6fc
- - rebuild again
- * Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.0-3jpp_5fc.3
- - patch to not use target= in build.xml
- * Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.0-3jpp_5fc.1
- - rebuild again with gcc-4.1
- * Fri Dec 09 2005 Warren Togami <wtogami@redhat.com> 0:2.6.0-3jpp_5fc
- - rebuild with gcc-4.1
- * Tue Nov 1 2005 Archit Shah <ashah at redhat.com> 0:2.6.0-3jpp_4fc
- - Exclude war which blocks aot compilation of main jar (#171005).
- * Tue Jul 19 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp_3fc
- - Build on ia64, ppc64, s390 and s390x.
- - Switch to aot-compile-rpm (also BC-compiles xsltc and samples).
- * Tue Jun 28 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp_2fc
- - Remove a tarball from the tarball too.
- - Fix demo subpackage's dependencies.
- * Wed Jun 15 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp_1fc
- - Remove jarfiles from the tarball.
- * Fri May 27 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp
- - Add NOTICE file as per Apache License version 2.0.
- - Build with servletapi5.
- * Fri May 27 2005 Gary Benson <gbenson@redhat.com> 0:2.6.0-2jpp_3fc
- - Remove now-unnecessary workaround for #130162.
- - Rearrange how BC-compiled stuff is built and installed.
- * Tue May 24 2005 Gary Benson <gbenson@redhat.com> 0:2.6.0-2jpp_2fc
- - Add DOM3 stubs to classes that need them (#152255).
- - BC-compile the main jarfile.
- * Fri Apr 1 2005 Gary Benson <gbenson@redhat.com>
- - Add NOTICE file as per Apache License version 2.0.
- * Wed Jan 12 2005 Gary Benson <gbenson@redhat.com> 0:2.6.0-2jpp_1fc
- - Sync with RHAPS.
- * Mon Nov 15 2004 Fernando Nasser <fnasser@redhat.com> 0:2.6.0-2jpp_1rh
- - Merge with latest community release
- * Thu Nov 4 2004 Gary Benson <gbenson@redhat.com> 0:2.6.0-1jpp_2fc
- - Build into Fedora.
- * Thu Aug 26 2004 Ralph Apel <r.ape at r-apel.de> 0:2.6.0-2jpp
- - Build with ant-1.6.2
- - Try with -Djava.awt.headless=true
- * Mon Jul 26 2004 Fernando Nasser <fnasser@redhat.com> 0:2.6.0-1jpp_1rh
- - Merge with latest community version
- * Fri Mar 26 2004 Frank Ch. Eigler <fche@redhat.com> 0:2.5.2-1jpp_2rh
- - add RHUG upgrade cleanup
- * Tue Mar 23 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.0-1jpp
- - Updated to 2.6.0
- - Patches supplied by <aleksander.adamowski@altkom.pl>
- * Thu Mar 4 2004 Frank Ch. Eigler <fche@redhat.com> - 0:2.5.2-1jpp_1rh
- - RH vacuuming
- * Sat Nov 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.5.2-1jpp
- - Update to 2.5.2.
- - Re-enable javadocs, new style versionless symlink handling, crosslink
- with local J2SE javadocs.
- - Spec cleanups.
- * Sat Jun 7 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.5.1-1jpp
- - Update to 2.5.1.
- - Fix jpackage-utils version in BuildRequires, add xerces-j2.
- - Non-versioned javadoc symlinking.
- - Add one missing epoch.
- - Clean up manifests from Class-Path's and other stuff we don't include.
- - xsltc no longer provides a jaxp_transform_impl because of huge classpath
- and general unsuitablity for production-use, system-installed transformer.
- - Own (ghost) %%{_javadir}/jaxp_transform_impl.jar.
- - Remove alternatives in preun instead of postun.
- - Disable javadoc subpackage for now:
- <http://issues.apache.org/bugzilla/show_bug.cgi?id=20572>
- * Thu Mar 27 2003 Nicolas Mailhot <Nicolas.Mailhot@One2team.com> 0:2.5.0.d1-1jpp
- - For jpackage-utils 1.5
- * Wed Jan 22 2003 Ville Skyttä <ville.skytta at iki.fi> - 2.4.1-2jpp
- - bsf -> oldbsf.
- - Use non-versioned jar in alternative, don't remove it on upgrade.
- - Remove hardcoded packager tag.
- * Mon Nov 04 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.4.1-1jpp
- - 2.4.1
- * Tue Sep 10 2002 Ville Skyttä <ville.skytta at iki.fi> 2.4.0-1jpp
- - 2.4.0.
- * Thu Aug 22 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.4-0.D1.3jpp
- - corrected case for Group tag
- - fixed servlet classpath
- * Tue Aug 20 2002 Ville Skyttä <ville.skytta at iki.fi> 2.4-0.D1.2jpp
- - Remove xerces-j1 runtime dependency.
- - Add bcel, jlex, regexp to xsltc runtime requirements:
- <http://xml.apache.org/xalan-j/xsltc_usage.html>
- - Build with -Dbuild.compiler=modern (IBM 1.3.1) to avoid stylebook errors.
- - XSLTC now provides jaxp_transform_impl too.
- - Earlier changes by Henri, from unreleased 2.4-D1.1jpp:
- Mon Jul 15 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.4-D1.1jpp
- - 2.4D1
- - use the jlex 1.2.5-5jpp (patched by Xalan/XSLTC team) rpm
- - use the stylebook-1.0-b3_xalan-2.jar included in source file till it will
- be packaged in jpackage
- - use jaxp_parser_impl (possibly xerces-j2) instead of xerces-j1 for docs
- generation, since it's tuned for stylebook-1.0-b3_xalan-2.jar
- - build and provide xsltc in a separate rpm
- * Mon Jul 01 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.1-2jpp
- - provides jaxp_transform_impl
- - requires jaxp_parser_impl
- - stylebook already requires xml-commons-apis
- - jaxp_parser_impl already requires xml-commons-apis
- - use sed instead of bash 2.x extension in link area to make spec compatible with distro using bash 1.1x
- * Wed Jun 26 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.3.1-2jpp
- - fix built classpath (bsf, bcel are existing jpackage rpms),
- - add buildrequires for javacup and JLex
- * Wed May 08 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.1-1jpp
- - 2.3.1
- - vendor, distribution, group tags
- * Mon Mar 18 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.0-2jpp
- - generic servlet support
- * Wed Feb 20 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.0-1jpp
- - 2.3.0
- - no more compat jar
- * Sun Jan 27 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.0-2jpp
- - adaptation to new stylebook1.0b3 package
- - used source tarball
- - section macro
- * Fri Jan 18 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.0-1jpp
- - 2.2.0 final
- - versioned dir for javadoc
- - no dependencies for manual and javadoc packages
- - stricter dependency for compat and demo packages
- - fixed package confusion
- - adaptation for new servlet3 package
- - requires xerces-j1 instead of jaxp_parser
- - xml-apis jar now in required xml-commons-apis external package
- * Wed Dec 5 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D14-1jpp
- - 2.2.D14
- - javadoc into javadoc package
- - compat.jar into compat package
- - compat javadoc into compat-javadoc package
- * Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 2.2.D13-2jpp
- - changed extension to jpp
- - prefixed xml-apis
- * Tue Nov 20 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 2.2.D13-1jpp
- - 2.2.D13
- - removed packager tag
- * Sat Oct 6 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D11-1jpp
- - 2.2.D11
- * Sun Sep 30 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D10-2jpp
- - first unified release
- - s/jPackage/JPackage
- * Fri Sep 14 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D10-1mdk
- - cvs references
- - splitted demo package
- - moved demo files to %{_datadir}/%{name}
- - only manual package requires stylebook-1.0b3
- - only demo package requires servletapi3
- * Wed Aug 22 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D9-1mdk
- - 2.2.9
- - used new source packaging policy
- - added samples data
- * Wed Aug 08 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D6-1mdk
- - first Mandrake release
|