koffice-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483
  1. %define sourcedir stable/koffice-%{version}/src
  2. Name: koffice
  3. URL: http://koffice.kde.org/
  4. Summary: Integrated office suite for KDE
  5. Summary(ja): KDE 向け統合オフィススイート
  6. Version: 1.6.3
  7. Release: 4%{?_dist_release}
  8. Epoch: 1
  9. Group: Applications/Productivity
  10. License: GPL
  11. Source: ftp://ftp.kde.org/pub/kde/{sourcedir}/%{name}-%{version}.tar.bz2
  12. Source1: %{name}-l10n-ja-%{version}.tar.bz2
  13. Patch0: koffice-1.6.3-gcc43.patch
  14. Patch1: koffice-1.6.3-gcc44-elif.patch
  15. Patch2: koffice-1.6.3-gcc44-glibc210.patch
  16. # security fix
  17. Patch100: koffice-xpdf-CVE-2007-3387.diff
  18. Patch101: koffice-1.6.3-xpdf2-CVE-2007-4352-5392-5393.diff
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: qt-devel >= 3.3.2, kdelibs3-devel >= 3.3, arts-devel >= 1:1.3
  21. BuildRequires: aspell-devel >= 0.50.2, wv2-devel >= 0.1.8
  22. BuildRequires: libjpeg-turbo-devel libmng-devel libtiff-devel zlib-devel
  23. BuildRequires: libxml2-devel libxslt-devel freetype2-devel libart_lgpl-devel
  24. BuildRequires: jasper-devel doxygen ImageMagick-devel pkgconfig
  25. BuildRequires: libpng-devel libgsf-devel lcms-devel libexif-devel
  26. BuildRequires: MySQL-devel postgresql-devel
  27. BuildRequires: poppler-qt-devel
  28. BuildRequires: python-devel
  29. BuildRequires: libwpd-devel >= 0.8.0
  30. #if %{?_dist_release}
  31. #BuildConflicts: ruby-devel
  32. #else
  33. BuildRequires: libpqxx-devel libtool-ltdl-devel ruby-devel
  34. #endif
  35. Requires: qt >= 3.3.2, kdelibs3 >= 3.3, arts >= 1:1.3
  36. Requires: freetype2 libjpeg libtiff libmng libpng
  37. Requires: zlib audiofile libxml2 libxslt
  38. Requires: libart_lgpl aspell wv2
  39. Requires(post): kdelibs3
  40. Obsoletes: killustrator kivio
  41. %description
  42. KOffice is a collection of office applications linked together by a common
  43. basis. This common basis assures that all office application can work
  44. together. You can, for instance, insert a spreadsheet in your thesis without
  45. leaving your document. Editing the spreadsheet happens _inside_ your thesis.
  46. The applications currently included in KOffice are:
  47. - KWord (Professional text editing)
  48. - KSpread (Professional number cruncher/spreadsheet)
  49. - KPresenter (Professional presentation program)
  50. - KChart (Graphing of your abstract data)
  51. - Karbon (Vector graphics tool)
  52. - Kugar (Database report creation)
  53. - Kivio (Flowcharting program)
  54. - Kexi (a database management tool)
  55. - KOffice Workspace (A combination of all of the above)
  56. %prep
  57. %setup -q -n %{name}-%{version}
  58. %if %{?_dist_release} == "vl6"
  59. %patch0 -p1 -b .gcc43
  60. %patch1 -p1 -b .elif
  61. %patch2 -p3 -b .glibc210
  62. %endif
  63. %patch100 -p0 -b .CVE-2007-3387
  64. %patch101 -p0 -b .xpdf
  65. # for Python 2.6
  66. %if %{?_dist_release} == "vl6"
  67. sed -i -e 's|""2\.5""|""2\.6""|g' configure
  68. %endif
  69. %build
  70. #only for beta
  71. #make -f Makefile.cvs
  72. unset QTDIR || : ; . /etc/profile.d/qt.sh
  73. export KDEDIR=%{_prefix}
  74. ./configure --prefix=%{_prefix} \
  75. --includedir=%{_includedir}/kde \
  76. --with-qt-libraries=$QTDIR/lib \
  77. --disable-rpath --disable-dependency-tracking \
  78. --enable-new-ldflags \
  79. --disable-debug --disable-warnings \
  80. --with-pic --enable-shared --disable-static \
  81. --with-extra-libs=%{_libdir} \
  82. --with-pgsqllibdir=%{_libdir} --with-pgsqlincdir=%{_includedir} \
  83. --with-pqxxlibdir=%{_libdir} --with-pqxxincdir=%{_includedir} \
  84. --disable-final
  85. make %{?_smp_mflags}
  86. tar xjf %{SOURCE1}
  87. cd %{name}-l10n-ja-%{version}
  88. ./configure --prefix=%{_prefix}
  89. make %{?_smp_mflags}
  90. %install
  91. rm -rf $RPM_BUILD_ROOT
  92. make RUN_KAPPFINDER=no DESTDIR=$RPM_BUILD_ROOT install
  93. # Drop -x
  94. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/kross/python/kexiapp/*
  95. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/copycenter/*
  96. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/exportxhtml/*
  97. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/importxhtml/*
  98. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/projectdocumentor/*
  99. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/changecs/*
  100. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/filterstest/*
  101. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/invertpython/*
  102. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/invertruby/*
  103. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/randompaint/*
  104. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/reshapehisto/*
  105. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/torturefilters/*
  106. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/torturepainting/*
  107. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kross/python/*.py
  108. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kross/python/RestrictedPython/*.py
  109. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kspread/scripts/exporthtml/*
  110. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kspread/scripts/scripteditor/*
  111. # Replace absolute symlinks with relative ones
  112. pushd $RPM_BUILD_ROOT%{_prefix}/share/doc/HTML/en
  113. for i in *; do
  114. if [ -d $i -a -L $i/common ]; then
  115. rm -f $RPM_BUILD_ROOT%{_prefix}/share/doc/HTML/en/$i/common
  116. ln -s ../common $RPM_BUILD_ROOT%{_prefix}/share/doc/HTML/en/$i
  117. fi
  118. done
  119. popd
  120. cd %{name}-l10n-ja-%{version}
  121. make DESTDIR=$RPM_BUILD_ROOT install
  122. rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/pl
  123. %clean
  124. rm -rf $RPM_BUILD_ROOT
  125. %post
  126. /sbin/ldconfig
  127. kbuildsycoca &>/dev/null || :
  128. %postun -p /sbin/ldconfig
  129. %files
  130. %defattr(-,root,root)
  131. %doc AUTHORS COPYING INSTALL README
  132. %doc %{_datadir}/doc/HTML/en/*
  133. %{_bindir}/*
  134. %{_includedir}/kde/*
  135. %{_libdir}/*
  136. %{_datadir}/applications
  137. %{_datadir}/applnk
  138. %{_datadir}/apps
  139. %config %{_datadir}/config
  140. %{_datadir}/config.kcfg
  141. %{_datadir}/icons
  142. %{_datadir}/locale/ja/LC_MESSAGES/*
  143. %{_datadir}/mimelnk
  144. %{_datadir}/services
  145. %{_datadir}/servicetypes
  146. %{_datadir}/templates
  147. %changelog
  148. * Sun Oct 3 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-4
  149. - rebuilt with ImageMagick-6.6.4.8
  150. * Tue May 4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-3
  151. - rebuilt with new toolchain and ImageMagick-6.6.1.5
  152. - fixed configure for building with python-2.6
  153. - added Patch0-2 for building new toolchain
  154. (Gentoo#228839, Debian#504870, Gentoo#270960)
  155. * Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.3-2
  156. - added libtiff(-devel) to dependency.
  157. - rebuilt with MySQL-5.1.34.
  158. * Sat May 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-1
  159. - applied new versioning policy
  160. - spec in UTF-8
  161. * Mon Nov 12 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl6
  162. - rebuild for VineSeed
  163. * Mon Nov 12 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl5
  164. - add Patch1 (CVE-2007-4352, 5392, 5393)
  165. * Thu Aug 2 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl4
  166. - add Patch0 (CVE-2007-3387)
  167. * Sat Jul 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.6.3-0vl3
  168. - added --with-qt-libraries configure option
  169. * Thu Jun 28 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl2
  170. - rebuild for VineSeed
  171. * Wed Jun 27 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl1
  172. - new upstream release
  173. * Tue Oct 10 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.0-0vl1
  174. - new upstream release
  175. * Mon Sep 11 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.91-0vl1
  176. - new upstream release
  177. * Mon Jul 10 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl2
  178. - rebuild for VineSeed
  179. * Mon Jul 10 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl1
  180. - new upstream release
  181. - drop obsolete patches
  182. * Mon May 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl2
  183. - rebuild for VineSeed
  184. * Mon May 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl1
  185. - new upstream release
  186. - drop obsolete patches
  187. - add BuildPrereq: libexif-devel
  188. - add --disable-final to configure option
  189. - add Patch0 and Patch1
  190. * Tue Apr 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl3
  191. - build with ruby-1.8.4-0vl1 on VineSeed
  192. - add Buildprereq: ruby-devel for VineSeed
  193. * Thu Apr 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl2
  194. - rebuild for VineSeed
  195. * Thu Apr 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl1
  196. - new upstream release
  197. - drop Patch1
  198. * Fri Mar 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl0.rc1
  199. - new upstream release
  200. - drop Patch0
  201. - add --disable-pie and --includedir=%%{_includedir}/kde to configure option
  202. - add BuildConflicts: ruby-devel
  203. - add Patch1
  204. - update %%files
  205. * Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl4
  206. - rebuild with libgsf-1.14.0-0vl1
  207. - add Japanese summary
  208. * Thu Jan 5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl3
  209. - add Patch0 (CAN-2005-3193)
  210. * Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl2
  211. - rebuild with libgsf-1.13.3-0vl1 and python-2.4.2-0vl4
  212. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl1
  213. - new upstream release
  214. - remove all patches
  215. - add SOURCE1 from snapshot
  216. * Mon Sep 26 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl2
  217. - add Patch0 - Patch8 to build with qt-3.3.5
  218. - add BuildPrereq: libtool-ltdl-devel
  219. * Thu Jul 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl1
  220. - new upstream release
  221. * Thu Jul 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0a-0vl1
  222. - new upstream release
  223. - remove i18n files
  224. - add BuildPrereq: automake17
  225. - add --disable-rpath to configure option
  226. * Tue Apr 26 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.91-0vl1
  227. - new upstream release
  228. - remove all patches
  229. - add BuildPrereq: lcms-devel MySQL-devel postgresql-devel libpqxx-devel
  230. - change Group to Applications/Productivity
  231. - update Summary and description
  232. * Mon Mar 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl8
  233. - rebuild with KDE-3.4.0 (VineSeed)
  234. * Mon Mar 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl7
  235. - rebuild with KDE-3.4.0 (Vine3.1)
  236. - clean up changelog to use (double-percent) everywhere
  237. * Sat Jan 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl6
  238. - rebuild for VineSeed
  239. * Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl5
  240. - add Patch1 (CAN-2005-0064)
  241. * Fri Jan 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl4
  242. - rebuild for VineSeed
  243. * Fri Jan 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl3
  244. - add patch0 (http://www.koffice.org/security/2004_xpdf_integer_overflow_2.php)
  245. * Sun Jan 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl2
  246. - rebuild for VineSeed
  247. * Sun Jan 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl1
  248. - new upstream release
  249. - remove about ia64
  250. - remove patch0
  251. * Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.4-0vl1
  252. - source upgrade
  253. - add Patch0 (security patch)
  254. * Thu Aug 12 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.2-0vl1
  255. - source upgrade
  256. - remove lines about vine26
  257. - add BuildPrereq: libgsf-devel
  258. * Thu May 6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.1-0vl1
  259. - source upgrade
  260. * Sat May 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl3
  261. - rebuild with kde-3.2.2
  262. * Wed Mar 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl2
  263. - rebuild with kde-3.2.1
  264. * Wed Jan 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl1
  265. - source upgrade
  266. * Mon Dec 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.95-0vl1
  267. - source upgrade
  268. - add BuildPrereq: jasper-devel doxygen ImageMagick-devel pkgconfig
  269. * Mon Sep 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.93-0vl1
  270. - source upgrade
  271. * Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.92-0vl2
  272. - rebuild with kdelibs-3.1.4 and gcc-3.2.3
  273. * Fri Aug 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.92-0vl1
  274. - source upgrade
  275. - BuildPrereq: wv2-devel >= 0.1.8 and add Requires: wv2
  276. * Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.91-0vl1
  277. - source upgrade
  278. - built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
  279. - change spec to build with gcc295
  280. - remove patch
  281. - add BuildPrereq: aspell-devel >= 0.50.2 and Requires: aspell
  282. - add BuildPrereq: wv2-devel
  283. * Mon May 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl4
  284. - rebuild with kdelibs-3.1.2
  285. * Thu Apr 4 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl3
  286. - rebuild with kdelibs-3.1.1
  287. * Sat Feb 8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl2
  288. - add patch
  289. * Fri Feb 7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl1
  290. - source upgrade
  291. - change spec to build both VineSeed and Vine2.5/2.6
  292. * Wed Oct 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2-0vl3
  293. - objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
  294. * Wed Oct 9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2-0vl2
  295. - rebuild with qt-3.0.5-0vl1
  296. - BuildPrereq: autoconf253
  297. * Mon Sep 23 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2-0vl1
  298. - source upgrade
  299. - no file conflicts from other package (maybe)
  300. - add BuildPrereq: objprelink2 instead of objprelink (obsolete)
  301. - add BuildPrereq: libart_lgpl-devel and Requires: libart_lgpl
  302. - add %%doc section
  303. * Fri Jul 5 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1.1-1vl3
  304. - add koffice-i18n-ja-1.1.1
  305. * Thu May 2 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1.1-1vl2
  306. - source upgrade to 1.1.1
  307. - delete some .desktop files (they conflict files from kdelibs)
  308. * Sun Mar 31 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1.1-1vl1
  309. - merged with rawhide 1.1-0.cvs20010725.1
  310. - source update to cvs-20020329
  311. - add BuildPrereq: autoconf252 automake15
  312. - add Epoch:1
  313. - There is Vine's previous changes, hacked for Vine
  314. -- Wed Dec 5 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1-6vl1
  315. - Delete Epoch
  316. - Change BuildRequires and Requires
  317. - Build for VineSeed
  318. * Wed Jul 25 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.1-0.cvs20010725.1
  319. - Increase Epoch
  320. * Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.1-0.cvs20010724.1
  321. - Don't build kivio on ia64 ATM (compiler bug)
  322. * Tue Feb 20 2001 Than Ngo <than@redhat.com>
  323. - update 2.1
  324. - fix dangling symlinks
  325. * Fri Feb 2 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  326. - Add ldconfig in %%post and %%postun, replace absolute symlinks
  327. with relative symlinks (#24878)
  328. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  329. - Update
  330. * Thu Jan 11 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  331. - Update
  332. - Don't build on sparc and ia64 (Bug #23809)
  333. * Sun Dec 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  334. - 2.0.1
  335. * Fri Nov 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  336. - Update to KDE_2_0_BRANCH
  337. * Mon Oct 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  338. - 2.0 final
  339. * Tue Oct 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  340. - 2.0
  341. * Mon Oct 2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  342. - new CVS
  343. - fix compilation
  344. * Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  345. - kill dupes from kdelibs
  346. * Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  347. - 1.93
  348. * Sun Aug 6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  349. - update (fixed compilation with gcc 2.96 in CVS)
  350. - work around compiler bugs on alpha
  351. * Fri Aug 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  352. - new snapshot
  353. - move to /usr/lib/kde2
  354. * Thu Jul 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  355. - rebuild
  356. * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  357. - new snapshot
  358. * Sun Jul 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  359. - new snapshot, new Qt
  360. * Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  361. - Don't hardcode Qt version
  362. - obsolete killustrator (powertools 6.x)
  363. - SMPify
  364. * Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  365. - use gcc 2.96
  366. - new snapshot
  367. * Mon Jul 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  368. - use kernelcc
  369. - new snapshot
  370. * Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  371. - new snapshot
  372. - ExcludeArch ia64
  373. * Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  374. - new snapshot
  375. - move it to /usr, where it belongs
  376. * Sat Oct 23 1999 Bernhard Rosenkraenzer <bero@redhat.de>
  377. - Initial RPM