OpenIPMI-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430
  1. # TODO: uses private copy of libedit, should be modified to use system one
  2. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. Summary: IPMI (Intelligent Platform Management Interface) library and tools
  4. Summary(ja): IPMI (Intelligent Platform Management Interface) ライブラリおよびツール
  5. Name: OpenIPMI
  6. Version: 2.0.18
  7. Release: 4%{?_dist_release}
  8. License: LGPLv2+ and GPLv2+ or BSD
  9. Group: System Environment/Base
  10. URL: http://sourceforge.net/projects/openipmi/
  11. Source: http://downloads.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
  12. Source1: openipmi.sysconf
  13. Source2: openipmi.initscript
  14. Source3: openipmigui.desktop
  15. Source4: README.initscript
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: gdbm-devel swig glib2-devel net-snmp-devel ncurses-devel
  18. BuildRequires: openssl-devel python-devel perl tcl tkinter
  19. BuildRequires: desktop-file-utils popt-devel
  20. Requires(post): chkconfig
  21. Requires(preun): chkconfig
  22. Patch1: OpenIPMI-2.0.18-pthread-pkgconfig.patch
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. %description
  26. The Open IPMI project aims to develop an open code base to allow access to
  27. platform information using Intelligent Platform Management Interface (IPMI).
  28. This package contains the tools of the OpenIPMI project.
  29. %package libs
  30. Group: Development/Libraries
  31. Summary: The OpenIPMI runtime libraries
  32. Summary(ja): OpenIPMI ランタイムライブラリ
  33. %description libs
  34. The OpenIPMI-libs package contains the runtime libraries for shared binaries
  35. and applications.
  36. %package perl
  37. Group: Development/Libraries
  38. Summary: IPMI Perl language bindings
  39. Summary(ja): IPMI Perl 言語バインディング
  40. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  41. %description perl
  42. The OpenIPMI-perl package contains the Perl language bindings for OpenIPMI.
  43. %package python
  44. Group: Development/Libraries
  45. Summary: IPMI Python language bindings
  46. Summary(ja): IPMI Python 言語バインディング
  47. %description python
  48. The OpenIPMI-python package contains the Python language bindings for OpenIPMI.
  49. %package devel
  50. Group: Development/Libraries
  51. Summary: The development environment for the OpenIPMI project
  52. Summary(ja): OpenIPMIの開発キット
  53. Requires: pkgconfig
  54. Requires: %{name} = %{version}-%{release}
  55. %description devel
  56. The OpenIPMI-devel package contains the development libraries and header files
  57. of the OpenIPMI project.
  58. %package gui
  59. Group: System Environment/Base
  60. Summary: IPMI graphical user interface tool
  61. Summary(ja): IPMI GUI ツール
  62. Requires: tix tkinter %{name}-python = %{version}-%{release}
  63. %description gui
  64. The OpenIPMI-gui package contains the graphical user interface to monitor
  65. and control IPMI-enabled devices.
  66. %prep
  67. %setup -q
  68. %patch1 -p1
  69. %build
  70. export CFLAGS="-fPIC $RPM_OPT_FLAGS"
  71. %configure \
  72. --with-pythoninstall=%{python_sitearch} \
  73. --disable-dependency-tracking \
  74. --with-tcl=no \
  75. --with-glib12=no \
  76. --disable-static
  77. # get rid of rpath
  78. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  79. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  80. make # not %{?_smp_mflags} safe
  81. %install
  82. rm -rf $RPM_BUILD_ROOT
  83. make install DESTDIR=$RPM_BUILD_ROOT
  84. rm -rf $RPM_BUILD_ROOT/%{_libdir}/*.la
  85. install -d ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
  86. install -m 644 %SOURCE1 ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/ipmi
  87. install -d ${RPM_BUILD_ROOT}%{_initrddir}
  88. install -m 755 %SOURCE2 ${RPM_BUILD_ROOT}%{_initrddir}/ipmi
  89. desktop-file-install --vendor="fedora" --dir=${RPM_BUILD_ROOT}%{_datadir}/applications %{SOURCE3}
  90. install -m 644 %SOURCE4 .
  91. %post
  92. /sbin/chkconfig --add ipmi
  93. %preun
  94. if [ $1 = 0 ]; then
  95. service ipmi stop >/dev/null 2>&1
  96. /sbin/chkconfig --del ipmi
  97. fi
  98. %postun
  99. if [ "$1" -ge "1" ]; then
  100. service ipmi condrestart >/dev/null 2>&1 || :
  101. fi
  102. %post libs -p /sbin/ldconfig
  103. %postun libs -p /sbin/ldconfig
  104. %clean
  105. rm -rf $RPM_BUILD_ROOT
  106. %files
  107. %defattr(-,root,root)
  108. %doc CONFIGURING_FOR_LAN COPYING COPYING.BSD COPYING.LIB FAQ README README.Force README.MotorolaMXP README.initscript
  109. %config(noreplace) %{_sysconfdir}/sysconfig/ipmi
  110. %{_initrddir}/ipmi
  111. %{_bindir}/ipmicmd
  112. %{_bindir}/ipmilan
  113. %{_bindir}/ipmish
  114. %{_bindir}/ipmi_ui
  115. %{_bindir}/openipmicmd
  116. %{_bindir}/openipmish
  117. %{_bindir}/rmcp_ping
  118. %{_bindir}/solterm
  119. %{_mandir}/man1/ipmi_ui*
  120. %{_mandir}/man1/openipmicmd*
  121. %{_mandir}/man1/openipmish*
  122. %{_mandir}/man1/rmcp_ping*
  123. %{_mandir}/man1/solterm*
  124. %{_mandir}/man7/ipmi_cmdlang*
  125. %{_mandir}/man7/openipmi_conparms*
  126. %{_mandir}/man8/ipmilan*
  127. %files perl
  128. %defattr(-,root,root)
  129. %attr(644,root,root) %{perl_vendorarch}/OpenIPMI.pm
  130. %{perl_vendorarch}/auto/OpenIPMI/
  131. %files python
  132. %defattr(-,root,root)
  133. %{python_sitearch}/*OpenIPMI*
  134. %files libs
  135. %defattr(-,root,root)
  136. %{_libdir}/*.so.*
  137. %files devel
  138. %defattr(-,root,root)
  139. %{_includedir}/OpenIPMI
  140. %{_libdir}/*.so
  141. %{_libdir}/pkgconfig/*.pc
  142. %files gui
  143. %defattr(-,root,root)
  144. %{_bindir}/openipmigui
  145. %{_mandir}/man1/openipmigui*
  146. %{python_sitearch}/openipmigui
  147. %{_datadir}/applications/fedora-openipmigui.desktop
  148. %changelog
  149. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-4
  150. - rebuild with python-2.7.2
  151. * Sat May 21 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.18-3
  152. - build with perl 5.12.3
  153. - add Vendor and Distribution tags
  154. * Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-2
  155. - rebuild with openssl-1.0.0d
  156. * Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.18-1
  157. - initial build for Vine Linux
  158. * Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.0.18-2
  159. - Mass rebuild with perl-5.12.0
  160. * Wed May 5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.18-1
  161. - updated to OpenIPMI-2.0.18
  162. - fixed OpenIPMIpthread pkgconfig file (#468067)
  163. * Mon May 3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.17-1
  164. - updated to OpenIPMI-2.0.17
  165. * Thu Mar 18 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-12
  166. - implemented mandatory 'force-reload' command in ipmi service
  167. * Thu Mar 11 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-11
  168. - rebuild against new gdbm
  169. * Wed Mar 3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-10
  170. - add README.initscript describing /etc/init.d/ipmi initscript exit codes
  171. (#562151)
  172. * Mon Feb 22 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-9
  173. - fix package License: field, there *are* sources with BSD header
  174. - distribute README files and COPYING in package
  175. * Tue Jan 5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-8
  176. - fix package License: field, there is no source with BSD header
  177. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 2.0.16-7
  178. - rebuild against perl 5.10.1
  179. * Tue Dec 1 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-6
  180. - fix package compilation to remove rpmlint errors
  181. * Wed Sep 30 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-5
  182. - rebuilt with new net-snmp
  183. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.16-4
  184. - rebuilt with new openssl
  185. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.16-3
  186. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  187. * Wed Apr 15 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-2
  188. - fix compilation flags, debuginfo package is correctly generated now
  189. * Thu Mar 19 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-1
  190. - new upstream release
  191. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.14-11
  192. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  193. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.14-10
  194. - rebuild with new openssl
  195. * Thu Dec 11 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-9
  196. - fix linking without rpath, prelink won't screw up the libraries
  197. anymore (#475265)
  198. * Wed Dec 10 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-8
  199. - shorter probe interval is used in init script, making the service startup
  200. quicker in most situations (#475101)
  201. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.14-7
  202. - Rebuild for Python 2.6
  203. * Thu Oct 30 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-6
  204. - removed static libraries from the -devel subpackage
  205. - fixed openipmigui.desktop file
  206. * Thu Oct 23 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-5
  207. - fixed typos in the descriptions
  208. - added .desktop file for openipmigui tool
  209. * Mon Oct 20 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-4
  210. - fixed description of the package
  211. * Thu Oct 16 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-3
  212. - split ipmitool to separate package
  213. - added 'reload' functionality to init script
  214. - added seraparate -gui subpackage
  215. * Wed Jul 30 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-2
  216. - Fixed rpath problem in libOpenIPMIposix.so.0.0.1
  217. * Tue Jul 29 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-1
  218. - Fixed several specfile problems (#453751)
  219. - Update to OpenIPMI-2.0.14
  220. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.13-2
  221. - Autorebuild for GCC 4.3
  222. * Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.13-1
  223. - Updated to OpenIPMI-2.0.13
  224. - Rebuild due to new openssl
  225. * Wed Oct 10 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-3
  226. - Added missing perl-devel buildrequires
  227. * Mon Sep 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
  228. - Added missing popt-devel buildrequires
  229. * Fri Aug 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
  230. - Fix rebuild problems due to glibc change
  231. - License review and fixes
  232. * Tue Apr 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-1
  233. - Update to OpenIPMI-2.0.11
  234. * Tue Feb 27 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-8
  235. - Update for ipmitool-1.8.9
  236. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 2.0.6-7
  237. - rebuild for python 2.5
  238. * Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-6.fc7
  239. - Update due to new net-snmp-5.4
  240. - Some specfile updates
  241. * Tue Jul 18 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-5
  242. - Fixed check for udev in initscript (#197956)
  243. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.0.6-4.1
  244. - rebuild
  245. * Fri Jun 16 2006 Bill Nottingham <notting@redhat.com> 2.0.6-4
  246. - don't include <linux/compiler.h>
  247. * Fri Jun 16 2006 Jon Masters <jcm@redhat.com> 2.0.6-3
  248. - Fix a build requires (needs glibc-kernheaders)
  249. * Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> 2.0.6-2
  250. - Bump for new glib2
  251. * Tue May 16 2006 Phil Knirsch <pknirsch@redhat.com> 2.0.6-1
  252. - Fixed bug with type conversion in ipmitool (#191091)
  253. - Added python bindings
  254. - Split off perl and python bindings in separate subpackages
  255. - Dropped obsolete patches
  256. - Added missing buildprereq on readline-devel
  257. - Made it install the python bindings properly on 64bit archs
  258. * Mon May 15 2006 Phil Knirsch <pknirsch@redhat.com>
  259. - Updated ipmitool to 1.8.8
  260. - Updated OpenIPMI to 2.0.6
  261. * Fri Feb 17 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-19
  262. - Added missing PreReq for chkconfig
  263. * Mon Feb 13 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2.1
  264. - rebump for build order issues during double-long bump
  265. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2
  266. - bump again for double-long bug on ppc(64)
  267. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.1
  268. - rebuilt for new gcc4.1 snapshot and glibc changes
  269. * Mon Feb 06 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-18
  270. - Updated ipmitool to latest upstream version.
  271. - Removed 3 patches for already fixed bugs in latest ipmitool.
  272. - Adapted warning message fix for ipmitool for latest version.
  273. * Tue Jan 24 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-17
  274. - Fixed some minor things in initscripts.
  275. * Mon Jan 09 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-16
  276. - Included FRU fix for displaying FRUs with ipmitool
  277. - Included patch for new option to specify a BMC password for IPMI 2.0 sessions
  278. * Tue Jan 03 2006 Radek Vokal <rvokal@redhat.com> 1.4.14-15
  279. - Rebuilt against new libnetsnmp
  280. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  281. - rebuilt
  282. * Wed Nov 23 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-14
  283. - Some more initscript and sysconfig updates from Dell.
  284. * Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-13
  285. - Rebuilt to link against latest openssl libs.
  286. - Fixed ipmitool not setting session privilege level (#172312)
  287. * Wed Nov 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-11
  288. - Rebuild to link against new net-snmp libs.
  289. * Tue Oct 11 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-10
  290. - Updated initscript to fix missing redhat-lsb bug (#169901)
  291. * Thu Sep 08 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-9
  292. - Another update to latest initscripts from Dell
  293. - Fixed some missing return statements for non-void functions (#164138)
  294. * Thu Sep 01 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-8
  295. - Updated initscript to latest version from Dell
  296. * Fri Aug 12 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-7
  297. - Fixed the unwanted output of failed module loading of the initscript. Behaves
  298. now like all our other initscripts (#165476)
  299. * Fri Aug 05 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-6
  300. - Fixed build problem on 64bit machines
  301. * Fri Jul 15 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-5
  302. - Fixed missing change to not autostart in the initscript
  303. * Wed Jul 06 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-4
  304. - Made the initscript a replacing configfile
  305. * Mon Jul 04 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-3
  306. - Updated versions of the initscripts and sysconf files
  307. - Fixed typo in preun script and changelog
  308. * Mon Jun 27 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-2
  309. - Updated to OpenIPMI-1.4.14
  310. - Split the main package into normal and libs package for multilib support
  311. - Added ipmitool-1.8.2 to OpenIPMI and put it in tools package
  312. - Added sysconf and initscript (#158270)
  313. - Fixed oob subscripts (#149142)
  314. * Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-5
  315. - Correctly put libs in the proper packages
  316. * Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-4
  317. - gcc4 rebuild fixes
  318. - Added missing gdbm-devel buildprereq
  319. * Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-3
  320. - bump release and rebuild with gcc 4
  321. * Tue Feb 08 2005 Karsten Hopp <karsten@redhat.de> 1.4.11-2
  322. - update
  323. * Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
  324. - Initial version