junit-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266
  1. # Copyright (c) 2000-2005, JPackage Project
  2. # All rights reserved.
  3. #
  4. # Redistribution and use in source and binary forms, with or without
  5. # modification, are permitted provided that the following conditions
  6. # are met:
  7. #
  8. # 1. Redistributions of source code must retain the above copyright
  9. # notice, this list of conditions and the following disclaimer.
  10. # 2. Redistributions in binary form must reproduce the above copyright
  11. # notice, this list of conditions and the following disclaimer in the
  12. # documentation and/or other materials provided with the
  13. # distribution.
  14. # 3. Neither the name of the JPackage Project nor the names of its
  15. # contributors may be used to endorse or promote products derived
  16. # from this software without specific prior written permission.
  17. #
  18. # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
  19. # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
  20. # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
  21. # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
  22. # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  23. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
  24. # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
  25. # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
  26. # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
  27. # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
  28. # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  29. #
  30. %define _with_gcj_support 1
  31. %define gcj_support %{?_with_gcj_support:1}%{!?_with_gcj_support:%{?_without_gcj_support:0}%{!?_without_gcj_support:%{?_gcj_support:%{_gcj_support}}%{!?_gcj_support:0}}}
  32. Name: junit
  33. Summary: Java regression test package
  34. Version: 3.8.2
  35. Release: 7%{?dist}
  36. License: CPL
  37. URL: http://www.junit.org/
  38. Group: Development/Tools
  39. # http://osdn.dl.sourceforge.net/junit/junit3.8.2.zip
  40. Source0: junit3.8.2.zip
  41. Source1: junit3.8.2-build.xml
  42. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  43. BuildRequires: ant
  44. BuildRequires: jpackage-utils >= 0:1.6
  45. %if ! %{gcj_support}
  46. Buildarch: noarch
  47. %endif
  48. %if %{gcj_support}
  49. BuildRequires: java-gcj-compat-devel
  50. Requires(post): java-gcj-compat
  51. Requires(postun): java-gcj-compat
  52. %endif
  53. %description
  54. JUnit is a regression testing framework written by Erich Gamma and Kent
  55. Beck. It is used by the developer who implements unit tests in Java.
  56. JUnit is Open Source Software, released under the IBM Public License and
  57. hosted on SourceForge.
  58. %package manual
  59. Group: Documentation
  60. Summary: Manual for %{name}
  61. %description manual
  62. Documentation for %{name}.
  63. #%package javadoc
  64. #Group: Documentation
  65. #Summary: Javadoc for %{name}
  66. #
  67. #%description javadoc
  68. #Javadoc for %{name}.
  69. %package demo
  70. Group: Development/Libraries
  71. Summary: Demos for %{name}
  72. Requires: %{name} = %{version}-%{release}
  73. %if %{gcj_support}
  74. BuildRequires: java-gcj-compat-devel
  75. Requires(post): java-gcj-compat
  76. Requires(postun): java-gcj-compat
  77. %endif
  78. %description demo
  79. Demonstrations and samples for %{name}.
  80. %prep
  81. %setup -q -n %{name}%{version}
  82. # extract sources
  83. #jar xf src.jar
  84. #rm -f src.jar
  85. #cp %{SOURCE1} build.xml
  86. %build
  87. #ant dist
  88. %install
  89. rm -rf $RPM_BUILD_ROOT
  90. # jars
  91. install -d -m 755 $RPM_BUILD_ROOT%{_javadir}
  92. install -m 644 %{name}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
  93. (cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}*; do ln -sf ${jar} ${jar/-%{version}/}; done)
  94. # javadoc
  95. #install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
  96. #cp -pr %{name}%{version}/javadoc/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
  97. # demo
  98. install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/%{name}/demo/junit # Not using %name for last part because it is
  99. # part of package name
  100. cp -pr %{name}/* $RPM_BUILD_ROOT%{_datadir}/%{name}/demo/junit
  101. %if %{gcj_support}
  102. rm -rf aot-compile-rpm
  103. # these --exclude options work around an aot-compile-rpm problem with test.jar
  104. %{_bindir}/aot-compile-rpm --exclude usr/share/junit/demo --exclude usr/share/junit/demo/junit/tests/runner/test.jar
  105. %endif
  106. #ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name}
  107. %clean
  108. rm -rf $RPM_BUILD_ROOT
  109. %post
  110. %if %{gcj_support}
  111. if [ -x %{_bindir}/rebuild-gcj-db ]
  112. then
  113. %{_bindir}/rebuild-gcj-db
  114. fi
  115. %endif
  116. %postun
  117. %if %{gcj_support}
  118. if [ -x %{_bindir}/rebuild-gcj-db ]
  119. then
  120. %{_bindir}/rebuild-gcj-db
  121. fi
  122. %endif
  123. %files
  124. %defattr(0644,root,root,0755)
  125. %doc README.html
  126. %{_javadir}/*
  127. %if %{gcj_support}
  128. %dir %{_libdir}/gcj/%{name}
  129. %attr(-,root,root) %{_libdir}/gcj/%{name}/junit-3.8.2.jar.*
  130. %endif
  131. %files manual
  132. %defattr(0644,root,root,0755)
  133. %doc doc/*
  134. #files javadoc
  135. #defattr(0644,root,root,0755)
  136. #doc %{_javadocdir}/%{name}-%{version}
  137. #doc %{_javadocdir}/%{name}
  138. %files demo
  139. %defattr(0644,root,root,0755)
  140. %{_datadir}/%{name}
  141. %changelog
  142. * Wed Sep 1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.8.2-7
  143. - Initial build for Vine Linux
  144. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.8.2-6.4
  145. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  146. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.8.2-5.4
  147. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  148. * Wed Jul 9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 3.8.2-4.4
  149. - drop repotag
  150. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.8.2-4jpp.3
  151. - Autorebuild for GCC 4.3
  152. * Thu Sep 20 2007 Deepak Bhole <dbhole@redhat.com> - 3.8.2-3jpp.3
  153. - Fix location of stylesheet for javadocs
  154. * Thu Sep 20 2007 Deepak Bhole <dbhole@redhat.com> - 3.8.2-3jpp.2
  155. - Rebuild for ppc32 execmem issue and new build-id
  156. * Mon Feb 12 2007 Thomas Fitzsimmons <fitzsim@redhat.com> - 3.8.2-3jpp.1.fc7
  157. - Add dist tag
  158. * Mon Feb 12 2007 Thomas Fitzsimmons <fitzsim@redhat.com> - 3.8.2-3jpp.1
  159. - Committed on behalf of Tania Bento <tbento@redhat.com>
  160. - Update per Fedora review process
  161. - Resolves rhbz#225954
  162. * Thu Aug 10 2006 Deepak Bhole <dbhole@redhat.com> - 0:3.8.2-3jpp.1
  163. - Added missing requirements.
  164. * Thu Aug 10 2006 Karsten Hopp <karsten@redhat.de> 0:3.8.2-2jpp_3fc
  165. - Require(post/postun): coreutils
  166. * Sun Jun 23 2006 Deepak Bhole <dbhole@redhat.com> - 0:3.8.2-2jpp_2fc
  167. - Rebuilt.
  168. * Sat Jun 22 2006 Deepak Bhole <dbhole@redhat.com> - 0:3.8.2-2jpp_1fc
  169. - Upgrade to 3.8.2
  170. - Added conditional native compilation.
  171. - Fix path where demo is located.
  172. * Mon Mar 03 2006 Ralph Apel <r.apel at r-apel.de> - 0:3.8.2-1jpp
  173. - First JPP-1.7 release
  174. * Sun Aug 23 2004 Randy Watler <rwatler at finali.com> - 0:3.8.1-4jpp
  175. - Rebuild with ant-1.6.2
  176. * Fri May 09 2003 David Walluck <david@anti-microsoft.org> 0:3.8.1-3jpp
  177. - update for JPackage 1.5
  178. * Fri Mar 21 2003 Nicolas Mailhot <Nicolas.Mailhot (at) JPackage.org> 3.8.1-2jpp
  179. - For jpackage-utils 1.5
  180. * Fri Sep 06 2002 Henri Gomez <hgomez@users.sourceforge.net> 3.8.1-1jpp
  181. - 3.8.1
  182. * Sun Sep 01 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.8-2jpp
  183. - used original zip file
  184. * Thu Aug 29 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.8-1jpp
  185. - 3.8
  186. - group, vendor and distribution tags
  187. * Sat Jan 19 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.7-6jpp
  188. - versioned dir for javadoc
  189. - no dependencies for manual and javadoc packages
  190. - stricter dependency for demo package
  191. - additional sources in individual archives
  192. - section macro
  193. * Sat Dec 1 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.7-5jpp
  194. - javadoc in javadoc package
  195. * Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 3.7-4jpp
  196. - fixed previous releases ...grrr
  197. * Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 3.7-3jpp
  198. - added jpp extension
  199. - removed packager tag
  200. * Sun Sep 30 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.7-2jpp
  201. - first unified release
  202. - s/jPackage/JPackage
  203. * Mon Sep 17 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 3.7-1mdk
  204. - 3.7
  205. - vendor tag
  206. - packager tag
  207. - s/Copyright/License/
  208. - truncated description to 72 columns in spec
  209. - spec cleanup
  210. - used versioned jar
  211. - moved demo files to %%{_datadir}/%%{name}
  212. * Sat Feb 17 2001 Guillaume Rousse <g.rousse@linux-mandrake.com> 3.5-1mdk
  213. - first Mandrake release