libsigc++-vl.spec 8.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280
  1. %define lib_name sigc++-2.0
  2. Summary: The Typesafe Signal Framework for C++
  3. Summary(ja): C++ 用の型安全なシグナルフレームワーク
  4. Name: libsigc++
  5. Version: 2.10.6
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv2
  11. URL: https://github.com/libsigcplusplus/libsigcplusplus
  12. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  13. Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  14. Buildroot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gcc-c++
  16. BuildRequires: m4
  17. BuildRequires: mm-common
  18. %description
  19. This library implements a full callback system for use in widget libraries,
  20. abstract interfaces, and general programming. Originally part of the Gtk--
  21. widget set, %{name} is now a seperate library to provide for more general
  22. use. It is the most complete library of its kind with the ablity to connect
  23. an abstract callback to a class method, function, or function object. It
  24. contains adaptor classes for connection of dissimilar callbacks and has an
  25. ease of use unmatched by other C++ callback libraries.
  26. Package gtkmm2, which is a C++ binding to the GTK2 library, uses libsigc++.
  27. %package devel
  28. Summary: development tools for the Typesafe Signal Framework for C++
  29. Group: programming
  30. Requires: %{name} = %{version}-%{release}
  31. Requires: pkgconfig
  32. %description devel
  33. The %{name}-devel package contains the static libraries and header files
  34. needed for development with %{name}.
  35. %package examples
  36. Summary: examples and tests for the Typesafe Signal Framework for C++
  37. Group: programming
  38. Requires: %{name}-devel = %{version}-%{release}
  39. %description examples
  40. The %{name}-devel package contains source code of example and test
  41. programs for %{name}.
  42. %debug_package
  43. %prep
  44. %setup -q
  45. %build
  46. ./autogen.sh
  47. %configure --disable-static --enable-silent-rules
  48. make %{_smp_mflags}
  49. %install
  50. rm -rf $RPM_BUILD_ROOT
  51. make install DESTDIR=$RPM_BUILD_ROOT
  52. # removed unpackage files
  53. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  54. mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
  55. cp -a examples tests $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
  56. find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .libs |xargs -r rm -rf
  57. find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .deps |xargs -r rm -rf
  58. find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type f |xargs file |
  59. grep -E '(relocatable|executable|shell script)' |cut -d: -f1 |xargs -r rm -f
  60. for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/{examples,tests}/Makefile; do
  61. rm -f $i.*
  62. done
  63. rm -rf docs-toinstall
  64. mkdir -p docs-to-install
  65. cp -pr $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0/* docs-to-install/
  66. rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0
  67. # devhelp path fix
  68. sed -i 's/doc\/%{name}-2.0/doc\/%{name}-devel-%{version}/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/%{name}-2.0/%{name}-2.0.devhelp2
  69. #sed -i 's/html\/..\/..\/index\.html/html\/index\.html/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/libglademm-%{ver}/libglademm-%{ver}.devhelp
  70. %post -p /sbin/ldconfig
  71. %postun -p /sbin/ldconfig
  72. %clean
  73. rm -rf $RPM_BUILD_ROOT
  74. %files
  75. %defattr(-,root,root,755)
  76. %license COPYING
  77. %doc AUTHORS README NEWS ChangeLog TODO
  78. %attr(755,root,root) %{_libdir}/lib*.so.*
  79. %files devel
  80. %defattr(-,root,root,755)
  81. %{_includedir}/*
  82. %{_libdir}/%{lib_name}/include
  83. %{_libdir}/pkgconfig/*.pc
  84. #{_libdir}/lib*.la
  85. %{_libdir}/lib*.so
  86. %{_datadir}/devhelp/books/%{name}-2.0/*
  87. %doc docs-to-install/index.html docs-to-install/images
  88. %doc docs-to-install/reference docs-to-install/tutorial
  89. %files examples
  90. %defattr(-,root,root,755)
  91. %{_libdir}/%{lib_name}/examples
  92. %{_libdir}/%{lib_name}/tests
  93. %changelog
  94. * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10.6-1
  95. - new upstream release.
  96. * Sat Aug 01 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10.3-1
  97. - new upstream release.
  98. * Wed Mar 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10.2-1
  99. - new upstream release.
  100. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10.0-1
  101. - new upstream release.
  102. * Fri Jul 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
  103. - new upstream release
  104. * Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-2
  105. - rebuild with gcc-5.4.0
  106. * Sat Nov 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
  107. - new upstream release
  108. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.1-1
  109. - new upstream release
  110. * Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.11-1
  111. - new upstream release
  112. * Sun Dec 25 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.10-1
  113. - new upstream release
  114. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.8-2
  115. - build with rpm-4.8.1-1 for pkg-config file
  116. * Thu Sep 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.8-1
  117. - new upstream release
  118. * Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-1
  119. - new upstream release
  120. - built with new toolchain
  121. * Sun Sep 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4.2-1
  122. - new upstream release
  123. - remove static libraries from devel package
  124. * Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
  125. - new upstream release
  126. - spec in UTF-8
  127. * Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-2vl5
  128. - removed .la files from devel package
  129. * Sun Apr 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-1vl5
  130. - new upstream release
  131. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.17-0vl2
  132. - rebuild with new environment/toolchain
  133. * Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
  134. - new upstream release
  135. * Tue Aug 2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl2
  136. - rebuild with new libtool
  137. * Tue Aug 2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl1
  138. - new upstream release
  139. * Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.15-0vl1
  140. - new upstream release
  141. * Sat Jun 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.14-0vl1
  142. - new upstream release
  143. * Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.10-0vl1
  144. - new upstream release
  145. - added tutorial to devel package
  146. * Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.6-0vl1
  147. - update to 2.0.6
  148. * Sun Dec 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
  149. - update to 1.2.5
  150. - add Requires: pkgconfig
  151. * Sat Oct 4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl3
  152. - rebuild to remove dependance <5371>
  153. - add Japanese summary
  154. - use better macros
  155. - s/Copyright/License/
  156. * Mon Nov 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl2
  157. - rebuild with new toolchain
  158. * Wed Feb 06 2002 Satoshi IWMAOTO <satoshi.iwamoto@nifty.ne.jp>
  159. - 1.0.4-0vl1
  160. - Build for Vine Linux 2.5
  161. * Wed Feb 21 2001 yoneda kenji <yoneda@n.isl.titech.ac.jp>
  162. - packaged for Vine Linux 2.1
  163. * Sat Apr 15 2000 Dmitry V. Levin <ldv@fandra.org>
  164. - updated Url and Source fileds
  165. - 1.0.0 stable release
  166. * Sat Jan 22 2000 Dmitry V. Levin <ldv@fandra.org>
  167. - filtering out -fno-rtti and -fno-exceptions options from $RPM_OPT_FLAGS
  168. - minor install section cleanup
  169. * Wed Jan 19 2000 Allan Rae <rae@lyx.org>
  170. - autogen just creates configure, not runs it, so cleaned that up too.
  171. * Wed Jan 19 2000 Dmitry V. Levin <ldv@fandra.org>
  172. - minor attr fix
  173. - removed unnecessary curly braces
  174. - fixed Herbert's adjustement
  175. * Sat Jan 15 2000 Dmitry V. Levin <ldv@fandra.org>
  176. - minor package dependence fix
  177. * Sat Dec 25 1999 Herbert Valerio Riedel <hvr@gnu.org>
  178. - fixed typo of mine
  179. - added traditional CUSTOM_RELEASE stuff
  180. - added SMP support
  181. * Thu Dec 23 1999 Herbert Valerio Riedel <hvr@gnu.org>
  182. - adjusted spec file to get tests.Makefile and examples.Makefile from scripts/
  183. * Fri Oct 22 1999 Dmitry V. Levin <ldv@fandra.org>
  184. - split into three packages: %name, %name-devel and %name-examples
  185. * Thu Aug 12 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  186. - updated source field and merged conflicts between revisions.
  187. * Tue Aug 10 1999 Dmitry V. Levin <ldv@fandra.org>
  188. - updated Prefix and BuildRoot fields
  189. * Thu Aug 5 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
  190. - made sure configure works on all alphas
  191. * Wed Jul 7 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  192. - Added autoconf macro for sigc.
  193. * Fri Jun 11 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  194. - Made into a .in to keep version field up to date
  195. - Still need to do release by hand
  196. * Mon Jun 7 1999 Dmitry V. Levin <ldv@fandra.org>
  197. - added Vendor and Packager fields
  198. * Sat Jun 5 1999 Dmitry V. Levin <ldv@fandra.org>
  199. - updated to 0.8.0
  200. * Tue Jun 1 1999 Dmitry V. Levin <ldv@fandra.org>
  201. - initial revision