graphviz-vl.spec 7.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301
  1. Name: graphviz
  2. Summary: Graph Visualization Tools
  3. Version: 2.26.3
  4. Release: 1%{?_dist_release}
  5. Group: Applications/Graphics
  6. License: CPL
  7. URL: http://www.graphviz.org/
  8. Source: http://www.graphviz.org/pub/%{name}/stable/SOURCES/%{name}-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildRequires: bison
  11. BuildRequires: cairo-devel
  12. BuildRequires: expat-devel
  13. BuildRequires: flex
  14. BuildRequires: fontconfig-devel
  15. BuildRequires: freetype2-devel
  16. BuildRequires: gd-devel
  17. BuildRequires: gtk2-devel
  18. BuildRequires: guile-devel
  19. BuildRequires: libjpeg-turbo-devel
  20. BuildRequires: libpng-devel
  21. BuildRequires: libSM-devel
  22. BuildRequires: libtool-ltdl-devel >= 2.2.6a
  23. BuildRequires: libXaw-devel
  24. BuildRequires: libXext-devel
  25. BuildRequires: m4
  26. BuildRequires: perl
  27. BuildRequires: python-devel
  28. BuildRequires: ruby-devel
  29. BuildRequires: swig
  30. BuildRequires: tcl >= 8.4
  31. BuildRequires: tk >= 8.4
  32. BuildRequires: zlib-devel
  33. Requires: urw-fonts
  34. # only for this release
  35. BuildConflicts: graphviz-devel
  36. %description
  37. A collection of tools and tcl packages for the manipulation and layout
  38. of graphs (as in nodes and edges, not as in barcharts).
  39. %package devel
  40. Group: Development/Libraries
  41. Summary: Development tools for version %{version} of %{name}
  42. Requires: %{name} = %{version}
  43. %description devel
  44. The %{name}-devel package contains the header files
  45. and man3 pages necessary for developing programs
  46. using version %{version} of the %{name} libraries.
  47. %package doc
  48. Summary: PDF and HTML documents for graphviz
  49. Group: Applications/Documentation
  50. %description doc
  51. Provides some additional PDF and HTML documentation for graphviz.
  52. %package guile
  53. Group: Applications/Graphics
  54. Summary: Guile extension for graphviz
  55. Requires: %{name} = %{version}-%{release}, guile
  56. %description guile
  57. Guile extension for graphviz.
  58. %package perl
  59. Group: Applications/Graphics
  60. Summary: Perl extension for graphviz
  61. Requires: %{name} = %{version}-%{release}
  62. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  63. %description perl
  64. Perl extension for graphviz.
  65. %package python
  66. Group: Applications/Graphics
  67. Summary: Python extension for graphviz
  68. Requires: %{name} = %{version}-%{release}
  69. Requires: python
  70. %description python
  71. Python extension for graphviz.
  72. %package ruby
  73. Group: Applications/Multimedia
  74. Summary: Ruby extension for graphviz
  75. Requires: %{name} = %{version}-%{release}
  76. Requires: ruby
  77. %description ruby
  78. Ruby extension for graphviz.
  79. %package tcl
  80. Group: Applications/Graphics
  81. Summary: Tcl extension & tools for graphviz
  82. Requires: tcl >= 8.4, tk >= 8.4
  83. Requires: %{name} = %{version}
  84. %description tcl
  85. Various tcl packages (extensions) for the graphviz tools.
  86. %prep
  87. %setup -q
  88. # using archdir instead of sitearchdir for Vine
  89. sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
  90. %build
  91. # XXX ix86 only used to have -ffast-math, let's use everywhere
  92. %{expand: %%define optflags %{optflags} -ffast-math}
  93. %configure \
  94. --with-x \
  95. --disable-static \
  96. --with-mylibgd \
  97. --with-ipsepcola \
  98. --with-pangocairo \
  99. --with-gdk-pixbuf \
  100. --without-mylibgd \
  101. --without-ming \
  102. --disable-sharp \
  103. --enable-guile \
  104. --enable-io \
  105. --disable-java \
  106. --disable-lua \
  107. --disable-ocaml \
  108. --enable-perl \
  109. --disable-php \
  110. --enable-python \
  111. --disable-r \
  112. --enable-ruby \
  113. --enable-tcl
  114. make %{?_smp_mflags}
  115. %install
  116. rm -rf $RPM_BUILD_ROOT __doc
  117. make DESTDIR=$RPM_BUILD_ROOT \
  118. docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
  119. pkgconfigdir=%{_libdir}/pkgconfig \
  120. install
  121. find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
  122. chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
  123. cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
  124. rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
  125. %clean
  126. rm -rf $RPM_BUILD_ROOT
  127. # run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
  128. %post
  129. /sbin/ldconfig
  130. %{_bindir}/dot -c
  131. # if there is no dot after everything else is done, then remove config
  132. %postun
  133. if [ $1 -eq 0 ]; then
  134. rm -f %{_libdir}/graphviz/config || :
  135. fi
  136. /sbin/ldconfig
  137. %files
  138. %defattr(-,root,root)
  139. %doc AUTHORS COPYING ChangeLog NEWS README
  140. %{_bindir}/*
  141. %dir %{_datadir}/%{name}
  142. %{_datadir}/%{name}/lefty
  143. %{_mandir}/man1/*
  144. %{_mandir}/man7/*
  145. %dir %{_libdir}/%{name}
  146. %{_libdir}/*.so.*
  147. %{_libdir}/%{name}/*.so.*
  148. %exclude %{_libdir}/graphviz/*/*
  149. %files devel
  150. %defattr(-,root,root)
  151. %{_includedir}/%{name}
  152. %{_libdir}/*.so
  153. %{_libdir}/%{name}/*.so
  154. %{_libdir}/pkgconfig/*.pc
  155. %{_datadir}/%{name}/graphs
  156. %{_mandir}/man3/*.3.gz
  157. %files doc
  158. %defattr(-,root,root,-)
  159. %doc __doc/*
  160. %files guile
  161. %defattr(-,root,root,-)
  162. %{_libdir}/graphviz/guile/
  163. %{_mandir}/man3/gv.3guile*
  164. %files perl
  165. %defattr(-,root,root,-)
  166. %{_libdir}/graphviz/perl/
  167. %{perl_vendorarch}/*
  168. %{_mandir}/man3/gv.3perl*
  169. %files python
  170. %defattr(-,root,root,-)
  171. %{_libdir}/graphviz/python/
  172. %{_libdir}/python*/*
  173. %{_mandir}/man3/gv.3python*
  174. %files ruby
  175. %defattr(-,root,root,-)
  176. %{_libdir}/graphviz/ruby/
  177. %{rarchdir}/*
  178. %{_mandir}/man3/gv.3ruby*
  179. %files tcl
  180. %defattr(-,root,root)
  181. %{_libdir}/%{name}/tcl/*
  182. %{_libdir}/tcl*/*
  183. %{_datadir}/%{name}/demo
  184. # hack to include gv.3tcl only if available
  185. # always includes tcldot.3tcl, gdtclft.3tcl
  186. %{_mandir}/man3/*.3tcl*
  187. %{_mandir}/man3/tkspline.3tk*
  188. %changelog
  189. * Sat Oct 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
  190. - new upstream release
  191. - built with rpm-4.8.1
  192. - split doc, guile, perl, python, ruby subpackage
  193. * Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
  194. - rebuild with libtool-2.2.6a
  195. * Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
  196. - new upstream release
  197. * Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
  198. - rebuild with libXaw.so.7 (libXaw-1.0.5)
  199. * Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
  200. - new upstream release
  201. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
  202. - new upstream release
  203. - build with expat-2.0.1
  204. - add man7
  205. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
  206. - rebuild with tcl/tk-8.4.16
  207. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
  208. - new upstream release
  209. - add BuildPrereq: swig
  210. - delete BuildPrereq: gd-progs gd-devel
  211. - add --with-mylibgd and --disable-FEATURE to configure option
  212. - update %%files
  213. * Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
  214. - added BuildPrereq: ruby-devel
  215. * Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
  216. - new upstream release
  217. - add BuildPrereq: libtool-ltdl-devel
  218. - move pkgconfig files to %%{_libdir}/pkgconfig
  219. - add --disable-rpath --disable-static to configure option
  220. - add %%post to every package
  221. * Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
  222. - new upstream release
  223. - BuildPrereq: tcl >= 8.4, tk >= 8.4
  224. - add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
  225. - update %%files
  226. - remove lines about Vine2.6
  227. - change License to CPL
  228. * Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
  229. - source upgrade
  230. - remove patch0 and commented lines
  231. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
  232. - build for VineSeed
  233. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
  234. - source upgrade
  235. - change spec to build both VineSeed and Vine2.5/2.6
  236. - add BuildPrereq: expat-devel and Requires: libexpat
  237. - add patch0 to build against freetype2-2.1.7
  238. - stop using autogen.sh script
  239. - add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
  240. - add graphviz-tcl package (VineSeed)
  241. * Thu Aug 7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
  242. - rebuild for new Vine
  243. * Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
  244. - import from offical site (src.rpm)