tracker-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277
  1. Summary: An object database, tag/metadata database, search tool and indexer
  2. Summary(ja): オブジェクト/タグ/メタデータデータベースおよび検索ツール
  3. Name: tracker
  4. Version: 0.8.15
  5. Release: 1%{?_dist_release}
  6. License: GPL
  7. Group: Applications/System
  8. URL: http://www.gnome.org/projects/tracker/
  9. Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.8/tracker-%{version}.tar.bz2
  10. Patch0: tracker-ldfind.patch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  12. BuildRequires: gmime-devel >= 2.4, poppler-devel, gettext, file
  13. BuildRequires: gnome-desktop-devel, gamin-devel
  14. BuildRequires: libexif-devel, libgsf-devel, totem-pl-parser-devel
  15. BuildRequires: gstreamer-devel
  16. BuildRequires: desktop-file-utils, intltool
  17. BuildRequires: raptor-devel >= 1.4.18
  18. BuildRequires: sqlite3-devel
  19. BuildRequires: dbus-devel >= 1.0
  20. BuildRequires: dbus-glib-devel >= 0.73
  21. BuildRequires: libgnome-devel >= 2.13.2
  22. BuildRequires: libgnomeui-devel >= 2.13.7
  23. BuildRequires: libSM-devel
  24. BuildRequires: libnotify-devel >= 0.4.3
  25. BuildRequires: libuuid-devel
  26. BuildRequires: vala-devel
  27. BuildRequires: libgee-devel
  28. BuildRequires: upower-devel
  29. BuildRequires: gnome-applets
  30. ## BuildRequires: autoconf, automake
  31. %description
  32. Tracker is a powerful desktop-neutral first class object database,
  33. tag/metadata database, search tool and indexer.
  34. It consists of a common object database that allows entities to have an
  35. almost infinte number of properties, metadata (both embedded/harvested as
  36. well as user definable), a comprehensive database of keywords/tags and
  37. links to other entities.
  38. It provides additional features for file based objects including context
  39. linking and audit trails for a file object.
  40. It has the ability to index, store, harvest metadata. retrieve and search
  41. all types of files and other first class objects
  42. %package devel
  43. Summary: Headers for developing programs that will use %{name}
  44. Group: Development/Libraries
  45. Requires: %{name} = %{version}-%{release}
  46. Requires: pkgconfig
  47. Requires: dbus-glib-devel
  48. %description devel
  49. This package contains the static libraries and header files needed for
  50. developing with tracker
  51. %package search-tool
  52. Summary: Tracker search tool(s)
  53. Group: User Interface/Desktops
  54. Requires: %{name} = %{version}-%{release}
  55. %description search-tool
  56. Graphical frontend to tracker search facilities. This has dependencies on
  57. GNOME libraries
  58. %prep
  59. %setup -q
  60. ## %patch0 -p0 -b .ld
  61. # remove shebangs from the python files as none should be executable scripts
  62. ## sed -e '/^#!\//,1 d' -i python/deskbar-handler/*.py
  63. %build
  64. libtoolize --force --copy
  65. intltoolize --copy --force
  66. autoreconf -i -f
  67. %configure --disable-static \
  68. --enable-video-extractor=external \
  69. --enable-tracker-search-tool
  70. # Disable rpath
  71. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  72. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  73. # make %{?_smp_mflags} fails
  74. # %__make
  75. make %{?_smp_mflags}
  76. %install
  77. rm -rf %{buildroot}
  78. make DESTDIR=%{buildroot} install
  79. mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
  80. echo "%{_libdir}/tracker-0.8" \
  81. > %{buildroot}%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
  82. desktop-file-install --delete-original \
  83. --vendor="" \
  84. --dir=%{buildroot}%{_datadir}/applications \
  85. %{buildroot}%{_datadir}/applications/%{name}-search-tool.desktop
  86. rm -rf %{buildroot}%{_libdir}/*.{a,la}
  87. rm -rf %{buildroot}%{_datadir}/tracker-tests
  88. %find_lang %{name}
  89. %clean
  90. rm -rf %{buildroot}
  91. %post
  92. /sbin/ldconfig
  93. touch --no-create %{_datadir}/icons/hicolor
  94. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  95. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  96. fi
  97. %postun
  98. /sbin/ldconfig
  99. touch --no-create %{_datadir}/icons/hicolor
  100. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  101. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  102. fi
  103. %files -f %{name}.lang
  104. %defattr(-, root, root, -)
  105. %doc AUTHORS ChangeLog COPYING NEWS README
  106. ## %doc %{_datadir}/gtk-doc/html/libtracker-common/
  107. ## %doc %{_datadir}/gtk-doc/html/libtracker-module/
  108. %{_bindir}/tracker*
  109. %exclude %{_bindir}/tracker-search-tool
  110. %exclude %{_bindir}/tracker-preferences
  111. ## %exclude %{_bindir}/tracker-applet
  112. %{_libexecdir}/tracker*
  113. %{_libdir}/*.so.*
  114. %{_libdir}/tracker-0.8/
  115. %{_datadir}/tracker/
  116. %{_datadir}/dbus-1/services/org.freedesktop.Tracker*
  117. %{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
  118. %{_sysconfdir}/xdg/autostart/tracker*.desktop
  119. %{_mandir}/*/tracker*.gz
  120. %exclude %{_mandir}/man1/tracker-search-bar.1.gz
  121. %exclude %{_mandir}/man1/tracker-preferences.1.gz
  122. %exclude %{_mandir}/man1/tracker-search-tool.1.gz
  123. %files devel
  124. %defattr(-, root, root, -)
  125. %{_includedir}/tracker-0.8/
  126. ## %{_includedir}/libtracker-gtk/*
  127. %{_libdir}/*.so
  128. %{_libdir}/pkgconfig/*.pc
  129. %{_datadir}/vala/vapi/tracker*.vapi
  130. %{_datadir}/vala/vapi/tracker*.deps
  131. %files search-tool
  132. %defattr(-, root, root, -)
  133. %{_bindir}/tracker-search-tool
  134. %{_bindir}/tracker-preferences
  135. %{_libdir}/bonobo/servers/GNOME_Search_Bar_Applet.server
  136. %{_datadir}/icons/*/*/apps/tracker.*
  137. %{_datadir}/applications/*.desktop
  138. %{_mandir}/man1/tracker-search-bar.1.gz
  139. %{_mandir}/man1/tracker-preferences.1.gz
  140. %{_mandir}/man1/tracker-search-tool.1.gz
  141. %changelog
  142. * Sun Jul 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.15-1
  143. - new upstream release
  144. * Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.13-1
  145. - new upstream release
  146. - fix URL of Source0
  147. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.12-1
  148. - new upstream release
  149. * Sun Jun 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.11-1
  150. - new upstream release
  151. * Sun May 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.9-1
  152. - new upstream release
  153. - fix %install and %files (make /etc/ld.so.conf.d/tracker-%{_arch}.conf)
  154. * Sun May 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
  155. - new upstream release
  156. * Sun Apr 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
  157. - new upstream release
  158. - add BuildRequires: upower-devel, gnome-applets
  159. - change BuildRequires: dbus-glib -> dbus-glib-devel
  160. * Sun Mar 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  161. - new upstream release
  162. - add BuildRequires: libgnome-devel, libgnomeui-devel, libSM-devel, libnotify-devel, libuuid-devel, libgee-devel
  163. - fix BuildRequires: gmime-devel >= 2.4
  164. - add configure option (--enable-tracker-search-tool)
  165. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.91-1
  166. - new upstream release
  167. * Sun Dec 14 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-2
  168. - rebuild with poppler-0.10.2
  169. - spec in UTF-8
  170. * Mon Mar 31 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-1
  171. - new upstream release
  172. - update Patch1
  173. - drop Patch10 (no more necessary)
  174. - add %%{_sysconfdir}/xdg/autostart/tracker-applet.desktop
  175. - remove --enable-external-sqlite option (no more bundled sqlite exist)
  176. - apply new versioning policy
  177. * Mon Sep 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
  178. - new upstream release
  179. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
  180. - add Patch10 to fix selecting video-extractor
  181. - use external video extractor(totem) instead of gstreamer/xine
  182. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
  183. - initial build for Vine Linux
  184. * Fri Mar 30 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-6
  185. - Ship both autostart desktop files in the main package (BZ #233323)
  186. * Tue Feb 13 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-3
  187. - Package the deskbar plugin properly (BZ #228308)
  188. * Mon Jan 29 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-2
  189. - Split out tracker-search-tool sub-packages, for the GUI facility
  190. - Add proper requires for the -devel subpackage
  191. - Deal with the rpmlint complaints on rpath
  192. * Sat Jan 27 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-1
  193. - Update to 0.5.4
  194. * Tue Dec 26 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.3-1
  195. - Update to 0.5.3
  196. * Mon Nov 27 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-2
  197. - Apply patch on Makefile.am instead of Makefile.in
  198. - Add libtool to BR
  199. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-1
  200. - Update to 0.5.2
  201. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
  202. - Update to new version
  203. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-7
  204. - Have the devel subpackage require pkgconfig
  205. - Make the description field not have more than 76 characters on a line
  206. - Fix up the RPM group
  207. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-6
  208. - Explicitly require dbus-devel and dbus-glib (needed for FC < 6)
  209. * Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-5
  210. - Remove unneeded BRs (gnome-utils-devel and openssl-devel)
  211. * Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-4
  212. - Add autostart desktop file.
  213. - Edit the package description as suggested in review
  214. * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-3
  215. - More cleaups to the spec file.
  216. * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-2
  217. - Add needed BRs
  218. * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-1
  219. - Initial packaging for Fedora Extras