google-gadgets-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263
  1. #define svnrev 1449
  2. #define alphatag 20090430svn%{svnrev}
  3. Name: google-gadgets
  4. Version: 0.11.1
  5. Release: 1%{?_dist_release}
  6. Summary: Google Gadgets for Linux
  7. Group: User Interface/Desktops
  8. License: ASL 2.0
  9. URL: http://code.google.com/p/google-gadgets-for-linux/
  10. Source0: http://google-gadgets-for-linux.googlecode.com/files/google-gadgets-for-linux-%{version}.tar.bz2
  11. #Source0: %{name}-%{version}-r%{svnrev}.tar.bz2
  12. # http://code.google.com/p/google-gadgets-for-linux/issues/detail?id=311
  13. # patch taken from svn r1239
  14. Patch0: %{name}-0.11.1-gecko_ver.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: curl-devel libxml2-devel zlib-devel libtool-ltdl-devel
  17. # still needed even if we're not buliding gtkmoz element, for JavaScript
  18. BuildRequires: xulrunner-devel-unstable
  19. BuildRequires: dbus-devel gstreamer-devel gstreamer-plugins-base-devel
  20. BuildRequires: cairo-devel gtk2-devel librsvg2-devel
  21. BuildRequires: qt4-devel zip
  22. #BuildRequires: WebKit-qt-devel
  23. # Desktop integration
  24. BuildRequires: NetworkManager-devel startup-notification-devel
  25. # libxml2-devel needed for desktop file generation
  26. BuildRequires: libxml2-devel desktop-file-utils
  27. BuildRequires: pkgconfig
  28. Requires: %{name}-frontend = %{version}-%{release}
  29. Requires: hicolor-icon-theme
  30. %description
  31. Google Gadgets for Linux provides a platform for running desktop
  32. gadgets under Linux, catering to the unique needs of Linux users. It
  33. can run, without modification, many Google Desktop gadgets as well as
  34. the Universal Gadgets on iGoogle.
  35. %package gtk
  36. Summary: GTK+ front-end for %{name}
  37. Group: User Interface/Desktops
  38. Requires: %{name} = %{version}-%{release}
  39. Provides: %{name}-frontend = %{version}-%{release}
  40. %description gtk
  41. The %{name}-gtk package contains the GTK+ front-end for %{name}.
  42. %package qt
  43. Summary: Qt front-end for %{name}
  44. Group: User Interface/Desktops
  45. Requires: %{name} = %{version}-%{release}
  46. Provides: %{name}-frontend = %{version}-%{release}
  47. %description qt
  48. The %{name}-qt package contains the Qt front-end for %{name}.
  49. %package devel
  50. Summary: Development files for %{name}
  51. Group: Development/Libraries
  52. Requires: %{name} = %{version}-%{release}
  53. Requires: pkgconfig dbus-devel gtk2-devel qt4-devel
  54. Requires: %{name}-gtk
  55. Requires: %{name}-qt
  56. %description devel
  57. The %{name}-devel package contains libraries and header files for
  58. developing applications that use %{name}.
  59. %prep
  60. %setup -q -n %{name}-for-linux-%{version}
  61. %patch0 -p1 -b .gecko_ver
  62. # Permission fixes
  63. chmod -x ggadget/qt/utilities.h
  64. %build
  65. #autotools/bootstrap.sh
  66. #ln -s %{_datadir}/automake-*/mkinstalldirs libltdl/
  67. %configure --disable-static \
  68. --with-browser-plugins-dir=%{_libdir}/mozilla/plugins
  69. # Rpath fix by Mamoru Tasaka
  70. # we don't want to obliterate all RPATHs, since it is used during build
  71. # Add library search path
  72. sed -i.libdir_syssearch -e \
  73. '/sys_lib_dlsearch_path_spec/s|/usr/lib |/usr/lib /usr/lib64 /lib /lib64 |' \
  74. configure
  75. # Remove the redundant RPATH for %%{_libdir}, already searched by Fedora libtool
  76. sed -i.extra_R -e \
  77. 's|-R\$(libdir)||' \
  78. hosts/*/Makefile.in
  79. # default compile flags are impossibly strict
  80. make %{?_smp_mflags} DEFAULT_COMPILE_FLAGS=
  81. # Remove quotes from .pc files
  82. find . -name '*.pc' -exec sed -i 's|\"||g' '{}' \;
  83. %install
  84. rm -rf $RPM_BUILD_ROOT
  85. make install DESTDIR=$RPM_BUILD_ROOT \
  86. INSTALL="install -p" CPPROG="cp -p"
  87. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  88. # reinstall desktop files
  89. for i in gtk qt; do
  90. desktop-file-install \
  91. --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
  92. --delete-original \
  93. $RPM_BUILD_ROOT%{_datadir}/applications/ggl-$i.desktop
  94. done
  95. # wipe prematurely-generated MIME info
  96. rm -rf $RPM_BUILD_ROOT%{_datadir}/mime
  97. rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
  98. %clean
  99. rm -rf $RPM_BUILD_ROOT
  100. %post
  101. /sbin/ldconfig
  102. touch --no-create %{_datadir}/icons/hicolor || :
  103. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  104. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  105. fi
  106. %postun
  107. /sbin/ldconfig
  108. touch --no-create %{_datadir}/icons/hicolor || :
  109. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  110. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  111. fi
  112. %post gtk
  113. /sbin/ldconfig
  114. update-desktop-database &> /dev/null || :
  115. %postun gtk
  116. /sbin/ldconfig
  117. update-desktop-database &> /dev/null || :
  118. %post qt
  119. /sbin/ldconfig
  120. update-desktop-database &> /dev/null || :
  121. %postun qt
  122. /sbin/ldconfig
  123. update-desktop-database &> /dev/null || :
  124. %files
  125. %defattr(-,root,root,-)
  126. %doc AUTHORS COPYING README
  127. %{_libdir}/google-gadgets
  128. %exclude %{_libdir}/google-gadgets/gtkmoz-browser-child
  129. %exclude %{_libdir}/google-gadgets/modules/gtk*.so
  130. %exclude %{_libdir}/google-gadgets/modules/qt*.so
  131. %exclude %{_libdir}/google-gadgets/include
  132. %{_libdir}/lib*.so.*
  133. %exclude %{_libdir}/lib*gtk*
  134. %exclude %{_libdir}/lib*qt*
  135. %{_datadir}/google-gadgets
  136. %{_datadir}/pixmaps/google-gadgets.png
  137. %{_datadir}/icons/hicolor/*/*/*.png
  138. %files gtk
  139. %defattr(-,root,root,-)
  140. %{_bindir}/ggl-gtk
  141. %{_libdir}/libggadget-gtk*.so.*
  142. %{_libdir}/google-gadgets/gtkmoz-browser-child
  143. %{_libdir}/google-gadgets/modules/gtk*.so
  144. %{_datadir}/applications/*gtk.desktop
  145. %{_datadir}/applications/*designer.desktop
  146. %files qt
  147. %defattr(-,root,root,-)
  148. %{_bindir}/ggl-qt
  149. %{_libdir}/libggadget-qt*.so.*
  150. %{_libdir}/google-gadgets/modules/qt*.so
  151. %{_datadir}/applications/*qt.desktop
  152. %files devel
  153. %defattr(-,root,root,-)
  154. %{_includedir}/google-gadgets
  155. %{_libdir}/lib*.so
  156. %{_libdir}/google-gadgets/include
  157. %{_libdir}/pkgconfig/*.pc
  158. %changelog
  159. * Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.1-1
  160. - new upstream release
  161. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.0-2
  162. - Initial build for Vine Linux
  163. * Wed Jul 1 2009 Michel Salim <michel@erdos.localdomain> - 0.11.0-1
  164. - Update to 0.11.0
  165. * Sat May 2 2009 Michel Salim <salimma@fedoraproject.org> - 0.10.6-0.1.20090430svn1449%{?dist}
  166. - Update to SVN checkout, for xulrunner 1.9.1 compatibility
  167. * Mon Apr 27 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-6
  168. - Rebuild against newer gecko
  169. * Fri Mar 27 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-4
  170. - Rebuild against newer gecko
  171. * Fri Mar 06 2009 Jan Horak <jhorak@redhat.com> - 0.10.5-3
  172. - Rebuild against newer gecko
  173. * Wed Feb 04 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-2
  174. - Rebuild against newer gecko
  175. * Wed Jan 14 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.10.5-1
  176. - 0.10.5, req'd by kde
  177. * Tue Dec 30 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.4-2
  178. - BR: Network-Manager-devel, startup-notification-devel
  179. - Pass the browser plugin directory to ./configure
  180. - Move designer desktop entry to -gtk subpackage
  181. * Sat Dec 20 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.10.4-1
  182. - Update to 0.10.4 (#477251)
  183. - -devel: Requires: %%name-gtk %%name-qt (devel symlinks)
  184. - BR: pkgconfig (automatic pkgconfig deps)
  185. * Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.3-1
  186. - Update to 0.10.3
  187. * Sat Nov 8 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.10.1-5
  188. - s/qt-devel/qt4-devel/
  189. - -qt: fix summary
  190. * Tue Sep 2 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-4
  191. - Unquote version strings in .pc files
  192. * Thu Aug 28 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-3
  193. - RPATH and timestamp fixes from Mamoru Tasaka
  194. * Tue Aug 26 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-2
  195. - Fix desktop file creation
  196. * Mon Aug 25 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-1
  197. - Update to 0.10.1
  198. * Mon Jul 14 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.0-1
  199. - Update to 0.10.0
  200. - Add missing dependencies for -devel subpackage
  201. * Sun Jul 6 2008 Michel Salim <salimma@fedoraproject.org> - 0.9.3-1
  202. - Update to 0.9.3
  203. * Fri Jun 6 2008 Michel Salim <salimma@fedoraproject.org> - 0.9.1-1
  204. - Initial package