123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279 |
- %define _gnupg_ver 2.4.3
- %define _libgpg_error_ver 1.36
- %define _unpackaged_files_terminate_build 1
- Summary: GPGME - GnuPG Made Easy
- Summary(ja): GPGME - GnuPG Made Easy
- Name: gpgme
- Version: 1.22.0
- Release: 2%{?_dist_release}
- Group: system
- Vendor: Project Vine
- Distribution: Vine Linux
- License: LGPL
- URL: https://gnupg.org/software/gpgme/index.html
- Source: https://gnupg.org/ftp/gcrypt/gpgme/%{name}-%{version}.tar.bz2
- ## downstream patches
- # Don't add extra libs/cflags in gpgme-config/cmake equivalent
- Patch1001: 0001-don-t-add-extra-libraries-for-linking.patch
- # add -D_FILE_OFFSET_BITS... to gpgme-config, upstreamable
- Patch1002: gpgme-1.3.2-largefile.patch
- # Let's fix stupid AX_PYTHON_DEVEL
- Patch1003: 0001-fix-stupid-ax_python_devel.patch
- # Allow extra options to be passed to setup.py during installation
- Patch1004: 0002-setup_py_extra_opts.patch
- ## temporary downstream fixes
- # Skip lang/qt/tests/t-remarks on gnupg 2.4+
- Patch3001: 1001-qt-skip-test-remarks-for-gnupg2-2.4.patch
- # fix FTBFS caused by include path order, for <= 1.22.0
- Patch3002: gpgme-1.22.0-ftbfs-aee18a2a.patch
- Patch3003: gpgme-1.22.0-ftbfs-d23528ca.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: gnupg2 >= %{_gnupg_ver}
- BuildRequires: libgpg-error-devel >= %{_libgpg_error_ver}
- BuildRequires: libassuan-devel >= 2.4.2
- BuildRequires: chrpath
- BuildRequires: swig
- BuildRequires: python-rpm-macros
- BuildRequires: python3-devel
- BuildRequires: python3-setuptools
- BuildRequires: python3-rpm-macros
- Requires: gnupg2 >= %{_gnupg_ver}
- Requires: libgpg-error >= %{_libgpg_error_ver}
- Obsoletes: gpgme10
- Provides: gpgme10
- %description
- GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier
- for applications. It provides a High-Level Crypto API for encryption,
- decryption, signing, signature verification and key management. Currently it
- uses GnuPG as it's backend but the API isn't restricted to this engine; in
- fact it is planned to add other backends to it.
- %description -l ja
- GnuPG Made Easy (GPGME) は、アプリケーションがより簡単に GnuPG にアクセスでき
- るように設計されたライブラリです。暗号化や復号、署名、署名の検証、鍵の管理の
- ための高レベルの暗号 API を提供します。
- 現在のところ、バックエンドとして GnuPG を使用しますが、API はこのエンジンに限
- 定されません。実際、他のバックエンドを追加することが計画されています。
- %package devel
- Summary: GnuPG Made Easy (GPGME) Header files and libraries for development
- Summary(ja): GnuPG Made Easy (GPGME) 開発用ヘッダーファイル・ライブラリ
- Group: programming
- Requires: %{name} = %{version}
- Requires: libgpg-error-devel >= 0.5
- Requires: libassuan-devel >= 2.0.2
- Obsoletes: %{name} < 0.3.16-0vl2
- Obsoletes: gpgme10-devel
- Provides: gpgme10-devel
- %description devel
- GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier
- for applications.
- Install this package if you want to develop applications that will use the
- gpgme library.
- %description -l ja devel
- GnuPG Made Easy (GPGME) は、アプリケーションがより簡単に GnuPG にアクセスでき
- るように設計されたライブラリです。
- GPGME ライブラリを使用するアプリケーションを開発するのであれば、このパッケー
- ジをインストールしてください。
- %package -n python3-gpg
- Summary: %{name} bindings for Python 3
- Group: programming
- %{?python_provide:%python_provide python3-gpg}
- Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
- %description -n python3-gpg
- %{summary}.
- %prep
- %autosetup -p1
- ## HACK ALERT
- # The config script already suppresses the -L if it's /usr/lib, so cheat and
- # set it to a value which we know will be suppressed.
- sed -i -e 's|^libdir=@libdir@$|libdir=@exec_prefix@/lib|g' src/gpgme-config.in
- # The build machinery does not support Python 3.9+ yet
- # https://github.com/gpg/gpgme/pull/4
- sed -i 's/3.8/%{python3_version}/g' configure
- %build
- # Since 1.16.0, we need to explicitly pass -D_LARGEFILE_SOURCE and
- # -D_FILE_OFFSET_BITS=64 for the QT binding to build successfully on 32-bit
- # platforms.
- export CFLAGS='%{optflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64'
- export CXXFLAGS='%{optflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64'
- # Explicit new lines in C(XX)FLAGS can break naive build scripts
- export CFLAGS="$(echo ${CFLAGS} | tr '\n\\' ' ')"
- export CXXFLAGS="$(echo ${CXXFLAGS} | tr '\n\\' ' ')"
- export SETUPTOOLS_USE_DISTUTILS=local
- %configure \
- --disable-static \
- --disable-silent-rules \
- --enable-languages=cpp,python \
- --disable-gpgsm-test
- %make_build
- %install
- %__rm -rf %{buildroot}
- # When using distutils from setuptools 60+, ./setup.py install use
- # the .egg format. This forces setuptools to use .egg-info format.
- # SETUP_PY_EXTRA_OPTS is introduced by the Patch1004 above.
- export SETUPTOOLS_USE_DISTUTILS=local
- export SETUP_PY_EXTRA_OPTS="--single-version-externally-managed --root=/"
- %make_install
- # remove unneeded files
- %__rm -rf %{buildroot}%{_datadir}/common-lisp
- %__rm -f %{buildroot}%{_libdir}/*.la
- %__rm -f %{buildroot}%{_infodir}/dir
- chrpath -d %{buildroot}%{_bindir}/%{name}-tool
- chrpath -d %{buildroot}%{_bindir}/%{name}-json
- chrpath -d %{buildroot}%{_libdir}/lib%{name}*.so*
- # autofoo installs useless stuff for uninstall
- rm -vf %{buildroot}%{python2_sitelib}/gpg/install_files.txt
- rm -vf %{buildroot}%{python3_sitelib}/gpg/install_files.txt
- %clean
- %__rm -rf %{buildroot}
- %files
- %defattr(-,root,root)
- %license COPYING*
- %doc AUTHORS ChangeLog NEWS README* THANKS TODO VERSION
- %{_bindir}/gpgme-json
- %{_libdir}/libgpgme*.so.*
- %files devel
- %defattr(-,root,root)
- %{_bindir}/gpgme-config
- %{_bindir}/gpgme-tool
- %{_libdir}/libgpgme*.so
- %{_libdir}/cmake/*
- %{_libdir}/pkgconfig/*
- %{_datadir}/aclocal/gpgme.m4
- %{_includedir}/*
- %{_infodir}/*
- %files -n python3-gpg
- %doc lang/python/README
- %{python3_sitearch}/gpg-*.egg-info
- %{python3_sitearch}/gpg/
- %changelog
- * Thu Oct 19 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.22.0-2
- - fixed cmake files.
- * Thu Oct 19 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.22.0-1
- - new upstream release.
- - dropped python2 support.
- - dropped install-info scriptlets.
- - dropped ldconfig scriptlets.
- * Thu Feb 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.1-1
- - new upstream release.
- * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.0-1
- - new upstream release.
- * Thu Mar 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.1-1
- - new upstream release.
- * Fri Nov 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-2
- - enabled python{2,3} bindings.
- * Mon Nov 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-1
- - new upstream release.
- * Fri Jul 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.3-1
- - new upstream release.
- * Tue Apr 5 2011 IWAI, Masaharu <iwai@alib.jp> 1.3.0-1
- - new upstream release
- - add BuildRequires: libassuan-devel >= 2
- - add Requires: libassuan-devel >= 2 for devel subpackage
- - update GnuPG min version
- * Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.8-1
- - new upstream release
- * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.4-2vl5
- - removed *.la
- - spec in utf-8
- * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.4-1vl5
- - applied new versioning policy
- * Fri Mar 09 2007 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.1.4-0vl1
- - upstream release
- - add new macros: %%_gnupg_ver, %%_libgpg_error_ver
- - update %%_gnupg_ver to 1.3.0
- - update %%_libgpg_error_ver to 1.4
- * Tue Sep 27 2005 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.0.3-0vl1
- - upstream release
- * Sat Mar 12 2005 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.0.2-0vl3
- - add Obsoletes/Provides: gpgme10{,-devel}
- * Sun Feb 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
- - fix spec file's encoding from iso-2022-jp to euc-jp
- - add PreReq: ldconfig
- - add PreReq: install-info (devel)
- - change group to System Environment/Libraries (main)
- - add poor Japanese description
- * Tue Feb 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
- - upstream release
- - change license from GPL to LGPL
- - update {Build,}Requires for GnuPG (>= 1.2.2)
- - add (Build)Requires: libgpg-error(-devel) >= 0.5
- - add docs
- - run ldconfig at post/postun
- - separate devel package
- - Requires: libgpg-error-devel
- - Obsoletes: gpgme <= 0.3.16
- * Sun Apr 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.3.16-0vl1
- - update to 0.3.16
- - s/Copyright/License/
- - update URL
- * Fri Mar 7 2003 IWAI Masaharu <iwai@alib.jp> 0.3.15-0vl1
- - update to 0.3.15
- - update {Build,}Requires for GnuPG
- * Mon Sep 23 2002 IWAI Masaharu <iwai@alib.jp> 0.3.11-0vl1
- - update to 0.3.11
- - added {Build,}Requires: gnupg = 1.0.7
- - added info files
- - added %%post and %%preun section for info files
- - fixed %%install section (executing rm command)
- * Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.1-0vl1
- - initial release
|