libatomic_ops-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: libatomic_ops
  3. Summary: Atomic memory update operations
  4. Version: 7.6.14
  5. Release: 1%{?_dist_release}
  6. Group: system
  7. # libatomic_ops MIT, libatomic_ops_gpl GPLv2
  8. License: GPLv2 and MIT
  9. URL: https://www.hboehm.info/gc/
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Source0: https://www.hboehm.info/gc/gc_source/libatomic_ops-%{version}.tar.gz
  13. # updated GPLv2 license text
  14. Source1: http://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
  15. %description
  16. Provides implementations for atomic memory update operations on a
  17. number of architectures. This allows direct use of these in reasonably
  18. portable code. Unlike earlier similar packages, this one explicitly
  19. considers memory barrier semantics, and allows the construction of code
  20. that involves minimum overhead across a variety of architectures.
  21. %package devel
  22. Summary: Development files for %{name}
  23. Group: programming
  24. Requires: %{name}%{?_isa} = %{version}-%{release}
  25. %description devel
  26. Files for developing with %{name}.
  27. %package static
  28. Summary: Static library files for %{name}
  29. Group: programming
  30. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  31. %description static
  32. Files for developing with %{name} and linking statically.
  33. %package -n compat32-%{name}
  34. Summary: Atomic memory update operations
  35. Group: system,legacy
  36. Requires: %{name} = %{version}-%{release}
  37. %description -n compat32-%{name}
  38. Provides implementations for atomic memory update operations on a
  39. number of architectures. This allows direct use of these in reasonably
  40. portable code. Unlike earlier similar packages, this one explicitly
  41. considers memory barrier semantics, and allows the construction of code
  42. that involves minimum overhead across a variety of architectures.
  43. %package -n compat32-%{name}-devel
  44. Summary: Development files for %{name}
  45. Group: programming,legacy
  46. Requires: compat32-%{name} = %{version}-%{release}
  47. Requires: %{name}-devel = %{version}-%{release}
  48. %description -n compat32-%{name}-devel
  49. Files for developing with %{name}.
  50. %debug_package
  51. %prep
  52. %autosetup -p1
  53. install -m644 -p %{SOURCE1} ./COPYING
  54. %build
  55. %configure \
  56. --enable-shared \
  57. --disable-silent-rules
  58. make %{?_smp_mflags}
  59. %install
  60. make install DESTDIR=%{buildroot}
  61. ## unpackaged files
  62. rm -fv %{buildroot}%{_libdir}/lib*.la
  63. # omit dup'd docs
  64. rm -fv %{buildroot}%{_datadir}/libatomic_ops/{COPYING,README*,*.txt}
  65. rm -rf %{buildroot}%{_docdir}/libatomic_ops
  66. %check
  67. ## ignore failures on powerpc, atomic stack feature not working (#883748)
  68. #ifarch ppc ppc64 ppc64le aarch64
  69. #global arch_ignore ||:
  70. #endif
  71. make check %{?arch_ignore}
  72. %files
  73. %license COPYING doc/LICENSING.txt
  74. %doc AUTHORS ChangeLog README.md
  75. %{_libdir}/libatomic_ops.so.1*
  76. %{_libdir}/libatomic_ops_gpl.so.1*
  77. %files devel
  78. %doc doc/README*
  79. %{_includedir}/atomic_ops.h
  80. %{_includedir}/atomic_ops_malloc.h
  81. %{_includedir}/atomic_ops_stack.h
  82. %{_includedir}/atomic_ops/
  83. %{_libdir}/libatomic_ops.so
  84. %{_libdir}/libatomic_ops_gpl.so
  85. %{_libdir}/pkgconfig/atomic_ops.pc
  86. %files static
  87. %{_libdir}/libatomic_ops.a
  88. %{_libdir}/libatomic_ops_gpl.a
  89. %if %{build_compat32}
  90. %files -n compat32-%{name}
  91. %defattr(-,root,root)
  92. %{_libdir}/libatomic_ops.so.1*
  93. %{_libdir}/libatomic_ops_gpl.so.1*
  94. %files -n compat32-%{name}-devel
  95. %defattr(-,root,root)
  96. %{_libdir}/libatomic_ops.so
  97. %{_libdir}/libatomic_ops_gpl.so
  98. %{_libdir}/pkgconfig/atomic_ops.pc
  99. %endif
  100. %changelog
  101. * Fri Nov 18 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.6.14-1
  102. - new upstream release.
  103. - dropped ldconfig scriptlets.
  104. * Tue Sep 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.6.10-1
  105. - new upstream release.
  106. - dropped all patches.
  107. * Sat Jul 2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.4.4-4
  108. - added compat32 packages.
  109. * Sat Jul 2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.4.4-3
  110. - fixed %%changelog.
  111. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.4.4-2
  112. - imported all stuff from rawhide.
  113. * Fri Jun 17 2016 Rex Dieter <rdieter@fedoraproject.org> - 7.4.4-1
  114. - libatomic_ops-7.4.4 (#1346524)
  115. * Mon Mar 28 2016 Rex Dieter <rdieter@fedoraproject.org> 7.4.2-9
  116. - make check fails on test_stack for ppc64le arch (#1096574), drop reference to 0032.patch
  117. * Mon Mar 28 2016 Rex Dieter <rdieter@fedoraproject.org> - 7.4.2-8
  118. - pull in upstream (7.4 branch) fixes
  119. - Add support for 64-bit MIPS (#1317509)
  120. - use %%license
  121. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 7.4.2-7
  122. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  123. * Tue Jul 7 2015 Peter Robinson <pbrobinson@fedoraproject.org> 7.4.2-6
  124. - Don't fail check on aarch64
  125. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.4.2-5
  126. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  127. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.4.2-4
  128. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  129. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.4.2-3
  130. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  131. * Tue May 13 2014 Rex Dieter <rdieter@fedoraproject.org> 7.4.2-2
  132. - link libatomic_ops_gpl against libatomic_ops for missing symbol(s)
  133. * Tue May 13 2014 Rex Dieter <rdieter@fedoraproject.org> 7.4.2-1
  134. - libatomic_opts-7.4.2
  135. - new upstream/source URLs
  136. - %%check: skip ppc64le too
  137. - License: MIT and GPLv2
  138. - update/longer %%description
  139. - updated GPLv2 license text (with correct address)
  140. * Wed Dec 04 2013 Rex Dieter <rdieter@fedoraproject.org> 7.4.0-1
  141. - separate libatomic_ops lives again!
  142. * Fri Jul 24 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.2-8.gc
  143. - use gc tarball, tag gc release
  144. * Thu Jul 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.2-7
  145. - devel: Provides: %%name-static ...
  146. - consolidate %%doc's
  147. - %%files: track libs
  148. * Wed May 20 2009 Dan Horak <dan[t]danny.cz> - 1.2-6
  149. - added fix for s390
  150. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-5
  151. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  152. * Thu May 22 2008 Jon Stanley <jonstanley@gmail.com> - 1.2-4
  153. - Fix license tag
  154. * Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
  155. - initial build for Vine Linux
  156. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2-3
  157. - Autorebuild for GCC 4.3
  158. * Tue May 29 2007 Pierre Ossman <drzeus@drzeus.cx> 1.2-2
  159. - Added fix for PPC AO_load_acquire.
  160. * Fri Nov 10 2006 Pierre Ossman <drzeus@drzeus.cx> 1.2-1
  161. - Update to 1.2.
  162. * Sat Sep 9 2006 Pierre Ossman <drzeus@drzeus.cx> 1.1-2
  163. - Fix naming of package.
  164. - General cleanup of spec file.
  165. * Wed Aug 30 2006 Pierre Ossman <drzeus@drzeus.cx> 1.1-1
  166. - Initial package for Fedora Extras.