avogadro-vl.spec 7.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249
  1. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.1)
  2. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
  3. %define ENABLE_TESTS -DENABLE_TESTS:BOOL=ON
  4. Name: avogadro
  5. Summary: An advanced molecular editor for chemical purposes
  6. Version: 1.0.1
  7. Release: 6%{?_dist_release}
  8. Group: Applications/Editors
  9. License: GPLv2
  10. URL: http://avogadro.openmolecules.net/
  11. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
  12. # fix FTBFS with SIP 4.11 (Gentoo#335644)
  13. # patch submitted: http://bugs.gentoo.org/attachment.cgi?id=247308 (upstream is
  14. # CCed on the Gentoo bug)
  15. Patch0: avogadro-1.0.1-sip411.patch
  16. # fix crash with current SIP and Python 2.7 (#642248)
  17. Patch1: avogadro-1.0.1-pycapsule.patch
  18. BuildRequires: cmake >= 2.6.0
  19. BuildRequires: qt4-designer >= 4.5.1
  20. BuildRequires: qt4-devel >= 4.5.1
  21. BuildRequires: eigen2-devel >= 2.0.3
  22. BuildRequires: openbabel-devel >= 2.2.2
  23. BuildRequires: libboost-devel >= 1.35
  24. BuildRequires: glew-devel >= 1.5.0
  25. BuildRequires: desktop-file-utils
  26. BuildRequires: docbook-utils
  27. BuildRequires: sip-devel
  28. BuildRequires: numpy
  29. Requires: %{name}-libs = %{version}-%{release}
  30. %description
  31. An advanced molecular editor designed for
  32. cross-platform use in computational chemistry,
  33. molecular modeling, bioinformatics, materials science,
  34. and related areas, which offers flexible rendering and
  35. a powerful plugin architecture.
  36. %package libs
  37. Summary: Shared libraries for Avogadro
  38. Group: System Environment/Libraries
  39. Requires: sip
  40. %description libs
  41. This package contains the shared libraries for the
  42. molecular editor Avogadro.
  43. %package devel
  44. Summary: Development files for Avogadro
  45. Group: Development/Libraries
  46. Requires: %{name}-libs = %{version}-%{release}
  47. Requires: qt4-devel = %{_qt4_version}
  48. %description devel
  49. This package contains files to develop applications using
  50. Avogadros libraries.
  51. %prep
  52. %setup -q
  53. %patch0 -p1 -b .sip411
  54. %patch1 -p1 -b .pycapsule
  55. # nuke unpatched copy, use working version included in cmake instead -- Rex
  56. rm -f cmake/modules/FindPythonLibs.cmake
  57. %build
  58. mkdir -p %{_target_platform}
  59. pushd %{_target_platform}
  60. cmake -Wno-dev \
  61. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  62. -DBIN_INSTALL_DIR:PATH=bin \
  63. -DLIB_INSTALL_DIR:PATH=%{_lib} \
  64. -DENABLE_GLSL:BOOL=ON \
  65. -DENABLE_PYTHON:BOOL=ON \
  66. %{?ENABLE_TESTS} ..
  67. popd
  68. make %{?_smp_mflags} -C %{_target_platform}
  69. %install
  70. rm -rf $RPM_BUILD_ROOT
  71. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  72. %check
  73. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/avogadro.desktop
  74. # all of these currently require an active X session, so will fail
  75. # in mock
  76. %{?ENABLE_TESTS:make test -C %{_target_platform} ||:}
  77. %post libs -p /sbin/ldconfig
  78. %postun libs -p /sbin/ldconfig
  79. %files
  80. %defattr(-,root,root,-)
  81. %doc AUTHORS ChangeLog COPYING
  82. %{_bindir}/avogadro
  83. %{_bindir}/avopkg
  84. # TODO: %lang'ify stuff under %%{_datadir}/avogadro/i18n/
  85. %{_datadir}/avogadro/
  86. %{_datadir}/pixmaps/avogadro-icon.png
  87. %{_datadir}/applications/avogadro.desktop
  88. %{_mandir}/man1/avogadro.1*
  89. %{_mandir}/man1/avopkg.1*
  90. %files devel
  91. %defattr(-,root,root,-)
  92. %{_includedir}/avogadro/
  93. %{_libdir}/libavogadro.so
  94. %{_libdir}/avogadro/*.cmake
  95. %{_libdir}/avogadro/1_0/*.cmake
  96. # these look like dups of system copies?, take a closer look and/or ask upstream -- Rex
  97. %{_libdir}/avogadro/1_0/cmake/
  98. %{_qt4_prefix}/mkspecs/features/avogadro.prf
  99. %files libs
  100. %defattr(-,root,root,-)
  101. %{python_sitelib}/Avogadro.so
  102. %{_datadir}/libavogadro/
  103. %{_libdir}/libavogadro.so.1*
  104. %dir %{_libdir}/avogadro/
  105. %dir %{_libdir}/avogadro/1_0/
  106. %{_libdir}/avogadro/1_0/colors/
  107. %{_libdir}/avogadro/1_0/extensions/
  108. %{_libdir}/avogadro/1_0/engines/
  109. %{_libdir}/avogadro/1_0/tools/
  110. %changelog
  111. * Wed Feb 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-6
  112. - rebuilt with qt4-4.7.1
  113. - added Patch0 and 1 from Fedora
  114. * Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> - 1.0.1-5
  115. - rebuilt with libboost-1.45.0
  116. * Fri Aug 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-4
  117. - Initial build for Vine Linux
  118. * Wed Aug 04 2010 Rahul Sundaram <sundaram@fedoraproject.org> - 1.0.1-3
  119. - Rebuild for Boost soname bump
  120. - Update to match current guidelines
  121. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.0.1-2
  122. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  123. * Mon May 24 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.1-1
  124. - avogadro-1.0.1
  125. - -devel: move cmake-related files here
  126. - -devel: Req: qt4-devel
  127. - %%files: track lib sonames
  128. - %%check section
  129. * Wed Feb 10 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.0-6
  130. - reenable plugin builds and libs subpackage
  131. - fix their build with sip 4.10
  132. * Fri Jan 08 2010 Sebastian Dziallas <sebastian@when.com> - 1.0.0-5
  133. - disable plugin builds and libs subpackage
  134. * Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-4
  135. - rebuild (sip)
  136. * Mon Nov 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-3
  137. - rebuild (for qt-4.6.0-rc1, f13+)
  138. * Mon Nov 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-2
  139. - -libs: Requires: sip-api(%%_sip_api_major) >= %%_sip_api (#538124)
  140. - Requires: %%{name}-libs ...
  141. * Thu Oct 29 2009 Sebastian Dziallas <sebastian@when.com> 1.0.0-1
  142. - update to new upstream release
  143. * Tue Oct 20 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.8-3
  144. - rebuild (eigen2)
  145. * Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-2
  146. - fix typo in file list
  147. * Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-1
  148. - update to new upstream release
  149. - enable python and glsl support again
  150. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-2
  151. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  152. * Sat Jun 06 2009 Sebastian Dziallas <sebastian@when.com> 0.9.6-1
  153. - new upstream release to fix issue with qt 4.5.0 and earlier
  154. * Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-3
  155. - remove remaining python parts
  156. - fix files section finally
  157. * Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-2
  158. - disable python and glsl for now
  159. - fix files section
  160. * Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-1
  161. - update to new release
  162. * Tue May 12 2009 Sebastian Dziallas <sebastian@when.com> 0.9.4-1
  163. - update to new release
  164. * Fri Apr 10 2009 Sebastian Dziallas <sebastian@when.com> 0.9.3-1
  165. - update to new release
  166. * Sat Mar 21 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-2
  167. - get desktop file properly installed
  168. * Sat Mar 14 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-1
  169. - update to new release
  170. * Wed Feb 25 2009 Sebastian Dziallas <sebastian@when.com> 0.9.1-1
  171. - update to new release
  172. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-2
  173. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  174. * Thu Jan 22 2009 Sebastian Dziallas <sebastian@when.com> 0.9.0-1
  175. - update to new release
  176. * Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-6
  177. - add handbook to docs
  178. * Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-5
  179. - add build requirements and fix group names
  180. * Wed Aug 13 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-4
  181. - fix typos
  182. * Sat Aug 9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-3
  183. - reorganize spec file
  184. * Sat Aug 9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-2
  185. - rename shared library package and structure spec file
  186. * Sun Aug 3 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-1
  187. - initial pacakging release based on PackMan release