PyOpenGL-vl.spec 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116
  1. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %define pyver %(python -c 'import sys;print(sys.version[0:3])')
  3. Name: PyOpenGL
  4. Version: 3.0.0
  5. Release: 2%{_dist_release}
  6. Summary: Python bindings for OpenGL
  7. License: BSD
  8. Group: System Environment/Libraries
  9. URL: http://pyopengl.sourceforge.net/
  10. Source0: http://downloads.sourceforge.net/pyopengl/%{name}-%{version}.tar.gz
  11. Patch0: PyOpenGL-3.0.0a6-shebang.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: python-devel python-setuptools
  14. BuildArch: noarch
  15. Requires: python-numeric python-setuptools
  16. Requires: freeglut
  17. # in some other repositories this is named python-opengl
  18. Provides: python-opengl = %{version}-%{release}
  19. Obsoletes: python-opengl < %{version}-%{release}
  20. %description
  21. PyOpenGL is the cross platform Python binding to OpenGL and related APIs. It
  22. includes support for OpenGL v1.1, GLU, GLUT v3.7, GLE 3 and WGL 4. It also
  23. includes support for dozens of extensions (where supported in the underlying
  24. implementation).
  25. PyOpenGL is interoperable with a large number of external GUI libraries
  26. for Python including (Tkinter, wxPython, FxPy, PyGame, and Qt).
  27. %package Tk
  28. Summary: %{name} OpenGL Tk widget
  29. Group: System Environment/Libraries
  30. Requires: %{name} = %{version}-%{release}, tkinter
  31. %description Tk
  32. %{name} Togl (Tk OpenGL widget) 1.6 support.
  33. %package doc
  34. Summary: Documentation files for %{name}
  35. Group: Development/Languages
  36. Requires: %{name} = %{version}-%{release}
  37. %description doc
  38. Documentation files for %{name}.
  39. %prep
  40. %setup -q
  41. %patch0 -p1 -z .shebang
  42. %build
  43. python setup.py build
  44. %install
  45. rm -rf $RPM_BUILD_ROOT
  46. python setup.py install -O1 --skip-build --root="$RPM_BUILD_ROOT" \
  47. --prefix="%{_prefix}"
  48. chmod -x $RPM_BUILD_ROOT%{python_sitelib}/%{name}-%{version}-py%{pyver}.egg-info
  49. %clean
  50. rm -rf $RPM_BUILD_ROOT
  51. %files
  52. %defattr(-,root,root,-)
  53. %doc license.txt
  54. %{python_sitelib}/*OpenGL*
  55. %exclude %{python_sitelib}/OpenGL/Tk
  56. %files Tk
  57. %defattr(-,root,root,-)
  58. %{python_sitelib}/OpenGL/Tk
  59. %files doc
  60. %defattr(-,root,root,-)
  61. %doc documentation/*
  62. %changelog
  63. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 3.0.0-2
  64. - rebuilt with python-2.6.4
  65. * Sat Jul 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
  66. - new upstream release 3.0.0
  67. - remove Requires: XOrg-gl (libGL should be pulled by freeglut)
  68. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.0-0.b1.2
  69. - rebuilt with python-2.5.2
  70. * Mon Apr 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.0.0-0.b1.1
  71. - Initial build for Vine Linux
  72. * Mon Dec 31 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.5.b1
  73. - New upstream release 3.0.0b1
  74. * Thu Aug 30 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.4.a6
  75. - Change BuildRequires python-setuptools to python-setuptools-devel for
  76. the python-setuptools package split
  77. * Fri Apr 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.3.a6
  78. - Add missing freeglut, libGL and libGLU requires (bz 236159)
  79. * Thu Mar 29 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.2.a6
  80. - Remove tests from the package (bz 234121)
  81. - Add -Tk subpackage (bz 234121)
  82. - Remove shebang from files with shebang instead of chmod +x (bz 234121)
  83. - Better description
  84. * Sat Mar 24 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.1.a6
  85. - Initial Fedora Extras package