glib2-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define _unpackaged_files_terminate_build 1
  3. Summary: A library of handy utility functions.
  4. Name: glib2
  5. Version: 2.62.2
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Libraries
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
  11. License: LGPLv2+
  12. URL: http://www.gtk.org
  13. %define shortver %(echo %{version} | cut -d. -f1-2)
  14. Source: https://download.gnome.org/sources/glib/%{shortver}/glib-%{version}.tar.xz
  15. Source2: glib2.sh
  16. Source3: glib2.csh
  17. BuildRoot: %{_tmppath}/glib-%{version}-root
  18. BuildRequires: dbus-devel
  19. BuildRequires: docbook-style-xsl
  20. BuildRequires: gamin-devel
  21. BuildRequires: libattr-devel
  22. BuildRequires: libffi-devel
  23. BuildRequires: libmount-devel
  24. BuildRequires: libxslt
  25. BuildRequires: meson
  26. BuildRequires: pcre-devel >= 8.13
  27. BuildRequires: pkgconfig >= 0.14
  28. BuildRequires: python3-devel
  29. BuildRequires: zlib-devel
  30. Obsoletes: glib-gtkbeta
  31. # for gio-querymodules
  32. Requires(post,postun): libffi
  33. %description
  34. GLib is the low-level core library that forms the basis
  35. for projects such as GTK+ and GNOME. It provides data structure
  36. handling for C, portability wrappers, and interfaces for such runtime
  37. functionality as an event loop, threads, dynamic loading, and an
  38. object system.
  39. This package provides version %{shortver} of GLib.
  40. %package devel
  41. Summary: Development files for the GLib library
  42. Group: Development/Libraries
  43. Requires: %{name} = %{version}
  44. Requires: pkgconfig >= 0.14
  45. Requires: libffi-devel
  46. Requires: zlib-devel
  47. Obsoletes: glib-gtkbeta-devel
  48. Conflicts: glib-devel <= 1.2.8
  49. %description devel
  50. The glib-devel package includes the header files for
  51. version %{shortver} of the GLib library.
  52. ## to build compat32 for x86_64 architecture support
  53. %package -n compat32-%{name}
  54. Summary: A library of handy utility functions.
  55. Group: System Environment/Libraries
  56. %description -n compat32-%{name}
  57. GLib is the low-level core library that forms the basis
  58. for projects such as GTK+ and GNOME. It provides data structure
  59. handling for C, portability wrappers, and interfaces for such runtime
  60. functionality as an event loop, threads, dynamic loading, and an
  61. object system.
  62. This package provides version %{shortver} of GLib.
  63. %package -n compat32-%{name}-devel
  64. Summary: Development files for the GLib library
  65. Group: Development/Libraries
  66. Requires: pkgconfig >= 0.14
  67. Requires: compat32-%{name} = %{version}
  68. Conflicts: glib-devel <= 1.2.8
  69. %description -n compat32-%{name}-devel
  70. The glib-devel package includes the header files for
  71. version %{shortver} of the GLib library.
  72. %prep
  73. %setup -q -n glib-%{version}
  74. %build
  75. %meson \
  76. -Dselinux=disabled \
  77. -Dman=true
  78. %meson_build
  79. %install
  80. rm -rf $RPM_BUILD_ROOT
  81. %meson_install
  82. ## glib2.sh and glib2.csh
  83. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  84. install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  85. install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  86. #mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
  87. #ln -sf %{_libdir}/gdbus-2.0/codegen $RPM_BUILD_ROOT%{python_sitearch}/codegen
  88. mkdir -p $RPM_BUILD_ROOT%{_libdir}/gio/modules
  89. touch $RPM_BUILD_ROOT%{_libdir}/gio/modules/giomodule.cache
  90. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  91. rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
  92. rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
  93. %find_lang glib20
  94. %clean
  95. rm -rf $RPM_BUILD_ROOT
  96. %post
  97. /sbin/ldconfig
  98. gio-querymodules %{_libdir}/gio/modules
  99. %postun
  100. /sbin/ldconfig
  101. gio-querymodules %{_libdir}/gio/modules
  102. %post -n compat32-%{name} -p /sbin/ldconfig
  103. %postun -n compat32-%{name} -p /sbin/ldconfig
  104. %files -f glib20.lang
  105. %defattr(-, root, root)
  106. %license COPYING
  107. %doc AUTHORS NEWS README*
  108. %{_bindir}/gapplication
  109. %{_bindir}/gdbus
  110. %{_bindir}/gio
  111. %{_bindir}/gio-launch-desktop
  112. %{_bindir}/gio-querymodules
  113. %{_bindir}/glib-compile-schemas
  114. %{_bindir}/gsettings
  115. %{_libdir}/libglib-2.0.so.*
  116. %{_libdir}/libgthread-2.0.so.*
  117. %{_libdir}/libgmodule-2.0.so.*
  118. %{_libdir}/libgobject-2.0.so.*
  119. %{_libdir}/libgio-2.0.so.*
  120. %dir %{_libdir}/gio
  121. %dir %{_libdir}/gio/modules
  122. #%{_libdir}/gio/modules/giomodule.cache
  123. #%{_libdir}/gio/modules/lib*.so
  124. %{_sysconfdir}/profile.d/*
  125. %dir %{_datadir}/bash-completion/completions
  126. %dir %{_datadir}/bash-completion
  127. %{_datadir}/bash-completion/completions/gapplication
  128. %{_datadir}/bash-completion/completions/gdbus
  129. %{_datadir}/bash-completion/completions/gio
  130. %{_datadir}/bash-completion/completions/gsettings
  131. %files devel
  132. %defattr(-, root, root)
  133. %{_bindir}/gdbus-codegen
  134. %{_bindir}/glib-compile-resources
  135. %{_bindir}/glib-genmarshal
  136. %{_bindir}/glib-gettextize
  137. %{_bindir}/glib-mkenums
  138. %{_bindir}/gobject-query
  139. %{_bindir}/gresource
  140. %{_bindir}/gtester
  141. %{_bindir}/gtester-report
  142. %{_libdir}/lib*.so
  143. #%{_libdir}/lib*.a
  144. #%{_libdir}/gdbus-2.0/codegen/*
  145. %{_libdir}/glib-2.0
  146. %{_libdir}/pkgconfig/*
  147. #%{python_sitearch}/codegen
  148. %{_includedir}/*
  149. %{_datadir}/aclocal/*
  150. %{_datadir}/glib-2.0
  151. %{_datadir}/gettext/its/gschema.its
  152. %{_datadir}/gettext/its/gschema.loc
  153. #%doc %{_datadir}/gtk-doc/html/*
  154. %doc %{_mandir}/man1/*
  155. %{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
  156. %{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
  157. %dir %{_datadir}/bash-completion/completions
  158. %dir %{_datadir}/bash-completion
  159. %{_datadir}/bash-completion/completions/gresource
  160. %if %{build_compat32}
  161. %files -n compat32-%{name}
  162. %defattr(-, root, root)
  163. %{_libdir}/libglib-2.0.so.*
  164. %{_libdir}/libgthread-2.0.so.*
  165. %{_libdir}/libgmodule-2.0.so.*
  166. %{_libdir}/libgobject-2.0.so.*
  167. %{_libdir}/libgio-2.0.so.*
  168. %dir %{_libdir}/gio
  169. %dir %{_libdir}/gio/modules
  170. %files -n compat32-%{name}-devel
  171. %defattr(-, root, root)
  172. %{_libdir}/lib*.so
  173. %{_libdir}/glib-2.0
  174. %endif
  175. %changelog
  176. * Fri Nov 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.62.2-1
  177. - new upstream release.
  178. * Sat Apr 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.58.3-1
  179. - new upstream release.
  180. * Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.58.2-1
  181. - new upstream release.
  182. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.55.0-1
  183. - new upstream release.
  184. - dropped Patch0: fixed in upstream.
  185. - added BR:libmount-devel.
  186. * Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.48.1-1
  187. - new upstream release
  188. - add BuildRequires: pcre-devel
  189. * Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.2-2
  190. - add Requires: libffi
  191. * Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.2-1
  192. - new upstream release
  193. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.1-1
  194. - new upstream release
  195. * Thu May 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.1-1
  196. - new upstream release
  197. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.0-1
  198. - new upstream release
  199. * Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.2-1
  200. - new upstream release
  201. * Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.1-1
  202. - new upstream release
  203. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.0-1
  204. - new upstream release
  205. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-2
  206. - rebuild with libffi-3.0.13
  207. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-1
  208. - new upstream release
  209. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.2-1
  210. - new upstream release
  211. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.1-1
  212. - new upstream release
  213. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
  214. - new upstream release
  215. - remove Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
  216. * Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
  217. - new upstream release
  218. - add Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
  219. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.2-1
  220. - new upstream release
  221. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
  222. - new upstream release
  223. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.3-1
  224. - new upstream release
  225. * Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
  226. - new upstream release
  227. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
  228. - new upstream release
  229. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
  230. - new upstream release
  231. * Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.4-1
  232. - new upstream release
  233. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
  234. - new upstream release
  235. * Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
  236. - new upstream release
  237. * Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
  238. - new upstream release
  239. - add BuildRequires: python-devel
  240. - add Patch0 (glib-2.32.1-dconf-path.patch)
  241. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  242. - new upstream release
  243. * Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  244. - new upstream release
  245. * Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  246. - new upstream release
  247. - add Requires: libffi-devel, zlib-devel (-devel sub package)
  248. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
  249. - new upstream release
  250. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
  251. - new upstream release
  252. - remove Patch0,1
  253. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
  254. - new upstream release
  255. - Patch0: glib-2.29.16-fixes-bug-656387.patch
  256. - Patch1: glib-2.29.16-fixes-bug-656675.patch
  257. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
  258. - new upstream release
  259. - add BuildRequires: libffi-devel, dbus-devel
  260. * Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
  261. - new upstream release
  262. * Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
  263. - new upstream release
  264. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
  265. - new upstream release
  266. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
  267. - new upstream release
  268. * Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
  269. - new upstream release
  270. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  271. - new upstream release
  272. * Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
  273. - new upstream release
  274. * Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  275. - new upstream release
  276. * Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
  277. - move the following files from glib2-devel to glib2 package
  278. (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
  279. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
  280. - new upstream release
  281. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
  282. - new upstream release
  283. - fix Source (add URL)
  284. - fix %files to add /etc/bash_completion.d files
  285. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
  286. - build with rpm-4.8.1-1 for pkg-config file
  287. * Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
  288. - new upstream release
  289. * Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
  290. - new upstream release
  291. * Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
  292. - new upstream release
  293. - add BuildRequires: zlib-devel
  294. * Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
  295. - new upstream release
  296. * Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
  297. - new upstream release
  298. * Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
  299. - new upstream release
  300. * Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  301. - new upstream release
  302. * Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
  303. - new upstream release
  304. * Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
  305. - new upstream release
  306. * Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
  307. - new upstream release
  308. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
  309. - new upstream release
  310. * Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
  311. - new upstream release
  312. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
  313. - new upstream release
  314. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
  315. - new upstream release
  316. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
  317. - new upstream release
  318. * Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
  319. - new upstream release
  320. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
  321. - new upstream release
  322. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
  323. - new upstream release
  324. * Mon Jul 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
  325. - new upstream release
  326. * Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
  327. - updated %%if %%{build_compat32} case related statements
  328. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
  329. - new upstream release
  330. - removed lib*.la files from devel package
  331. * Sun Apr 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
  332. - new upstream release
  333. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
  334. - added %%{?_dist_release}
  335. - BuildRequires: gamin-devel
  336. * Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
  337. - new upstream release
  338. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
  339. - new upstream release
  340. * Wed Jan 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
  341. - new upstream release
  342. * Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
  343. - new upstream release
  344. * Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
  345. - new upstream release
  346. - removed BuildRequires: automake17
  347. * Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
  348. - new upstream release
  349. * Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
  350. - new upstream release
  351. * Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
  352. - new upstream release
  353. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
  354. - rebuild with new environment
  355. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
  356. - new upstream release
  357. * Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
  358. - new upstream release
  359. * Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
  360. - new upstream release
  361. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
  362. - new upstream release
  363. * Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
  364. - new upstream release
  365. * Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
  366. - new upstream release
  367. * Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
  368. - new upstream release
  369. * Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
  370. - rebuild
  371. * Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
  372. - update glib2.{sh,csh}
  373. - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
  374. * Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
  375. - new upstream release
  376. * Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
  377. - new upstream release
  378. * Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
  379. - new upstream release
  380. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  381. - new upstream release
  382. * Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
  383. - added compat32-* packages for x86_64 architecture support
  384. - chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
  385. * Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
  386. - new upstream release
  387. * Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
  388. - new upstream release
  389. * Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
  390. - new upstream release
  391. * Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
  392. - new upstream release
  393. * Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
  394. - fixed typo in glib2.csh
  395. * Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
  396. - update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
  397. G_BROKEN_FILENAMES.
  398. * Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
  399. - new upstream release
  400. * Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
  401. - new upstream release
  402. * Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
  403. - new upstream release
  404. * Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
  405. - new upstream release
  406. * Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
  407. - new upstream release
  408. * Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
  409. - new upstream release
  410. - add *.la to build arts (should be fixed in arts?)
  411. * Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
  412. - new upstream release
  413. * Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
  414. - new upstream release
  415. * Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
  416. - new upstream release
  417. * Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
  418. - new upstream release
  419. * Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
  420. - new upstream release
  421. * Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
  422. - rebuilt
  423. * Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
  424. - new upstream release
  425. * Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
  426. - new upstream release
  427. * Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
  428. - new upstream release
  429. * Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
  430. - new upstream release
  431. * Sat Jun 5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
  432. - new upstream release
  433. * Sat May 1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
  434. - new upstream release
  435. * Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  436. - new upstream release
  437. * Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
  438. - rebuild with new toolchain
  439. * Sat Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
  440. - new upstream release
  441. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
  442. - new upstream release
  443. * Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
  444. - new upstream release
  445. * Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  446. - new upstream release
  447. * Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
  448. - new upstream release
  449. - build for Vine Linux
  450. * Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
  451. - install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
  452. - blow away unpackaged files in install
  453. * Thu Aug 8 2002 Owen Taylor <otaylor@redhat.com>
  454. - Version 2.0.6
  455. - Remove fixed-ltmain.sh; shouldn't be needed any more.
  456. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  457. - automated rebuild
  458. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  459. - 2.0.4
  460. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  461. - automated rebuild
  462. * Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
  463. - rebuild in different environment
  464. * Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
  465. - Fix missing .po files (#63336)
  466. * Wed Apr 3 2002 Alex Larsson <alexl@redhat.com>
  467. - Update to version 2.0.1
  468. * Fri Mar 8 2002 Owen Taylor <otaylor@redhat.com>
  469. - Version 2.0.0
  470. * Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
  471. - Update to 1.3.15
  472. * Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
  473. - Bump for rebuild
  474. * Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
  475. - Update to 1.3.14
  476. * Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
  477. - add horrible buildrequires hack
  478. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  479. - 1.3.13.91 cvs snap
  480. * Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
  481. - rebuild from CVS snapshot
  482. - use setup -q
  483. * Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
  484. - rebuild
  485. * Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
  486. - 1.3.13
  487. * Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
  488. - attempting rebuild in rawhide
  489. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  490. - remove 64-bit patch now upstream, 1.3.12.90
  491. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  492. - add some missing files to file list, langify
  493. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  494. - add temporary patch to fix GTypeFundamentals on 64-bit
  495. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  496. - Version 1.3.11
  497. * Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
  498. - Version 1.3.10
  499. * Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
  500. - Version 1.3.9
  501. * Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
  502. - Version 1.3.8
  503. * Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
  504. - Make -devel package require main package (#45388)
  505. - Fix description and summary
  506. - Configure with --disable-gtk-doc
  507. * Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  508. - add some portability fixes needed at least on s390
  509. - copy config.{guess,sub} instead of calling libtoolize
  510. * Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
  511. - try a new glib tarball with Makefile changes to work around
  512. libtool linking to installed .la files
  513. - make -devel require pkgconfig
  514. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  515. - either libtool or the bad libtool hacks caused link
  516. against glib-gobject 1.3.2, rebuild
  517. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  518. - 1.3.6
  519. - bad libtool workarounds
  520. * Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
  521. - 1.3.5, rename to glib2
  522. * Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
  523. - Final 1.3.2
  524. * Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
  525. - Version 1.3.2pre1
  526. - Remove pkgconfig
  527. * Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
  528. - Call 1.3.1b instead of snap... the snap* naming doesn't
  529. order correctly.
  530. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  531. - new snapshot with fixed .pc files
  532. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  533. - include .pc files in file list
  534. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  535. - Include pkg-config
  536. - Upgrade to a glib CVS snapshot
  537. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  538. - rebuild to cope with glibc locale binary incompatibility
  539. * Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
  540. - Remove glib-config.1 manpage from build since
  541. it conflicts with glib-devel. When we go to
  542. glib glib1.2 setup, we should add it back
  543. * Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
  544. - Version 1.3.1
  545. - Move back to standard %{prefix}
  546. * Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
  547. - Rebuild in /opt/gtk-beta
  548. * Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
  549. - New version (adds gobject)
  550. * Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
  551. - Don't blow away /etc/ld.so.conf (sorry!)
  552. * Mon Apr 24 2000 Owen Taylor <otaylor@redhat.com>
  553. - Snapshot RPM for Pango testing
  554. * Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
  555. - Added fixes from stable branch of CVS
  556. * Thu Oct 7 1999 Owen Taylor <otaylor@redhat.com>
  557. - version 1.2.6
  558. * Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
  559. - version 1.2.5
  560. * Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
  561. - version 1.2.4
  562. * Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
  563. - version 1.2.3
  564. * Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
  565. - version 1.2.1
  566. * Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
  567. - Version 1.2
  568. * Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
  569. - version 1.2.0pre1
  570. * Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
  571. - new description tags
  572. * Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
  573. - removed libtoolize from %build
  574. * Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
  575. - added libgthread to file list
  576. * Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
  577. - version 1.1.15
  578. * Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
  579. - version 1.1.14
  580. * Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
  581. - version 1.1.13
  582. * Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
  583. - version 1.1.12
  584. * Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
  585. - updated in preparation for the GNOME freeze
  586. * Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
  587. - Split out glib package