galera-vl.spec 8.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264
  1. %bcond_with systemd
  2. %bcond_with python3
  3. %define galera_api_version 26.4
  4. %define mariadb_version 10.4.9
  5. %if %{with python3}
  6. %global scons scons-3
  7. %else
  8. %global scons scons
  9. %endif
  10. Name: galera
  11. Version: %{galera_api_version}.3
  12. Release: 1%{?_dist_release}
  13. Summary: Synchronous multi-master wsrep provider (replication engine)
  14. License: GPLv2
  15. URL: http://galeracluster.com/
  16. # Actually, the truth is, we do use galera source tarball provided by MariaDB on
  17. # following URL (without macros):
  18. # https://mirror.vpsfree.cz/mariadb/mariadb-10.2.13/galera-25.3.23/src/galera-25.3.23.tar.gz
  19. Source0: https://downloads.mariadb.com/MariaDB/mariadb-%{mariadb_version}/galera-%{version}/src/%{name}-%{version}.tar.gz
  20. Source1: garbd.service
  21. Source2: garbd-wrapper
  22. Source3: garbd.init
  23. Patch0: galera-python3.patch
  24. BuildRequires: libboost-devel libboost-program-options check-devel openssl-devel scons gcc-c++ asio-devel
  25. %if %{with systemd}
  26. BuildRequires: systemd
  27. %endif
  28. Requires: nmap
  29. Provides: galera(%{galera_api_version})
  30. %if %{with systemd}
  31. Requires(post): systemd
  32. Requires(preun): systemd
  33. Requires(postun): systemd
  34. %else
  35. Requires(post): chkconfig
  36. Requires(preun): chkconfig initscripts
  37. %endif
  38. %description
  39. Galera is a fast synchronous multi-master wsrep provider (replication engine)
  40. for transactional databases and similar applications. For more information
  41. about wsrep API see http://launchpad.net/wsrep. For a description of Galera
  42. replication engine see http://www.codership.com.
  43. %prep
  44. %setup -q
  45. %if %{with python3}
  46. %patch0 -p1
  47. %endif
  48. %build
  49. CPPFLAGS="%{optflags}"
  50. CPPFLAGS=`echo $CPPFLAGS| sed -e "s|-Wp,-D_GLIBCXX_ASSERTIONS||g" `
  51. export CPPFLAGS
  52. %{scons} %{?_smp_mflags} strict_build_flags=0
  53. %install
  54. %if %{with systemd}
  55. install -D -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/garbd.service
  56. install -D -m 755 %{SOURCE2} %{buildroot}%{_sbindir}/garbd-wrapper
  57. %else
  58. install -D -m 644 %{SOURCE3} %{buildroot}%{_initdir}/garbd
  59. %endif
  60. install -D -m 755 garb/garbd %{buildroot}%{_sbindir}/garbd
  61. install -D -m 755 libgalera_smm.so %{buildroot}%{_libdir}/galera/libgalera_smm.so
  62. install -D -m 644 garb/files/garb.cnf %{buildroot}%{_sysconfdir}/sysconfig/garb
  63. install -D -m 644 COPYING %{buildroot}%{_docdir}/galera/COPYING
  64. install -D -m 644 chromium/LICENSE %{buildroot}%{_docdir}/galera/LICENSE.chromium
  65. install -D -m 644 asio/LICENSE_1_0.txt %{buildroot}%{_docdir}/galera/LICENSE.asio
  66. install -D -m 644 www.evanjones.ca/LICENSE %{buildroot}%{_docdir}/galera/LICENSE.crc32
  67. install -D -m 644 scripts/packages/README %{buildroot}%{_docdir}/galera/README
  68. install -D -m 644 scripts/packages/README-MySQL %{buildroot}%{_docdir}/galera/README-MySQL
  69. %post
  70. /sbin/ldconfig
  71. %if %{with systemd}
  72. %systemd_post garbd.service
  73. %else
  74. /sbin/chkconfig --add garbd
  75. %endif
  76. %preun
  77. %if %{with systemd}
  78. %systemd_preun garbd.service
  79. %else
  80. if [ $1 = 0 ]; then
  81. /sbin/service garbd stop >/dev/null 2>/dev/null ||:
  82. /sbin/chkconfig --del garbd
  83. fi
  84. %endif
  85. %postun
  86. /sbin/ldconfig
  87. %if %{with systemd}
  88. %systemd_postun_with_restart garbd.service
  89. %endif
  90. %files
  91. %config(noreplace,missingok) %{_sysconfdir}/sysconfig/garb
  92. %dir %{_docdir}/galera
  93. %dir %{_libdir}/galera
  94. %{_sbindir}/garbd
  95. %if %{with systemd}
  96. %{_sbindir}/garbd-wrapper
  97. %{_unitdir}/garbd.service
  98. %else
  99. %{_initdir}/garbd
  100. %endif
  101. %{_libdir}/galera/libgalera_smm.so
  102. %license %{_docdir}/galera/COPYING
  103. %license %{_docdir}/galera/LICENSE.asio
  104. %license %{_docdir}/galera/LICENSE.crc32
  105. %license %{_docdir}/galera/LICENSE.chromium
  106. %doc %{_docdir}/galera/README
  107. %doc %{_docdir}/galera/README-MySQL
  108. %changelog
  109. * Wed Nov 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.3-1
  110. - new upstream release.
  111. * Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.2-1
  112. - updated to 26.4.2 for MariaDB-10.4.
  113. * Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 25.3.25-4
  114. - initial build for Vine Linux.
  115. * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.25-3
  116. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  117. * Tue Jan 29 2019 Jonathan Wakely <jwakely@redhat.com> - 25.3.25-2
  118. - Rebuilt for Boost 1.69
  119. * Tue Jan 01 2019 Michal Schorm <mschorm@redhat.com> - 25.3.25-1
  120. - Rebase to 25.3.25
  121. * Mon Jul 16 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-5
  122. - Require asio also on rhel
  123. * Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-4
  124. - Add explicit gcc-c++ BR
  125. - Use python3-scons
  126. * Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-3
  127. - Do not require asio on rhel
  128. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.23-2
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  130. * Fri Feb 16 2018 Michal Schorm <mschorm@redhat.com> - 25.3.23-1
  131. - Update to 25.3.23
  132. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.22-2
  133. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  134. * Fri Nov 24 2017 Honza Horak <hhorak@redhat.com> - 25.3.22-1
  135. - Update to 25.3.22
  136. * Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-6
  137. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  138. * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-5
  139. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  140. * Mon Jul 03 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-4
  141. - Rebuilt for Boost 1.64
  142. * Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.16-3
  143. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
  144. * Sat Feb 18 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-2
  145. - Use asio-devel instead of bundled asio library
  146. * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-2
  147. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  148. * Wed Jun 22 2016 Mike Bayer <mbayer@redhat.com> - 25.3.16-1
  149. - Update to 25.3.16
  150. * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.12-4
  151. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  152. * Fri Jan 15 2016 Jonathan Wakely <jwakely@redhat.com> - 25.3.12-3
  153. - Rebuilt for Boost 1.60
  154. * Wed Sep 30 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 25.3.12-2
  155. - Remove use of -mtune=native which breaks build on secondary architectures
  156. * Fri Sep 25 2015 Richard W.M. Jones <rjones@redhat.com> - 25.3.12-1
  157. - Update to 25.3.12.
  158. - Should fix the build on 32 bit ARM (RHBZ#1241164).
  159. - Remove ExcludeArch (should have read the BZ more closely).
  160. * Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 25.3.10-5
  161. - Rebuilt for Boost 1.59
  162. * Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.10-4
  163. - Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
  164. * Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 25.3.10-3
  165. - rebuild for Boost 1.58
  166. * Wed Jul 08 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-2
  167. - Disable ARM builds (#1241164, #1239516)
  168. * Mon Jul 06 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-1
  169. - Update to version 25.3.10
  170. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-11
  171. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  172. * Mon Jan 26 2015 Petr Machata <pmachata@redhat.com> - 25.3.5-10
  173. - Rebuild for boost 1.57.0
  174. * Thu Nov 27 2014 Richard W.M. Jones <rjones@redhat.com> - 25.3.5-9
  175. - Add aarch64 support.
  176. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-8
  177. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  178. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-7
  179. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  180. * Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 25.3.5-6
  181. - Rebuild for boost 1.55.0
  182. * Wed Apr 30 2014 Dan Horák <dan[at]danny.cz> - 25.3.5-5
  183. - set ExclusiveArch
  184. * Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-4
  185. - Use strict_build_flags=0 to avoid -Werror
  186. - Remove unnecessary clean section
  187. * Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-3
  188. - Include galera directories in file list
  189. - Set CPPFLAGS to optflags
  190. * Wed Apr 23 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-2
  191. - Fix client certificate verification (#1090604)
  192. * Thu Mar 27 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-1
  193. - Update to version 25.3.5
  194. * Mon Mar 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-2
  195. - Add systemd service
  196. * Sun Mar 09 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-1
  197. - Initial build