exiv2-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218
  1. %define _unpackaged_files_terminate_build 1
  2. Name: exiv2
  3. Summary: Exif and IPTC metadata manipulation library
  4. Summary(ja): Exif, IPTC メタデータ操作ライブラリ
  5. Version: 0.27.2
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: GPLv2
  9. URL: https://www.exiv2.org/
  10. Source0: https://www.exiv2.org/builds/exiv2-%{version}-Source.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: cmake
  13. BuildRequires: expat-devel
  14. BuildRequires: gettext
  15. BuildRequires: pkgconfig
  16. BuildRequires: curl-devel
  17. BuildRequires: libssh-devel
  18. BuildRequires: zlib-devel
  19. Obsoletes: libexiv2 <= 0.13
  20. Provides: libexiv2 = %{version}-%{release}
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. %description
  24. Exiv2 comprises of a C++ library and a command line utility to access image metadata. Exiv2 supports full read and write access to the Exif and Iptc metadata, Exif MakerNote support, extract and delete methods for Exif thumbnails, classes to access Ifd and so on.
  25. The command line utility allows you to:
  26. * print the Exif metadata of Jpeg images as summary info, interpreted values,
  27. or the plain data for each tag (here is a sample)
  28. * print the IPTC metadata of Jpeg images
  29. * print the Jpeg comment of Jpeg images
  30. * set, add and delete Exif and Iptc metadata of Jpeg images
  31. * adjust the Exif timestamp (that's how it all started...)
  32. * rename Exif image files according to the Exif timestamp
  33. * extract, insert and delete Exif metadata, IPTC metadata and Jpeg comments
  34. * extract, insert and delete the thumbnail image embedded in the Exif metadata
  35. %description -l ja
  36. Exiv2 は、イメージメタデータにアクセスするための C++ ライブラリと
  37. コマンドラインユーティリティにより構成されています.Exiv2 は Exif,
  38. IPTC メタデータの完全な読込み及び書込みアクセス,Exif MakerNote,
  39. Exif サムネイルを抽出/削除するためのメソッド,Ifd 等にアクセスする
  40. ためのクラス等をサポートします.
  41. コマンドラインユーティリティにより、次のようなことができます:
  42. * JPEG イメージの EXIF メタデータを各タグごとに表示する
  43. * JPEG イメージの IPTC メタデータを表示する
  44. * JPEG イメージのコメントを表示する
  45. * JPEG イメージに EXIF 情報や IPTC メタデータを設定/追加/削除する
  46. * EXIF タイムスタンプを調整する
  47. * EXIF タイムスタンプに基づいて EXIF イメージファイルをリネームする
  48. * EXIF メタデータ,IPTC メタデータ,JPEG コメントを抽出/挿入/削除する
  49. * EXIF メタデータ中のサムネイルイメージを抽出/挿入/削除する
  50. #'
  51. %package devel
  52. Summary: Header files, libraries and development documentation for exiv2
  53. Summary(ja): exiv2 の開発用ファイル
  54. Group: Development/Libraries
  55. Requires: %{name} = %{version}-%{release}
  56. Obsoletes: libexiv2-devel <= 0.13
  57. Provides: libexiv2-devel = %{version}-%{release}
  58. %description devel
  59. Header files, libraries and development documentation for exiv2
  60. %description -l ja devel
  61. exiv2 用ヘッダファイル,ライブラリ,開発用ドキュメントです.
  62. %prep
  63. %setup -q -n %{name}-%{version}-Source
  64. %build
  65. %cmake \
  66. -DEXIV2_ENABLE_NLS:BOOL=ON \
  67. -DEXIV2_BUILD_PO:BOOL=ON \
  68. -DEXIV2_BUILD_SAMPLES:BOOL=OFF \
  69. -DEXIV2_ENABLE_LIBXMP:BOOL=ON \
  70. .
  71. make %{?_smp_mflags}
  72. %install
  73. rm -rf $RPM_BUILD_ROOT
  74. make install/fast DESTDIR=%{buildroot}
  75. %find_lang exiv2 --with-man
  76. ## unpackaged files
  77. rm -fv %{buildroot}%{_libdir}/libexiv2.la
  78. rm -fv %{buildroot}%{_libdir}/libxmp.a
  79. rm -fv %{buildroot}%{_libdir}/pkgconfig//exiv2.lsm
  80. # set eXecute bit on installed lib
  81. chmod a+x $RPM_BUILD_ROOT%{_libdir}/lib*.so.*
  82. ## FIXME/TODO: patch installed exiv2-config to instead pull values from pkgconfig
  83. %clean
  84. rm -rf $RPM_BUILD_ROOT
  85. %post -p /sbin/ldconfig
  86. %postun -p /sbin/ldconfig
  87. %files -f %{name}.lang
  88. %defattr(-,root,root,-)
  89. %license COPYING*
  90. %doc README*
  91. %{_bindir}/exiv2
  92. %{_libdir}/lib*.so.*
  93. %{_mandir}/man1/*
  94. %files devel
  95. %defattr(-,root,root,-)
  96. #doc doc/index.html doc/include
  97. #{_bindir}/exiv2-config
  98. %{_includedir}/exiv2/*
  99. %{_libdir}/libexiv2.so
  100. %{_libdir}/*.a
  101. %{_libdir}/pkgconfig/exiv2.pc
  102. %dir %{_libdir}/cmake
  103. %{_libdir}/cmake/*
  104. #{_datadir}/exiv2
  105. %changelog
  106. * Fri Nov 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.27.2-1
  107. - new upstream release.
  108. * Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.27-1
  109. - new upstream release.
  110. - dropprd all patches.
  111. * Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.25-2
  112. - rebuilt with new toolchain.
  113. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.25-1
  114. - new upstream release
  115. * Tue Dec 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.24-1
  116. - new upstream release
  117. - add Patch3 (exiv2-0.24-visibility.patch)
  118. * Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.23-1
  119. - new upstream release
  120. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22-1
  121. - new upstream release
  122. * Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.21.1-1
  123. - new upstream release
  124. - updated Patch3
  125. * Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.19-2
  126. - rebuilt with rpm-4.8.1 for pkg-config
  127. * Wed May 5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.19-1
  128. - new upstream release
  129. - updated Patch3
  130. * Mon Oct 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.18.2-1
  131. - new upstream release
  132. - updated Japanese description
  133. * Fri May 1 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.18.1-2
  134. - add Patch3 not to use -fvisibility-inlines-hidden
  135. (this will also fix build failure on ppc)
  136. http://dev.exiv2.org/issues/show/627
  137. * Sun Apr 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.18.1-1
  138. - new upstream release
  139. * Tue Sep 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17.1-1vl5
  140. - new upstream release
  141. * Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 0.15-1vl5
  142. - applied new versioning policy, spec in utf-8
  143. * Wed Dec 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.15-0vl4
  144. - add patch100 for fix CVE-2007-6353 ("setDataArea()" Integer OF)
  145. * Sat Aug 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15-0vl3
  146. - add Obsoletes: libexiv2 <= 0.13 , libexiv2-devel <= 0.13
  147. to upgrade from 0.13-0vl[12]
  148. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.13-0vl2
  149. - rebuild with new environment/toolchain
  150. * Fri Mar 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.13-0vl1
  151. - initial build for Vine Linux
  152. * Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.15-0vl2
  153. - rebuilt for VineSeed
  154. * Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.15-0vl1
  155. - new upstream release
  156. - remove Requires: kdelibs-devel at devel package
  157. * Fri Jan 5 2007 TOSHI <vine-jp@mail.goo.ne.jp> 0.12-0vl1
  158. - build for vine 4.0
  159. * Tue Nov 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.12-1
  160. - exiv2-0.12
  161. # end of file