perl-Test-Fatal-vl.spec 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113
  1. Summary: Incredibly simple helpers for testing code with exceptions
  2. Name: perl-Test-Fatal
  3. Version: 0.010
  4. Release: 1%{?_dist_release}
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. Url: http://search.cpan.org/dist/Test-Fatal/
  8. Source0: http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Test-Fatal-%{version}.tar.gz
  9. Patch0: Test-Fatal-0.008-old-EU::MM.patch
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
  11. BuildArch: noarch
  12. BuildRequires: perl(Carp)
  13. BuildRequires: perl(Exporter) >= 5.57
  14. BuildRequires: perl(ExtUtils::MakeMaker)
  15. BuildRequires: perl(Test::Builder::Tester)
  16. BuildRequires: perl(Test::More)
  17. BuildRequires: perl(Test::Pod)
  18. BuildRequires: perl(Try::Tiny) >= 0.07
  19. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  20. %description
  21. Test::Fatal is an alternative to the popular Test::Exception. It does much
  22. less, but should allow greater flexibility in testing exception-throwing code
  23. with about the same amount of typing.
  24. %prep
  25. %setup -q -n Test-Fatal-%{version}
  26. %build
  27. perl Makefile.PL INSTALLDIRS=vendor
  28. make %{?_smp_mflags}
  29. %install
  30. rm -rf %{buildroot}
  31. make pure_install DESTDIR=%{buildroot}
  32. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  33. find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
  34. %{_fixperms} %{buildroot}
  35. %check
  36. make test RELEASE_TESTING=1
  37. %clean
  38. rm -rf %{buildroot}
  39. %files
  40. %defattr(-,root,root,-)
  41. %doc Changes LICENSE README
  42. %{perl_vendorlib}/Test/
  43. %{_mandir}/man3/Test::Fatal.3pm*
  44. %changelog
  45. * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.010-1
  46. - initial build for Vine Linux
  47. * Thu Feb 16 2012 Paul Howarth <paul@city-fan.org> 0.010-1
  48. - Update to 0.010
  49. - Avoid tickling an overloading bug in perl 5.6 during testing
  50. (CPAN RT#74847)
  51. * Fri Feb 10 2012 Paul Howarth <paul@city-fan.org> 0.009-1
  52. - Update to 0.009
  53. - Advise against using isnt(exception{...},undef)
  54. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 0.008-2
  55. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  56. * Mon Nov 7 2011 Paul Howarth <paul@city-fan.org> 0.008-1
  57. - Update to 0.008
  58. - Revert the mistake by which 0.004 allowed blocks after "exception" as well
  59. as "success"
  60. - BR: perl(Carp)
  61. - Update patch for building with ExtUtils::MakeMaker < 6.30
  62. * Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> 0.006-2
  63. - Perl mass rebuild
  64. * Thu Jun 2 2011 Paul Howarth <paul@city-fan.org> 0.006-1
  65. - Update to 0.006
  66. - Crank back the Test::More and Exporter requirements (CPAN RT#62699)
  67. - Add lives_ok and dies_ok emulation (CPAN RT#67598)
  68. - Versions patch replaced by workaround for old ExtUtils::MakeMaker
  69. - BR: perl(Test::Builder::Tester)
  70. * Tue Apr 26 2011 Paul Howarth <paul@city-fan.org> 0.005-1
  71. - Update to 0.005
  72. - Fix the logic that picks tests for 5.13.1+
  73. * Tue Apr 26 2011 Paul Howarth <paul@city-fan.org> 0.004-1
  74. - Update to 0.004
  75. - success blocks now allow trailing blocks like finally, catch, etc.
  76. - Remove remaining uses of macros for commands
  77. - Re-order %%install section to conventional position in spec
  78. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 0.003-2
  79. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  80. * Fri Oct 29 2010 Paul Howarth <paul@city-fan.org> 0.003-1
  81. - Update to 0.003
  82. - More tests for false exceptions, especially on 5.13
  83. - Update versions patch
  84. * Thu Oct 28 2010 Paul Howarth <paul@city-fan.org> 0.002-1
  85. - Update to 0.002
  86. - Add tests for handling of false exceptions
  87. - Fix precedence error in documentation
  88. - Update versions patch
  89. * Wed Oct 27 2010 Paul Howarth <paul@city-fan.org> 0.001-2
  90. - Sanitize spec for Fedora submission
  91. * Tue Oct 26 2010 Paul Howarth <paul@city-fan.org> 0.001-1
  92. - Initial RPM version