neon-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: neon
  3. Summary: An HTTP and WebDAV client library.
  4. Summary(ja): HTTP と WebDAV クライアントのライブラリ
  5. Version: 0.29.6
  6. Release: 1%{?_dist_release}
  7. License: LGPLv2+
  8. Group: System Environment/Libraries
  9. URL: http://www.webdav.org/neon/
  10. Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. Requires: expat
  13. Requires: zlib >= 1.1.4
  14. Requires: krb5-libs
  15. BuildRequires: expat-devel
  16. BuildRequires: gnutls-devel
  17. BuildRequires: krb5-devel
  18. BuildRequires: libxml2-devel
  19. #BuildRequires: openssl-devel
  20. BuildRequires: sed
  21. BuildRequires: zlib-devel
  22. BuildRequires: keyutils-libs-devel
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. %description
  26. neon is an HTTP and WebDAV client library, with a C interface;
  27. providing a high-level interface to HTTP and WebDAV methods along
  28. with a low-level interface for HTTP request handling. neon
  29. supports persistent connections, proxy servers, basic, digest and
  30. Kerberos authentication, and has complete SSL support.
  31. %package devel
  32. Summary: Development libraries and C header files for the neon library
  33. Summary(ja): neon の開発用ライブラリおよび C言語ヘッダファイル
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}
  36. Requires: zlib-devel
  37. #Requires: openssl-devel
  38. Requires: expat-devel
  39. Requires: gnutls-devel
  40. Requires: krb5-devel
  41. Requires: keyutils-libs-devel
  42. %description devel
  43. The development library for the C language HTTP and WebDAV client library.
  44. %description devel -l ja
  45. C言語による HTTP と WebDAV クライアントのライブラリの開発用パッケージ
  46. ## to build compat32 for x86_64 architecture support
  47. %package -n compat32-%{name}
  48. Summary: C language HTTP and WebDAV client library.
  49. Group: System Environment/Libraries
  50. Requires: expat
  51. Requires: zlib >= 1.1.4
  52. %description -n compat32-%{name}
  53. A C language HTTP and WebDAV client library.
  54. %package -n compat32-%{name}-devel
  55. Summary: A C language HTTP and WebDAV client library.
  56. Group: Development/Libraries
  57. Requires: compat32-%{name} = %{version}
  58. Requires: compat32-zlib-devel
  59. #Requires: compat32-openssl-devel
  60. Requires: compat32-expat-devel
  61. Requires: compat32-keyutils-libs-devel
  62. Requires: compat32-krb5-devel
  63. %description -n compat32-%{name}-devel
  64. The development library for the C language HTTP and WebDAV client library.
  65. %prep
  66. %setup -q
  67. %build
  68. %configure \
  69. --with-expat \
  70. --with-ssl=gnutls \
  71. --enable-threadsafe-ssl=posix \
  72. --enable-shared \
  73. --disable-static \
  74. --with-force-ssl
  75. %__make %{?_smp_mflags}
  76. %install
  77. %__rm -rf %{buildroot}
  78. %makeinstall
  79. sed -ri "/^dependency_libs/{s,-l[^ ']*,,g}" \
  80. $RPM_BUILD_ROOT%{_libdir}/libneon.la
  81. %find_lang %{name}
  82. ## remove unuse files
  83. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  84. %clean
  85. rm -rf $RPM_BUILD_ROOT
  86. %post -p /sbin/ldconfig
  87. %postun -p /sbin/ldconfig
  88. %post -n compat32-%{name} -p /sbin/ldconfig
  89. %postun -n compat32-%{name} -p /sbin/ldconfig
  90. %files -f %{name}.lang
  91. %defattr(-,root,root)
  92. %doc AUTHORS BUGS ChangeLog INSTALL.win32 NEWS README THANKS TODO
  93. %doc doc/html
  94. %{_libdir}/*.so.*
  95. %files devel
  96. %defattr(-,root,root)
  97. %{_bindir}/*
  98. %{_includedir}/*
  99. %{_mandir}/man1/*
  100. %{_mandir}/man3/*
  101. #{_libdir}/*.a
  102. #{_libdir}/*.la
  103. %{_libdir}/*.so
  104. %{_libdir}/pkgconfig/*.pc
  105. %if %{build_compat32}
  106. %files -n compat32-%{name}
  107. %defattr(-,root,root)
  108. %{_libdir}/*.so.*
  109. %files -n compat32-%{name}-devel
  110. %defattr(-,root,root)
  111. #{_libdir}/*.a
  112. #{_libdir}/*.la
  113. %{_libdir}/pkgconfig/*.pc
  114. %endif
  115. %changelog
  116. * Sun Jan 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-2
  117. - rebuild with VineSeed environment
  118. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-1
  119. - update to 0.29.6
  120. * Mon May 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.3-2
  121. - add BuildRequires: keyutils-libs-devel
  122. - add Requires: krb5-devel, keyutils-libs-devel (-devel package)
  123. * Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 0.29.3-1
  124. - new upstream release
  125. * Thu Mar 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.6-3
  126. - rebuilt with krb5-libs-1.8.2
  127. - removed BR: openssl-devel
  128. - removed static library from devel package
  129. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.28.6-2
  130. - rebuilt with rpm-4.8.1 for pkg-config
  131. * Tue Aug 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.6-1
  132. - new upstream release with security fix (CVE-2009-2473, 2474)
  133. * Sat Jan 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.28.3-3vl5
  134. - rebuild with gnutls-2.6.3
  135. * Sun Oct 19 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-2vl5
  136. - add Requires/BuildRequires krb5-libs/krb5-devel tags
  137. - add _smp_mflags into make section
  138. * Fri Oct 17 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-1vl5
  139. - new upstream release with security fix (CVE-2008-3746)
  140. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.28.2-3vl5
  141. - removed *.la
  142. - spec in utf-8
  143. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-2vl5
  144. - added --with-ssl=gnutls --enable-threadsafe-ssl
  145. - added BuildRequires: gnutls-devel
  146. * Fri Apr 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-1vl5
  147. - new upstream release
  148. * Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.26.3-0vl3
  149. - removed %%if !%%{build_compat32} case condition
  150. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.26.3-0vl2
  151. - rebuild with expat-2.0.1
  152. * Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.26.3-0vl1
  153. - new upstream release
  154. * Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl3
  155. - add Requires: zlib-devel, openssl-devel, expat-devel
  156. * Mon May 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl2
  157. - move %%configure from %%prep to %%build
  158. - remove unneeded locales.patch (for neon-0.26.x or later)
  159. * Wed Apr 05 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl1
  160. - new upstream release
  161. - drop doc.patch (patch0)
  162. - use more macros
  163. - drop BuildRequires: autoconf, automake
  164. - add *.pc to -devel (and compat32's) package
  165. - change group
  166. - add Requires: %%{name} = %%{version} to -devel (and compat32's) package
  167. - add doc/html instead of doc/* to %%doc
  168. - move %%{_mandir}/man1/* and %%{_bindir}/* to -devel package
  169. - run ldconfig in %%post,postun
  170. - add locales.patch (patch0)
  171. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl3
  172. - moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
  173. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl2
  174. - added compat32- packages for x86_64 architecture support
  175. - added --libdir=%{_libdir} option to configure
  176. * Sun Sep 5 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.24.7-0vl1
  177. - new upstream release
  178. * Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.4-0vl1
  179. - upstream release
  180. - update URL and Source0 tag: valid URL
  181. * Fri Sep 19 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.2-0vl1
  182. - upstream release
  183. - add BuildRequires: openssl-devel, libxml2-devel, zlib-devel
  184. - add Japanese Summary and %%description
  185. * Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.23.5-1vl1
  186. - build VineLinux
  187. * Mon Nov 04 2002 David Summers <david@summersoft.fay.ar.us> 0.23.5-1
  188. - Updated to 0.23.5.
  189. * Tue Aug 27 2002 David Summers <david@summersoft.fay.ar.us> 0.23.2-1
  190. - Upgraded to 0.23.2.
  191. * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.22.0-1
  192. - Upgraded to 0.22.0.
  193. - Fixed compilation from CVS.
  194. - Took out man pages until I can figure out xmlto program.
  195. * Sat Aug 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-3
  196. - Fixed compilation on RedHat 7.2 by upgrading libtool and auto* packages
  197. to RedHat 7.3 versions and fixing bug in spec file.
  198. - Gave up on CVS version of neon until we can figure out why autogen.sh doesn't
  199. work.
  200. * Wed Jul 24 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-2
  201. - Fixed file ownership problems. Made them owned by root.
  202. * Fri Jul 19 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-1
  203. - Updated to neon 0.21.3.
  204. * Sun Jun 16 2002 David Summers <david@summersoft.fay.ar.us> 0.21.2-1
  205. - Updated to neon 0.21.2.
  206. * Mon Jun 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.1-1
  207. - Updated to neon 0.21.1.
  208. - Now requires zlib >= 1.1.4.
  209. - Broke into zlib and zlib-devel.
  210. - Now builds shared library.
  211. * Sat Apr 27 2002 David Summers <david@summersoft.fay.ar.us> 0.19.4-1
  212. - Updated to neon 0.19.4.
  213. * Fri Feb 22 2002 David Summers <david@summersoft.fay.ar.us> 0.19.2-1
  214. - Updated to neon 0.19.2.
  215. * Thu Dec 20 2001 David Summers <david@summersoft.fay.ar.us> 0.18.2-1
  216. - Updated to neon 0.18.2.
  217. * Wed Oct 31 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-2
  218. - Took out dependency on libxml and w3c-libwww packages.
  219. - Added dependency on expat.
  220. * Sat Oct 27 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-1
  221. - Release 0.17.2-1: Updated neon.
  222. * Wed Oct 24 2001 David Summers <david@summersoft.fay.ar.us>
  223. - Release 2: Fixed prefix to be /usr instead of /usr/local.
  224. * Sat Oct 20 2001 David Summers <david@summersoft.fay.ar.us>
  225. - Release 2001-10-20: Initial Version.