mysql-connector-odbc-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258
  1. #%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define build_compat32 0
  3. Summary: ODBC driver for MySQL
  4. Name: mysql-connector-odbc
  5. Version: 5.3.2
  6. Release: 2%{?_dist_release}
  7. Group: System Environment/Libraries
  8. URL: http://dev.mysql.com/downloads/connector/odbc/
  9. # exceptions allow library to be linked with most open source SW,
  10. # not only GPL code.
  11. License: GPLv2 with exceptions
  12. Source0: http://dev.mysql.com/get/Downloads/Connector-ODBC/5.2/%{name}-%{version}-src.tar.gz
  13. # mysql-connector-odbc expects to be able to get at a bunch of utility
  14. # functions inside libmysqlclient. Now that we are restricting what symbols
  15. # are exported by libmysqlclient, that doesn't work. Instead, copy those
  16. # functions here. mysql and mysql-connector-odbc are published under the same
  17. # license, so this creates no legal issues. (Note: we don't worry about
  18. # polluting application namespace in mysql-connector-odbc, since it's never
  19. # directly statically linked with any application code.)
  20. Source1: mariadb-mysys.tar.gz
  21. Patch1: myodbc-add-mysys.patch
  22. Patch2: myodbc-shutdown.patch
  23. Patch3: myodbc-64bit.patch
  24. Patch4: myodbc-movecmpfunc.patch
  25. Patch5: mysql-connector-odbc-buffsize.patch
  26. Patch6: mysql-connector-odbc-cleartext.patch
  27. Patch7: mysql-connector-odbc-format-security.patch
  28. Patch8: mysql-connector-odbc-5.2.5-aarch64.patch
  29. Patch9: myodbc-mariadb10.patch
  30. BuildRequires: libmysqlclient-devel unixODBC-devel gtk3-devel
  31. BuildRequires: cmake
  32. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  33. %description
  34. An ODBC (rev 3) driver for MySQL, for use with unixODBC.
  35. %package -n compat32-%{name}
  36. Summary: ODBC driver for MySQL
  37. Group: System Environment/Libraries
  38. Requires: %{name} = %{version}-%{release}
  39. %description -n compat32-%{name}
  40. An ODBC (rev 3) driver for MySQL, for use with unixODBC.
  41. %prep
  42. %setup -q -n %{name}-%{version}-src
  43. tar xfz %{SOURCE1}
  44. %patch1 -p1
  45. %patch2 -p1
  46. %patch3 -p1
  47. %patch4 -p1
  48. %patch5 -p1
  49. %patch6 -p1
  50. %patch7 -p1
  51. %patch8 -p1
  52. %patch9 -p1
  53. # mysql_config does not support --cxxflags option
  54. sed -i 's/--cxxflags/--cflags/g' cmake/FindMySQL.cmake
  55. %build
  56. # mysql 5.5.10 has stopped #define'ing THREAD in its exports, and has
  57. # started #define'ing MY_PTHREAD_FASTMUTEX, and neither of those changes
  58. # sit well with mysql-connector-odbc 5.1.10. Revisit need for these hacks
  59. # when updating to newer release.
  60. export CFLAGS="%{optflags} -lpthread -fno-strict-aliasing -DTHREAD=1 -UMY_PTHREAD_FASTMUTEX -DDBUG_OFF"
  61. cmake . -G "Unix Makefiles" \
  62. -DWITH_UNIXODBC=1 \
  63. -DRPM_BUILD=1 \
  64. -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
  65. -DMYSQLCLIENT_LIB_NAME=mysqlclient
  66. make %{?_smp_mflags} VERBOSE=1
  67. %install
  68. export tagname=CC
  69. make DESTDIR=$RPM_BUILD_ROOT install
  70. # Remove stuff not to be packaged (possibly reconsider later)
  71. rm -f $RPM_BUILD_ROOT%{_bindir}/myodbc-installer
  72. rm -f $RPM_BUILD_ROOT/usr/COPYING
  73. rm -f $RPM_BUILD_ROOT/usr/README
  74. rm -f $RPM_BUILD_ROOT/usr/README.debug
  75. rm -f $RPM_BUILD_ROOT/usr/ChangeLog
  76. rm -f $RPM_BUILD_ROOT/usr/INSTALL
  77. rm -f $RPM_BUILD_ROOT/usr/Licenses_for_Third-Party_Components.txt
  78. # Create a symlink for library to offer name that users are used to
  79. ln -sf libmyodbc5w.so $RPM_BUILD_ROOT%{_libdir}/libmyodbc5.so
  80. # Upstream provides a test suite with functional and regression tests.
  81. # However, some tests fail, so it would deserve some more investigation.
  82. # We don't include the test suite until it works fine.
  83. rm -rf $RPM_BUILD_ROOT/usr/test
  84. %post
  85. /sbin/ldconfig
  86. %postun
  87. /sbin/ldconfig
  88. %post -n compat32-%{name}
  89. /sbin/ldconfig
  90. %postun -n compat32-%{name}
  91. /sbin/ldconfig
  92. %files
  93. %doc README README.debug ChangeLog COPYING
  94. %{_libdir}/lib*so
  95. %if %{build_compat32}
  96. %files -n compat32-%{name}
  97. %{_libdir}/lib*so
  98. %endif
  99. %changelog
  100. * Tue Jul 8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.2-2
  101. - initial build for Vine Linux.
  102. * Thu Jun 12 2014 Jakub Dorňák <jdornak@redhat.com> - 5.3.2-1
  103. - Rebase to version 5.3.2
  104. - MariaDB 10 compatibility
  105. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.6-2
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  107. * Fri Jan 24 2014 Jakub Dorňák <jdornak@redhat.com> - 5.2.6-1
  108. - Update to 2.5.6
  109. Resolves: #1047895
  110. * Wed Jan 8 2014 Marcin Juszkiewicz <mjuszkiewicz redhat com> - 5.2.5-5
  111. - Build failed because whether to use lib64 or not is done by checking
  112. list of known 64-bit architectures. So added AArch64 to that list.
  113. Resolves: #1041348
  114. * Thu Dec 12 2013 Jakub Dorňák <jdornak@redhat.com> - 5.2.5-4
  115. - format-security
  116. Resolves: #1037209
  117. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.5-3
  118. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  119. * Mon Jun 17 2013 Honza Horak <hhorak@redhat.com> - 5.2.5-2
  120. - Avoid potential segfault
  121. Resolves: #974794
  122. * Fri May 24 2013 Honza Horak <hhorak@redhat.com> - 5.2.5-1
  123. - Update to 5.2.5
  124. - Enlarge buffer size for query string when getting info about tables
  125. Related: #948619
  126. * Wed Apr 3 2013 Honza Horak <hhorak@redhat.com> - 5.2.4-2
  127. - Fix libdir in cmake for ppc64
  128. * Tue Mar 5 2013 Honza Horak <hhorak@redhat.com> - 5.2.4-1
  129. - Update to 5.2.4
  130. * Fri Mar 1 2013 Honza Horak <hhorak@redhat.com> - 5.1.11-3
  131. - Fix data types for mariadb
  132. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.11-2
  133. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  134. * Sun Jul 22 2012 Tom Lane <tgl@redhat.com> 5.1.11-1
  135. - Update to 5.1.11
  136. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.10-2
  137. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  138. * Sun Feb 5 2012 Tom Lane <tgl@redhat.com> 5.1.10-1
  139. - Update to 5.1.10
  140. * Tue Jan 10 2012 Tom Lane <tgl@redhat.com> 5.1.9-1
  141. - Update to 5.1.9
  142. - Add --with-unixODBC-libs to configure command for safer multilib behavior
  143. Related: #757088
  144. * Wed Mar 23 2011 Tom Lane <tgl@redhat.com> 5.1.8-3
  145. - Rebuild for libmysqlclient 5.5.10 soname version bump
  146. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.8-2
  147. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  148. * Thu Dec 23 2010 Tom Lane <tgl@redhat.com> 5.1.8-1
  149. - Update to 5.1.8
  150. - Deal with mysql packaging changes that prevent us from using mysys
  151. utility functions directly
  152. * Wed Jan 20 2010 Tom Lane <tgl@redhat.com> 5.1.5r1144-7
  153. - Correct Source: tag and comment to reflect how to get the tarball
  154. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 5.1.5r1144-6
  155. - rebuilt with new openssl
  156. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.5r1144-5
  157. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  158. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.5r1144-4
  159. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  160. * Fri Feb 20 2009 Tom Lane <tgl@redhat.com> 5.1.5r1144-3
  161. - Fix some 64-bitness issues with unixODBC 2.2.14.
  162. * Fri Feb 20 2009 Tom Lane <tgl@redhat.com> 5.1.5r1144-2
  163. - Rebuild for unixODBC 2.2.14.
  164. - Fix problem with null username/password specifications
  165. * Thu Jan 22 2009 Tom Lane <tgl@redhat.com> 5.1.5r1144-1
  166. - Update to mysql-connector-odbc 5.1.5r1144, to go with MySQL 5.1.x.
  167. Note the library name has changed from libmyodbc3 to libmyodbc5.
  168. * Tue Aug 5 2008 Tom Lane <tgl@redhat.com> 3.51.26r1127-1
  169. - Update to mysql-connector-odbc 3.51.26r1127
  170. * Tue Mar 25 2008 Tom Lane <tgl@redhat.com> 3.51.24r1071-1
  171. - Update to mysql-connector-odbc 3.51.24r1071
  172. * Tue Feb 12 2008 Tom Lane <tgl@redhat.com> 3.51.23r998-1
  173. - Update to mysql-connector-odbc 3.51.23r998
  174. * Wed Dec 5 2007 Tom Lane <tgl@redhat.com> 3.51.14r248-3
  175. - Rebuild for new openssl
  176. * Thu Aug 2 2007 Tom Lane <tgl@redhat.com> 3.51.14r248-2
  177. - Update License tag to match code.
  178. * Fri Apr 20 2007 Tom Lane <tgl@redhat.com> 3.51.14r248-1
  179. - Update to mysql-connector-odbc 3.51.14r248
  180. Resolves: #236473
  181. - Fix build problem on multilib machines
  182. * Mon Jul 17 2006 Tom Lane <tgl@redhat.com> 3.51.12-2.2
  183. - rebuild
  184. * Mon Mar 27 2006 Tom Lane <tgl@redhat.com> 3.51.12-2
  185. - Remove DLL-unload cleanup call from connection shutdown (bz#185343)
  186. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.51.12-1.2.1
  187. - bump again for double-long bug on ppc(64)
  188. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.51.12-1.2
  189. - rebuilt for new gcc4.1 snapshot and glibc changes
  190. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  191. - rebuilt
  192. * Fri Nov 11 2005 Tom Lane <tgl@redhat.com> 3.51.12-1
  193. - New package replacing MyODBC.