glib2-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A library of handy utility functions.
  3. Name: glib2
  4. Version: 2.24.2
  5. Release: 2%{?_dist_release}
  6. License: LGPLv2+
  7. Group: System Environment/Libraries
  8. Source: glib-%{version}.tar.bz2
  9. Source2: glib2.sh
  10. Source3: glib2.csh
  11. BuildRoot: %{_tmppath}/glib-%{version}-root
  12. BuildRequires: pkgconfig >= 0.14
  13. BuildRequires: gamin-devel
  14. BuildRequires: gtk-doc
  15. BuildRequires: zlib-devel
  16. Obsoletes: glib-gtkbeta
  17. URL: http://www.gtk.org
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
  21. %description
  22. GLib is the low-level core library that forms the basis
  23. for projects such as GTK+ and GNOME. It provides data structure
  24. handling for C, portability wrappers, and interfaces for such runtime
  25. functionality as an event loop, threads, dynamic loading, and an
  26. object system.
  27. This package provides version 2.20 of GLib.
  28. %package devel
  29. Summary: Development files for the GLib library
  30. Group: Development/Libraries
  31. Obsoletes: glib-gtkbeta-devel
  32. Requires: pkgconfig >= 0.14
  33. Requires: %{name} = %{version}
  34. Conflicts: glib-devel <= 1.2.8
  35. %description devel
  36. The glib-devel package includes the header files for
  37. version 2.20 of the GLib library.
  38. ## to build compat32 for x86_64 architecture support
  39. %package -n compat32-%{name}
  40. Summary: A library of handy utility functions.
  41. Group: System Environment/Libraries
  42. %description -n compat32-%{name}
  43. GLib is the low-level core library that forms the basis
  44. for projects such as GTK+ and GNOME. It provides data structure
  45. handling for C, portability wrappers, and interfaces for such runtime
  46. functionality as an event loop, threads, dynamic loading, and an
  47. object system.
  48. This package provides version 2.20 of GLib.
  49. %package -n compat32-%{name}-devel
  50. Summary: Development files for the GLib library
  51. Group: Development/Libraries
  52. Requires: pkgconfig >= 0.14
  53. Requires: compat32-%{name} = %{version}
  54. Conflicts: glib-devel <= 1.2.8
  55. %description -n compat32-%{name}-devel
  56. The glib-devel package includes the header files for
  57. version 2.20 of the GLib library.
  58. %prep
  59. %setup -q -n glib-%{version}
  60. %build
  61. %configure --disable-selinux --enable-static
  62. make %{?_smp_mflags}
  63. %install
  64. rm -rf $RPM_BUILD_ROOT
  65. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  66. %makeinstall
  67. ## glib2.sh and glib2.csh
  68. ./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  69. install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  70. install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  71. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  72. rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
  73. %find_lang glib20
  74. %clean
  75. rm -rf $RPM_BUILD_ROOT
  76. %post -p /sbin/ldconfig
  77. %postun -p /sbin/ldconfig
  78. %post -n compat32-%{name} -p /sbin/ldconfig
  79. %postun -n compat32-%{name} -p /sbin/ldconfig
  80. %files -f glib20.lang
  81. %defattr(-, root, root)
  82. %doc AUTHORS COPYING ChangeLog NEWS README
  83. %{_libdir}/libglib-2.0.so.*
  84. %{_libdir}/libgthread-2.0.so.*
  85. %{_libdir}/libgmodule-2.0.so.*
  86. %{_libdir}/libgobject-2.0.so.*
  87. %{_libdir}/libgio-2.0.so.*
  88. %{_libdir}/gio/modules/lib*.so
  89. %{_sysconfdir}/profile.d/*
  90. %files devel
  91. %defattr(-, root, root)
  92. %{_libdir}/lib*.so
  93. %{_libdir}/lib*.a
  94. %{_libdir}/glib-2.0
  95. %{_includedir}/*
  96. %{_datadir}/aclocal/*
  97. %{_libdir}/pkgconfig/*
  98. %{_datadir}/glib-2.0
  99. %{_bindir}/*
  100. %doc %{_datadir}/gtk-doc/html/*
  101. %doc %{_mandir}/man1/*
  102. %{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
  103. %{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
  104. %if %{build_compat32}
  105. %files -n compat32-%{name}
  106. %defattr(-, root, root)
  107. %{_libdir}/libglib-2.0.so.*
  108. %{_libdir}/libgthread-2.0.so.*
  109. %{_libdir}/libgmodule-2.0.so.*
  110. %{_libdir}/libgobject-2.0.so.*
  111. %{_libdir}/libgio-2.0.so.*
  112. %{_libdir}/gio/modules/lib*.so
  113. %files -n compat32-%{name}-devel
  114. %defattr(-, root, root)
  115. %{_libdir}/lib*.so
  116. %{_libdir}/lib*.a
  117. %{_libdir}/glib-2.0
  118. %{_libdir}/pkgconfig/*
  119. %endif
  120. %changelog
  121. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
  122. - build with rpm-4.8.1-1 for pkg-config file
  123. * Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
  124. - new upstream release
  125. * Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
  126. - new upstream release
  127. * Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
  128. - new upstream release
  129. - add BuildRequires: zlib-devel
  130. * Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
  131. - new upstream release
  132. * Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
  133. - new upstream release
  134. * Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
  135. - new upstream release
  136. * Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  137. - new upstream release
  138. * Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
  139. - new upstream release
  140. * Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
  141. - new upstream release
  142. * Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
  143. - new upstream release
  144. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
  145. - new upstream release
  146. * Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
  147. - new upstream release
  148. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
  149. - new upstream release
  150. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
  151. - new upstream release
  152. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
  153. - new upstream release
  154. * Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
  155. - new upstream release
  156. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
  157. - new upstream release
  158. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
  159. - new upstream release
  160. * Mon Jul 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
  161. - new upstream release
  162. * Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
  163. - updated %%if %%{build_compat32} case related statements
  164. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
  165. - new upstream release
  166. - removed lib*.la files from devel package
  167. * Sun Apr 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
  168. - new upstream release
  169. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
  170. - added %%{?_dist_release}
  171. - BuildRequires: gamin-devel
  172. * Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
  173. - new upstream release
  174. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
  175. - new upstream release
  176. * Wed Jan 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
  177. - new upstream release
  178. * Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
  179. - new upstream release
  180. * Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
  181. - new upstream release
  182. - removed BuildRequires: automake17
  183. * Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
  184. - new upstream release
  185. * Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
  186. - new upstream release
  187. * Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
  188. - new upstream release
  189. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
  190. - rebuild with new environment
  191. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
  192. - new upstream release
  193. * Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
  194. - new upstream release
  195. * Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
  196. - new upstream release
  197. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
  198. - new upstream release
  199. * Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
  200. - new upstream release
  201. * Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
  202. - new upstream release
  203. * Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
  204. - new upstream release
  205. * Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
  206. - rebuild
  207. * Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
  208. - update glib2.{sh,csh}
  209. - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
  210. * Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
  211. - new upstream release
  212. * Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
  213. - new upstream release
  214. * Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
  215. - new upstream release
  216. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  217. - new upstream release
  218. * Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
  219. - added compat32-* packages for x86_64 architecture support
  220. - chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
  221. * Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
  222. - new upstream release
  223. * Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
  224. - new upstream release
  225. * Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
  226. - new upstream release
  227. * Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
  228. - new upstream release
  229. * Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
  230. - fixed typo in glib2.csh
  231. * Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
  232. - update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
  233. G_BROKEN_FILENAMES.
  234. * Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
  235. - new upstream release
  236. * Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
  237. - new upstream release
  238. * Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
  239. - new upstream release
  240. * Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
  241. - new upstream release
  242. * Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
  243. - new upstream release
  244. * Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
  245. - new upstream release
  246. - add *.la to build arts (should be fixed in arts?)
  247. * Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
  248. - new upstream release
  249. * Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
  250. - new upstream release
  251. * Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
  252. - new upstream release
  253. * Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
  254. - new upstream release
  255. * Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
  256. - new upstream release
  257. * Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
  258. - rebuilt
  259. * Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
  260. - new upstream release
  261. * Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
  262. - new upstream release
  263. * Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
  264. - new upstream release
  265. * Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
  266. - new upstream release
  267. * Sat Jun 5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
  268. - new upstream release
  269. * Sat May 1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
  270. - new upstream release
  271. * Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  272. - new upstream release
  273. * Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
  274. - rebuild with new toolchain
  275. * Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
  276. - new upstream release
  277. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
  278. - new upstream release
  279. * Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
  280. - new upstream release
  281. * Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  282. - new upstream release
  283. * Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
  284. - new upstream release
  285. - build for Vine Linux
  286. * Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
  287. - install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
  288. - blow away unpackaged files in install
  289. * Thu Aug 8 2002 Owen Taylor <otaylor@redhat.com>
  290. - Version 2.0.6
  291. - Remove fixed-ltmain.sh; shouldn't be needed any more.
  292. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  293. - automated rebuild
  294. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  295. - 2.0.4
  296. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  297. - automated rebuild
  298. * Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
  299. - rebuild in different environment
  300. * Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
  301. - Fix missing .po files (#63336)
  302. * Wed Apr 3 2002 Alex Larsson <alexl@redhat.com>
  303. - Update to version 2.0.1
  304. * Fri Mar 8 2002 Owen Taylor <otaylor@redhat.com>
  305. - Version 2.0.0
  306. * Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
  307. - Update to 1.3.15
  308. * Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
  309. - Bump for rebuild
  310. * Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
  311. - Update to 1.3.14
  312. * Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
  313. - add horrible buildrequires hack
  314. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  315. - 1.3.13.91 cvs snap
  316. * Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
  317. - rebuild from CVS snapshot
  318. - use setup -q
  319. * Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
  320. - rebuild
  321. * Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
  322. - 1.3.13
  323. * Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
  324. - attempting rebuild in rawhide
  325. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  326. - remove 64-bit patch now upstream, 1.3.12.90
  327. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  328. - add some missing files to file list, langify
  329. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  330. - add temporary patch to fix GTypeFundamentals on 64-bit
  331. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  332. - Version 1.3.11
  333. * Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
  334. - Version 1.3.10
  335. * Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
  336. - Version 1.3.9
  337. * Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
  338. - Version 1.3.8
  339. * Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
  340. - Make -devel package require main package (#45388)
  341. - Fix description and summary
  342. - Configure with --disable-gtk-doc
  343. * Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  344. - add some portability fixes needed at least on s390
  345. - copy config.{guess,sub} instead of calling libtoolize
  346. * Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
  347. - try a new glib tarball with Makefile changes to work around
  348. libtool linking to installed .la files
  349. - make -devel require pkgconfig
  350. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  351. - either libtool or the bad libtool hacks caused link
  352. against glib-gobject 1.3.2, rebuild
  353. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  354. - 1.3.6
  355. - bad libtool workarounds
  356. * Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
  357. - 1.3.5, rename to glib2
  358. * Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
  359. - Final 1.3.2
  360. * Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
  361. - Version 1.3.2pre1
  362. - Remove pkgconfig
  363. * Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
  364. - Call 1.3.1b instead of snap... the snap* naming doesn't
  365. order correctly.
  366. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  367. - new snapshot with fixed .pc files
  368. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  369. - include .pc files in file list
  370. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  371. - Include pkg-config
  372. - Upgrade to a glib CVS snapshot
  373. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  374. - rebuild to cope with glibc locale binary incompatibility
  375. * Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
  376. - Remove glib-config.1 manpage from build since
  377. it conflicts with glib-devel. When we go to
  378. glib glib1.2 setup, we should add it back
  379. * Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
  380. - Version 1.3.1
  381. - Move back to standard %{prefix}
  382. * Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
  383. - Rebuild in /opt/gtk-beta
  384. * Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
  385. - New version (adds gobject)
  386. * Wed Apr 25 2000 Owen Taylor <otaylor@redhat.com>
  387. - Don't blow away /etc/ld.so.conf (sorry!)
  388. * Tue Apr 24 2000 Owen Taylor <otaylor@redhat.com>
  389. - Snapshot RPM for Pango testing
  390. * Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
  391. - Added fixes from stable branch of CVS
  392. * Thu Oct 7 1999 Owen Taylor <otaylor@redhat.com>
  393. - version 1.2.6
  394. * Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
  395. - version 1.2.5
  396. * Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
  397. - version 1.2.4
  398. * Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
  399. - version 1.2.3
  400. * Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
  401. - version 1.2.1
  402. * Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
  403. - Version 1.2
  404. * Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
  405. - version 1.2.0pre1
  406. * Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
  407. - new description tags
  408. * Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
  409. - removed libtoolize from %build
  410. * Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
  411. - added libgthread to file list
  412. * Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
  413. - version 1.1.15
  414. * Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
  415. - version 1.1.14
  416. * Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
  417. - version 1.1.13
  418. * Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
  419. - version 1.1.12
  420. * Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
  421. - updated in preparation for the GNOME freeze
  422. * Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
  423. - Split out glib package