wireshark-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376
  1. %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  2. Summary: Network traffic analyzer
  3. Summary(ja): ネットワークトラフィック解析プログラム
  4. Name: wireshark
  5. Version: 1.6.3
  6. Release: 1%{_dist_release}
  7. License: GPLv2
  8. Group: Applications/System
  9. Source0: http://www.wireshark.org/download/src/%{name}-%{version}.tar.bz2
  10. Source1: wireshark.pam
  11. Source2: wireshark.console
  12. Source3: wireshark.desktop
  13. Patch1: wireshark-0.99.7-pie.patch
  14. Patch3: wireshark-nfsv4-opts.patch
  15. Patch4: wireshark-0.99.7-path.patch
  16. Patch5: wireshark-1.4.0-lua-vine.patch
  17. URL: http://www.wireshark.org/
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: libcap-devel
  20. BuildRequires: net-snmp-devel >= 5.0
  21. BuildRequires: net-snmp-utils >= 5.0
  22. BuildRequires: zlib-devel, bzip2-devel
  23. BuildRequires: openssl-devel
  24. BuildRequires: glib2-devel, gtk2-devel
  25. BuildRequires: libelf-devel
  26. BuildRequires: python, pcre-devel
  27. BuildRequires: gnutls-devel
  28. BuildRequires: desktop-file-utils, automake, libtool
  29. BuildRequires: bison, flex
  30. %if %{?_dist_release} != "vl4"
  31. BuildRequires: krb5-devel
  32. BuildRequires: libpcap-devel
  33. BuildRequires: lua-devel
  34. %else
  35. BuildRequires: libpcap
  36. %endif
  37. Requires: usermode >= 1.37
  38. Requires(post): desktop-file-utils
  39. Requires(postun): desktop-file-utils
  40. Obsoletes: ethereal
  41. Obsoletes: ethereal-base ethereal-gnome ethereal-gtk+
  42. Obsoletes: ethereal-kde ethereal-usermode
  43. Provides: ethereal ethereal-gnome
  44. Vendor: Project Vine
  45. Distribution: Vine Linux
  46. Packager: inagaki, Takemikaduchi
  47. %description
  48. Wireshark is a network traffic analyzer for Unix-ish operating systems.
  49. This package lays base for libpcap, a packet capture and filtering
  50. library, contains command-line utilities, contains plugins and
  51. documentation for wireshark. A graphical user interface is also
  52. included with this package.
  53. %description -l ja
  54. Wireshark は,UNIX 系 OS 用のネットワークトラフィック解析プログラムです.
  55. このパッケージは,パケットキャプチャ/フィルタリングライブラリである
  56. libpcap を使ったコマンドラインツールと,プラグイン,ドキュメント等が
  57. 収められています.GUI もこのパッケージに収められています.
  58. %prep
  59. %setup -q -n %{name}-%{version}
  60. #patch1 -p1 -b .pie
  61. %patch3 -p1
  62. %patch4 -p1
  63. %patch5 -p1 -b .lua-vine
  64. %build
  65. %ifarch s390 s390x
  66. export PIECFLAGS="-fPIE"
  67. %else
  68. export PIECFLAGS="-fpie"
  69. %endif
  70. # FC5+ automatic -fstack-protector-all switch
  71. export RPM_OPT_FLAGS=${RPM_OPT_FLAGS//-fstack-protector/-fstack-protector-all}
  72. ## export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS -I%{_includedir}/pcap -I%{_includedir}/pcre"
  73. export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS -I%{_includedir}/pcre"
  74. export CXXFLAGS="$RPM_OPT_FLAGS $CPPFLAGS"
  75. export LDFLAGS="$LDFLAGS -lm -lcrypto"
  76. export PATH="$PATH:/usr/kerberos/bin"
  77. ./autogen.sh
  78. # --disable-warning-as-erros needs for compiling with glib 2.14.0
  79. %configure \
  80. --bindir=%{_sbindir} \
  81. --enable-ipv6 \
  82. --with-gnu-ld \
  83. --disable-static \
  84. --disable-usr-local \
  85. --enable-wireshark \
  86. --with-pic \
  87. --with-ssl \
  88. --with-pcap \
  89. --with-pcre \
  90. %if %{?_dist_release} != "vl4"
  91. --with-krb5 \
  92. %else
  93. --without-krb5 \
  94. %endif
  95. --with-plugins=%{_libdir}/%{name}/plugins/%{version} \
  96. --disable-warnings-as-errors
  97. time make %{?_smp_mflags}
  98. %install
  99. rm -rf $RPM_BUILD_ROOT
  100. # The evil plugins hack
  101. perl -pi -e 's|-L../../epan|-L../../epan/.libs|' plugins/*/*.la
  102. make DESTDIR=$RPM_BUILD_ROOT install
  103. #symlink tshark to tethereal
  104. ln -s tshark $RPM_BUILD_ROOT%{_sbindir}/tethereal
  105. #empty?!
  106. rm -f $RPM_BUILD_ROOT%{_sbindir}/idl2wrs
  107. # install support files for usermode, gnome and kde
  108. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d
  109. install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d/wireshark
  110. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps
  111. install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps/wireshark
  112. mkdir -p $RPM_BUILD_ROOT/%{_bindir}
  113. ln -s consolehelper $RPM_BUILD_ROOT/%{_bindir}/wireshark
  114. # install man
  115. ## mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
  116. ## install -m 644 *.1 $RPM_BUILD_ROOT/%{_mandir}/man1
  117. # Install python stuff.
  118. mkdir -p $RPM_BUILD_ROOT%{python_sitelib}
  119. install -m 644 tools/wireshark_be.py tools/wireshark_gen.py $RPM_BUILD_ROOT%{python_sitelib}
  120. desktop-file-install --vendor= \
  121. --dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
  122. %{SOURCE3}
  123. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/pixmaps
  124. install -m 644 image/wsicon48.png $RPM_BUILD_ROOT/%{_datadir}/pixmaps/wireshark.png
  125. # Remove .la files
  126. rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}/plugins/%{version}/*.la
  127. # Remove .la files in libdir
  128. rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
  129. %clean
  130. rm -rf $RPM_BUILD_ROOT
  131. %post
  132. /sbin/ldconfig
  133. update-desktop-database -q
  134. %postun
  135. /sbin/ldconfig
  136. update-desktop-database -q
  137. %files
  138. %defattr(-,root,root)
  139. %doc AUTHORS COPYING ChangeLog INSTALL NEWS README*
  140. %{_sbindir}/editcap
  141. #%{_sbindir}/idl2wrs
  142. %{_sbindir}/tshark
  143. %{_sbindir}/mergecap
  144. %{_sbindir}/text2pcap
  145. %{_sbindir}/dftest
  146. %{_sbindir}/capinfos
  147. %{_sbindir}/randpkt
  148. %{_sbindir}/dumpcap
  149. %{_sbindir}/tethereal
  150. %{_sbindir}/rawshark
  151. %{python_sitelib}/*
  152. %{_libdir}/lib*
  153. %{_mandir}/man1/editcap.*
  154. %{_mandir}/man1/tshark.*
  155. %{_mandir}/man1/idl2wrs.*
  156. %{_mandir}/man1/mergecap.*
  157. %{_mandir}/man1/text2pcap.*
  158. %{_mandir}/man1/capinfos.*
  159. %{_mandir}/man1/dumpcap.*
  160. %{_mandir}/man4/wireshark-filter.*
  161. %{_libdir}/wireshark
  162. %config(noreplace) %{_sysconfdir}/pam.d/wireshark
  163. %config(noreplace) %{_sysconfdir}/security/console.apps/wireshark
  164. %{_datadir}/wireshark
  165. %{_datadir}/applications/*.desktop
  166. %{_datadir}/pixmaps/wireshark.png
  167. %{_bindir}/wireshark
  168. %{_sbindir}/wireshark
  169. %{_mandir}/man1/wireshark.*
  170. %{_mandir}/man1/rawshark.*
  171. %{_mandir}/man1/dftest.*
  172. %{_mandir}/man1/randpkt.*
  173. %changelog
  174. * Sat Nov 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
  175. - new upstream release
  176. * Thu Sep 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
  177. - new upstream release
  178. * Sun Jul 31 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
  179. - new upstream release
  180. * Sun Jun 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.7-1
  181. - new upstream release
  182. (including security fix for CVE-2011-1957,1958,1959,2174,7175)
  183. * Sun Apr 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
  184. - new upstream release
  185. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-2
  186. - rebuild with krb5-libs-1.8.2
  187. * Wed Mar 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
  188. - new upstream release
  189. (including security fix for CVE-2011-0538 and CVE-2011-0713)
  190. * Sat Jan 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
  191. - new upstream release
  192. (including security fix for CVE-2010-4538)
  193. * Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-2
  194. - rebuild with openssl-1.0.0c
  195. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  196. - new upstream release
  197. * Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
  198. - new upstream release
  199. (including security fix for CVE-2010-3445)
  200. * Sun Sep 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  201. - new upstream release
  202. - add Patch5 (wireshark-1.4.0-lua-vine.patch)
  203. * Mon Aug 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
  204. - new upstream release
  205. (including security fix for CVE-2010-2287 and CVE-2010-2284)
  206. * Wed Jul 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.9-1
  207. - new upstream release
  208. * Tue May 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.8-2
  209. - rebuilt with libpcap-1.1.1
  210. * Sat May 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
  211. - new upstream release
  212. (including security fix for CVE-2010-1455)
  213. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-1
  214. - new upstream release
  215. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.5-3
  216. - rebuilt with python-2.6.4
  217. * Sun Dec 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-2
  218. - added --enable-wireshark instead of --enable-gtk2
  219. - added BR: bison, flex
  220. * Sat Dec 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.5-1
  221. - new upstream release with security fixes (SNA/SMB/IPMI issues)
  222. * Fri Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
  223. - new upstream release
  224. (includeing security fix for CVE-2009-3549,3550 and 3551)
  225. * Wed Sep 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-2
  226. - add BR: lua-devel (Vine 5.0 and later)
  227. * Sat Sep 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-1
  228. - new upstream release
  229. * Tue Jul 21 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
  230. - new upstream release
  231. * Mon Jul 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-1
  232. - new upstream release
  233. * Sat May 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.8-1
  234. - new upstream release
  235. * Fri Apr 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.7-1
  236. - new upstream release
  237. * Sun Feb 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.6-1
  238. - new upstream release
  239. - used more macros
  240. * Sat Jan 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-1
  241. - new upstream release
  242. * Sun Nov 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-2vl5
  243. - rebuilt
  244. * Mon Oct 27 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-1
  245. - new upstream release with security fix
  246. - add BuildRequires krb5-devel
  247. - SPEC in UTF-8
  248. * Fri Sep 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.3-1
  249. - new upstream release with security update
  250. * Wed Apr 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0-1
  251. - new upstream release with security update
  252. - add Vendor/Distribution tag
  253. - add BuildRequires: libcap-devel
  254. - new versioning policy
  255. * Tue Jan 8 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.99.7-0vl2
  256. - modified Source3 because of desktop-file-install error, like this:
  257. /var/tmp/wireshark-0.99.7-root/usr/share/applications/wireshark.desktop:
  258. error: value "wireshark.png" for key "Icon" in group "Desktop Entry" is
  259. an icon name with an extension, but there should be no extension as
  260. described in the Icon Theme Specification if the value is not an
  261. absolute path
  262. this warning/error occurs with desktop-file-utils >= 0.14
  263. * Wed Jan 2 2008 Satoshi MACHINO <machino@vinelinux.org> 0.99.7-0vl1
  264. - new upstream release
  265. - imported patch4 from fc9
  266. * Sun Sep 2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl2
  267. - rebuilt with libpcap-0.9.7
  268. - added --disable-warning-as-errors to %%configure for glib-2.14.0
  269. * Sat Jul 7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl1
  270. - new upstream release
  271. - rebuilt with libpcap-0.9.6
  272. - added --with-pcap, --with-pcre
  273. * Fri Jun 1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl2
  274. - rebuilt with new toolchain and environment
  275. * Thu Feb 8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl1
  276. - new upstream release
  277. * Mon Nov 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.4-0vl1
  278. - new upstream release
  279. * Wed Oct 4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.3-0vl1
  280. - initial built for Vine Linux based on Fedora
  281. - Obsoletes: ethereal, Provides: ethereal
  282. * Fri Aug 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.3-fc5.1
  283. - upgrade to 0.99.3-1
  284. - CVE-2006-4330 Wireshark security issues (CVE-2006-4333 CVE-2006-4332 CVE-2006-4331)
  285. * Wed Jul 26 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.2
  286. - fix BuildRequires
  287. * Tue Jul 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.1
  288. - build for FC5
  289. * Tue Jul 18 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-1
  290. - upgrade to 0.99.2
  291. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.99.2-0.pre1.1
  292. - rebuild
  293. * Tue Jul 11 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-0.pre1
  294. - upgrade to 0.99.2pre1, fixes (#198242)
  295. * Tue Jun 13 2006 Radek Vokal <rvokal@redhat.com> 0.99.1-0.pre1
  296. - spec file changes
  297. * Fri Jun 9 2006 Radek Vokal <rvokal@redhat.com> 0.99.1pre1-1
  298. - initial build for Fedora Core