gnome-shell-vl.spec 8.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268
  1. %define pkg_version 3.8.1
  2. %define pkg_release 1%{?_dist_release}
  3. Summary: Window management and application launching for GNOME
  4. Name: gnome-shell
  5. Version: %{pkg_version}
  6. Release: %{pkg_release}
  7. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.8/%{name}-%{version}.tar.xz
  8. # settings for Vine
  9. Patch101: gnome-shell-vine-settings.patch
  10. License: GPLv2+
  11. Group: User Interface/Desktops
  12. URL: http://live.gnome.org/GnomeShell
  13. Requires(post,postun): scrollkeeper >= 0.1.4
  14. Requires: mutter
  15. Requires: caribou
  16. Requires: ca-certificates
  17. Requires: at-spi2-atk
  18. Requires: telepathy-logger
  19. Requires: network-manager-applet
  20. Requires: gnome-tweak-tool
  21. BuildRequires: gnome-common
  22. BuildRequires: libtool
  23. BuildRequires: automake
  24. BuildRequires: autoconf
  25. BuildRequires: pkgconfig
  26. BuildRequires: gtk2-devel
  27. BuildRequires: clutter-devel
  28. BuildRequires: mutter-devel
  29. BuildRequires: gjs-devel
  30. BuildRequires: gnome-desktop3-devel
  31. BuildRequires: gnome-menus-devel
  32. BuildRequires: libSM-devel
  33. BuildRequires: libffi-devel
  34. BuildRequires: startup-notification-devel
  35. BuildRequires: gnome-doc-utils
  36. BuildRequires: desktop-file-utils
  37. BuildRequires: libcroco-devel
  38. BuildRequires: librsvg2-devel
  39. BuildRequires: gobject-introspection-devel
  40. BuildRequires: control-center-devel
  41. BuildRequires: gcr-devel
  42. BuildRequires: gstreamer-devel
  43. BuildRequires: dbus-glib-devel
  44. BuildRequires: telepathy-logger-devel
  45. BuildRequires: polkit-devel
  46. BuildRequires: pulseaudio-libs-devel
  47. BuildRequires: evolution-data-server-devel
  48. BuildRequires: folks-devel
  49. BuildRequires: NetworkManager-glib-devel
  50. BuildRequires: libnm-gtk-devel
  51. BuildRequires: libgudev1-devel
  52. BuildRequires: libcanberra-gtk3-devel
  53. BuildRequires: caribou-devel
  54. BuildRequires: ca-certificates
  55. BuildRequires: intltool
  56. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  57. Vendor: Project Vine
  58. Distribution: Vine Linux
  59. Packager: Takemikaduchi
  60. %description
  61. GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
  62. It provides core interface functions like switching to windows and launching
  63. applications. GNOME Shell takes advantage of the capabilities of modern graphics
  64. hardware and introduces innovative user interface concepts to provide a delightful
  65. and easy to use experience.
  66. %package docs
  67. Summary: Documentation for %{name}
  68. Summary(ja): %{name} 用のドキュメント
  69. Group: Documentation
  70. Requires: %{name} = %{version}-%{release}
  71. BuildArch: noarch
  72. %description docs
  73. This package contains documentation for %{name}.
  74. %prep
  75. %setup -q
  76. %patch101 -p1 -b .vine
  77. %build
  78. libtoolize --copy --force
  79. autoreconf
  80. %configure \
  81. --disable-static
  82. %{__make} %{?_smp_mflags}
  83. %install
  84. %{__rm} -rf ${RPM_BUILD_ROOT}
  85. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  86. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  87. %find_lang %{name}
  88. %clean
  89. %{__rm} -rf ${RPM_BUILD_ROOT}
  90. %post
  91. /sbin/ldconfig
  92. touch --no-create %{_datadir}/icons/hicolor
  93. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  94. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  95. fi
  96. %postun
  97. /sbin/ldconfig
  98. touch --no-create %{_datadir}/icons/hicolor
  99. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  100. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  101. fi
  102. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  103. %posttrans
  104. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  105. %files -f %{name}.lang
  106. %defattr(-,root,root,-)
  107. %doc COPYING NEWS README
  108. %{_bindir}/gnome-shell
  109. %{_bindir}/gnome-shell-extension-tool
  110. %{_bindir}/gnome-shell-extension-prefs
  111. %{_bindir}/gnome-shell-perf-tool
  112. %{_libdir}/%{name}/*
  113. %{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
  114. %{_libexecdir}/gnome-shell-calendar-server
  115. %{_libexecdir}/gnome-shell-hotplug-sniffer
  116. %{_libexecdir}/gnome-shell-perf-helper
  117. %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
  118. %{_datadir}/applications/gnome-shell.desktop
  119. %{_datadir}/applications/gnome-shell-extension-prefs.desktop
  120. %{_datadir}/applications/evolution-calendar.desktop
  121. %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
  122. %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
  123. %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
  124. %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
  125. %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
  126. %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
  127. %{_datadir}/%{name}/*
  128. %{_datadir}/gnome-control-center/keybindings/50-gnome-shell-screenshot.xml
  129. %{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
  130. %{_mandir}/man1/%{name}.1.gz
  131. %files docs
  132. %defattr(-,root,root,-)
  133. %{_datadir}/gtk-doc/html/shell
  134. %{_datadir}/gtk-doc/html/st
  135. %changelog
  136. * Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
  137. - new upstream release
  138. - update Patch101 (gnome-shell-vine-settings.patch)
  139. - add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
  140. - add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
  141. - create %%{name}-docs subpackage
  142. * Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
  143. - new upstream release
  144. - remove Source102 (gnome-shell.gnome-3-6.ja.po)
  145. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  146. - new upstream release
  147. - add Source102 (gnome-shell.gnome-3-6.ja.po)
  148. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  149. - new upstream release
  150. - remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
  151. * Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
  152. - rebuild with telepathy-logger-0.6.0
  153. - add Patch0 (gnome-shell-3.4.1-git20121031.patch)
  154. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
  155. - new upstream release
  156. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  157. - new upstream release
  158. - add Patch0 (gnome-shell-3.5.92-git20120921.patch)
  159. - update Patch101 (gnome-shell-vine-settings.patch)
  160. - change BuildRequires: ca-certificates instead of openssl
  161. - add BuildRequires: libcanberra-gtl3-devel
  162. * Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  163. - new upstream release
  164. - remove Patch103 (gnome-shell-ja.po-date.patch)
  165. * Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  166. - new upstream release
  167. - update Patch101,103
  168. - remove Patch0,102
  169. - add BuildRequires: gcr-devel
  170. - remove BuildRequires: GConf2-devel
  171. - add Requires: at-spi2-atk
  172. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
  173. - new upstream release
  174. - remove Patch1
  175. * Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
  176. - add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
  177. - add Patch1 (gnome-shell-3.2.1-ja.po.patch)
  178. - rename Patch103 (gnome-shell-ja.po-date.patch)
  179. - drop Patch102
  180. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  181. - new upstream release
  182. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  183. - new upstream release
  184. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  185. - new upstream release
  186. - update Patch101
  187. - update Patch102
  188. - update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
  189. - add BuildRequires: libgudev1-devel, openssl
  190. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
  191. - new upstream release
  192. - add BuildRequires: folks-devel, NetworkManager-glib-devel
  193. - add Requires: caribou
  194. - remove Patch0
  195. - update Patch101
  196. - update Patch102
  197. - update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
  198. * Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
  199. - rebuild with gnome-menus-3.1.5
  200. - add Patch0 (gnome-shell-git20110821.patch)
  201. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  202. - new upstream release
  203. - add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
  204. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  205. - remove BuildRequires: xulrunner-devel
  206. - add Patch101 (gnome-shell-vine-settings.patch)
  207. - add Patch102 (gnome-shell-vine-customize.patch)
  208. - add Patch103 (gnome-shell-3.1.4-ja.po.patch)
  209. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
  210. - add Requires: mutter
  211. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
  212. - new upstream release
  213. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  214. - initial build for Vine Linux